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Windows and Windows XP are registered trademarks of Microsoft Corporation. 

Other products and company names mentioned herein may be the trademarks of their respective owners. 

 

Junctions 9 uses an implementation of the ‘Mersenne Twister’ random number generator which includes the 
following copyright notice: 

A C-program for MT19937, with initialization improved 2002/1/26. 
Coded by Takuji Nishimura and Makoto Matsumoto. 
Copyright (C) 1997 - 2002, Makoto Matsumoto and Takuji Nishimura, 
All rights reserved. 
 
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are 
met: 
 
1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. 
 
2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the 
documentation and/or other materials provided with the distribution. 
 
3. The names of its contributors may not be used to endorse or promote products derived from this software without specific prior written 
permission. 
 
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT 
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE COPYRIGHT 
OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR  
PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING  
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 
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For advice on the use of the software, sales and distribution information please contact: 

 

                                                                                                       
 
TRL | Crowthorne House | Nine Mile Ride | Wokingham | Berkshire | RG40 3GA | United Kingdom 
 
 
Telephone: +44 (0)1344 379777 
  
Fax: +44 (0)1344 770356 
 
Email: software@trl.co.uk 
 
Website: www.trlsoftware.co.uk 
 

 
 
 

 
 
 
 
 
 

Junctions 9 is the latest version of the internationally-recognised software application for predicting capacities, 
queue lengths and delays (both queueing and geometric) at non-signalised roundabouts and priority intersections.  
It can also be used to predict accident frequencies or indices for a particular layout from information about traffic 
flow and site data.  The product is used as a tool by intersection design engineers to help them to assess their 
designs and is used primarily for modelling peak periods.  

This User Guide describes in detail the features this new version of the program has to offer. 

Other topics in the guide include a description of the theory and research incorporated into the product, how the 
model should be specified and guidance on how to measure and enter data. Also described is the output and how 
it should be interpreted.   

 

mailto:software@trl.co.uk
http://www.trlsoftware.co.uk/
https://twitter.com/newsfromtrl
https://www.linkedin.com/company/trl
https://www.youtube.com/channel/UC_4Abcni7qybHPwGi1auMpQ
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Junctions 9 is a software package for predicting capacities, queues and delays at roundabouts, major/minor 
priority intersections and signalised intersections.  It can also predict accident rates and geometric delays for 
certain intersection types. 

All of these predictions can be used in testing design options both for new intersections and modifications to 
existing ones.  Another possible use is for examining the changes in queues and delays at existing intersections 
when the level or balance of traffic demand changes, perhaps due to changes in routeing patterns following 
improvements in the highway network.  The program is also able to predict the daily variability of queues. The 
program is normally used to model peak periods, but any period (up to 24 hours) can be investigated.   

Junctions 9 consists of three modules, which are licensed separately:  

         

The Roundabouts Module [ARCADY 9] is based on previous versions of ARCADY (Assessment of Roundabout 
Capacity and Delay). 

The Priority Intersections Module [PICADY 9] is based on the related program, PICADY (Priority Intersection 
Capacity and Delay). 

The Signalised Intersections Module [OSCADY 9] is based on the related program, OSCADY (Optimised Signal 
Capacity and Delay).  This module is available in Junctions 9.5 onwards. 

 

Junctions 9 therefore brings together the traffic models from previous versions of ARCADY, PICADY and OSCADY 
into a single user interface.  If all modules are licensed, then you can seamlessly switch intersection type at any 
time. For a summary of the junction types that can be modelled, please see Junction types in Junctions 9. 

The original versions of ARCADY, PICADY and OSCADY originated in the 1980s. 

Please note that ARCADY, PICADY and OSCADY are intended as aids in the design of junctions and are not intended 
to cover all aspects of design.   

Junctions 
9 

Roundabouts 
Module 

[ARCADY 9] 

Priority 
Intersection 

Module 
[PICADY 9] 

Signalised 
Intersection 

Module  
[OSCADY 9] 
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If you are using Junctions 9 for the first time, having previously used PICADY 5 or ARCADY 6, then you will find that 
Junctions 9 offers many benefits, such as: 

 Flexible User Interface 

 Multiple scenarios analysed at the same time 

 Interactive Junction Diagram 

 Choice of units 

 Performance Analysis 

 More traffic demand options 

 Customisable data grids  

 Convert reports to PDF format 

 File comparison tool 

 Glossary screen 

 Work with multiple files 

 Linked roundabouts 

 Puffin crossings 

 Entry and exit restrictions (for roundabouts) 

 Linking to Autodesk
®
 Vehicle Tracking.  

 Set up various junction types using the same user 
interface, and save in the same file format 

 Change junction type at any time without losing 
data 

 Lane Simulation mode allows you to investigate 
the relative performance of alternative lane 
configurations. 

 HCM roundabouts 
 

Junctions 9 introduces many new features, including:    
 

 Revised model for Mini-roundabouts 

 HCM TWSC and AWSC intersections (HCM 
Intersections) 
 

 Lane Simulation Mode for T-junctions  

 Lane Simulation for linked roundabouts and T-
junctions  

 Lane Simulation for pedestrian crossings 
 

 Measuring roundabout geometries using the 
junction diagram 

 Stick diagram mode 

 Junction diagram: text is clearer 

 Editing Traffic Flow using the junction diagram 
 

 Audit Trail 

 Calculating TEMPRO Growth Factors 

 Reading Demand Set flow data from Excel 
 

 Edit O-D data for more than one junction at a time 

 The same O-D data can be used by more than one 
junction  

 

 Faster report generation and inclusion of graphs 

 All results colour coded to show whether they are 
up to date 

 Multiple Data Editors can be used at the same time   

 A new padlock state allows freezing of the 
contents of data editing screens (Padlock system) 

 Analysis/Demand sets can be renumbered  

 More control over which data fields differ between 
Analysis/Demand sets  

 Results for all Analysis/Demand sets stored in the 
file 

 Analysis/Demand sets within a file can be 
compared (see Comparing files and data sets) 

 Various UI improvements 

 

Junctions 9.5 adds the following: 

 Inclusion of OSCADY model for isolated signalised junctions 

 Lane Simulation: Circulating lanes at roundabouts  

 Lane Simulation: individual signalised lanes 
 

 
Please browse through this User Guide to read about these and many more features. 
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If you are new to the program, we recommend that you firstly read Basic Theory and Research. 

Users looking for a quick overview of the user interface may prefer to skip straight to How to use Junctions 9. 

 

 

This product can model both drive-on-the-left and drive-on-the-right situations.  The program can be switched 
from drive-on-the-left (e.g. UK) to drive-on-the-right (e.g. mainland Europe and North America) at any time by 
setting the Driving Side data field in the Junction Network data section of the Data Outline.   
 
The default driving side for new files can be set in the File>Preferences screen. 

Throughout Junctions 9 and also in some parts of this User Guide, the terms nearside and offside are used in place 
of left and right wherever possible.   

If you wish to change the driving side of an existing file and ALSO mirror the appearance of the junction diagram, 
use the Tools>Mirror File (Swap Driving Side) option. 
 
REFER TO YOUR PRODUCT LICENCE AGREEMENT FOR DETAILS OF THE TERMS AND CONDITIONS OF USE OF THIS 
PRODUCT. ANY UK/INTERNATIONAL RESTRICTIONS OF USE WILL STILL APPLY. YOU MUST STILL BE LICENCED TO 
USE THIS PRODUCT IN THE COUNTRY IN WHICH IT IS BEING USED. 

ARCADY, PICADY and OSCADY are predominantly empirical models based on UK data.  For use outside of the UK 
the appropriateness of the model should be checked by the user. 
 

 

 

Terminology in Junctions 9 is largely based on UK standards, but certain phrases can be set to appear using US 
terminology. This preference is set via File>Preferences>US Terminology.  ‘PCU’ will then appear as ‘PCE’, and so 
on.  If there are other potential terminology changes that you think would benefit certain users, please contact TRL 
and these will be considered for inclusion in future versions. 

Units for many data items can be set via the Data>Units screen. 

This User Guide primarily uses UK terminology.  The term junction is synonymous with intersection. 

 

 

A file saved from any version of Junctions 9 can generally be loaded into older versions of Junctions 9.  Please note 
that when you load a file into a different version of Junctions 9, you may be shown an information screen, which 
can usually be ignored.  (The screen will show, for reference, a list of data items that have been automatically 
added or removed in order to match the relevant version’s file format.) 
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Junctions 9 can load ARCADY 7 files and Junctions 8 files; a similar screen to that mentioned above may be shown. 

Junctions 9 cannot export to Junctions 8 or ARCADY 7 but import options may be available in the latest 
maintenance versions of those products; please check with TRL for details. 

You can save files in ARCADY 6 (.vai) or PICADY 5 (.vpi) format from the File>Export menu.  In this case, only the 
currently selected junction will be exported, which must be either a Roundabout or a Priority Intersection as 
appropriate. 

ARCADY 5/6 files and PICADY 5 files can be imported by dragging them into the program. 

For more details about importing/exporting to/from ARCADY 6 or PICADY 5, see Appendix A – Importing from and 
exporting to from ARCADY 5/6. 

 

 

ARCADY Lite is a simplified version of Junctions that provides basic roundabout analysis and is designed primarily 
for use in North America.   The user interface is the same as that of Junctions 9, but certain features and options 
are omitted. 

ARCADY Lite is available in two forms: 

 If only an ARCADY Lite licence is purchased and registered, then only the simplified interface and features 
are available.    
 

 If a full ARCADY licence is purchased and registered, then the full interface and features are available.  
However, the Lite interface can optionally be used by selecting File>Preferences>General>Use Lite Mode 
for new files.   
 

Please also note the following: 

 A file saved from ARCADY Lite (in either of the forms above) can be loaded into both ARCADY Lite and the 
full version of ARCADY.  In the full version, the file can be ‘upgraded’ to a full file by deselecting Data>Use 
Lite Mode. 
 

 Files saved from the full version cannot be loaded into ARCADY Lite. 
 

 ARCADY Lite can be upgraded at any time by purchasing and registering a full licence. 
 

ARCADY Lite has its own user guide.  If using ARCADY Lite, please consult that version of the user guide instead 
of this full version. 
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Junctions 9 will run on any modern PC running Windows, and as such there are no specific hardware or software 
requirements. As may be expected, the program will run more smoothly on a PC with a fast processor and plenty 
of memory. 

 

To install the software, browse the product download file for SETUP.EXE, and run this file.  This will launch the 
product installer.  If you have been supplied with the product as a zip file, extract all the zipped files to a temporary 
folder, and then run SETUP.EXE from this temporary folder. 

During installation, all necessary files are copied to the specified folder and an entry added to the Windows Start 
menu.  To uninstall the software, please use the Windows Add/Remove Programs system, which is available from 
the Windows Control Panel, or use the Uninstall option under the program’s Start menu entry. 

 

 

Junctions 9 is a copy-protected software product.  Having installed Junctions 9 it will 
initially run in demo mode and in order to use the full product you must register it 
with TRL.  If you have obtained an evaluation version of the software, it will run in 
unrestricted mode for a certain number of days, and then revert to demo mode.  You 
must then purchase an unlock key to unlock the full version of the software.   

Junctions 9 contains three ‘modules’:  a Roundabout Module [ARCADY], a Priority Intersection Module [PICADY] 
and a Signalised Intersection Module [OSCADY].  Each module must be licensed separately.   You must register at 
least one module in order to use the program.   

For details of how to register and unlock your software, as well as how to transfer/update licences, please refer to 
the “SOFTWARE REGISTRATION” or similarly named document that is provided with your download.   

If you have not registered the software, a ‘Manage Licences’ screen will be shown each time you start the 
software.  You can also show this screen at any time from within the program by clicking Help>Manage Licences. 

The current security status of the program is also shown in the splash screen, which is available from within the 
program by selecting Help>About. 

If you have any questions or need assistance, please contact software@trl.co.uk. 

mailto:software@trl.co.uk
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This chapter describes the basic theory and research incorporated in Junctions 9. In particular, it outlines the 
theory of junction capacity and the use of time-dependent queuing theory, which are fundamental to the 
product.  It is intended as an overview covering the detail required by traffic engineers to assist them in getting the 
best out of the product.   

Those with no traffic engineering experience should not really be tackling junction design and assessment without 
at least some training and/or the assistance of others with some traffic engineering experience. 

 

 

The table below shows the main junction types that can be modelled in Junctions 9.   

Category Junction Type Distinguishing features 

Roundabouts 
[ARCADY 
model] 

Standard roundabout 
Any roundabout that is not either of the two other roundabout 
types 

Mini-roundabout 
Small roundabout (central island diameter<4m) with traversable 

painted central circle/dome central island.  

Large/grade-separated roundabout 
Roundabout with diameter>130m or that connects with a dual 
carriageway/motorway 

Priority 
Intersections 

[PICADY 
model] 

T-junction 3-arm minor/major junction 

Crossroads 4-arm minor/major junction 

Offside-Nearside Stagger * 
4-arm minor/major junction where traffic travelling straight 
ahead from a minor road makes an offside turn into the major 
road and then a nearside turn into the second minor road 

Nearside-Offside Stagger * 
4-arm minor/major junction where traffic travelling straight 
ahead from a minor road makes a nearside turn into the major 
road and then an offside turn into the second minor road 

Signalised 
Intersections 

[OSCADY 
model] 

Signalised Typically a 3 or 4-arm junction where all arms are signalised.   

HCM** 
 

Roundabout Roundabouts as described in HCM 

TWSC Two Way Stop Control intersections as described in HCM 

AWSC All Way Stop Control intersections as described in HCM 
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* The naming of staggers uses the terms Nearside/Offside so that the stream structure is identical regardless of driving side.   
Alternative names, as used in PICADY, are shown below, according to the driving side: 
 

Junction Type Abbreviation Drive-on-the-left Drive-on-the-right 

Offside-Nearside Stagger OS-NS Stagger Right-Left Stagger Left-Right Stagger 

Nearside-Offside Stagger  NS-OS Stagger Left-Right Stagger Right-Left Stagger 

 

** Please note that HCM Intersections are modelled using an entirely different model.  Unless otherwise stated, it 
 should be assumed that everything in this User Guide refers to the ARCADY/PICADY/OSCADY models only. 

 

 Lane Simulation 3.2.1

Junctions 9 includes the ability to model some junction types using a simulation technique.  This complements, and 
in some cases replaces, the ‘core’ ARCADY/PICADY/OSCADY models.  This mode (Lane Simulation) is fully 
described in Lane Simulation Mode.   Unless otherwise stated, everything else in this User Guide refers to the core 
models. 

The table below summarises the main differences between Lane Simulation and the core models: 

 Core models Lane Simulation 

Underlying principle Uses analytical methods Uses simulation 

Speed Fast Slower 

Repeatability Results identical every time 
Results vary slightly due to stochastic 

nature of simulation 

Source 
Based on longstanding 

ARCADY/PICADY/OSCADY models 
Developed more recently 

Flexibility 
Certain combinations of options not 

allowed 
Generally more flexible 

Can model blocking back, lane 
choice and linked junctions? 

Only in limited cases Yes 
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 More about junction types 3.2.2

By default when starting a new file a setup screen will be shown.  (See Quick start.) The choices made in this 
 screen combine as follows, colour coded by whether the ARCADY/PICADY/OSCADY licences are needed: 

Junction Type 
selected in New 

File screen 

Control 
type 

Lane 
Simulation? 

Resulting file 
Licences 
required 

Roundabout 
 

Priority 

No ARCADY roundabout using the ARCADY empirical model ARCADY 

Yes 

ARCADY roundabout in Lane Simulation mode.  Useful for 
modelling unequal lane usage and various other scenarios 
such as circulating lanes.  Give-way capacities based on the 
ARCADY empirical model. 

ARCADY 

Signals 

No N/A  

Yes 
ARCADY roundabout in Lane Simulation mode, as above.  
You can then signalise individual lanes. 

ARCADY, 
OSCADY 

T-junction 
Crossroads 

Stagger 

Priority 

No PICADY junction using the PICADY empirical model PICADY 

Yes 
PICADY junction in Lane Simulation mode; useful for 
modelling certain scenarios.  Give-way capacities based on 
the PICADY empirical model. 

PICADY 

Signals 

No 

OSCADY junction (all arms signalised) using the OSCADY 
analytical model.  Initial junction type is used only to set 
arm positions; junction type in the program will appear as 
“Signalised”. 

OSCADY 

Yes 

Signalised junction in Lane Simulation mode; all lanes 
initially signalised but can be turned on/off individually as 
required.  Initial junction type is used only to set arm 
positions; junction type in the program will appear as 
“Signalised”. 

OSCADY 

 

The junction type can be changed at any time by changing Data Outline>Junction Network>Junction>Junction Type.   
Use this to select any junction type not listed above, such as large roundabouts or HCM Intersections.   

If the junction type is set inside the program to T-junction/crossroads/stagger, this implies a specific junction 
shape and use of the PICADY model.  If the junction type is set to signalised, this does not imply any specific 
junction shape but means that the junction will use neither the ARCADY nor PICADY core models and will instead 
use the OSCADY core model (unless in Lane Simulation mode).   

Lane simulation mode can be toggled at any time by changing Data Outline>Analysis Set>Use Lane Simulation.  
However, depending on the junction type, the data requirements may differ between the core model and Lane 
Simulation mode. 

The OSCADY module must be licensed to use any type of signals.  This includes use of the OSCADY core model 
(Junction Type = Signalised; Lane Simulation = No), or for ANY junction type in Lane Simulation where one or more 
lanes are signalised.   
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For Roundabouts, the program uses empirical formulae to calculate the capacity of each entry arm as a function of 
the geometry of the entry and the circulating flow crossing in front of the entry.  The operation of the roundabout 
as a whole is calculated on the basis that the entries to the roundabouts are linked by the common circulating 
carriageway. This is the ARCADY model. 

For Priority Intersections, the program uses empirical formulae based on traffic flows and the geometry of the 
junction to calculate the capacity of each of several non-priority traffic streams (i.e. streams that must give-way to 
priority traffic).  These formulae depend on geometries such as the lane width available to the non-priority stream, 
the visibility to waiting drivers, the width of the major road and so on.   This is the PICADY model. 

For Signalised Intersections, the program uses the OSCADY model to calculate the capacity of traffic streams 
based on their saturation flows and various other properties combined with details of the signal timings at the 
junction.  The signal timings can optionally be optimised by the program. 

For all junction types, queues and delays are calculated using time-dependent queuing theory.  This method treats 
the whole range of demand and capacity and takes proper account of the statistical nature of traffic and of the 
variations with time of demand and capacity.  

 

 

ARCADY, PICADY and OSCADY are to be used as an aid in achieving good design, and it must be stressed that 
factors additional to those required for input to the program will need to be taken into account in junction design, 
for safety and convenience of operation.  Factors to be considered include: 

i) Entry width and deflection criteria. 
ii) Crossfall and drainage. 
iii) Space requirements for heavy flows of heavy vehicles. 
iv) Standards of visibility (e.g. minimum required visibility distances for new junctions). 
v) The design of ghost and solid islands, and central reserve openings at dual-carriageway sites. 
vi) Provision of deceleration/acceleration lanes. 

 
Other important factors include: 

vii) Road User specific requirements (e.g. Pedestrians and Cyclists) 
viii) Junction type 
ix) Lighting provision. 
x) The use of signs, markings and road furniture. 
xi) Surface characteristics 
xii) Circulatory carriageway design/speeds 
xiii) Segregated left-turning lanes 
xiv) Aesthetic considerations (e.g. landscaping). 

 
You should consult your relevant national standards authority or other relevant guidelines.  The use of Junctions, 
ARCADY, PICADY or OSCADY does not in itself imply an acceptable intersection design. 
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Note also that ARCADY, PICADY and OSCADY are concerned only with the operational performance of individual 
junctions.  For the overall appraisal of wider based road schemes, an economic evaluation will be required. 

Please also see Accuracy and reliability. 
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 Roundabout arm capacities (ARCADY) 3.5.1

A fundamental feature of the ARCADY model is the equation relating the entry capacity to circulation flow for 
roundabouts.  For standard roundabouts, this is formulated in LR942 (Kimber, 1980) as: 

  Qe = Fi -  fi Qc    

where:  Qe = entry capacity 

  Qc  = circulating flow 

Fi and fi (the intercept and slope respectively) are constants determined by the geometric 

characteristics of the roundabout. 

 
For standard roundabouts, the geometric features which have the most effect on the values of Fi and fi are listed 

as follows: 

V approach road half-width (metres) 

E entry width measured along the normal to the nearside kerbline (metres). 

l' average effective length over which the flare is developed (metres). 

R the entry radius measured as the minimum radius of curvature of the nearside kerbline at entry 
(metres). 

D inscribed circle diameter (metres). 

Φ (phi) the entry angle in degrees (geometric proxy for the conflict angle between entering and 
circulating streams). 

It must be emphasised that the ARCADY model for standard roundabouts has been calibrated only over the range 
of junction geometries included in the LR942 study.  It follows, therefore, that there is an increasing risk of 
unreliable results, due to extrapolation, as junction designs or individual geometric parameters extend beyond this 
range.  Of the geometric parameters determining entry capacity, all but the flare length (l') have limits built into 
the program.  Although the research data included flare lengths up to 27 metres, it is suggested that values 
extending beyond 30 metres can still be used, but should be treated with increasing caution.  

For mini-roundabouts, research identified three main geometric features which affect the intercept and slope:  

K entry corner kerb line distance (metres) - distinguishes entries that are further than usual from 
the next arm clockwise. 

e effective entry width (metres). 

G50 approach gradient over 50 metres (metres). 

Mini-roundabout analysis would also suffer the risk of unreliable results if junction designs or individual geometric 
parameters are extended beyond the range to which the model is calibrated.  Therefore suitable limits are built 
into the program to help prevent this happening.  
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 Interaction between arms at roundabouts 3.5.2

Another basic feature of ARCADY is the way in which flows from individual arms of a roundabout are linked.  This 
applies equally to standard roundabouts and mini-roundabouts.  The circulating flow across any entry, QC, is 

derived from the entry flows and turning proportions from previous arms.  As an example, Figure 3-1 shows the 
components of circulating flow across arm A of a 4-arm roundabout.  In this case: 

QC (circulating flow) = p
CB

 x (entry flow from arm C) + 

   (p
DB

 + p
DC

) x (entry flow from arm D). 

Where  pCB = the proportion of traffic from arm C going to arm B, etc. 

 
The circulating flows across other arms are derived similarly.  During an ARCADY run, an iterative process is used to 
calculate the final entry, circulating and exit flows at each arm. 

 

 

Figure 3-1  Components of the circulating flow Qc at arm A of a four-arm roundabout 
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 Priority Intersection stream capacities (PICADY) 3.5.3

A fundamental feature of the Priority Intersection model (PICADY) is the set of relationships for stream capacities.   

A stream is defined as one or more traffic movements that are considered together for the purpose of calculating 
capacities, queues and delays.  Streams do not necessarily relate to physical lanes at a road, although in many 
cases they will do.  The number and type of streams depends on the junction type and various other junction 
features, and is automatically assigned by the program.  See Priority Intersection streams for details of the naming 
convention for streams. 

Figure 3-2 shows the six streams at a T-junction (a 3-arm major/minor junction) for drive-on-the-left countries. The 
two straight-through major road streams (C-A and A-C) and the left-turning stream off the major road (A-B) have 
uninterrupted priority, and are assumed to suffer no delay due to the presence of the other streams. These are 
referred to as priority streams.  The two minor road streams (B-C and B-A) must, however, give way to other 
(controlling) streams and hence incur delay, as does the major road right-turning stream C-B.  These streams are 
non-priority streams. 

Only non-priority streams have capacities, queues and delays defined.   

The situation at 4-arm junctions is more complex, but the same principle of priority and non-priority streams is the 
same.  See Figure 3-4 to Figure 3-9. 

The capacity of these non-priority streams (i.e. the maximum flow to the stream’s destination when there is steady 
queuing for the stream in question) is determined by formulae involving: 

 the magnitude of the flows in the controlling streams 
 

 various geometric characteristics, such as lane and road widths and visibilities 

 

The diagrams below show the basic streams at each junction type.  (These streams may be modified depending on 
other junction features.) 

 

  



 Basic Theory and Research    Page 19     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 

Figure 3-2  Basic traffic streams at a T-junction (drive-on-the-left) 

 

 

 

Figure 3-3  Basic traffic streams at a T-junction (drive-on-the-right) 
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Figure 3-4  Basic traffic streams at a crossroads (drive-on-the-left) 

 

 

Figure 3-5  Basic traffic streams at a crossroads (drive-on-the-right) 

Crossroads

Arm B

(Minor)

Arm A

(Major)

Stream A-D

Stream A-C

Stream A-B

Arm D

(Minor)

Stream C-D

Stream C-A

Stream C-B

Arm C

(Major)

Crossroads

Arm B

(Minor)

Arm A

(Major)

Stream A-D

Stream A-C

Stream A-B

Arm D

(Minor)

Stream C-D

Stream C-A

Stream C-B

Arm C

(Major)



 Basic Theory and Research    Page 21     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 

Figure 3-6  Basic traffic streams at an Offside-Nearside stagger (drive-on-the-left; ‘right-left stagger’) 

 

 

Figure 3-7  Basic traffic streams at an Offside-Nearside stagger (drive-on-the-right; ‘left-right stagger’) 
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Figure 3-8  Basic traffic streams at a Nearside-Offside stagger (drive-on-the-left; ‘left-right stagger’) 

 

 

 

Figure 3-9  Basic traffic streams at a Nearside-Offside stagger (drive-on-the-right; ‘right-left stagger’) 
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 Signalised Intersection capacities (OSCADY) 3.5.4

For signalised intersections, the capacity of a stream depends on factors such as the saturation flow(s) of the 
stream and the proportion of green signal available to traffic on the stream.   Please see OSCADY junctions. 

 

 

Another essential feature of Junctions 9 is time-dependent queuing theory which, because of the time-varying 
nature of traffic flow, is used to calculate queue-lengths and delays.  This theory deals with the random nature of 
traffic arrivals and is necessary to predict queue lengths when traffic demand lies approximately in the region of 
80%-110% of the entry’s capacity.  In this region, queues and delays are unlikely to be predicted accurately if more 
simplistic models were to be used. 

 

 

 Roundabouts 3.7.1

The ARCADY model assumes that the relationship between the width of a roundabout entry and its capacity is 
continuous - i.e. it is not dependent on the number of lanes; it has been demonstrated that entry width is the best 
predictor of capacity.  However, the method assumes that all of the entry width will be used as long as there is a 
queue.  There are cases where that assumption does not hold.  Some of these are:  

 

 Where there is entry starvation, due to a little-used, dedicated left-turn or right-turn lane. 
 

 Where the roundabout exits are the limiting factor in determining capacity.   ARCADY assumes that all of 
the entry width is usable to good effect - this would not be the case when exits impose a capacity 
restriction.  The onus is on the roundabout designer to ensure that exits have adequate capacity.  
Junctions 9 contains an optional exit restriction model, and this will model increased queue and delay on 
an entry due to restricted exists.      
 

 Entry starvation due to uneven turning proportions and lane markings.  One typical case is a 3-arm 
roundabout where, say, 90% of approach flow on one arm turns right.  If the exit is only one lane, then 
vehicles will tend to queue in only one lane to avoid exit merging problems.  ARCADY results will be overly 
optimistic in such a case.  Junctions 9 contains a Lane Simulation Mode, which can be used to examine 
such cases and also as an alternative way of modelling exit restrictions. 

It should be borne in mind that there are other less obvious reasons why drivers may not use all of the available 
entry width, and a suitable adjustment to the input value of roundabout geometry must be made in such cases. 

It should also be remembered that ARCADY assumes there is never queueing inside the roundabout itself; all 
queues form behind each give-way line. 

The results of extensive research into capacities at mini-roundabouts showed no evidence to support the separate 
modelling of different movements at multi-lane entries.  However, at any roundabout type, the Lane Simulation 
Mode can be used to investigate the relative performance of alternative lane configurations.  
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 Priority Intersections 3.7.2

The Priority Intersection model (PICADY) assumes that all of the entry area upstream of a minor arm's give-way 
line can be used, as long as there is a queue.  The most common case where such an assumption is not true is 
where the exits are the limiting factor in determining capacity.  Again, the model assumes that all of the entry area 
(specifically the entry-width) is usable to good effect - this would not be the case when exits impose a capacity 
restriction.  The onus is on the junction designer to ensure that every exit is able to discharge traffic at the rate at 
which traffic is able to reach it, or at least to make due adjustment to the model if this is not possible.    

It should be borne in mind that there are other less obvious reasons why drivers may not use all of the available 
entry-area, and a suitable adjustment to the geometric data values must be made in such cases. 

As with roundabouts, in Junctions 9 you can optionally use Lane Simulation Mode to study the effects of exit 
restrictions. 

 

 

 Roundabouts 3.8.1

For roundabouts, there is no particular requirement to use an arm numbering convention; the user may set up any 
arm ordering and the program will automatically allow for this.  However, many users will continue to find the 
convention as used in all previous versions of ARCADY a convenient one. 

The usual labelling procedure for a roundabout is shown Figure 3-1. In drive-on-the-left mode arms are labelled 
clockwise A, B and C, where arm A is usually the first arm clockwise from 12 o’clock (but not at 12 o’clock).  For 
drive-on-the-right mode the arms are labelled in a counter-clockwise direction starting with the first arm anti-
clockwise from 12 o’clock. 

 

 Priority Intersection arms 3.8.2

The labelling of arms at Priority Intersections is automatic in Junctions 9.  (You can, however, enter your own 
name for each arm, which will supplement the automatically assigned arm IDs.) 

For a 3-arm junction, in drive-on-the-left mode, arms are labelled clockwise A, B and C, where Arm B is always the 
minor road.  For drive-on-the-right mode the arms are labelled in a counter-clockwise direction, again with Arm B 
as the minor road. 

For a 4-arm junction, the same convention is used, with Arms B and D being the minor arms. 

See Figure 3-2 onwards for illustrations of Priority Intersection arm labelling. 

 

 Priority Intersection streams 3.8.3

Streams are automatically labelled according to the arms the traffic is coming from and going to.  For example:  
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Stream A-B contains traffic coming from arm A and going to arm B.  

Stream B-AC contains traffic coming from arm B and going to arm A and to arm C.  (This represents the case 
where the minor road has only one lane for traffic turning both left and right). 

The various basic streams are shown for each junction type in Figure 3-2 onwards. 

The actual streams used by the model are initially determined by the junction type but are further modified due to 
features such as: 

 a single lane minor road  

 a pedestrian crossing on an arm  

 the blocking of through traffic by major road traffic making an offside turn into a minor arm 

The relevant streams are always listed in the PICADY Streams section of the Data Outline, and can be visualised in 
 the Junction Diagram Screen.   

NOTE:  If using Lane Simulation Mode, streams are not used and are replaced with lanes. 

 

At a Nearside-Offside staggered junction, many turning movements pass through two streams.  Some, such as 
vehicles travelling from Arm B to Arm D, experience delays in two separate queues, namely, B-CD whilst queueing 
on the minor road, and then AB-D whilst queueing in the centre of the junction.  Here, AB-D refers to the total 
traffic from both Arms A and B which travels to Arm D.   The full set of streams at such a junction is shown in Figure 
3-8 and also below in the form of a screenshot from the Junction Diagram Screen.  (Drive-on-the-left example; 
solid lines represent priority movements; dotted lines show non-priority movements where traffic must give way 
to priority traffic.)    
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 Signalised Intersections 3.8.4

For convenience, Signalised Intersections initially have their arms labelled as for Priority Intersections (i.e. A, B, C, 
D, with Arm A on the east and the others following clockwise).   You can however override this labelling.  

If using the OSCADY core model, each signalised arm contains one or more Traffic Streams, which each contain one 
or more lanes.  These are initially numbered automatically but these IDs can be overridden at any time.  Please see 
Traffic Streams and Lanes. 

 

 

As well as the general aspects of the model described in the preceding sections, there are some further basic 
considerations for Priority Intersections. 

(For a complete list of other modelling features, see Additional Modelling Theory and Features) 

 

 Blocking of major road traffic by offside-turners 3.9.1

Traffic on the major road making a right-turn (drive-on-the-left) or left-turn (drive-on-the-right) into the minor 
road represents a non-priority movement, and therefore such traffic may need to wait in the middle of the 
junction before turning.  Such waiting vehicles may block other traffic that would otherwise have travelled straight 
on unimpeded.  Whether or not this blocking happens depends on the layout of the junction and the mix of 
vehicles. 

The queue which contains the offside-turning vehicles, plus other traffic which has been blocked, is considered as a 
single stream, with an associated capacity, queue and delay. 

At some junctions there is limited road space in which offside-turning vehicles can store and not block traffic (i.e. 
‘partial blocking’) as a result of the road widening at the junction or by the provision of a dedicated offside-turn 
bay.  I.e., the offside-turning vehicles may sometimes block other traffic.  In these situations the amount of 
available ‘non-blocking’ space is used by the model to calculate the probability of traffic entering the junction 
being blocked and hence work out the queue length associated with the mix of traffic. 

Please see Appendix B - Measurement of geometric parameters affecting capacity for more details. 

NOTE:  if using Lane Simulation Mode, similar concepts apply but the model and results operate in terms of lanes 
 rather than streams. 
 

 RFCs at Priority Intersections 3.9.2

For Priority Intersections, a ‘satisfactory’ RFC depends on the speeds encountered at the junction. The capacity 
formulae used in PICADY were mainly developed from studies at UK major/minor junctions on public roads.  Most 
of these junctions had major roads with speed limits of 50 mph or less.  At high-speed major roads, a lower RFC 
(e.g. 0.75) is recommended instead.  Please see your relevant design guidelines, such as UK TA 23/81. 
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 Interpreting results for Priority Intersections 3.9.3

Please see Results for Priority Intersections. 
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NOTE: the following is only a very brief overview.  See General User Interface operation for a general description of 
the user interface.  For details of further program functionality please browse through the rest of this User Guide. 

NOTE: Certain inputs, results and screens are hidden unless the program is set to use Advanced Mode.  This 
option is set when you run the program for the first time, and can subsequently be changed via File Preferences, 
or, for the current file, via the Data menu.   

There is no fixed route through Junctions 9.  In general, data can be entered in any order and changed at any time, 
with screens updating automatically. 

The below is one suggested way to build a new file.  Please note that this is only a suggestion, and with experience, 
you will find your own preferences and may well find yourself building files in a completely different order.   

If in doubt, the Task List always shows any current problems with the file.  It shows a list of errors and warnings 
similar to the screenshot below, which should give you an idea of what needs to be done.  Double clicking on a row 
in the Task List will often take you to an appropriate screen.   

 

When the program first starts, or you click File>New, a basic setup screen will be shown.  The options chosen here 
are used to create a basic skeleton file.   
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You will then see the main Junctions 9 user interface. 

  

Use the Data Outline (see Data Outline and Structure) and the toolbar icons to access each data area. If you make a 
mistake at any point, use the Undo/Redo buttons. 

Roughly speaking, the icons on the main vertical toolbar are ordered from top to bottom in the order that they 
tend to be accessed when building a new file. 

A suggested order for basic use of the program is as follows.   

1. Fill in the file title and description etc in the File Description section of the Data Outline 
 

2. If necessary, set up Analysis Sets and Demand Sets (or return to these later) 
 

3. Set the driving side and some other important options in Junction Network.   
 

4. If necessary, set the junction type in Junction.   
 

5. Expand the Arms section of the Data Outline and add or delete arms to give the required number 
 

6. Show the Junction Diagram (at any point) and move the arms into the required positions. The Junction Diagram is not 
necessary to model junctions but is a useful reminder of the junction layout and offers some powerful tools to show 
results overlaid on the diagram. 
 

7. Use either the Data Editor or a Data Grid to edit the properties of each arm.  As a minimum, you should enter the arm 
name and geometric parameters. 
 

8. If necessary, add pedestrian crossings to each arm, and set up any required advanced features. 
 

9. Use the Origin-Destination screen and/or Demand screen to set up and enter traffic demand flows 
 

10. Use the Vehicle Mix screen to set up the percentage of heavy vehicles and other options 
 

11. Save and run the file (see Running Files ) 
 

12. Check the overall performance as shown in the Summary Results screen 
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13. Check the performance of individual arms and time segments by selecting the relevant sections in the Data Outline 
(Data Grids are useful here) 
 

14. Generate a report summarising all inputs and outputs 
 

15. Investigate the performance of the junction further by using the Analyser Screen 

 

 

To select the type of the current junction (e.g. roundabout, T-junction etc), firstly press the Junction (or 
Intersection) button on the main vertical toolbar.  This will take you to the Junction section of the Data Outline, 
from where you can use the Data Editor to set the Junction Type. 

 

 

 

 

 

Junctions 9 allows multiple junctions to be handled within the same file.  There are two main purposes to this: 

1. Modelling of Linked junctions   
 

2. Storing various junction designs within the same file.  Although Analysis Sets (see Working with Analysis 
Sets, Demand Sets and Time Segments) can be used to store different geometric parameters, they do not 
allow major changes such as differing numbers of arms, or different junction types.  Storing more than 
one junction design within the same file allows you to get around this limitation. 

When multiple junctions are stored in the same file, they appear as separate junctions in the Data Outline and in 
the Junction Diagram.  Until you set up links between the junctions and turn them into a junction network, they 
are assumed to be independent entities. 

By default, a new file contains a single junction and this is located inside the Junction Network part of the Data 
Outline and referred to as Junction 1.  To add more junctions, select Junction 1 and then use the Add button in the 
Data Outline.  As with any other item added in this way, either a new junction with default parameters or else a 
copy of the current junction can be used, depending on how you use the Add button – see Data Outline Screen for 
details.  Junctions can also be added and deleted using the Junction Diagram. 
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Many screens, such as the Demand and Vehicle Mix screen, show data for the currently selected junction only.  To 
show data for other junctions, click on any item within the junction in the Data Outline or via the Junction Diagram, 
or use the drop-down menu of the Junction button on the main vertical toolbar.   

Most of these screens include a padlock in one corner.  If clicked, the screen will become locked to the junction 
that was active when you clicked the padlock.  You can show multiple instances of each screen, each locked to a 
different junction and in this way view the data for each junction at the same time. 

Some other screens such as Data Grids, and tables in reports, show data for ALL arms in the junction network.  
Each row in the grid specifies the junction and the arm.  You can restrict Data Grids to showing only data for the 
current junction by using the Filter menu in the Data Grid. 

 
TIP: To combine junctions from several files into a single file, use the File>Merge Junction option. 

TIP: Sometimes you may want to split junction out into separate files.  This can be achieved by using File>Copy into New File, 
which will duplicate the entire file, and then deleting the appropriate junction (s) from each file until only the desired junction is 
left.  (Of course many users will prefer to simply work with separate files in the first place.) 

 

 

Important data such as geometric parameters and time segment results can be viewed for one arm at a time using 
the Data Editor.  The data can also be viewed using Data Grids, which show data for all arms together.  You can use 
as many data grids at any one time as you like, and can position these around the screen to allow, for example, 
viewing of input and output data at the same time. 

There are User Preferences which allow you to choose whether to show data grids automatically when clicking on 
 certain buttons on the main toolbars.  For example, when clicking the main Results button, you can choose 
whether this should show the Data Editor (for one arm at a time) or a data grid (for all arms). 
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The Junctions 9 user interface contains many screens, many of which can be displayed at the same time.  Double 
clicking any screen’s title bar will toggle whether the screen is inside or outside the main application window. 

Altering a value on one screen will if necessary update relevant values on other screens. The undo/redo buttons 
allow any change made to the file to be undone at any time. 

If the file contains no errors, it can be run at any time and the results automatically updated.  

At any time there is one active item, such as an Arm or a Junction. The current item is highlighted in the Data 
Outline and other screens.  If the Data Editor or a Data Grid is visible, then the properties for the current item will 
be displayed and should be editable.  The Data Outline is used to add/delete items.  

Double clicking or right-clicking on an item will generally show the item's properties, or bring up an appropriate 
screen. 

Note that Junctions 9 does not save a separate output file; instead, all results are saved within the input file.  
Results are automatically re-run whenever a report is generated or you display summary results.  If you wish to 
‘lock’ a set of results for future reference, you should treat the entire file as being locked and should save it 
separately from any work-in-progress files.   

 

 

 

 
To access this User Guide, use the Help menu, or, press the Help button on the main toolbar.   

 
Press this button on the main toolbar to show the Glossary Screen.  This screen shows extra help for 
many individual data fields.   This window can be left open and will show help, where appropriate, for the 
current data item at all times.  Simply click on any item in the Data Editor or elsewhere, and the Glossary 

Screen will update. 

Click the Lock option on the Glossary to lock the screen to the currently displayed topic.  Click the option again to 
unlock the screen and return to the normal mode of updating whenever a different data item is clicked. 

To print the contents of the Glossary screen, or to access other options, right-click on the screen. 
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Many of the colours used in Junctions 9 can be customised in the Colours section of the User Preferences screen.   

The font size used in both the Data Outline and the Data Editor can be changed by setting 
File>Preferences>Window Font Scheme.   

 
 
. 
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Assuming you are using the full version of Junctions 9 (i.e. not ARCADY Lite), there are two modes available: 

Basic Mode:  in this mode, only the most common data items and options are shown.  This is recommended if 
you are new to ARCADY/PICADY or, alternatively, if you wish to streamline the data entry process to only the 
most important items.   

Advanced Mode:  in this mode, all items and options are shown. 

The mode applies to the file itself.  When the file is subsequently loaded, Junctions 9 will switch into Basic or 
Advanced mode as appropriate. 

The DEFAULT setting for new files is chosen when you first run the program, and can be set via 
File>Preferences>Use Advanced Mode by default.   

To change a Basic Mode file to Advanced Mode, click Data>Use Advanced Mode.   

 

 

Some input items that are hidden when in Basic Mode are still used by the program.  In 
order to prevent these values being changed while in Advanced Mode and subsequently 
hidden in Basic Mode, which clearly would be dangerous, Junctions prevents Advanced 
Mode files from being set back to Basic Mode.   

I.e., once a file is in Advanced Mode it will always remain so.   

 
The table below is not exhaustive but illustrates some of the items that are available only in Advanced Mode.   () 
means that the item is available but some aspects of that item are hidden. 
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 Basic Mode Advanced Mode 

Junction Diagram ()  

Analysis Sets ()  

Demand Sets ()  

Geometries   

Pedestrian Crossings   

Turning Counts ()  

Traffic Flows ()  

Vehicle Mix ()  

Junction Results ()  

Lane Simulation   

Geometric Delay   

Accident Prediction   

Analyser Screen   

Calibration   

Bypasses   

Exit Restrictions   

Queue Options   

 
      

 

Junctions 9 saves data as files with an .j9 extension.   

Output can be saved permanently in the form of Reports, which are generated by the Report Generator.  Reports 
are produced in the form of HTML documents for viewing within the viewer built into Junctions 9 and can also be 
converted to Word and PDF documents. 

Several files can be opened at once.  The names of any open files are shown in buttons in the blue bar at the 
bottom of the screen.  To switch between files, click on the appropriate button.  

 

 

 Duplicating a file 5.5.1

When a file is open, you can create a duplicate copy of the file that you can then make adjustments to and 
compare to the original.  To do this, use the File>Copy into New File option. A new file will be created, containing a 
copy of all data.  The new file is not saved to disk until you use File>Save As. 

It is also possible to compare multiple files; see Comparing files and data sets. 
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 Saving files without results 5.5.2

Occasionally you may find that the size of the saved file is very large.  This can be due to large amounts of results 
data being present in the file.  For example, for certain Lane Simulation files, a full set of results data will be stored 
for each movement, for each lane, for each arm at each junction, for each time segment, and so on.  In such cases 
you may wish to save the file via File>Export>Save without results.   This will strip out some results data before 
saving the file, leading to a smaller file size.  You will of course need to re-run the file to generate new results when 
you subsequently load the file. 
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 Horizontal toolbar 5.6.1

 

From left to right, the buttons on the horizontal toolbar are: 

Icon User guide reference 

New File 

Managing files Open File 

Save File 

Copy to Clipboard 
Copying data to the clipboard 

Paste 

Print 
Printing 

Print Preview 

Undo 
Undo/Redo 

Redo 

Show Data Outline Data Outline Screen 

Show Data Editor Data Editor Screen 

Show a new Data Grid Data Grids 

Show Task List Task List 

Audit Trail Audit Trail 

Window Manager Window Manager 

Back 

Changing the Active Data Item 

Forwards 

Sync 

Previous 

Next 

Run File Running Files  

Generate Report Generating Reports 

Show User Guide 
Getting help 

Show Glossary Screen 
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 Vertical toolbar 5.6.2

From top to bottom, the buttons on the vertical toolbar are as follows.  Please note that some items are only 
visible if the file is currently in Advanced Mode, and others are only visible if the current junction type or mode 
allows.  Some buttons are not shown here but are described in the appropriate part of this User Guide (e.g. 
screens for editing signals data.) 

Launching a screen from the vertical toolbar will generally launch a new copy of that screen.  In other cases, 
buttons do not launch a new screen but simply jump to predefined points in the Data Outline. 

  
  

 

 

 

 

 

 

Icon 

Show a new Junction Diagram Screen  

Jump to the Junction section of the Data Outline, or select a different junction using the 
drop-down menu 

Show the HCM Intersections screen (visible if current junction is a HCM Roundabout) 

Jump to the Geometry section of the Data Outline, or show a specialised screen, 
depending on the type of the current junction  

Jump to the Pedestrian Crossing section of the Data Outline 

Show the Origin-Destination screen; see Origin-Destination (O-D)  

Show the Demand screen; see Demand Screen 

Show the Vehicle Mix screen 

Show the Lane Simulation Mode screen 

Show the Geometric Delay screen; see Geometric Delay and Journey Times 

Jump to the Safety Options section of the Data Outline; see Accident prediction 

Jump to the Time Segment Results section of the Data Outline (or the whole period 
results, by using the drop-down menu) 

Show/hide the Summary Results Screen 

Show/hide the Analyser Screen 
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A file is run (i.e. the traffic analysis model is run using the current data file and results generated) whenever you do 
any of the following: 

 Click the Run Model button on the main toolbar, or press F5.  

 

 Generate a report. 

 

 

 

The Undo and Redo buttons on the main toolbar allow you to step back through recent changes, and then re-do 
these changes if necessary.   

Use the drop-down menus on the Undo/Redo buttons to show a list of recent changes and jump straight to a 
particular change. 

For more complex, intentional changes (when you wish to compare one version of a junction to another), consider 
using the File>Copy Into New File option (Duplicating a file). 

 

 

The Active Data Item is the data item that is currently selected and highlighted in the Data Outline (and other 
screens) and will have its data fields displayed in the Data Editor. The Active Data Item may be, for example, Arm 
2. It may also be a specific type of data such as Arm 2: Standard Geometry, or a general item such as Analysis 
Options.   

There in several ways to set the Active Data Item: 

 Click on the item in Main Data Entry Sections 

 Click on a row header in a Data Grid (see Data Grids) 

 Click or double-click on the item in the Junction Diagram 

 Click or double-click on the item in any other appropriate screen, where applicable 

 
In addition, you can use the following toolbar buttons: 

 
Use the Back/Forwards buttons on the main toolbar. 
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These remember a history of 'visited' data items in a similar way to a web browser.  The Back button will set the 
Active Data Item to its previous item, and similarly for the Forwards button.  These are very useful when the data 
item you were looking at changed because you clicked on a different item elsewhere and you then wish to quickly 
go back to the original item. 

 

 
Use the Next/Previous buttons on the main toolbar. 

 
These move the Active Data Item to the next/previous data item that is of the same type as the current data item.  
E.g., when on Arm 1: Pedestrian Crossings, the Next button will move to Arm 2: Pedestrian Crossings, and so on.  
This allows you to quickly move between all items of the same type without having to find them in the Data 
Outline.  Note: the use of Data Grids is generally a more convenient way of viewing the data of several items at 
once. 

 

The Sync button on the main toolbar will, if relevant, set the Active Data Item to be the item associated with the 
currently selected field in Data Grids or certain other screens.  This is similar to clicking on a row/column header in 
a Data Grid but also works with other screens. 
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Some screens automatically update themselves so that they always show data for the Active Data Item, where 
appropriate.   

If you want to prevent such screens from automatically updating, you can lock them to the item that they are 
currently displaying.  Do this by clicking on the padlock icon shown in the top-left corner of the screen to toggle 
between locked and unlocked modes. 

Some screens (in particular, the Data Editor and Data Grid) have a special padlock that cycles through four modes 
as you click on it: 

 

1. Normal mode: the screen updates as usual whenever you click on an item in the Data Outline (or Junction 
Diagram or any other appropriate screen).  Sometimes this may be inconvenient, in which case use one of the 
modes below. 

 

 

2. Lock to type of item mode.  The screen stays fixed to the current type of item (for example Arm Geometry), but 
will update to show e.g. Geometry for Arm 1, Arm 2, Arm 3, etc, as you select different arms.  You don’t need to 
click on Geometry for each arm in the Data Outline: clicking on any part of an arm, or the arm itself in the Junction 
Diagram, is sufficient.   

With Data Grids, this mode locks the rows in the grid to the currently selected type of row and/or filter, but does 
not prevent the rows themselves from updating.  For example, if you show a data grid of arm geometries and then 
use this locking mode, then the data grid will only ever show arm geometries, whatever you click on in the Data 
Editor.   

 

 

3. Lock to specific items mode.  The screen stays fixed to the current item, no matter where you click in the Data 
Outline.  E.g. it shows Arm Geometry data for Arm 1, and will not show data for Arm 2 or Arm 3 until you unlock it. 

With Data Grids, this mode locks the specific rows in the grid. 

 

 

4. Lock entire screen.  In this mode all the data on the screen freezes and becomes read-only and will stay fixed 
even if you change the file.  In this way you can compare data in several screens without having to worry about the 
data changing when you re-run the file. 
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Some screens such as the O-D, Veh Mix and Demand screens have a small padlock which will lock the screen so 
that it always shows data for the junction that was active when you clicked the padlock.  In the example below, 
two Origin-Destination screens are shown at the same time, each locked to a different junction, so that data for 
both junctions can be edited together.    

 

 
Clicking this padlock a second time will freeze the screen:  it will become read-only and will stay the same even if 
you change the file.  For example you can view data for one Demand Set, freeze the screen, then show a second 
instance of the screen and select a different Demand Set; in this way you can view data for several Demand Sets at 
the same time.  It is also useful for leaving a frozen version of the screen visible before you start making changes to 
the data in another instance of the screen. 
 

 
 
 
Clicking the padlock again will revert to the usual system, which is that the screen will follow the active junction.  It 
will immediately update to show the current data for the junction. 
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 Editable items are shown with a normal white background 

 Some normally editable items may be disabled and are shown with a grey background.  There are several 
reasons why items may be disabled: 

o It may be directly inapplicable (e.g. pedestrian data for an arm that doesn’t have a pedestrian 
crossing) 

o It may be inapplicable because of data entered elsewhere (e.g. some data for accident prediction 
is taken automatically from capacity screens) 

o It may be inapplicable because of the current program mode or options set elsewhere 

o It may be a data item that is shown for information only and is always calculated by the program 
(i.e. never editable) 

 If a data item is a result, i.e., an output from the traffic model, it is shown with a light green background 
once the traffic model has been run.  Before you run the model, or if you subsequently make a change to 
the file, these items are shown with a red background to indicate that they are potentially inconsistent 
with the input data. 
 

 
 

 Use the Options>Analysis Options section of the Data Outline to control the thresholds above which RFCs, 
queues and delays are shown in red. 
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 Units 5.11.1

You can set a variety of units for both inputs and outputs and switch between them at any time (with certain 
restrictions).  Select units from the Data>Units screen.   

Note that all unit options are saved as part of the file (as opposed to user preferences). 

See also:  Units for data input;  Units for data output. 

 

 Item IDs 5.11.2

Many items, such as junctions and arms, are assigned a short ID (e.g. Arm “1”, Stream “B-C”, etc.) 

Optionally, you can also enter a longer name and description for most items. 

By default, items are referred to by their IDs (e.g. “Arm 1”, “Arm B” etc).  Optionally, the UI can display items using 
their full names instead.  To turn on this mode, use the Data Outline to browse to Data Outline>Options>Sorting 
and Display and tick the Show arm and junction names option. 

Generally, when adding a new item, the program will automatically assign the ID as the next available number, but 
you can subsequently change it using the Data Editor.   

When you change an item’s ID (via the Data Editor) any other data that references the original ID will be 
automatically updated.   

Note that all sorting and display options are saved as part of the file (as opposed to user preferences).   

 

 Sorting and grouping 5.11.3

Many screens show lists of arms, streams, etc, as do generated reports and as does the Data Outline itself.  You 
can control the sorting and grouping of these lists via the Options>Sorting and Display section of the Data Outline. 

Note that the Data Grid screen also lets you sort by any column simply by clicking on the column header. 

Note that all sorting options are saved as part of the file (as opposed to user preferences).   

 

 Abbreviated terms 5.11.4

Once familiar with the meaning of data items, you can choose to show them in abbreviated form by switching on 
File>Preferences>General>Use abbreviated terms. 
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 Copying data to the clipboard 5.12.1

 

The Copy button on the main toolbar will, where appropriate, copy data from the currently active screen (the 
screen last clicked on) to the Windows clipboard.  The data can then be pasted into a word processor, spreadsheet 
etc.  Some screens also have their own Copy buttons for specific purposes, or you can right-click in individual 
windows/screens. 

The format of the data depends on the screen but columns and rows are generally separated by tabs and new 
lines.  In some cases, the Paste Special option in the word processor/spreadsheet can be used to select between 
options of pasting text or a picture. 

In many cases you can also use the CTRL+C shortcut, or, right-click and choose Copy, but note that in some 
situations this will copy only the current line of text rather than the entire table. 

It is also possible to copy data for all Demand Sets in one operation – see Copying and Pasting all Demand Sets. 

 

 Pasting data from the clipboard 5.12.2

The Paste button on the main toolbar will, in many cases, copy data from the clipboard into the currently selected 
screen.  This relies on the data being in the expected format for the screen; the easiest way to determine the 
format is to press the Copy button on the same screen and paste the contents into a spreadsheet or similar.  
Altering the data in the spreadsheet and then copying exactly the same area and pasting back into Junctions 9 
should then successfully replace the data in Junctions 9 with the edited data. 

It is also possible to paste data for all Demand Sets in one operation – see Copying and Pasting all Demand Sets 

 

 Printing 5.12.3

The Print and Print Preview buttons on the main toolbar will, where appropriate, print or show a print preview 
screen for the currently active screen (the screen last clicked on).  This applies to the Junction Diagram, the Report 
Viewer, and also various other screens. 

Use File>Page Setup to control the paper size and orientation. 
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There is a standard Windows menu on the main toolbar which will show a list of all currently open windows and 
allow selection from this list.  It also contains a Close All option which will close all open windows. 

You can also store custom window layouts. This allows you to save the layout of all the windows as they currently 
appear, and quickly select the same layout next time you use the program. 
Click Window Layouts>Store Current Window Layout… to assign a name to the current window layout (i.e. the 
position and size of all windows as they currently appear). The layout will then appear in the menu whenever you 
use Junctions 9.  Layouts are saved as part of your personal preferences, not in the data file.   

Layouts take account of the contents of datagrids, in terms of which data fields are shown in the grid and their 
order.  However the actual content will obviously depend on the currently loaded file. 

 

 Window Manager 5.13.1

Use the menu option Window Layouts>Window Manager… option to display the Window Manager.  
Alternatively, press this button on the main toolbar. 

 

The Window Manager allows new window layouts to be added, renamed or deleted and also provides quick access 
to any of the saved layouts.  Double-click on one of the layouts to switch to it.  Any of the saved layouts can also be 
set as the default layout which will be used whenever you start the program or start a new file (click Toggle 
default). 

Depending on your version of Junctions, some built-in layouts may be already included.  Layouts may be specific to 
the version of Junctions used to save them. 

 

 
Layouts can be exchanged with colleagues or other users of Junctions.  Select the layout(s) that you wish to share 
(select in the list with CTRL or SHIFT) and click Export to generate a file containing the layout definitions.   To 
import such a file, use the Import layouts  button. 
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 Toggling windows in and out of the main application window 5.13.2

By default, new windows appear inside the main application window.  To take a window outside the main 
application window, double click on the window’s title bar.  You can then position and resize the window on a 
second monitor, for example.  To send the window back inside Junctions 9, double click its title bar again.  

 

 Docking windows 5.13.3

A docking system is provided which allow individual windows to be docked to any side of the main window area.  
Docked items remain on top at all times and therefore can offer an alternative way of using the available space 
within the main window.   

To dock a window right-click on the window’s Title Bar and continue to hold the right mouse button down.  The 
window will be darkened and you will also see a set of four directional icons. Move the cursor over one of the 
icons and the screen will darken in the direction indicated by the icon.  This indicates to which edge the docking 
will take place.  Let go of the mouse button to dock to the highlighted edge.  Multiple windows can be docked 
using this system. 

To un-dock a window, double-click on its title bar. 
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Select File>Preferences from the main application menu to access a set of preferences which are saved as part of 
your personal preferences (not in data files). 

This screen also provides a number of utility options at the bottom-left of the screen.  In particular, click Reset 
suppressed messages to restore any message boxes where you have previously clicked ‘Do not show this message 
again’. 

 

Some options are explained in this User Guide in the relevant section, and some are self-explanatory, but brief 
descriptions of selected items are given below. 

To reset all options to factory defaults, press the Defaults button.  You can also use File>First time use wizard to set 
certain common preferences. 

 
General > Default Traffic Units/Period:  controls whether new files should use traffic flow units of PCU/hr or 
Vehicles/min, etc. 

Appearance > Default Editor:   when clicking certain common buttons on the main vertical toolbar (e.g. Geometry, 
Crossings, Results), they can either launch a Data Editor for the current arm only, or a Data Grid showing data for 
all arms.   Use this option to select which you prefer. 

General > Show Summary Results screen after running model:  usually, as soon as the model runs, the Summary 
Results screen automatically appears.   This isn’t always needed, especially if using a window layout that already 
includes results.  In this case, turn this option off. 

Reports: All options shown here set the defaults for the options shown at the top of the Report Viewer screen, 
apart from Reports Folder and Report Location Mode.  If the latter is set to ‘use same location as input file’, then 
all HTML reports will be saved to a folder with the same name and location as the main data file.  Otherwise, if ‘use 
specified folder’ is selected, you can nominate a Reports Folder, which will be used for all generated reports. 

Summary Results Screen:  All options shown here are duplications of the options in the menus in the Summary 
Results screen and will apply to all new files. 

 



 General User Interface operation    Page 49     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 Transferring user preferences 5.14.1

To transfer user settings between two copies of Junctions 9 (for example different versions on the same PC, or 
between different PCs or users), use the following procedure: 

1. Show the Preferences screen 
2. Click on the Open preferences folder link at the bottom of the screen 
3. Windows Explorer will open a folder where you will find a .config file.  Make a copy of this file. 
4. On the target PC, repeat the above procedure and replace the .config file with the version copied from 

the original PC. 

Note that the above procedure only applies to settings that are visible in the File>Preferences screen.  All other 
settings are stored in individual data files. 
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Data in Junctions 9 is organised in a hierarchy, which can be viewed via the tree-view style list in the Data Outline 
Screen.  Although use of the Data Outline screen is not strictly necessary in order to view and edit files, it presents 
a summary of the data in the file and provides a convenient way to access items within the file.  At the same time, 
there are many short-cuts within the program for rapidly accessing items; for example, an Arm can be accessed by 
simply clicking on it in the Junction Diagram rather than finding and selecting it in the Data Outline.   

Data in any part of the Data Outline can be accessed and edited in any order - there is no need to fill in data in a 
specific order. 

  

The first line in the tree-view shows the filename for the file being edited.  (To change this, you need to use the 
File>Save As menu option.) 

 

 File Description contains a number of data item fields for describing the file, such as a textual description, job 
number, etc. 

 

 Analysis Sets and Demand Sets contain definitions of analysis and demand sets, which allow you to set up 
data for e.g. different periods of day, or different layout plans.   

 

 Junction Network contains the bulk of data and defines the junction(s) being modelled. 
 

 Options contains a number of additional, advanced options, which are saved with the file. 
 
The screenshot below shows the basic hierarchy expanded by one level, and shows that Junction Network contains 
a single junction, Junction 1.   
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Within each Junction there is a collection of Arms: 

 

Each arm contains data for Capacity modelling and for Accident Prediction (hidden until you turn on accident 
prediction.)  Within the Capacity section can be found most of the important data for each arm. 

  

NOTE: the sections available depend on the options chosen elsewhere, and whether the file is in Advanced Mode. 
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To show/hide the Data Outline, click this icon on the main toolbar. 

 

The Data Outline is used to access most data items within the file.  Items in bold have  
associated data fields that can be edited.    

Clicking any item will show its data or highlight the item in all relevant screens that are currently open, such as the 
Data Editor, Data Grids, Junction Diagram etc. 

Double-clicking an item will show the default editor (Data Editor or Data Grids according to the option set in 
File>Preferences) if it is not already shown.   If the editor is already shown but is locked to another item, then a 
new instance will be shown. 

The Data Outline is also used to add new data items such as junctions and arms, and to remove existing ones.  For 
example, to add a new arm, firstly select any of the existing arms (or the Arms item), and then click the Add 
button.  You can also right-click on any valid item in the Data Outline for similar options.  You can also add/delete 
items via buttons in various other screens, including the Junction Diagram. 

Notes: 

 When adding a new item, the new item's data fields are copied from the Active Data Item.  For example, if 
you select Arm 2 and then click Add, then the new arm will be added to the end of the list and the values 
of its data fields (including its traffic flows) will be the same as those for Arm 2.  This means that you can 
easily make copies of existing items.  To reset data fields to their default values, simply use the Default 
values button on the Data Editor.  However, if you select Arms and then click Add, then a new Arm with 
default properties will be added. 

 If using the Data Outline to add a new Analysis Set or Demand Set, the new set will contain a copy of ALL 
data for the current analysis/demand set.   

 The font size used in both the Data Outline and the Data Editor can be changed by setting 
File>Preferences>Window Font Scheme.   
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To show/hide the Data Editor, click the Data Editor button on the main toolbar, or double-click on a data 
item, or right-click on a data item and select Properties. 

The Data Editor is used to edit data item fields for the Active Data Item.   

 

NOTE: The Data Editor can be resized horizontally in order to make the text-boxes longer.  

NOTE: The font size used in both the Data Outline and the Data Editor can be changed by setting File>Preferences>Window Font 
Scheme.  A similar option switches between bold and regular fonts. 

 
There is no save button on the Data Editor; values are saved automatically whenever you make a change, and 
any other open screens will automatically update.  To save a change, press Enter or Tab or click in any other data 
field, or click on any other screen.  If you make a mistake, use the Undo/Redo buttons on the main toolbar.  The 
Data Editor screen can be left open all the time – there is no need to close it down after having made changes. 

Clicking on any field will show a textual description of the field at the bottom of the screen, along with its units, 
range and default value.   Double clicking on any field (the label, not the text box) will show a glossary screen, 
which can also be accessed via the main Help menu. 

Click the Defaults button to set all fields to their defaults. 

See also: Padlock system. 
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To show this screen, click this icon on the main toolbar. 

 

The Task List shows any warnings or errors in the current file.  Junctions 9 checks the data file every time a change 
is made, and automatically updates the Task List.  As soon as you 'fix' a problem, the Task List will update and the 
error/warning should disappear.  The Task List acts as a central checklist that at any time shows you what needs to 
be done in order to run the file. 

 

Note that the Task List shows problems associated with the data file before it is run in the traffic model.  
Occasionally, errors may only come to light when you try to run the file.  These will then be added to the Task List.  
Therefore it is a good idea to have the Task List displayed at all times, or at least to check it regularly. 

Errors prevent the file from running, whereas warnings serve as reminders that you may want to double check 
something, but will not prevent runs.  Info items are simply for confirmation purposes. In most cases, double 
clicking in the row will open an appropriate screen (or item in the Data Outline) where you can fix the problem. 

If the grid is too small to show the full text of a problem, then either resize the grid or else hover over the 
description to show the full text.  (Alternatively, generate a report, since the Task List items are shown at the top 
of the report.) 
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To show the Units screen, click Data>Units from the main menu. 

NOTE: This section discusses units for data INPUT.  For units for outputs, see Units for data output. 

The Units screen lets you choose between alternative units for data input, as listed below.  (Other items on the 
screen affect results/outputs only – see Units for data output.)  Units can be switched at any time. Please note 
that, when switching units, some data values are automatically updated but others are not; please read through 
this section for further details. 

 

TIP:  All unit options are saved as part of the file (as opposed to user preferences).  You can select default units for 
traffic flows for new files by setting File>Preferences>General>Default Traffic Units and Default Traffic Units 
Period.  This allows you to define that you want all new files to use units of, say, PCU/hr, or veh/min.    

 

 Distance and Speed Units 6.5.1

Choose whether to work in metres or feet and kph/mph or any other available options.  If you have already 
entered data, the data is automatically converted to the new unit type.    NOTE:  some loss of accuracy may result 
due to the rounding of decimal numbers. 

See also:  Measurement Converter. 

 

 Traffic Flows and Traffic Units 6.5.2

You can work with traffic flows (vehicular and pedestrian) per minute, per hour, or per time segment.  When 
switching units, all inputs and outputs automatically appear in the new units. This does not affect the underlying 
data and so units can be switched any number of times. 

For example if the current time segment length is set to 15 minutes, then screens may show a flow of 600 PCU/hr, 
or 10 PCU/min, or 150 PCU/TS*, all of which are exactly equivalent.  

* TS = ‘Time Segment’ 
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NOTE: This affects ALL traffic flow screens.  Always check the units shown in each data editing screen.  For 
example if you have been supplied with 15-minute count data, but the data editing screen shows units of ‘PCU/hr’, 
then you should either 1) multiply your counts by 4 or 2) change the traffic flow input units to ‘per time segment’ 
(assuming the time segment length is 15 minutes). 

 
NOTE:  If working in ‘per hour’ units, traffic flow inputs and outputs such as capacity, demand and so on are shown 
as whole numbers.  If working in ‘per minute’ or ‘per time segment’ units, two decimal places are shown.  You can 
control this behaviour by setting File>Preferences>Appearance>Round flows to whole numbers. 

        

 
 

 PCU/Veh data input 6.5.3

Traffic flows, queues and other traffic data can be expressed either in vehicles or in PCU.  If a heavy vehicle is 
worth 2 PCU and a particular traffic stream is known to consist of 50% heavy vehicles, then each vehicle in that 
stream is equivalent to 1.5 PCU.  If the traffic flow is counted as 100 vehs per hour, this is equivalent to 150 
PCU/hr. 

The vehicle mix (e.g. percentage of heavy vehicles out of the total number of vehicles) always depends on the arm, 
and, depending on which options are used, may also depend on the time segment and the turning movement.  In 
addition, there is a different vehicle mix for entry flows, exit flows and circulating flows – except in the case where 
the vehicle mix on every arm is identical.  Junctions 9 handles all these considerations automatically. 

If you switch between PCU and Veh inputs, some but not all screens will automatically convert the existing inputs 
into the new units.  If in doubt, simply look on the screen to see what the current units are.  If you want to change 
units but keep the actual numerical values (e.g. if you realise you’ve entered data using the wrong unit), you can 
copy data from the screen to the clipboard, change units, and then paste the old values. 

If there are no heavy vehicles, then 1 Veh = 1 PCU.  In this case, it makes no difference whether Vehicles or PCU 
are used.  More usually, however, each vehicle will be worth, say, 1.2 PCU.  Entering a flow of 100 Veh/hr now has 
a different meaning to 100 PCU/hr.   100 Veh/hr is equivalent here to 120 PCU/hr, which is a higher flow than 100 
PCU/hr.   

Note also that if changing between PCU and Vehicles for data input, you will need to re-run the file to see any 
effect on model results. 

NOTE: some input parameters, such as intercept corrections, are ALWAYS entered in PCU.  This is to avoid any potential 
confusion arising from unit conversion. 

NOTE: even if you are working with PCUs, you should still enter values for the Vehicle Mix grid.  This is because some parts of 
the traffic model, such as the queue and delay calculations, always work in vehicles and so the program always needs to be able 
to convert internally between PCU and Vehicles.  (However in practise this will only make a noticeable difference when the RFC 
of an arm is close to 1.0.) 
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NOTE: Whether you enter your demand data in units of Vehicles or PCU, you should always work out the HV% in terms of 
vehicles.   For example if you count 12 cars and 3 heavy vehicles, that is a total of 15 vehicles, or (12+3*2)=18 PCU altogether 
(assuming that a HV is worth 2 PCU) and the HV% would be (3/15*100)=20%.    

TIP: You can select default units for traffic flows for new files by setting File>Preferences>General>Default Traffic Units and 
Default Traffic Units Period.  This allows you to define that you want all new files to use units of, say, PCU/hr, or veh/min.    

 

 

Data Grids provide a convenient way of viewing and editing several rows of data at one time.   

Click the Data Grid button on the main toolbar to show a new data grid, which will show data for the current active 
item (e.g. Arm Geometries, or any other data section).  The grid will show data for all such items in the file. 

 

Click the Full-size-mode to toggle the top and bottom parts of the Data Grid screen on/off.  Turning them off can 
be useful if you are familiar with the data and want to save space on the screen. 

See also: Padlock system 

 

 Grid orientation 6.6.1

You may prefer to lay grids out vertically rather than horizontally.  To do this, toggle the Rotate Grid button.  In this 
mode, you can use the Widths slider to control the width of all columns.   Data grids can be set to appear in 
rotated mode by default by setting File>Preferences>General>Use rotated grids by default. 
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 Selecting items 6.6.2

If working with for example a Data Grid showing all Arms, you can make any Arm the current Active Item by 
clicking on the row header (the grey section at the far left of the row).  Any other windows showing arms data will 
update accordingly.  If the grid is rotated then click on the column header.  In either mode, you can also use the 
Sync button on the main program toolbar. 

TIP:  In some cases you can edit multiple items simultaneously by selecting several cells (by clicking with CTRL or 
SHIFT held down) and then right-clicking and selecting Edit All. 

 

 Using an external spreadsheet 6.6.3

You may find it more convenient to edit or obtain data using an external spreadsheet or any other program.  Copy 
data from any Data Grid to the clipboard using the main application Copy button, which you can then paste into a 
spreadsheet.  Once the data has been edited, make a selection in the spreadsheet that covers the same area and 
then paste this into the Data Grid. 

You can also make a selection within the data grid and then use the right-click context menu to copy/paste that 
selection. 

NOTE: you cannot add in new items in this way; the items must already exist in the file before you can paste data. 

 

 Sorting and grouping rows 6.6.4

Each data grid show rows in the order specified by the Options>Sorting section of the Data Outline, which allows 
you to specify whether items should be sorted alphabetically or numerically and also a number of other grouping 
options, such as grouping all shared arms together. 

You can also sort by any column by clicking on the column header, which will toggle between ascending and 
descending order.  

 

 Adding/deleting rows 6.6.5

To add/delete rows, right-click on any row header (or column header, if the grid is rotated).  This will show a menu 
where you can choose to delete the current row or add a copy of the current row.  You can also add a new row, 
which will use default values for all fields as opposed to copying the current row.   
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 Custom grids 6.6.6

You can swap columns by dragging column headers with the mouse. 

Right-click on any column header to delete that column or to add any other column from the drop-down menu of 
available items.   

You can also add fields by clicking Customise>Add fields from Data Editor; as you click on fields in the Data Editor, 
they will be added as columns to the Data Grid, until you turn off this mode. 

For example to set up a Data Grid to show the ID, Name, Entry Width and Max RFC for all arms, follow these steps: 

1. Press the Data Grid button on the main toolbar to show a new Data Grid 
 

2. Click on any Arm in the Data Outline or in the Junction Diagram. The Data Grid should show all main fields for all 
Arms 
 

3. In the Data Grid, click the Padlock icon so that Data Grid is locked and doesn’t change when you use the Data 
Outline 
 

4. In the Data Grid, select Customise >Remove all Columns 
 

5. In the Data Grid, select Customise >Add fields from Data Editor  
 

6. In the Data Outline, double click any Arm to show the Data Editor.  In the Data Editor, click once in the ID and 
then the Name fields, to add these to the Data Grid. 
 

7. Use the Data Outline to browse to Standard Geometry for any arm.  In the Data Editor, click one in the Entry 
Width field to add this to the Data Grid. 
 

8. Repeat the above process with the other fields.  
 

9. Remember to turn off the Add fields from Data Editor mode, otherwise all other fields that you subsequently 
click on will get added to the Data Grid. 
  

The Data Grid should now look like this: 

 

In the example above, both inputs and outputs are mixed in the same grid.  This system lets you set up whatever 
inputs and outputs you find most useful and, optionally, can also be used in reports. 

NOTE:  If you find that you cannot add a field, it is usually because the field you are trying to add is at a deeper 
level of detail than the original data grid.  E.g. you cannot by default add a time segment result to a grid that 
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originally contained only arm data.  In this case, show a new Data Grid for the most detailed level of data (e.g. time 
segment data), and add/remove columns from there. 

 

 Saving and managing Custom Grids 6.6.7

NOTE:  From Junctions 8.0.4 onwards, data grid definitions are also saved as part of Window Layouts 
(Windows>Window Layouts>Store current).  To some extent this lessens the need to use custom grids.  However 
the facility is still available as it can sometimes be useful for advanced users. 

 

You can save grid layouts by selecting Customise>Store current layout…  This will prompt you to enter a name, and 
this layout will then be available in the Customise menu every time you run the program.  Note that the layout will 
only be applicable to the appropriate data type (e.g. Arms, not Roundabouts), and will only be visible in the menu 
when the data grid is showing this data type.  The saved column layout does not store the fact that it applies to 
Arms and not Roundabouts; you must select an Arms data grid before selecting an Arms column layout. Column 
layouts are saved to your personal user preferences; not in the file. 

Select Customise>Custom Grids Manager to access a screen where you can see all saved grid layouts and 
rename/delete them.  If you tick the IsDefault column then this layout becomes the default layout for that data 
item and will be chosen automatically every time you show an appropriate Data Grid.  

Tick the Use In Reports checkbox if you would like the layout to be used when you generate reports (assuming that 
‘Custom Grids’ is set in the report options).  In this way you can set up your own selection of data which will then 
be populated every time you run a report. 

 

 
Custom Data Grids also appear in the drop-down menu on the main Data Grids button on the main program 
toolbar.  Some built-in data grids are also provided.  When a custom data grid is selected using this button, the 
relevant data section is automatically loaded and the data grid is locked, to prevent it changing when you choose 
other data. 

 

 Filtering rows 6.6.8

If working with a large number of arms or junctions, you can restrict a Data Grid to show only the currently 
selected arm and/or junction.  To do this, use the Filters menu. 



 Data Entry    Page 61     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 

Some screens present data in the form of an origin-destination grid.  Depending on the data, total or average 
rows/columns may also be shown.   

As an alternative to the origin-destination style, the matrices can also arrange columns into ‘1
st

 exit’, ‘2
nd

 exit’ and 
so on.  The last column in this mode always represent u-turners.  To switch modes, use Data 
Outline>Options>Sorting and Display>Data Matrix Style.   

The two screenshots below show the same matrix in each mode. 

 

 

 

Select the Data Field finder from the Help menu or by pressing F3 at any time. 

The Data Field Finder acts as a simple index to all data fields in the program.  It is useful when you are not sure 
where a particular data item is located in the Data Outline. Enter a word or phrase to search for and then click 
Find; any data items that contain the word will be listed.  Select an item from the list and then double click the row 
or click Go to selected item to jump to the first occurrence of that item in the Data Outline.  Note that it is only the 
names of items that are searched for, not the actual values of the data items. 

Please note that fields which are currently disabled or not applicable in the current file may not be listed.  Also 
note that the search only relates to fields that are normally visible in the Data Editor or Data Grids and not 
necessarily those that are only shown in special screens. 
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This section lists some of the main section of the Data Outline in approximate order.  For full details of the data, 
see the appropriate section elsewhere in this User Guide or consult the Appendices. 

NOTE:  Some sections and items are only available if the file is in Advanced Mode.   The sections available also depend on the 
junction type. 

NOTE:  For full details of units, ranges and default values, use the Data Editor and/or the Glossary screen.  Units and ranges are 
not listed in this User Guide unless there is a specific reason to do so. 

 

The File Description contains a number of descriptive fields that help to identify and describe the junction being 
modelled.  All fields are optional.   

 Web links 7.1.1

Expand the File Description part of the Data Outline to access the Web Links section.  By default there are no web 
links but you can add any number of these via the Add button on the Data Outline.   

Web links allow you to specify additional sources of information or references that help to describe the junction(s) 
or the analysis job.  Web links appear as hyperlinks and also appear in generated reports.   

One use of web links is to supply a URL for a map of the junction location. 

Add a new web address by pressing the … button and entering a website URL. 

NOTE: You can also enter addresses that point to locations (including files, folders and applications) on your own PC or on your 
network area.  If you can access a file by entering its address in the Windows Start menu>Run button, you can enter it as web 
link. 

  

 

 

Please see Working with Analysis Sets, Demand Sets and Time Segments for a discussion of Analysis and Demand 
Sets.  The sections shown towards the top of the Data Outline show the defined sets and allow their definitions 
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and properties to be altered, including the start and duration of the modelled period and the time segment length 
for the Demand Set.  To add or delete sets, use the buttons in the Data Outline.   

 

 

This section contains some options that affect ALL junctions in the file, such as the driving side. 

 

 

 

 

     
    This section can be jumped to by clicking this icon on the vertical toolbar.  

 
(alternative appearance when in US Terminology mode) 

 

Each junction has some basic options that can be set here: 
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The ID identifies this junction in the case where there are other junctions in the file, but can otherwise be ignored.  
By default it is simply the number 1,2,3… but it can be overwritten with any short identifier. 

The Name is optional and can be used to further distinguish the junction. 

Also set here the Junction Type.  (See Junction types in Junctions 9 for more information.) 

When the model runs certain Results for Signalised (OSCADY) Intersections 

For Signalised Intersections using the OSCADY model, the main results are for each Traffic Stream.   For this 
junction type, DOS (Degree of Saturation) is shown in place of RFC, but the meaning is equivalent. 

For details of the extra outputs for OSCADY junctions, see OSCADY Outputs. 

 

Whole Junction Results are also shown here. 

For roundabouts, Arm Order determines the order in which arms follow each other (clockwise for drive-on-the-left, 
counter-clockwise for drive-on-the-right).  The arm order is critical to the correct modelling of the roundabout 
because ARCADY needs to know the previous and next arm for any given arm.  Usually the arm order is set 
automatically as arms are added in the Data Outline and you do not need to set the Arm Order manually, but you 
occasionally may need to if you make a mistake or wish to rearrange the arms. 

The order can be set automatically by the program by positioning arms in the Junction Diagram and then clicking 
Tools>Set Arm Ordering.  This will assign the arm ordering to follow the positions of arms in the Junction Diagram.  
The Junction Diagram always shows a confirmation of the arm ordering: if there is a mistake, the circulating links 
will cross over each other and the diagram will appear nonsensical. 

For Priority Intersections, arms are automatically labelled A,B,C,D and the arm order is fixed. 

 

 

Each arm for the junction is located inside the Arms section within the Junction.  For Priority Intersections, the 
number of arms is fixed and depends on the junction type.  For other junction types, use the Data Outline or the 
Junction Diagram to add or delete arms.   
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Each arm has a short identifier (ID) and, optionally, a Name.  The Description is also optional if any further 
information is required. 

Most screens throughout Junctions 9, along with generated reports, can either refer to names by their IDs or by 
their Names.  IDs are usually shorter and take up less space in tables etc, but Names may make it easier to identify 
which arm is which.  This choice can be made by setting Data Outline>Options>Sorting and Display>Show arm and 
junction names.  When using Arm Names, the Data Outline will appear as in the example below, and Data Grids 
will also show full arm names. 

 

 

 

 

If the file is in Advanced Mode, the options in this section allow some additional control over the capacity of the 
arm.  These apply to roundabouts only. 

 

Minimum Capacity and Maximum Capacity:  enter values here if you know that the capacity on the arm should be 
capped to certain values.   

In some cases capacity at a roundabout will never actually drop to zero even though this may be predicted by 
ARCADY, because drivers may become more aggressive in response to extremely busy situations, or other effects 
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may occur.  ARCADY does not model such effects, and they are likely to be localised and specific to particular 
junctions.  Entering a value as the Minimum Capacity will prevent the capacity on the arm from falling below this 
value. 

Conversely, it may be that the capacity on the arm is known to be limited to a certain Maximum Capacity.  This 
may be due to a restriction (e.g. a narrowing) or some other feature on the entry that is not covered by any of the 
geometric parameters or other inputs to ARCADY.  In this case, enter a value here and the capacity will be 
prevented from rising above this value. 

 

Usually, the queue at the start of the first time segment is assumed to be zero.  Sometimes it may be known that a 
queue already exists even before the first time segment.  We would recommend extending the modelled period to 
cover this earlier period, but, if this is not possible, then the Initial Queue can be specified directly.  This will appear 
as the Start Queue in the first time segment’s outputs. 

 

 

 

This section can be jumped to by pressing this icon on the vertical toolbar.  The screen shown depends on 
the junction type. 

For ARCADY and PICADY junctions, see Appendix B - Measurement of geometric parameters affecting capacity for 
full details of the geometric measurements. The Glossary Screen (see Getting help) can be positioned on the 
screen at the same time to provide a reminder and illustration of each parameter. 

NOTE: if parameters are disabled, this may be because you have not registered the relevant module.  Go to 
Help>Manage Licences and check your licence status. 

 

 Roundabout Geometry [ARCADY] 7.7.1

The geometric parameters requested depend on the roundabout type.    See Appendix B - Measurement of 
geometric parameters affecting capacity for full details of the geometric measurements. 

NOTE: Effective flare length is measured in a different way for standard and mini-roundabouts. 
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As with most data in Junctions 9, use of a Data Grid (see Working with data grids) is a convenient way to view and 
edit data for all arms together.   

Also see Measuring roundabout geometries using the junction diagram. 

 

 Priority Intersection Geometry [PICADY] 7.7.2

For Priority Intersections, a set of geometries is entered for: 

 each minor arm.  This includes parameters such as the flare length (if any) and visibilities for traffic 
emerging from the minor arm. 
 

 the area opposite each minor arm.  This covers properties of the major road, such as the major 
carriageway width, measured in the area where traffic on the major road makes an offside turn into the 
minor arm.  (If you look in the Data Outline, you will see that this data is stored on the appropriate major 
arm, so that, for example, the geometry measured opposite Arm B is stored on Arm C, because Arm C 
carries offside-turners into Arm B.  This is true for all junction types.) 
 

 

The easiest way to enter geometries for Priority Intersections is to press the Geometry button on the 
main vertical toolbar.  This will take you to a special Priority Intersection Geometry screen.  Select an arm 

to edit via the options at the top of the screen.   
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See Appendix B - Measurement of geometric parameters affecting capacity for full details of the geometric 
measurements. 

As with all of Junctions 9, you can use the Glossary Screen (see Getting help) to show details of most of the 
measurements. 

Advanced users may alternatively wish to use the two shortcuts on the Geometry button, which will take you to 
the appropriate place in the Data Outline.   

 

 

 Signalised Intersection Geometry [OSCADY] 7.7.3

For OSCADY junctions, the Geometry button is replaced with a Streams button which will take you to the first 
OSCADY Traffic Stream in the Data Outline.   
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These sections show results from the traffic model after the file has been run. Please see Traffic Model Outputs. 

 

For Priority Intersections, a set of streams relevant to the current junction type is listed within this section of the 
Data Outline.  The streams also depend on various junction features, such as the presence of pedestrian crossings, 
the minor road type, etc.   

The Streams section of the Data Outline contains mostly the model results for each stream. 

Clicking on any stream will highlight it in the Junction Diagram Screen. 

See Results for Priority Intersections for more details. 

 

 

 

The Options section of the Data Outline provides some options which are saved in the file rather than as user 
preferences.  If you wish to always use the same options, we recommend setting the options in a blank file and 
then saving the file as a template file that you can load whenever you launch the program.   

The options here apply to the entire file. 
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 Sorting and Display Options 7.10.1

 

Show arm and junction names:  Tick if arm and junction names rather than IDs should be shown in the Data 
Outline, Data Grids, reports, matrices and so on.  Also tick Include arm and junction IDs if you would like both the 
ID and the name to be shown. 

Hide Priority Streams:  For Priority Intersections, tick this to hide priority streams (e.g. C-A; streams that have no 
queue and delay results) from lists of results. 

Hide exit lanes:  If using Lane Simulation Mode, tick this to hide exit lanes from results.  (They will still be modelled 
but their results will be hidden.) 

Analysis/demand set sorting:  This controls whether analysis and demand sets should be sorted in the Data Outline 
and the main toolbar dropdowns by their ID or their name.  

The other options in this screen control the type of ordering used in lists of arms/streams, and the column 
ordering within data matrix screens. 
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 Analysis Options 7.10.2

 

Vehicle Length: This option allows the vehicle length of a light vehicle/car (i.e. 1 PCU equivalent) to be changed. 
The distance represents the spacing of vehicles in a stationary queue from front bumper to front bumper. The 
default value is 5.75 metres.  This is used when estimating queue lengths from PCU values and when showing 
queues in the Junction Diagram but otherwise does not affect the model. 

Calculate Queue Percentiles: Switch this on to activate queue variations and queue marker outputs (see Queue 
Variations (percentiles) and Queue Markers) 

Calculate detailed queueing delay:  Switch this on to show extra queueing delay results (see Queuing Delay) 

Calculate Residual Capacity:  This is automatically turned on if you select Network Residual Capacity in the 
Summary Results screen.  See Residual Capacity . 

RFC/Delay/Queue Threshold:  Any values that exceed these thresholds will be highlighted in red. 

 

 Lane Simulation Options 7.10.3

See Lane Simulation Mode. 
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There are three components of traffic flow data that must be entered into any Junctions 9 file: 

 Demand (the volume of traffic wishing to use a junction) 

 Turning Proportions 

 Vehicle Mix  

There are a number of different ways and combinations that this data can be entered, depending on the level of 
detail of the data you have available.  There are several screens in Junctions 9 corresponding to the items above, 
which can be used in various combinations.  

It is common to enter demand in the form of an origin-destination matrix, in which case a single set of data covers 
the first two items in the list above. 

 
NOTE: Units for traffic demand in all relevant screens can be chosen via the Data>Units screen (see Units for data 
input). 

NOTE: When measuring demand, or turning counts, you should measure demand at a point further upstream 
from the junction than the maximum queue encountered.   A common cause of error is to measure demand at 
the roundabout itself, which will in fact mean that you are measuring entry flows rather than demand.   

 

 

 

 
Press this button on the vertical toolbar to show the O-D Screen 

 
Turning proportions specify the proportion of traffic that turns in each direction from each arm at the junction.  It 
is common to specify the demand itself as an origin-destination matrix, in which case both the demand and the 
turning proportions are implicit in a single set of data.  Alternatively, you can enter demand and turning 
proportions separately. 

Please note that when measuring origin-destination demand, you should measure demand at a point further 
upstream from the junction than the maximum queue encountered.   A common cause of error is to measure 
counts at the roundabout itself, which will in fact mean that you are measuring entry flows rather than demand.  
(The demand should reflect the volume of traffic that wishes to use the junction, for each movement.) 

 
NOTE:  O-D data is entered either as PCU or Vehicles (as selected on the Data>Units>Traffic Unit>Inputs screen).  50% of PCUs 
turning left is not the same as 50% of vehicles turning left, although, this difference will be negligable if the proportion of heavy 
vehicles is low. We recommend choosing between Vehicles and PCUs before entering data. 

NOTE: Everything shown in the O-D Screen relates to the current Demand Set.  (See Demand Sets).   To select a different 
Demand Set, use the Demand Set drop-down list at the top of the main screen. 

NOTE: Everything shown in the screen relates to the current junction.  To select a different junction, select any item within that 
junction in the Data Outline or the Junction Diagram, or use the Junction drop-down list on the main vertical toolbar.  Use the 
padlock to lock the screen, i.e. prevent it from changing when you click on other junctions. 
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NOTE:  The screen will be locked if values do not vary over time and a time segment other than the first time segment is 
selected. 

TIP: You can choose whether the Turning Counts screen should arrange its columns either by destination or by movement (as 
shown in the two screenshots below) by setting Data Outline>Options>Sorting and Display>Data Matrix Style. 

   

 

 

 Entering O-D demand data directly 8.1.1

If you have demand data in the form of O-D matrices, then you should: 

 Enter the O-D data directly in the O-D screen. 
 

 In the Demand Screen, check that Use O-D data is ticked for each arm. By default in a new file this will 
 already be ticked.  (If this option is NOT ticked then Junctions 9 will treat the O-D data purely as turning 
proportions and will expect you to enter the actual demand volume elsewhere; see the next section.) 

The actual demand that the traffic model uses for each time segment will be based on this entered data and will 
optionally be ‘shaped’ into a typical peak period curve according to the currently selected traffic profile type. 

 

 Using demand and turning proportions separately 8.1.2

If you know that, for example, the demand on Arm 1 is 600 PCU/hr in total and you know separately that 25% 
turns left, 50% straight on and 25% turns right, then you can EITHER: 

 Convert this information into O-D data and enter it directly as described in the previous section.  I.e. enter 
150, 300 and 150 PCU/hr as the O-D demand for Arm 1. 
 

 Then, In the Demand screen, tick Use O-D Data.  The Average Demand in this screen will automatically 
appear as 600, i.e. the total of the O-D data. 

OR 
 

 In the O-D screen, enter the proportions directly.  You could enter 0.25, 0.50, 0.25, or 25, 50, 25, or 
indeed 150, 300, 150; these all represent the same proportions and the actual volume does not matter. 
 

 Then, in the Demand screen, un-tick Use O-D Data, and manually enter the total demand (600) in the 
Average Demand field.  
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The actual demand that the traffic model uses for each time segment will be based on this entered data and will 
optionally be ‘shaped’ into a typical peak period curve according to the currently selected traffic profile type. 

 

 

 Calculations and Options tabs 8.1.3

NOTE: some of these items are only available if the current file is in Advanced Mode. 

The Calculations tab of the O-D screen shows some read-only values which are calculated by Junctions 9.  For 
examples of the use of these tabs please see  Traffic flows – numerical overlays. 
 

Options>Varies Over Time:  tick this if different movement volumes or proportions are available for each time 
segment.  (If not, they are assumed to apply to the whole modelled period).  In this mode, use the time segment 
drop-down selector at the top of the main screen to select each time segment; the turning grids will update to 
show data for each time segment. 

Options>Estimate from entry/exit counts: Sometimes it may be that turning proportions are not available, but a 
set of entry and exit counts on each arm exists instead.  In this case, turn on this option and enter exit counts in 
the Exit Counts tab of the Demand Screen.  The O-D data will then be automatically updated to give an estimate of 
turning proportions as derived from the entry and exit counts. 
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The Demand Screen is used to specify or to check Demand Flows and to set up some advanced options.   
If using O-D data directly then use of the Demand Screen is not strictly necessarily but it is still a good 
idea to check the data shown here. 

 
The screenshot below shows an example of the Demand Screen.  The large blue button at the top confirms that all 
flows on the screen are Traffic Demands as opposed to the other possible options of Exit Counts or Pedestrian 
Demand.  If these options are available, they will also appear at the top of the screen. 

 

The rest of the screen is split into two parts.  The upper part allows you to specify the type of traffic profile for the 
current Demand Set (which can also be set by editing the Demand Set’s properties directly), and various options 
for each arm.    

By default, each arm in the upper grid has Use O-D data ticked, which means that the demand is based on the 
values entered in the Origin-Destination (O-D) screen. 

The lower part of the screen always shows a read-only set of demands for each arm for each time segment. This 
summarises and confirms the demand resulting from whatever traffic profile is selected for each arm along with 
any other options such as flow scaling factors.   The Calculations>Model Demand tab in the O-D screen shows 
corresponding data for each movement. 

 
NOTE: Everything shown in the Demand Screen relates to the current Demand Set.  (See Demand Sets).   To select a 
different Demand Set, use the Demand Set drop-down list at the top of the main screen. 
 
NOTE: Everything shown in the screen relates to the current junction.  To select a different junction, select any item 
within that junction in the Data Outline or the Junction Diagram, or use the Junction drop-down list on the main vertical 
toolbar.  Use the padlock to lock the screen, i.e. prevent it from changing when you click on other junctions. 
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In the screenshot below, all arms have a ONE HOUR traffic profile.  There are three arms and the modelled period 
covers 0800-0930, split into six 15-minute time segments.  The traffic demand for each arm is specified by the 
Average Demand value.  This in turn can either be entered directly in this screen (as on Arm 3) or else, as on the 
other arms, can be automatically based on O-D data, which is entered in the Origin-Destination (O-D) screen. 

 

In this case the total demand on Arm 1, based on data from the O-D screen, is 400 PCU/hr.  The ONE HOUR profile 
shapes this demand into a ‘peak profile’, where the demand for the first time segment starts off lower than the 
entered demand (about 75%), rises to a higher value and then decreases again.  (All the profile types except for 
FLAT and DIRECT assume that the user is modelling a peak period and therefore assume that the traffic demand 
rises to a peak roughly in the centre of the modelled period and then declines.)  This is confirmed in the resultant 
demand shown in the lower grid.  You will see the same numbers in the Demand output of time segment results 
when you run the traffic model. 

Note that Arm 2 has the same average demand as Arm 1, but the user has specified a Flow Scaling Factor of 200% 
and so the resultant demand for Arm 2 is double that of Arm 1. 

NOTE:  Usually, all arms use the same profile type based on the profile type of the current Demand Set (indicated 
by square brackets in the Profile Type column in the upper grid).  If necessary you can set a different profile types 
on an individual arm by editing the Profile type column. 

 

The following sections describe the alternative traffic profiles available.   

 

 

 

 

 



 Working with Traffic Flows    Page 77     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 FLAT traffic profile 8.2.1

In a FLAT profile, the demand is the same for each time segment. 

 

 DIRECT traffic profile 8.2.2

DIRECT mode allows direct entry of demand for each time segment.   

If you have accurate data then DIRECT profiles can be the most accurate method of entering flows.  However, you 
should be careful to avoid simply replicating noise in your data.  Using one of the other profile types (e.g. ONE 
HOUR) has the advantage of smoothing out any noise and generating a smooth profile.   

If you know that the traffic profile at the junction is unusual – for instance, two distinct peaks within the modelled 
period – and that this pattern is consistent and predictable from day to day - then you should use a DIRECT profile.   
Please note a single set of traffic observations that happens to show random variations from one time segment to 
the next would NOT fall into this category. 

There are two ways of using a DIRECT profile: 

1. Tick Use O-D data and in the O-D screen, tick Options>Varies over time.  Then enter an O-D matrix for 
each time segment. 
 

2. Un-tick Use O-D data. A DIRECT tab will then become available in the Demand screen, where you can 
enter the demand for each time segment.   Data in the O-D screen will then represent turning proportions 
for the relevant arms, and this in turn can either be entered for each time segment, or just once for the 
whole period. 
 
 

 ONE HOUR (ODTAB) traffic profile  8.2.3

If a one-hour peak period is to be modelled then Junctions 9 can estimate the traffic profile based on a single 
demand measurement for the hour.  This is based on assumptions about the typical shape of the traffic profile at a 
typical site and so may not be suitable for all sites.  An example of such a synthesised curve is shown below: note 
that it is symmetrical either side of the centre. 
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NOTE: When using the ONE HOUR profile type, traffic demand is entered for a single hour, but the synthesised flows include an 
extra 15 minutes either side of this period to allow for typical warm-up and run-down periods either side of the central hour.  
Therefore the actual modelled time period is always 90 minutes and you will see SIX time segments in the results (if using 15-
minute time segments).   However you can optionally choose to show only the central hour in the results and hide the warm-
up/run-down segments, by selecting the Results for Central Hour Only option of the current Demand Set.  This option simply 
hides the results for the other time segments, and does NOT affect the model itself. 

NOTE: Because the demand entered is measured over one hour, the name of this profile is ONE HOUR.  (In older versions, the 
term ODTAB was used but this would imply that the data must be entered in the form of an OD matrix.  Although using an OD 
matrix is the most common application of the ONE HOUR profile, it is not the only way of using it.) 

NOTE: Using ONE HOUR mode together with the Use O-D data option is equivalent to the ODTAB mode in ARCADY 6/PICADY 5.  
Normally in this mode, turning counts should not vary over time, as the ONE HOUR synthesis will deal with the time-varying 
aspect.  If turning counts DO vary over time, then using a DIRECT profile with Use Turning Counts turned on would be more 
appropriate. 

 

Optionally, it is possible to synthesise a profile in ONE HOUR mode by turning off Use O-D data and then simply 
entering a single number as the Average Demand for each arm, which should represent the overall demand for a 
60-minute period.  Junctions 9 will then form a profile based on this single value, adding an extra 15 minutes either 
side of the central period, again making up a 90-minute modelled period.  The screenshot below shows this: the 
ONE HOUR profile is selected and the average hourly flow on Arm 1 has been entered as 800 PCU/hr.  This has 
been ‘shaped’ into a varying profile.  Note that the average of the 4 central time-segment values is equal to 800 
PCU/hr. 

demand flow

t1 t2 t3 time
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 LEVELS traffic profile  8.2.4

In LEVELS mode, the user sets up a peak profile by entering the times when the flow begins to rise, when it reaches 
a peak and when it stops falling, and the flow associated with each point. The figure below shows the 'theoretical' 
shape of a synthesised profile in which each part of the central (peak) region forms part of a normal curve.   

 

The figure below shows the histogram produced when the time period is divided into eight time segments. These 
diagrams show the required input parameters: q1 is the pre-peak flow, t1 the time of onset of the peak, q2 the 
flow at the height of the peak, t2 the time that this occurs, t3 the end of the peak and q3 the post-peak flow.  
These may differ from arm to arm.  The exponential term ('shaping term') in the equation of a normal curve is used 
to obtain appropriate values of q between the fixed points t1 and t2 and between the fixed points t2 and t3. The qi 
(i = 1 to 3) values act as scaling factors. 

Demand flow

q2

q3

q1

t1 t2 t3 time
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If a LEVELS profile is selected for any arm, then the LEVELS tab of the Demand Screen becomes available.  Use the 
upper grid to enter the LEVELS data.  As data is entered, the lower grid will automatically update to show the 
synthesised flows.  In the example below, the peak of 500 PCU/hr is reached at 30 mins into the modelled period.  
There is no time segment centred on 08:30 so the two time segments either side show a flow lower than 500. 

TIP:  You can choose whether to work with ‘relative’ or ‘absolute’ times.  If a demand set starts at 08:00, then an absolute time 
of 08:30 is the same as a relative time of 30 minutes.  Set this option via Data Outline>Options>Sorting and Display>Time Style. 

 

The Time Graph mode in the Analyser Screen can be used to quickly plot the direct flows to reveal the shape of the 
profile.  (Alternatively the lower grid can be copied to the clipboard and then pasted into a spreadsheet.) 

q1

t1 t2 t3 time

q3

q2
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 FOUR traffic profile  8.2.5

Traffic demand data may be available for a series of consecutive one-hour periods, which can be used as the basis 
for a peak period curve. 

 

Again the profile is assumed to be a normal curve, as illustrated above.  From the four hourly counts the program 
calculates the required parameters, and hence the demand flow in each time segment..  This option may be used 
only where the flows for the four hours (q1, q2, q3 and q4) are such that q2>q1 and q3>q4.  

If a FOUR profile is selected for any arm, then the FOUR tab of the Demand Screen becomes available.  Use the 
upper grid to enter the FOUR data.  As data is entered, the lower grid will automatically update to show the 
synthesised flows.  When using FOUR, the modelled period is expected to be four hours, i.e. 240 minutes – if not, a 
warning is shown in the Task List but ARCADY will continue as usual.  

demand flow

1st hour 2nd hour 3rd hour 4th hour time

q4

q3

q2

q1
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The Time Graph mode in the Analyser Screen can be used to quickly plot the direct flows to reveal the shape of the 
profile.  (Alternatively the lower grid can be copied to the clipboard and then pasted into a spreadsheet.) 

 

 

 PHF (Peak Hour Factor)  8.2.6

Junctions 9 offers the ability to synthesis a simple traffic profile based on a known PHF and hourly traffic flow.  
Note that this method makes a number of assumptions and is not recommended unless this is the only source of 
data. 

Peak Hour Factor (PHF) is defined (US HCM 1994)   as  

PHF = hourly volume / peak rate of flow within the hour 

Typically PHF uses 15 minute periods i.e. 

PHF = (V1 + V2 + V3 + V4 ) / (4* the greater of (V2 or V3)) 

where Vn is the flow or volume within each 15 minute segment  (flow per 15 mins) 

 The higher the PHF, the smoother the traffic profile. 
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If the profile type to PHF, the current Demand Set is automatically set to contain 4 x 15-minute time segments.  
The PHF tab of the Flows Screen then shows the following columns: 

Hourly Volume:  this is simply a repeat of the Average Demand shown on the main tab. 

Peak Hour Factor:  enter the PHF value; it is automatically copied to all arms. 

Peak Time Segment:  you can choose which time segment should contain the peak of the profile.    

For the current Demand Set, if you tick Single Time Segment only, then the Peak Time Segment option becomes 
irrelevant and the PHF profile simply gives a demand flow of [hourly volume/PHF]. 

 

  

 Pedestrian Demand 8.2.7

If any arm has a crossing, then Pedestrian Demand can be edited in the Demand Screen.  Choose the Pedestrian 
Demand button at the top of the screen and then use the upper and lower grids as usual.  Each crossing can have a 
different profile type and can be set up in the same way as normal traffic profiles. 

NOTE: You can also enter pedestrian demand directly as one of the properties of the crossing itself, which will 
usually be simpler unless specifically needing to set up a profile type for the pedestrian demand.  
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Press this button on the vertical toolbar to show the Vehicle Mix Screen 

See also:  PCU/Veh data input. 

Modelling traffic at a junction requires knowledge of the vehicle mix at the junction.  Some parts of the model 
work with PCUs (Passenger Car Units) and others with Vehicles, and although you only need to enter one or the 
other, a vehicle mix is required in order for the program to convert between PCUs and Vehicles. 

In Junctions 9, a full set of vehicle classes is not required and instead there are two modes that the user can choose 
from:  (Vehicle Mix Source option in the Options tab of the Vehicle Mix screen.) 

1. Heavy Vehicles Percentage (HV%) mode:  A set of percentages of heavy vehicles is entered.  This is the 
default setting. 
 

2. PCU Factors mode:  A set of ‘average PCU per vehicle’ values is entered.   

Both modes are used in conjunction with a value that tells the program the average PCU value of a ‘Heavy Vehicle’ 
(HV).  The definition of ‘Heavy Vehicle’ is left to the user and is really no more than a label, but is intended to 
represent ‘heavier than usual’ vehicles.  The usual definition within Junctions 9 is that a heavy vehicle is defined as 
a vehicle with more than four tyres in contact with the road, including any trailer, and it has a PCU factor of 2.0.  
You may wish to adjust this for use in your region, via the Options tab. 

Whichever mode is used, values for the other mode are always calculated automatically by the program. The basic 
relationship PCU = Veh x AveragePCUPerVeh applies to any data that involves PCUs or vehicles.  If a full set of 
vehicle classes is available, or if accurate PCU factors for each stream are known, then the Average PCU Per Veh 
values can be entered directly.   

 

NOTE: even if you are working with PCUs, you should still enter values for the Vehicle Mix grid.  This is because some parts of 
the traffic model, such as the queue and delay calculations, always work in vehicles and so the program always needs to be able 
to convert internally between PCU and Vehicles.  (However in practise this will only make a noticeable difference when the RFC 
of an arm is close to 1.0.) 

NOTE: Whether you enter your demand data in units of Vehicles or PCU, you should always work out the HV% in terms of 
vehicles.   For example if you count 12 cars and 3 heavy vehicles, that is a total of 15 vehicles, or (12+3*2)=18 PCU altogether 
(assuming that a HV is worth 2 PCU) and the HV% would be (3/15*100)=20%.    
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NOTE: Everything shown in the Vehicle Mix Screen relates to the current Demand Set.  (See Demand Sets).   To select a different 
Demand Set, use the Demand Set drop-down list at the top of the main screen. 

NOTE: Everything shown in the screen relates to the current junction.  To select a different junction, select any item within that 
junction in the Data Outline or the Junction Diagram, or use the Junction drop-down list on the main vertical toolbar.  Use the 
padlock to lock the screen, i.e. prevent it from changing when you click on other junctions. 

NOTE:  The screen will be locked if values do not vary over time and a time segment other than the first time segment is 
selected. 

 

 Vehicle Mix screen options 8.3.1

If necessary, use the Options tab to choose a Vehicle Mix Source mode.  Check that the PCU Factor for a HV value is 
sensible. 

 

When Vehicle Mix Source is set to HV Percentages (the default setting), the HV% tab is enabled, otherwise the PCU 
per Veh tab is enabled.   Values in the disabled tab will automatically update based on the values from the enabled 
tab. 

Use Vehicle Mix Varies Over Time if different factors are available for each time segment.  (If not, they are 
assumed to apply to the whole modelled period).  In this mode, use the time segment drop-down selector at the 
top of the main screen to select each time segment; the data grids will update to show data for each time 
segment. 

If Vehicle Mix Varies Over Turn is turned off, then a single value is entered for each arm, which is assumed to 
apply to each exit from that arm.  E.g. if 25% is entered for Arm A, then this applies to ALL traffic entering the 
roundabout on Arm A, regardless of destination.  

If Vehicle Mix Varies Over Entry is turned off, then values are entered for the first arm only, which are assumed to 
apply to all other arms.   

If both of the above options are turned off, then a single value is entered for the entire junction. 

 

 Effects of changing Vehicle Mix on inputs and outputs 8.3.2

Consider firstly a simple file where there are no heavy vehicles and the Average PCU Per Veh for all arms is 1.0.  In 
this case, 1 Vehicle = 1 PCU.  The demand on each arm is entered as 10 veh/min and the RFC (on each arm) 
happens to be 0.85. 
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A datagrid showing custom columns can be used as a convenient way of checking demand input, output and RFC, 
as shown below.  The Average Demand is the flow as entered in the Demand screen, and can be edited directly via 
the data grid.  The other two columns are shown in green because they are outputs from the model.  The Demand 
column shows the final traffic demand as used in the model, after all scaling and any other effects, and is treated 
as an output.  Usually it will be the same as the input demand. 

 

In this case, both the input and output demands are shown in veh/min and both show 10, as expected.  If the 
Data>Units screen is used to switch to PCUs instead of Vehs, there will be no change, because in this file there are 
no heavy vehicles and so 1 PCU = 1 Veh. 

Consider now changing the Vehicle Mix so that there are 50% heavy vehicles on all arms, giving a corresponding 
Average PCU per Veh factor of 1.5 for each arm. 

 

If the file is re-run, the flows are still shown in vehicles but the RFC has now increased.  The junction contains more 
heavy vehicles than before, so the performance is worse.  Queues and delays will also be found to be worse.   

 

If the Data>Units screen is used to select PCU as the unit for outputs, then as shown below the Demand column 
now shows 15 PCU/min, as expected. 
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Suppose now that you want to enter the flows of 15 PCU/min directly.  In this case, select PCU as the unit for 
inputs, enter 15 directly for each arm and re-run.  Both columns now show 15 PCU/min.  In this mode, a vehicle 
mix still needs to be entered so that the program can calculate the number of vehicles on each arm, as used in 
queue and delay calculations.  

 

See also:  Units for data input;  Units for data output 

 

Sometimes you may want to enter a single set of demand and HV% data and apply this to several junctions.  This 
can be useful when comparing junction types and saves having to enter (and keep updating) traffic data for each 
junction. 

If, for example, you want Junction 2 and Junction 3 to both use the same flows as Junction 1, then you would: 

- Go to the properties of Junction 2  
- Tick the Copy Flows option  
- Enter the ID of Junction 1 as the Junction to copy flows from 
- Repeat for Junction 3 

 

All relevant traffic flow screens such as the O-D,  Demand and Vehicle Mix screens, will then be read-only when 
looking at Junctions 2 or 3, and will contain a copy of data from Junction 1.   If you change the flows for Junction 1, 
it will automatically be copied into Junctions 2 and 3. 

NOTE:  For comparing layout options, you can also use Analysis Sets, but different junctions are required if comparing different 
junction types, or if there are different numbers of arms or any other ‘structural’ changes. 
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Results (outputs) are generated when you run a file (see Running Files ). There are several types of results, 
 including: 

 Results for each arm/stream for each time segment (e.g. delay on Arm 1 for time-segment ending 08:15) 

 Results for each arm/stream for the whole modelled period (e.g. average delay on Arm 1 for 08:00-09:00) 

 Summary results for each Analysis/Demand set, shown in the Summary Results screen. 

 
Results can be viewed in various places, such as: 

 Summary Results screen 

 Data Outline sections (use the Results button on the main toolbar to jump to these sections) 

 Reports  

 Junction Diagram overlays 

 
NOTE:  Remember that results are those from the last successful run of the traffic model.  If you subsequently 
change input data but don’t re-run the model, then the results may be inconsistent with the current data file.  In 
general, results are shown with a red background if the file has changed since the last run; this will change to a 
green background once the file has been run. 

TIP:  To compare results between different runs or files, see Comparing files and data sets. 

 

 

To show the Units screen, click Data>Units from the main menu. 

The Units screen lets you choose between alternative units for data output, as listed below.  (Other items on the 
screen affect inputs only – see Units for data input.)  Units can be switched at any time.   

Note that all unit options are saved as part of the file (as opposed to user preferences).   
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 Traffic Flow Units 9.1.1

You can work with traffic flows (vehicular and pedestrian) per minute, hour, or time segment.  When switching 
units, all inputs and outputs automatically appear in the new units. This does not affect the underlying data and so 
units can be switched any number of times. 

For example if the current time segment length is set to 15 minutes, then screens may show a flow of 600 PCU/hr, 
or 10 PCU/min, or 150 PCU/TS*, all of which are exactly equivalent.  

* TS = ‘Time Segment’ 

NOTE: If working in ‘per time segment’ mode, note that this affects ALL traffic flow screens.   

 

 PCU/Veh data output 9.1.2

Traffic flows, queues and other traffic data can be expressed either in vehicles or in PCU.  If a heavy vehicle is 
worth 2 PCU and a particular traffic stream is known to consist of 50% heavy vehicles, then each vehicle in that 
stream is equivalent to 1.5 PCU.  If the traffic flow is counted as 100 vehs per hour, that is equivalent to 150 
PCU/hr. 

Outputs are available in both PCUs and Vehicles.  If the vehicle mix is changed, you must re-run the file. 

The choice of PCU/Veh is set separately for inputs and outputs.  The output unit can be switched at any point and 
the results screens will automatically update to reflect your choice. 

Generally outputs displayed in PCU will be larger numbers than when displayed in Vehs. 

See also: Vehicle Mix screen. 

 

 Delay Units 9.1.3

There are three types of delay used in results: 

1. Average Delay: This is the delay, in seconds or minutes, experienced by an ‘average’ vehicle.  This may 
appear in some outputs simply as ‘Delay’ or as ‘Average delay per arriving vehicle’.  It is used as the 
measure of delay shown in the Summary Results Screen, and for the Max Delay output in whole period 
results, and is also used for Level of Service and for Point-to-point journey times. 
 

2. Total Delay:  This is the total delay experienced by a quantity of traffic in a given time period, in units of 
vehicle-minutes, or PCU-hours, for example.   This is useful if, for instance, you are performing an 
economic comparison and need to know the TOTAL delay experienced by all traffic. 
 

3. Rate of Delay: This is the total delay in a given time period, divided by the time period length – i.e., the 
rate at which delay accumulates over the time period.  Its units are veh-min/min, or PCU-hr/hr, for 
example.  When applied to queueing delay, the units of veh-min/min are equivalent to veh, and the rate 
of queueing delay is equivalent to the average queue at any given time.   
 

For example, consider a 10-minute period where the queue, observed every minute, is observed to be 5 vehicles 
long.  This could represent 10 successive queues of 5 vehicles each, where each vehicle is delayed for one minute, 
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giving a total delay of 10 x 5 = 50 veh-min.  Alternatively it could be the same 5 vehicles, all delayed by 10 minutes.  
Again this would give the same total delay of 5 x 10 = 50 veh-min.  In both cases the rate of delay is 5 veh-min/min, 
or 5 veh.  Of course in reality the situation will be somewhere between these extremes and the queue length itself 
will vary over time.  The Average Delay (per Arriving Vehicle) is the most useful output to determine how long each 
vehicle is actually likely to be delayed for. 

 

 

 
The Summary Results screen shows a summary of the results from the last run of the file.  It is shown 
automatically whenever you run the file (unless you turn off Preferences>General>Show Summary 
Results screen after running model).  To show results from the last run, you can also click this button 

on the main vertical toolbar. 

  

The results shown in this screen represent the ‘worst’ values over all time segments – generally, the highest 
values.  Note that these may come from different time segments; for example, the longest queue for a particular 
arm may occur during a different time segment to when the highest delay occurs, which in turn may differ 
between arms.  The values shown here are also available through the Data Outline in the Whole Period Results 
sections.  For more detailed results, study the individual time segment results, or generate a report. 

 Use the Show menu to control whether to show all Analysis and Demand sets (as shown in the 
screenshot), or, more simply, only the currently selected set.  See Analysis/Demand Sets and Summary 
Results for a full discussion of the use of the Summary Results screen with Analysis and Demand Sets. 
 

 If showing all sets, then a bold font is used for the results for the currently active Analysis/Demand set 
pair. In the screenshot above, the user is currently working with the proposed layout for the 2020 AM 
scenario, which corresponds to the bottom-left segment of the Summary Results screen and so these 
results are shown in bold. 
 

 Use the Columns menu to control which results should be shown.  See also:  Queue Variations 
(percentiles) and Queue Markers and Residual Capacity. 
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 Colour-coding is used to indicate where values exceed user defined thresholds, which can be set in Data 
Outline>Options>Analysis Options. 
 

 If working with multiple junctions, you can filter the results to the currently selected junction only by 
turning off Mode>Show all junctions. 

As with all other outputs, a green background indicates that the results are up to date.  A red background 
indicates that the file has changed since the last run and that you should re-run the file.  In the screenshot above, 
the user has made a change to the traffic flows for the 2020 AM period.  Therefore the summary results for both 
the existing and proposed layout for 2020 AM are shown with a red background.  They will turn green when each 
set is run – either one at a time, or by clicking Run Model>Run all data sets on the main Junctions 9 toolbar. 

NOTE:  Results for all Analysis/Demand sets are stored in the file.  This means that even if showing results for one set at a time, 
you can change set and the results for that set will be shown.  (This is in contrast to Junctions 8 and earlier, where the results 
for only one set at a time were stored.) 

 

 

Click this icon on the vertical toolbar to jump to the Time Segment Results section of the Data Outline 
for the current junction.  This will be for arms, streams or lanes, depending on the junction.  
Alternatively, use the drop-down arrow to choose which results to show.  Depending on options in 
File>Preference it may show the Data Editor or a Data Grid. 

Remember that the results shown on screen are for the currently selected time segment only.  To change time 
segment, use the time segment drop-down selector at the top of the main screen. 

To display results for all arms/streams together, use a Data Grid.  (See Working with data grids for more details.) 

It is not possible to display results for all time segments together in a grid but such tables are printed when you 
generate a report.  The Time Graph Mode of the Analyser Screen is also a convenient way to quickly show how 
values vary over time. 

It must be stressed that the calculated queues and queuing delays are average values of broad distributions, and 
considerable variation about these values will be encountered in practice. In fact, day-to-day variations in the 
queue-lengths and delays can occur at any given time in the peak period. 

The number of outputs shown depend on whether the file is in Advanced Mode.  The screenshot below shows the 
Data Editor for a roundabout file in Advanced Mode. 
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Total Demand: This shows the total traffic demand on the arm, after all scaling effects.   

Junction Arrivals:  The total number of vehicles or PCU that arrive during this time segment (= demand x time 
segment length) 

Circulating Flow:  This is the calculated circulating flow past this arm (for roundabouts only) 

Throughput (or Entry Flow):  This is the calculated throughput across the give-way line.  It is the lower of the 
demand or the capacity during the time segment, as shown by the blue line in the graph below.  The graph shows 
the demand (green line) rising steadily as the network flow scaling factor is increased.  The capacity (red line) 
decreases as the junction becomes busier.  The throughput (blue line) initially follows the demand but is then 
restricted by the capacity, and then falls in line with the decreasing capacity.  At the point where the demand is 
close to capacity (i.e. RFC is around 1.0), the throughput is less than both the demand and the capacity.  This is due 
to the random nature of traffic arrivals and random queueing theory.  When the RFC is close to 1.0, this 
randomness is most noticeable and means that vehicles may randomly bunch up and cause momentary queueing, 
which results in the throughput being less than the theoretically available capacity.  At lower flow rates, this 
randomness has little effect, and at higher flow rates, there is likely to be continuous queueing which will negate 
any randomness.  
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Throughput (exit side) (or Exit Flow):  This is the calculated flow OUT of the junction on this arm.   

Pedestrian Demand: The two-way pedestrian flow (if any) across the arm. 

Capacity: The calculated capacity of the entry.  See the graph and discussion above. 

RFC:  Ratio of flow to capacity.  The RFC provides a basis for judging the acceptability of junction designs and 
typically an RFC of less than 0.85 is considered to indicate satisfactory performance.  This depends however on the 
context of the study and so the user’s own judgement is also required.  Also known as V/C ratio (traffic 
volume/capacity ratio). 

For Priority Intersections, a ‘satisfactory’ RFC depends on the speeds encountered at the junction. The capacity 
formulae used in PICADY were mainly developed from studies at UK major/minor junctions on public roads.  Most 
of these junctions had major roads with speed limits of 50 mph or less.  At high-speed major roads, a lower RFC 
(e.g. 0.75) is recommended instead.  Please see your relevant design guidelines, such as UK TA 23/81. 

For Signalised Intersections, the RFC output is replaced with DOS (Degree Of Saturation), which has an equivalent 
meaning. 

 
Start Queue / End Queue: The queue at the start and the end of the time segment. The difference between the 
two shows the evolution of the queue during this time segment.    The values are the total number of queueing 
vehicles on the arm, regardless of their distribution on the road.  E.g. a queue of 10 vehicles could be 10 single-file 
vehicles, or a row of 5 vehicles queueing two abreast.  (If using Lane Simulation mode, you can however look at 
individual lane results to see more details.)   Queues include slowly moving vehicles as well as stationary vehicles.  
As with most other outputs, the values shown are expected values and represent the value you would expect to 
observe on a typical day, at the start/end of the appropriate time segment.  If comparing with observations you 
should bear in mind that your observations should be averaged over several days.  

 

Delay:  This is the average time that a vehicle must wait on the approach before it can enter the junction.  See also: 
Delay Units. 

LOS:  This is the unsignalised Level of Service.  See Queuing Delay for details. 
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 Queuing Delay 9.3.1

This sub-section of time segment results can be accessed by clicking the relevant section in the Data Outline, under 
the Arm Results or Stream Results section. 

To view these results you must be in Advanced Mode and must also tick Options>Analysis Options>Calculate 
 detailed queueing delay. 

 

Queuing Total Delay: This is the delay suffered during the time segment by all the vehicles which are queuing 
during that time.    See Delay Units. 

Queueing Rate of Delay:  See Delay Units. 

The Level of Service (Highway Capacity Manual (HCM 2000)) outputs show the unsignalised, and equivalent 
signalised, level of service values for the time segment, based on the Average Delay per Arriving Vehicle.  The 
transportation LOS system uses the letters A through F, with the definitions below being typical: 

A = Free flow 
B = Reasonably free flow 
C = Stable flow 
D = Approaching unstable flow 
E = Unstable flow 
F = Forced or breakdown flow 

 
The thresholds A-F are based on the queuing delay on each arm, and these thresholds differ for unsignalised and 
signalised junctions.  (One reason for this is that delay at a signalised junction is more ‘acceptable’, because drivers 
expect to be delayed at traffic lights.  For example, a delay of around 20s may correspond to unsignalised LOS C, 
but signalised LOS B.)  Junctions 9 shows the LOS according to both the unsignalised and the signalised thresholds, 
for comparison purposes.  If the junction is a signalised one, the LOS shown in results will be the signalised LOS. 
 
Note that the LOS in Junctions 9 is based purely on the queueing delay, taking into account delay experienced in 
previous time segments (i.e. the Average Delay Per Arriving Vehicle).  In some definitions, the control delay at an 
intersection also includes elements of geometric delay; these are NOT included due to the extra amount of data 
that would be needed.  If you are interested in including these elements, you should use the Geometric Delay 
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model and add the resulting geometric delay values to the queueing delay and then use the published thresholds 
to look up the corresponding LOS. 
 
For further details about Level of Service, see http://en.wikipedia.org/wiki/Level_of_service. 

 
 

 

 
 
To jump to whole period results, use the dropdown menu of the Results button on the main vertical toolbar.  
 
 
The results shown here are for the entire modelled period and in most cases are aggregates of the individual time 
segment results.   The most useful results are also shown in the Summary Results screen. 
 
To display results for all arms together, use a Data Grid.  See Data Grids for more details. 

The number of outputs shown depend on whether the file is in Advanced Mode.  The screenshot below shows the 
Data Editor for a file in Advanced Mode.  To view all possible results you must also tick Options>Analysis 
Options>Calculate detailed queueing delay. 

 
 
The Max RFC, Delay, Queue and LOS are the ‘worst’ values over the time period.  Note that the max RFC may 
occur in a different time segment than the max queue, and so on.  These values are also displayed in the Summary 
Results Screen.   The maximum queue shown here represents the longest expected queue encountered in any of 
the time segment results.  For any given time segment, the actual queue at the site will vary around this expected 
value from day to day.  You can use Queue Variations (percentiles) and Queue Markers to show additional outputs 
 such as the the queue that would be expected on 95% of occasions. 

http://en.wikipedia.org/wiki/Level_of_service
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Average Demand:  This is an average of the demand in each time segment. 
Total Junction Arrivals:  This is the sum of the arrivals in each time segment. 
 
Total Queueing Delay:  The total delay experienced by all vehicles over all time segments.  The Average Queueing 
Delay and Rate of Queueing Delay are derived as described in Delay Units. 
 
The Inclusive delay values take account of any vehicles still queueing at the end of the last time segment.  This will 
only differ from the non-inclusive values if there is significant queueing during the last time segment. 
 

 

For Priority Intersections, the main results are for each stream.  The screenshot shows a set of basic stream 
results. (More columns will be shown if the file is in Advanced Mode). 

 

You can choose whether or not to show priority streams by setting Data Outline>Options>Sorting and 
Display>Hide Priority Streams.  If this option is ticked, then streams such as A-C, are hidden.  (These streams carry 
unimpeded traffic and so never have queue and delay outputs.) 

 

The order of streams can be controlled via Data Outline>Options>Sorting and Display>Stream Grouping.  You can 
choose to list streams alphabetically by origin or destination, or, list them in a similar order to that used by PICADY 
5. 

Additionally, you can use the Data Outline to show some results for each arm.  This shows a small set of outputs 
for each arm, such as the total entry flow (throughput) on the arm. 
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 Results for blocked streams 9.5.1

The screenshot below shows results from a T-junction where there is no blocking on the major arm.  Demands on 
Arms A and B have been set to zero for clarity, so the only flow is on Arm C.  The turning counts have been entered 
such that the demand for each of C-A and C-B is 400 PCU/hr.   As expected, the entry flow (throughput) for C-A is 
identical to its demand, because C-A is a priority stream with effectively infinite capacity.  Also as expected, the 
entry flow (throughput) for C-B (the right-turn into the minor arm) is slightly lower than its demand, with a 
corresponding small queue.  (The queue would be much higher if there were non-zero flows on arm B.) 

Note that stream B-AC is a non-priority stream, and so has a RFC defined, but which happens to be zero in this case 
because the turning counts from Arm B are zero. 

  

In the non-blocking case shown above, the demand shown in the results for Arm C is 400 + 400 = 800 PCU/hr. 

If the file is changed so that full blocking is specified on Arm C, then the results below are shown. 
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Because the right-turners into Arm B now block straight-ahead C-A traffic, the stream definitions are changed.  The 
priority stream C-A still exists, but the C-B stream is replaced with a C-AB stream that represents ALL blocked 
traffic.  This C-AB stream includes right-turners plus straight-ahead traffic that is blocked by the right-turners. 

In blocking cases, the meaning of the Demand field shown in results changes slightly.  It indicates the way that 
traffic is assigned to either the C-A or C-AB stream, and this will vary depending on blocking effect.  In this 
example, 43.90 PCU/hr of straight-ahead traffic is calculated as having uninterrupted priority (i.e. will be 
unaffected by blocking).  A much larger proportion of traffic (756.10 PCU/hr) does experience blocking, and the 
traffic in this stream and its associated queue consists of both right-turners AND blocked straight-ahead traffic.   
The sum of these two demands is 800 PCU/hr, i.e. the originally specified demand for Arm C. 

If the blocking type is changed to partial blocking, by specifying a non-zero value for the Blocking Queue field, a 
higher proportion of traffic straight-ahead traffic is uninterrupted and so is assigned to the C-A stream.   Again, the 
sum of the two demands 594 and 206 totals 800. 

 

If the Blocking Queue is increased further, representing a larger space available on the road for right-turners to 
queue, then the results will eventually reduce to those of the non-blocking case: 
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For Signalised Intersections using the OSCADY model, the main results are for each Traffic Stream.   For this 
junction type, DOS (Degree of Saturation) is shown in place of RFC, but the meaning is equivalent. 

For details of the extra outputs for OSCADY junctions, see OSCADY Outputs. 

 

 

Junctions 9 includes an estimate of delay and LOS for the overall junction by calculating a demand-weighted 
average of the arm/stream results.  This is shown in the Summary Results screen (if selected via the Columns 
menu) and also in the Junction section of the Data Outline. 

In the example shown below, the overall Junction Delay and Junction LOS lie somewhere between the individual 
arm values.  (If the demand on Arm A were much higher than other arm demands, then the Junction Delay and LOS 
would be more biased towards the Arm A value.) 
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NOTE:  Some items are only available if the current file is in Advanced Mode. 

 

 Analysis Sets allow you to store multiple sets of geometric layout data within the same file, or to compare 
different options such as overall flow scaling or lighting/surface conditions.   

 Demand Sets allow you to store different sets of traffic demand data, which can optionally be combined 
together, within the same file.  Each Demand Set is associated with a time of day (e.g. AM, PM, etc) and also a 
scenario, such as base or development flows, or current/future years.   

When a file is run, all combinations of Analysis and Demand Sets can be run automatically. In this way, the results 
for each flow scenario, for each time of day, for each geometric layout option, can be summarised together.   

 Time Segments are used to split a modelled period into smaller time segments.  Flows, queues and delays are 
entered and/or calculated for each time segment.  For example, you can model a 60-minute period using 4 time 
segments of 15 minutes each.  Flows can be entered directly for each time segment, or you can set up Junctions 9 
to calculate an automatic flow profile based on simple inputs.  In either case, a set of results will be available for 
each time segment, along with a set of overall whole period results representing the entire 60 minute period.  
Optionally, other data such as turning proportions and vehicle mix can also be entered for each individual time 
segment. 

 

At any time, there is a currently selected Analysis Set, Demand Set and Time Segment.   These are always shown at 
the top of the main window.  Click on the icon next to each one to jump to the appropriate part of the Data 
Outline where you can edit the properties of the selected set.   Right-click on the icons to access menus allowing 
you to add and delete sets. 

 

To change the current set, select it via the drop-down list.  Any screens that show data for each set will then 
automatically update.  You can also activate a set by clicking on it in the Data Outline. 

In the Data Editor and Data Grids, any data item with an Analysis Set icon ( ), for example, can be entered 
separately for each Analysis Set. The value shown on the screen for such a value is the value for the CURRENT 
Analysis Set.  A similar system applies to Demand Sets and Time Segments.  

 

Make sure you understand the distinction between editing the definitions of Analysis/Demand 
Sets versus editing the actual data for each set.  E.g. you may have an AM Peak and PM Peak 
Demand Set, each of which contains a separate set of flows and options.  Edit the traffic flows 
via the normal data entry screens, making sure that you have selected the correct 
Analysis/Demand set via the drop-down menus on the main program toolbar. 

The Demand Set itself (e.g. time period start/finish, time-segment length, name, etc), can be 
edited by selecting the relevant Demand Set in the Demand Sets section of the Data Outline.  
Alternatively, simply click on the Demand Set icon next to the Demand Set drop-down selector. 
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When you add a new Analysis Set or a new Demand Set, the new set contains a copy of all the 
data for the previously selected set.  E.g., all traffic flows for the new Demand Set will be a copy 
of the flows for the last selected Demand Set. 

 

TIP: When working with multiple Analysis and/or Demand Sets, it can sometimes be useful to confirm where, if any, the 
differences between sets are located.  To do this, see Comparing files and data sets 

TIP: In Analysis Set and Demand Set definitions, tick the Locked option if you have finished entering data for the set and want to 
avoid accidentally altering data.  In this mode, all relevant data fields will be locked when this set is chosen.  For example: lock 
one Analysis Set only and go to an arm’s Geometry screen: the entry width and other fields will be greyed out and disabled for 
the locked Analysis Set, but editable for the other set. 

TIP:  Optionally, you can assign a Colour to each Analysis and Demand Set.  Edit the colour by double clicking the colour in the 
Data Editor or a Data Grid.  The colours are used in the Data Outline and in the main Analysis/Demand Set dropdown menus.  In 
large files this can be useful to separate out categories of Demand Set, for your own reference whilst working with the file.  
(They are not used in reports.)  In the simple example below, the 2015, 2020 and 2025 Demand Sets have been assigned 
different colours.   

You can overrule any colours in a file and force the appearance to be the same as that used in earlier versions of Junctions by 
turning off Data Outline>Options>Sorting and Display>Colour Analysis/Demand Sets.  A corresponding option in 
File>Preferences>Colours controls this setting for new files. 
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  Click this icon at the top of the screen to jump to the properties for the current Analysis Set.   

When you start a new file, the file contains a single Analysis Set.  You can rename it by locating it in the Analysis 
Sets section of the Data Outline and then using the Data Editor to set its properties 

Many users may find that they only ever need to use a single Analysis Set. 

 

Add a new Analysis Set (via the Data Outline, or by right-clicking the icon next to the drop-down menu), and note 
that the drop-down menu at the top of the main Junctions 9 window now lets you choose between two Analysis 
Sets.   To actually enter data for each Analysis Set (e.g. geometric layouts), firstly select the Analysis Set from this 
menu OR by clicking on it in the Data Outline, and then use the normal data editing screens.  Also see Global and 
 independent values for Analysis and Demand Sets 

Normally, each Analysis Set represents a junction layout option that is independent of the traffic flow schemes 
defined by Demand Sets. By default, therefore, it is assumed that you will want to run EACH set of traffic flow 
options for each Analysis Set.  However, sometimes you may want to associate an Analysis Set with a specific 
Demand Set.  E.g. an experimental layout may have a separate set of flows that are intended only for use with that 
particular layout, and not for use with any other Analysis Sets that may be in the file.  In such a case, tick the Use 
Specific Demand Set option in the Analysis Set definition, and then enter a reference to one or more Demand Sets 
(e.g. enter ‘D2’ to use Demand Set 2, or “D2,D3” to run those two sets in turn).  This determines the flows that will 
be used for this Analysis Set.   

In more complex scenarios it may of course be easier simply to save the different setups as different files. 

See also Analysis/Demand Sets and Summary Results for an example of the use of Analysis and Demand Sets. 

Each Analysis Set has an associated Network Flow Scaling Factor.   The value entered here applies to ALL arms on 
ALL junctions, for this Analysis Set.  These combine with any individual scaling factors entered for individual arms 
and for individual Demand Sets.  These factors are a convenient way of trying out different scenarios where traffic 
flows increase or decrease as a whole over the entire junction system and over all Demand Sets. 

 



 Working with Analysis Sets, Demand Sets and Time Segments    Page 103     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 

  Click this icon at the top of the screen to jump to the properties for the current Demand Set. 

When you start a new file, the file contains a single Demand Set.  You can rename it by locating it in the Demand 
Sets section of the Data Outline and then using the Data Editor to set its properties.  To add new Demand Sets, use 
the Data Outline as usual, or right-click the icon next to the drop-down list.   

 

Each Demand Set defines a separate set of flows.  To actually enter data for each Demand Set, firstly select the 
Demand Set from the dropdown menu OR by clicking on it in the Data Outline and then use the normal data 
editing screens such as the Origin-Destination (O-D) screen. Also see Global and independent values for Analysis 
s and Demand Sets. 

Each Demand Set is intended to represent a set of flows that, typically, are for a particular year and time period.  
Clearly there are many ways to use this system but in Junctions 9 each Demand Set is given a Scenario Name and a 
Time Period Name.  The overall name of the Demand Set is formed automatically from a combination of these two 
names.  It is entirely up to the user how these names are used; the only restriction is that each Demand Set must 
have a unique name. 

Some examples for Scenario Name are  ‘2015’, ‘Observed’, ‘2021 Forecast’, ‘Development Flows’, etc.  

Some examples for Time Period Name are ‘AM’, ‘PM’, ‘Off-peak’, or blank.  If the flows represent extra 
development flows, to be added to other demand sets, then it may be that they do not have any particular time 
period, in which case the time period name can be left blank. 

See also Analysis/Demand Sets and Summary Results for an example of the use of Analysis and Demand Sets. 
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 Modelled Time Period and Time Segment Length 10.2.1

The Model Start Time, Model Time Period Length and Time Segment Length define the start and duration of the 
modelled period for this Demand Set, and the time segment length.   These items can be set separately for each 
Demand Set.  The Model Finish Time is set automatically from the Start Time and Time Period Length. 

If modelling a traffic peak it is important to include some off-peak time either side of the peak.  This is to ensure 
that the assumption, by the program, that queues at the start and end are zero is reasonable.   

Time Segment Length is the segment length into which the whole modelled period is to be split. The modelled 
period must be a whole number of segments.  Note that all flows (and therefore capacities and results) are 
assumed to be constant throughout a time segment.  For this reason the segment length should not normally 
exceed 15 minutes, particularly if modelling a peak period, otherwise this underlying assumption would (usually) 
be unreasonable.  Also, the segment length should not normally be less than 5 minutes, because very short 
segments involve a high random variability of flows from one time segment to the next. 

The Single Time Segment Only option is provided as a convenient way to set up a single time segment. However, 
usually we would recommend NOT using this option, because a single time segment may mask the changing 
behaviour of a junction over time, which is an important aspect of ARCADY and PICADY. 

 

 Traffic Profile Type 10.2.2

If you set the Traffic Profile Type on a Demand Set, it affects ALL flows on that demand set (entry, exit and 
pedestrian flows for all arms).  The profile type determines how traffic demand is assumed to vary over time, and 
can be used to conveniently model a peak period 

Traffic profiles are described further in Demand Screen. 

 

 

 

The Time Segment drop-down menu at the top-right of the main window contains an entry for each time segment. 
Displaying any set of results and then selecting a time segment from this menu will then show the results for that 
time segment.  You cannot see all time segments within the Data Outline or on one screen together, but generated 
reports can optionally show results for all time segments. 

Some matrix-style data (e.g. turning proportions, vehicle mix, geometric delay inputs/outputs) may also vary over 
time depending on options selected. 

Within the main Demand screen, time segments are treated in a different way and are shown together in the 
lower half of the window. 

It is possible to view how one or more outputs vary over time using the Analyser screen – Time Graph Mode. 
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The results shown in the Summary Results screen and also within the Results Summary section of the Data Outline 
are maxima, totals or averages over all time segments.  To confirm the type of totalling, show the glossary screen 
(or double click on a label). 
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When you start a new file and show the Summary Results Screen, results for the default Analysis and Demand set 
are shown. 

 

If you add more Analysis and Demand sets, then, by default, the Summary Results screen will always show the 
results from the CURRENT set only.  To compare the results from different sets, you need to select each in turn 
and, if necessary, re-run the file to refresh the Summary Results screen. 

The Summary Results screen can operate in a more powerful mode where all appropriate sets are automatically 
shown together.   Turn this on by choosing Show>Show All Analysis and Demand Sets.  (This mode is saved within 
the file itself, and the default for this mode is saved in your user preferences.)   

As an example:  start a new file, enter some basic flows and add a second Analysis Set.  Turn on Show>Show All 
Analysis and Demand Sets in the Summary Results screen: the grid will now show a section for each Analysis Set. 

 

To begin with, the results for the new Analysis Set are shown with a red background to indicate that the traffic 
model has not yet been run.  The results will appear and the background change to green as soon as you either run 
the set individually, or, click Run Model>Run all data sets on the main toolbar. 

 

Changing any data for a set will result in the relevant sections of the Summary Results screen being shown with a 
red background until you run the set (or run all sets). 

Continuing the example, add a second Demand Set and enter the Time Period Name as ‘PM’.  The Summary 
Results screen will update to show the Demand Sets as columns.   The results for these sets will appear when you 
run each set or when you click Run Model>Run all data sets. 
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In the example below, the user has added two more Demand Sets for future years.  The years are entered as the 
Scenario property of each Demand Set, and these translate into further rows in the table of results. 

 

 

TIP:  Demand Set and Analysis Set definitions can easily be viewed and edited together by showing a Data Grid and 
selecting any Demand Set or Analysis Set definition: 
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The system outlined above can also be used for more complex situations. 

The grid shown in the Summary Results screen is formed from the defined Analysis and Demand Sets and depends 
on their Include in Report, Use Specific Demand Set and Run Automatically properties respectively. There are 
various ways to set this up.  In the example below, the flows for 2009/12 AM/PM still exist, but the experimental 
layout Analysis Set definition has been altered so that it uses a special Demand Set (D5).  D5 has its Run 
Automatically property turned off (otherwise it would appear in the upper grid), and the Experimental Layout 
Analysis Set has Use Specific Demand Set turned on and D5 set as its Demand Set property.   

 

If an Analysis Set has Use Specific Demand Set turned on, the Demand Set property can refer to one or more 
Demand Sets. Continuing the example above, if a new set D6 were added, and the Experimental Layout Analysis 
Set applied to Demand Sets D5 and D6, then its Demand Set property would be entered as “D5,D6”, using commas 
to separate the sets. 

TIP:  If you want to exclude an Analysis Set from the Summary Results Screen and from reports, untick its Include In 
Report option. 

TIP:  The Summary Results screen can automatically be included at the top of reports if the appropriate option 
within the Report Viewer is selected. 
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By default, when you generate a report the report contains information for the currently selected Analysis and 
Demand set only.  Optionally you can generate reports containing all data for ALL sets by selecting the Show full 
details for all analysis sets option in the report generator.  This will generate a section for each Analysis Set, and 
within each, a section for each appropriate Demand Set.    

 

 

 

NOTE:  Some data items that were in Demand Sets in Junctions 8 and earlier are now in Analysis Sets, or vice versa.  For 
example, the Internal Storage Space for linked roundabouts is regarded as a per-Analysis Set item in Junctions 9 whereas it was 

per-Demand Set in Junctions 8. 

 

 Analysis Sets 10.6.1

If there is more than one Analysis Set in the file, then any data field that can potentially take a different value for 
each Analysis Set is shown with a ‘card stack’ icon in the Data Editor and Data Grid screens.  To begin with, these 
have a light grey colour. 

For example, all roundabout geometries are shown with the light grey card stack icon: 
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This means that although there are several Analysis Sets in the file, the same geometric data is used for each set.  
For instance if you change the entry width and then switch to a different Analysis Set, the same value (the global 
value) will appear in all other Analysis Sets.   

When you decide that a particular data field should be different in a particular Analysis Set, then select the 
Analysis Set and then click the card stack icon.   The icon will change to yellow, to indicate that this Analysis Set 
uses its own value (independent values) compared to other Analysis Sets.  (The value for the data field itself will 
not actually be different until you go ahead and enter a different value whilst the Analysis Set is selected.)   Click it 
again if you subsequently decide that you want to use the global value. 

NOTE:  in the specific case of roundabout geometries, changing the status of one geometry will also change the others.  E.g. if 
the entry width takes an independent value in one Analysis Set then so will the approach width, entry radius etc.   

 

 

If there are several Analysis Sets then the icon for any given data field can take three states: 

 

 
Light grey: the data is the same in all Analysis Sets.  All Analysis Sets use the global value for this data 
field. 
 

 

 
Yellow: the data in the current Analysis Set is independent from any other set.   
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Dark grey: the current Analysis Set uses the global value but there are other Analysis Sets in the file 
that use their own independent value. 
 

 
Using this system, you can choose which data fields are actually different between Analysis Sets.   Until you do this 
for a given field, the data will be the same between all sets.  

For example, you could set up two different calibration intercept corrections in two Analysis Sets without worrying 
about the geometric data accidentally diverging between the two sets.  
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 Demand Sets 10.6.2

If there is more than one Demand Set in the file, then some data fields ALWAYS take a different value for each 
Demand Set.  Such data includes O-D data and traffic demand data, since these are the main reasons for using 
Demand Sets in the first place. 

Certain other data fields that can potentially take a different value for each Demand Set are shown with a ‘card 
stack’ icon in the Data Editor and Data Grid screens.  To begin with, these have a light grey colour. 

For example the Scaling Factor space and some other properties in the Demand Screen have the light grey icon in 
their corners: 

 

This means that although there are several Demand Sets in the file, the same scaling factor is used for each set.  
For instance if you change the scaling factor and then switch to a different Demand Set, the same value (the global 
value) will appear in all other Demand Sets.   

When you decide that a particular data field should be different in a particular Demand Set, then select the 
Demand Set and then click the card stack icon.   The icons will change to green, to indicate that this Demand Set 
uses its own values (independent value) compared to other Demand Sets.  (The value for the data field itself will 
not actually be different until you go ahead and enter a different value.)   Click it again if you subsequently decide 
that you want to use the global value. 

 

 

If there are several Demand Sets then the icon for any given data field can take three states: 

 

 
Light grey: the data is the same in all Demand Sets.  All Demand Sets use the global value for this data 
field. 
 

 

 
Green: the data in the current Demand Set is independent from any other set.   
 

 

 
Dark grey: the current Demand Set uses the global value but there are other Demand Sets in the file 
that use their own independent value. 
 

 
Using this system, you can choose which data fields are actually different between Demand Sets.   Until you do this 
for a given field, the data will be the same between all sets.  

For example, you could set up two different scaling factors in two Demand Sets without worrying about the profile 
type accidentally diverging between the two sets.  
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NOTE: To use this feature the file must be in Advanced Mode. 

If you need to add together multiple sets of flows, add a new Demand Set and tick the Use Relationship option. In 
the Relationship box you can then enter the IDs of the Demand Sets that you wish to add together to form this 
new Demand Set, using a simple expression similar to an Excel formula.  A Demand Set cannot refer to itself in this 
way, so you must always add a new Demand Set for this purpose.  If the currently selected Demand Set is set up to 
use a relationship in this way, then traffic demand for individual arms will be greyed out and will show the 
calculated total demand. 

The calculated flows are automatically updated whenever any of the component Demand Sets change. 

For example, you may set up a Demand Set (D1) representing current demand at a junction and then a second set 
(D2) representing additional expected demand for each arm.  In order to analyse the performance of the junction 
with the total current + additional demand, you could set up a third set (D3) and manually enter the summed 
demand for each arm and/or turning movement.  An easier way is to use the relationship system: in the Demand 
Set definition for Demand Set 3, tick Use Relationship and in the Relationship box, type “D1+D2”.  This will 
automatically sum the appropriate demand for each arm for each time segment from D1 and D2. 

 

 

 

Alternatively, you may simply wish to analyse all Demand Set 1 flows if they grow by a further 20%.  This can be 
achieved simply be entering the Relationship as “D1 * 1.2”.   (Other alternatives to this particular example are to 
set the Flow Scaling Factor for each arm to 120% OR, to set the Network Flow Scaling Factor within the 
Roundabout Network options to 120 %.) 

You can also enter more sophisticated relationships such as “2 * (D1+D2+1.2*D3)”. 

 
NOTE: accident prediction flows, pedestrian flows and large roundabout circulating flows are NOT affected by Demand Set 
relationships. 

TIP:   You can set up a demand set to contain ‘multipliers’ for each O-D movement, and then use a relationship such as “D1 * 
D2” to apply the multipliers. 

TIP:   You can enter negative values in the O-D grid, to represent a decrease in traffic. 

 

 
Use the Relationship Type to choose between two modes, as follows. 
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 ‘Simple’ relationship 10.7.1

This is the default mode and is intended to be used when the traffic profile type is ONE HOUR and the ‘Use O-D 
data’ option is ticked in the Demand screen (these are also the default settings). 

In this mode, the O-D matrices for the demand sets are combined directly.   

Example: 

Demand Set 1 (D1) uses a ONE HOUR profile and contains a single set of O-D data of 100 PCU/hr for all movements.   The 
demand of 100 is subsequently shaped by the ONE HOUR profile into time segment data [75, 90, 110, 110, 90, 75]. 

Demand Set 2 (D2) uses relationship D2 = D1 * 1.5.   The O-D data of 100 is scaled to 150.  The demand of 150 is 
subsequently shaped by the ONE HOUR profile into time segment data [113, 135, 165, 165, 134, 113].    

 
NOTE:  The HV% is calculated automatically based on the HV% of the demand sets involved.  Usually this can be thought of as 
an average, weighted by the demand in each demand set.   

 

 

 ‘Advanced’ relationship 10.7.2

This was the default and only behaviour in Junctions 8 and previous versions. 

In this mode, relationships operate only on the direct/resultant flows for each arm, i.e., the flows shown in the 
lower half of the Flows screen.  This mode may be useful if using a traffic profile type other than ONE HOUR or if 
working with directly entered demand for each time segment. 

In this mode, resultant O-D data is derived from the calculated direct/resultant demand.  The ‘varies over time’ 
option is automatically turned on for the resultant demand set, and a DIRECT traffic profile used. 

Example: 

Demand Set 1 (D1) uses a ONE HOUR profile and contains a single set of O-D data of 100 PCU/hr for all movements.   The 
demand of 100 is shaped by the ONE HOUR profile into time segment data [75, 90, 110, 110, 90, 75]. 

Demand Set 2 (D2) uses relationship D2 = D1 * 1.5.   The scaled time segment data, using a DIRECT profile, is calculated as 
[113, 135, 165, 165, 134, 113].   The O-D screen will show corresponding values for each time segment and NOT a single 
value of 150 as you may expect. 

 
NOTE:  The HV% is calculated automatically based on the HV% of the demand sets involved.  Usually this can be thought of as 
an average, weighted by the demand in each demand set.   
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NOTE: To use these features the file must be in Advanced Mode. 

A common use of Demand Sets is to store estimated flows for future years.  As an alternative to entering these 
manually, you can specify one or more growth factors that can subsequently be referred to in Demand Set 
 Relationships. 

Use the Data Outline to browse to the Growth Factors section and add a new Growth Factor. 

     

 
If you already know the value of the Growth Factor, enter it directly here. 

You can then use the Growth Factor in a Demand Set Relationship.  In the screenshot above the Growth Factor has 
ID “1” and would be referred to as “G1”.  Typically it is used as a multiplier for a demand set as in this screenshot: 

 

You could of course simply enter “D1 * 1.4” as the relationship, but the use of Growth Factors can be convenient if 
wishing to apply the same factor to several Demand Sets. 

Any number of Growth Factors can be added, and referred to as G1, G2, G3 etc.  In this way you can add factors for 
‘low growth’, ‘high growth’ and so on. 

 

 Calculating TEMPRO Growth Factors 10.8.1

If you have TEMPRO datasets installed you can use Junctions 9 to calculate traffic growth factors based on the 
base/future year, geographical area and other properties.  Junctions 9 will read data directly from the TEMPRO 
datasets and produce a local growth factor.   This can save having to use the TEMPRO software separately and 
means that the Junctions 9 file can contain the base traffic flows, the future flows AND the information used to 
produce the growth factors. 

The following section assumes you are familiar with the use of TEMPRO. 

Start by adding a new Growth Factor as described in the previous section and ticking the Use TEMPRO option.   
This will reveal a Calculate… link at the top of the Growth Factor which will take you to the calculator screen. 
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If not already filled in, use the buttons at the top of the screen to select the folders where the NTM and regional 
TEMPRO datasets are stored.   Usually these will be similar to those shown in the screenshot below.   These paths 
are stored as part of your user preferences.  

If these locations contain appropriate TEMPRO database files, then the other fields on the calculator screen will be 
enabled and you can choose values from the dropdown menus.   Note that the choices depend on which TEMPRO 
databases you have installed.  For example, the Region menu will only contain those regions for which you have a 
TEMPRO database.    

After choosing the years, geographic region, area type and road type, click Calculate.  Junctions 9 will fetch data 
from the TEMPRO databases and perform calculations to produce a local growth factor.   Press Save to use this 
value as the Growth Factor, which can then optionally be used in Demand Set Relationships.  The TEMPRO inputs 
are also stored as part of the Growth Factor and can subsequently be edited (and a new factor calculated) by 
returning to the calculator screen. 

NOTE:  From Junctions 9.0.2 onwards, the NTEM (Regional) Dataset Version is selected AFTER choosing a Region.   

 

You should obtain identical results to those generated from the TEMPRO software.  Using the same example as the 
screenshot above, the steps in TEMPRO 7.2 would be: 

 Dataset version = 72 

 Result type = Trip ends 

 Set area definition and base/future years 

 Trip purpose = All purposes 

 Transport mode = Car driver 

 Select time period type 

 Trip end type = Origin/Destination 

 Click ‘Display Data’ 

 Go to NTM Traffic Growth Calculations screen 

 Use NTM AF15 

 Area type = All 

 Click ‘calculate’.   This gives the Local Growth Figure of 1.1834, as shown in the Junctions 9 screenshot above.  
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Many screens respond to the Copy and Paste buttons on the main toolbar.  The format of data depends on the 
screen but can easily be seen by pressing Copy and then pasting from the clipboard into a spreadsheet or any text 
editor. 

In addition, many screens respond to the Edit>Copy/Paste All options.  These options select each Demand Set in 
turn and then copy or paste data from the active screen.  In this way, a collection of data representing all Demand 
Sets can be pasted into a spreadsheet and edited within the spreadsheet for subsequent pasting back into 
Junctions 9. 

NOTE: the options in the various Demand Sets must be broadly the same – e.g., the system will not work if one 
Demand Set has turning proportions varying over time but another set does not. 

NOTE: if you use this system to edit data, you can only edit the numerical values.  You cannot change the names  
or the structure of Demand Sets. 

To use this system, firstly go to the screen that contains the data of interest – e.g. the O-D screen or the Vehicle 
Mix screen, or time segment results in the Data Editor. If necessary, go to the tab within the screen or click on a 
particular data grid.  Then click Edit>Copy/Paste All to show the Copy/Paste All screen.  Choose an option and then 
click Go.  If copying, the data will then be available on the clipboard for pasting into another application or another 
Junctions 9 file.  If pasting, data will be taken from the clipboard and pasted into the Demand screen (or whichever 
screen was active). 

 

 

Current Demand Set, all time segments:   

This operates on each time segment for the currently active Demand Set.  
It is only useful if the data of interest actually varies over time – e.g. O-D 
screen in ‘varies over time’ mode.   

Data pasted into Excel from the O-D screen will look similar to the 
example in the screenshot.  Immediately after pasting into Excel it is 
useful to change the colour of the pasted area.  This makes it easy to 
identify the area to be copied back into Junctions 9 later, if required. 

The numbers for all time segments can be altered in Excel and then 
pasted back using the Paste option, as long as exactly the same area is 
copied from Excel, including all header rows/columns and any blank 
rows/columns that were included in the original operation. 
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Current time segments, all Demand Sets: 

This works on data for each Demand Set, for the current time segment.  If 
the data does not vary over time, then data will be for the whole period. 

Data pasted into Excel from the O-D screen will look similar to the example 
in the screenshot.   

 

 

 

 

 

All Demand Sets, all time segments: 

If data varies over time, then this option will copy/paste data for each time segment, for each Demand Set.   Time 
segment data is shown in rows, with each Demand Set in a different column. 

Data pasted into Excel from the O-D screen will look similar to the example in the screenshot below. 
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NOTE: To use these features the file must be in Advanced Mode. 

You may have traffic count data in Excel spreadsheets organised in such a way that makes it difficult to copy and 
paste into Junctions 9.  In this case, you can configure Junctions 9 to read in data from certain cells in the Excel 
spreadsheet.  Once set up, this can speed up the data entry process significantly.  The configuration is saved within 
the Junctions 9 file and so you can subsequently use the same Junctions 9 template file to read in data from 
different versions of the same spreadsheet. 

NOTE:  There is some trade-off between the time taken to set up the link versus the time saved when reading the data.  This 
trade-off depends on the volume and complexity of the data and whether you re-use the same configuration for several files.  
In some cases it may be quicker to simply rearrange the data in Excel and then paste into Junctions 9 using the normal 
copy/paste functions, or enter manually, rather than configuring this link. 

NOTE:  The units used will be those currently selected in Junctions 9.  (See Units for data input).   

 

 

 
The procedure is demonstrated in the following example.   For illustrative purposes this example uses most of the 
features of the system but you do not need to use all of these features; you may well find that you can configure 
the Excel link in a much simpler way. 

The example spreadsheet is shown below.  There is a row for each time segment and a value for both the traffic 
demand and the HV% for each turning movement (A to A, A to B etc).    Data in the same format is available for 
two time periods – ‘AM Peak’ and ‘PM Peak’ on two worksheets. 
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To set up Junctions 9 to read in this example data, use the following steps. 

 

1. Make sure that the Excel file is saved, but not open.   It is a good idea to make a backup copy of the file.   
 

2. In Junctions 9, add the required number of Demand Sets, set the modelling period and number of arms 
and so on.  In the O-D screen, turn on ‘Varies over time’ for each Demand Set. 
 

3. Go to Data>Read data from Excel… to show the configuration screen.   At the top of this screen, browse 
to the Excel file and click Open.  This should launch the file in Excel, which ideally you should position so 
that you can see both Excel and Junctions 9 at the same time.  Junctions 9 will show ‘Connected’ at the 
top of the screen until you close the file, either from Junctions 9 or by closing Excel. 
 

 
 
 

4. Activate the AM Demand Set and in the Excel sheet for demand set, enter the name of the corresponding 
worksheet in Excel.  Repeat for the other Demand Sets.   (If there is only one Demand Set, or if you simply 
want to read from the current active worksheet in Excel, then you can leave this field blank.) 
 

 
 
TIP:  If setting up lots of Demand Sets, you can show these options for all Demand Sets at once in a data grid by 
clicking Show details for all Demand Sets. 
 
 

5. In this example, data for each time segment (for both demand and HV%) is located in rows, one beneath 
the other. Choose ‘Offset’ for the Excel time segments source option, and then enter a value of 1 for the Y 
(up/down) component of the offset.   This means that data for each successive time segment in Excel is 
located one row below the previous time segment.  By entering different values for X (left/right) and Y 
(up/down), you can tell Junctions 9 that blocks of time segment data are separated by other distances.   
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Alternatively if time segment data is located in the same position but on different worksheets, then 
choose ‘Separate sheets’ and then enter the worksheet names as a comma-separated list in the Excel 
time segment sheets box.   Or, choose the ‘None/Manual’ option and then set up the references for each 
time segment semi-manually by using the tools described further below. 
 
NOTE:  The time segments data source option is only relevant if the OD and Vehicle Mix data in Junctions 9 have been 
set to vary over time.  Otherwise, leave this option set to ‘None/Manual’. 
 
 

6. In this example, the HV% data for each movement is in the cell to the right of the corresponding demand 
data cell.  Choose  ‘Offset from demand’ for the Excel vehicle mix source option and then enter a value of 
1 for the X (left/right) component of the offset.   
 
NOTE:  The offset for the HV% combines with the offset (if any) for the time segments source.   

 
Alternatively if HV% data is located in separate sections of a worksheet then choose the ‘Enter manually’ 
option and then set up the HV% references semi-manually by using the tools described further below. 
 
If HV% data is unimportant or not present, then choose the ‘Don’t read’ option. 
 
 
 

7. The next step is to tell Junctions 9 which cells in the spreadsheet correspond to which movement.   (The 
options set in the previous steps will save you having to repeat this for each time segment and demand 
set.) 
 
For instance, the demand data for the u-turn movement ‘A-A’ is located in cell D6 of the spreadsheet and 
so the entry for the ‘A-A’ movement in the grid in Junctions 9 should contain the value “D6” (or the fully 
qualified Excel reference such as “Sheet1!D6”).    
 
Make sure that the AM Demand Set is active and select the first time segment from the main program 
dropdowns.  Manually type “D6” into the top-left cell in the grid in Junctions 9.  You will see that it is 
automatically converted to ‘AM Peak’!D6, i.e. the fully qualified Excel reference is generated from the 
demand set worksheet name. 
 
Click the Vehicle Mix tab and you should see that the Excel reference for the first movement is 
automatically set as E6, i.e. the spreadsheet cell to the right of the demand cell. 
 
Choose another time segment and you should see that the Excel references are automatically set to the 
appropriate row of the spreadsheet, for each time segment. 
 
You can continue to enter all Excel references for each movement (for the first demand set and time 
segment) manually, or you can use the methods in the next step to speed up this process. 
 
 
 

8. Make sure that the AM Demand Set is active and select the first time segment from the main program 
dropdowns.    Click Clear all refs to remove any existing references (i.e. clear the grid). 
 
Tick Set reference when cell clicked in Excel.  Click on different cells in Excel and notice that the current 
cell in the movements grid in Junctions 9 updates to show the cell address.  In this way you can click in the 
grid in Junctions 9, then click in the cell in Excel that contains the traffic data for this movement, and 
populate the references grid. 
 
NOTE:  you may need to click twice when switching to Excel:  firstly to activate Excel and secondly to click the cell. 
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If you also tick …and auto-progress, then the movement grid will move to the next item as soon as you 
select a cell in Excel.  In this way you can quickly set up all movements by simply clicking on them in Excel, 
one after the other. 
 
Turn these options off as soon as you have completed the grid, to avoid accidentally later overwriting the 
grid. 
 
Whichever method you use, after setting up all movements, the demand grid for the first time segment 
for this example should look like this: 
 

 
 
The Vehicle Mix grid will contain the same references but all offset to the right by one cell. 
 
Selecting a different time segment will show the same references but offset down by one or more cells. 
 
 

9. References for the other Demand Sets are not set automatically but can be set in one go by clicking Copy 
refs from this demand set into all other demand sets.   The references for all items will be same as for the 
first set, but using the appropriate Excel worksheet prefixes.  For example, the Vehicle Mix grid for the PM 
Demand Set for the 0845-0900 time segment will look like this:  
 

 
 
 

10. At this stage (or before) it is a good idea to check the references.  Click Highlight referenced cell in Excel 
and click around the movements grid in Junctions 9, and select different Demand Sets and time segments.   
With Excel visible at the same time you should see the corresponding spreadsheet cell highlighted in 
yellow for demand data or green for HV% data.   Excel will switch to different worksheets if necessary. 
 
Click the Highlight all cells button to highlight ALL references (for either the traffic demand or HV% mix, 
but not both together).  Junctions 9 will temporarily replace the data in Excel with the corresponding 
Junctions 9 movement references.  (In Excel you may need to temporarily change the formatting or widen 
columns to read the full text.)    
 
This allows you to quickly scan the spreadsheet to check that the links have been set up correctly, and is 
especially useful if the data in Excel is positioned around a diagram or similar.   The highlighted cells show 
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the Junctions 9 Demand Set ID followed by the time segment and then the movement ID. 
 
To remove the highlights, click Clear highlighting.  (In case you accidentally save the Excel file with these 
highlights displayed, it is a good idea to make a backup of the Excel file as an initial step.) 
 

 
 
 
 

11. Once you are happy with the references, you can proceed to actually read the spreadsheet data from 
Excel into Junctions 9.  To do this click Read Data.   If all goes well, the O-D screen and the Vehicle Mix 
screen should automatically be populated with the correct data, for all time segments and all Demand 
Sets, as shown below for the first time segment and Demand Set for the O-D data. 
 

 
 
 

12. If you save the Junctions 9 file at this point (or before) you can treat it as a template file and re-use it to 
read data from other Excel spreadsheets (assuming they are in the same format) and thus quickly 
create new Junctions 9 files for different projects. 
 

Instead of using the methods above, you can of course simply manually enter Excel references for each movement 
as required. 
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Your Excel file may resemble the example below where traffic data is located around a schematic diagram.   This is 
no different from the previous example – the data just happens to be located in different positions.  (In this 
example there is only a single time segment, so the Excel time segment source option would be set to ‘None’.) 
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Click this button on the main toolbar to generate a report. 

 

After running the traffic model, you can choose to generate a report that summarises all input data and results.  
The report is in the form of a HTML file which you can optionally convert to a Word document or PDF file. 

To generate a report, click the Generate Report button on the main toolbar.  The newly generated report will be 
displayed in the Report Viewer.   

Generated reports are useful both a) as final reports summarising a Junctions 9 file and b) a convenient way to 
quickly view all data in a tabular format.   

Note that, for each chosen section, reports contain ALL data for that section.  Sometimes not all the data will be 
required.  In this case you can either set up Custom Grids and print only those in reports, or you can generate a full 
report and then edit it further in a word processor.  Alternatively, you can simply use the various Data Grids, 
graphs and other screens in Junctions 9, and copy their data to the clipboard for use in your own reports.  Nearly 
all screens in the program are copyable either by using the main Copy button on the main toolbar, or by right-
clicking in the screen. 

To generate a quick report, show the Report Viewer and then turn off all options other than the most basic 
options. 

 

 

Each generated report is an HTML document, whose filename is based on the filename of the current data file. It 
will be saved either to the same location as the data file (unless this cannot be accessed, such as if the data file was 
located on a drive without write permissions, in which case the Windows temporary folder will be used), or to a 
specified folder.  These options are set via the main User Preferences (not the Report Setup screen). 

If the data file has not yet been saved and therefore does not have a filename, the name “Untitled” will be used, 
and the report will be saved to the Windows temporary folder, overwriting any existing untitled report. 

If the report includes diagrams they are saved as separate .gif, .jpg or .emf files in the same location as the HTML 
file, and their names will be based on the HTML filename.  The Report Viewer contains options for converting the 
file to a Word or PDF document, in which all diagrams will be embedded and the file can easily be saved, emailed 
etc. 

NOTE:  If you intend to save reports as PDF files, then the HTML files are effectively only temporary files and we 
recommend using the Preferences Screen to set the Reports Folder to a temporary folder such as your c:\temp 
folder. 
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As soon as a report is generated, it is shown in the Report Viewer.  

 

To print the report, use the Print menu or right-click in the report and use the web browser context menu.  
Alternatively, click Convert>Save as PDF and then print the PDF.  If you wish to control the paper size or page 
breaks, we recommend pasting the report into a word processor and formatting from there.   

Tools>Keep Inside Application Window: turn this OFF to have the Report Viewer ‘disconnect’ from the main 
Junctions 9 application window, so that you can position it freely, e.g. on a second desktop monitor. 

Convert>Save as PDF document:  this will prompt for a filename and will then generate and open a PDF version of 
the report.    

Convert>Convert to Word document: provided you have MS Word installed, this will open a new Word document 
containing the contents of the report.  Note that the formatting may differ slightly from the appearance in the 
Report Viewer and may vary further depending on your particular version of Word. 

 

 Refreshing the Report 11.2.1

Whenever you change data in the file a message will appear above the Refresh button to indicate that the report is 
potentially out-of-date, i.e. does not reflect the contents of the current file. 

  

Click this button to refresh the report.  This does three things: it re-runs the file, it allows 
the report to reflect the current state of the data AND allows the report to take account of 
any changes to the Reporting Options. 
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There are various options affecting the contents and appearance of reports.  These can be set in two places: 

 Options at the top of the Report Viewer screen.  These affect the current file, and are saved within the 
file. 
 

 Options in File>Preferences>Reports.  These act as the defaults for all new files.   Also set here is the Font 
Size for Reports option. 

Note that the order of arms and streams in reports uses the sorting and grouping selected via the Options>Sorting 
and Display section of the Data Outline and you therefore control the ordering as an option associated with the 
data file, NOT as a user preference. 

 

 ‘Show’ tab 11.3.1

These options control which sections to print.   

NOTE:  you can include X-Y graphs and Time graphs saved from the Analyser Screen.  See Saving graphs; using 
 graphs in reports. 

 

 

 ‘Options’ tab 11.3.2

 

Include output from summary results screen:  if selected, the top of the report will contain a copy of the data 
shown in the Summary Results screen, using whichever options are selected in that screen.   

Group by arm instead of time segment: this controls the way some time segment tables are printed.  The two 
extracts below show a custom grid in the two grouping modes; in the first, each arm is shown for the first time 
segment and then the next; in the second, all time segments are shown for each arm in turn. 
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Show all analysis and demand sets:  If ticked, the report will contain a sub-report for EACH analysis set and all 
relevant demand sets. (Otherwise the report will only contain data for the CURRENT set). See Working with 
Analysis Sets, Demand Sets and Time Segments.    

Results for each time segment:  If ticked, full results will be printed out for each time segment in the modelled 
period, leading to a longer report. (Otherwise, only the summary for the whole period will be included). 
 
 

 ‘Advanced’ tab 11.3.3

 

Use vector diagrams: When selected, diagrams such as the Junction Diagram are shown as high quality vector 
images.  These types of images also give high quality hard copies.  Some web browsers or word processors, 
however, may not recognise the vector images.  In such cases, turn off this option to use standard bitmaps for all 
diagrams.   

Highlight Result Fields:  When selected, any result item will be shown with a green background, in the same style 
as that used by the Data Editor and Data Grids.  Turn this off if you would like a cleaner report with less colours. 
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 Highlighting threshold values 11.3.4

Queues, delays and RFCs that exceed certain thresholds are automatically highlighted in red.  To set the 
thresholds, use the Data Outline to browse to Options>Analysis Options. 

 

 

 Using Custom Grids in reports 11.3.5

If you use the Data Grid screen (see Data Grids) to store custom column layouts, then you can mark each custom 
layout for inclusion in reports.  To do this, you need to use the Data Grid menu item “Manage Stored column 
Layouts” to set the “UseInReport” flag.  You can then turn off the default report options in the Report Viewer, so 
that each report that you generate only contains your own Data Grid custom layouts. 

You must also turn on the Custom Grids option in the Report Viewer screen (and then refresh the report if 
needed). 

 

 

An extra application of the Report Viewer is to compare different files.  This can be used to compare existing files, 
variations on temporary files within Junctions 9, or to compare different Analysis/Demand Sets.   It can also be 
used to find out what is different between two files that give different results for an unknown reason. 

In all cases, the files need to be loaded into Junctions 9 or otherwise created (e.g. via the File>Copy Into New File 
option). 

File comparison is set up from outside the Report Viewer, via the Tools>Compare Files or Data Sets option.  This 
will show the screen below, which lists in the File dropdown each file currently loaded in Junctions 9 (i.e. the files 
as shown in the blue file bar at the bottom of the screen).  It is recommended that you save any new files with a 
meaningful name, otherwise they will all appear as ‘[New File]’, although this is OK for quick comparison runs. 

For each file that you want to compare, choose it from the File menu and click the Add button.  Optionally you can 
choose a colour for each file (by double clicking in the Colour column) to be used when differences are found. 
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Tick the Run files option if you want each file to be run before the comparison report is generated.  (If you leave 
this unticked, then you can use the comparison utility to compare two versions of a file where one has been run 
and one has not.) 

If the Only show differences option is turned on, values are only printed when they differ between the files, and 
blanks shown otherwise.  If this option is turned off, then all values for the master file (the file that is currently 
active in Junctions 9) are always printed, and values for the other files printed where they differ.  (The master file is 
also used during the comparison as the file that is assumed to have the correct number of arms etc.) 

Press OK to generate the comparison report, which will appear in the Report Viewer and from there can be 
refreshed as usual and saved as a PDF and so on. 

The top of the report shows the ‘master’ file and the comparison file(s) in their relevant colours: 

 

The report is then printed as usual, using options as set on the Report Viewer screen.   

The examples below show an extract from a comparison result with Only show differences turned off.  All numbers 
for the master file (red) are printed, and, when the comparison file(s) contain differences, the values from the 
other file(s) are shown in their appropriate colour.  This example clearly shows that the difference in the O-D data 
for some arms has led to differences in the results on all arms.  (Assuming that the Run files option was used.) 
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With Only show differences turned on, the same report extract appears as below.  This time, the rows and columns 
that are the same are not printed at all.  This makes it much easier to skim down the report and immediately pick 
out the differences.  Many sections will not be printed at all, although the headers and table titles are often 
printed regardless. 

 

 

 

If you try to compare files that have different numbers of arms, or do not match up at all, then you will either 
receive an error or else the report will appear but show question marks. 

 

 

 Comparing Analysis and Demand Sets 11.4.1

To compare different Analysis or Demand Sets within a file, use the Analysis Set and Demand Set dropdowns in the 
comparison tool and click the Add button.   Once you have added one set to the list of items to be compared, an 
Add all link will appear which can be used if you want to compare ALL sets. 

In the example below, all four Demand Sets within the file have been added to the list of items to compare. 



 Generating Reports    Page 132     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 

 

After clicking OK, the report lists at the top the Demand Sets and their colours. 

The example report extract below shows that all four Demand Sets have different O-D data (as expected) and that 
all values for the 4

th
 Demand Set (shown in light blue) are zero, which suggests that the user has forgotten to enter 

data for this Demand Set. 

 

As you would expect this leads to differences in all results. 

 

 

Comparing Analysis Set and Demand Sets in this file is useful if you need to confirm whether two or more sets are 
the same as each other.   You can also use it to compare sets within different files, assuming that the files are 
broadly similar (i.e. contain the same arms etc). 
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Press this button on the vertical toolbar to show a new Junction Diagram. 

 
You can show one or more Junction Diagram screens, each of which shows a graphical representation of the 
current junction(s).   

Please note that the diagram is schematic and serves only as a visual reminder of the junction layout.  Moving 
items in the diagram does NOT affect the model and you must enter data as usual through the Data Editor and 
other data entry screens to change model parameters. 

Much of the Junction Diagram is self-explanatory and we recommend that you experiment with the various 
features in the toolbars and in the various menus available by right-clicking on any item in the diagram. 

In general, to cancel a mode (e.g. to cancel Rotate mode), right-click in a blank area of the diagram, or click the 
Select button in the top-left of the toolbar. 

As with any other screen if you double click the title bar, the Junction Diagram window will become detached from 
the main Junctions 9 window and can be positioned on another monitor. 
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The diagram will automatically re-size to fit the window when you resize the window, or, you can click on View>Fit 
to Window. 

To zoom, use the mouse scroll wheel.  Alternatively, enter View>Zoom mode and then move the mouse with the 
left button. 

To pan, move the mouse with the middle mouse button or scroll wheel held down.  Alternatively, enter View>Pan 
mode and then move the mouse with the left button. 

 

The diagram can be printed using the main application Print and Print Preview buttons in the usual way.  In 
addition, you can use Print>Show Print Zone to show an outline overlay that represents the current printer paper 
size. You can then manoeuvre and zoom the network so that the desired portion fits inside this outline.  Pressing 
the Print button will then print out the same area. 

You can also copy the diagram to the clipboard by using the usual Copy button the main application toolbar or by 
using the right-click menu in a blank part of the network. 

 

 

 Auto-arrange 12.3.1

Press the auto-arrange button to automatically position the arms or streams of each junction into a default 
position appropriate to the junction type.   

By default, Arm 1 is always placed on the east, with the other arms following clockwise or counter-clockwise 
depending on the current driving side mode.  You can control the default placement of Arm 1 by going to 
File>Preferences>Localisation>Default Arm 1 Position. 

The positioning also depends on the current driving side and junction type. 

 

 Selecting items 12.3.2

Simply click on any item in the diagram to select it.  It will be shown with orange highlighting and any other 
relevant data screens (e.g. Data Editor, Data Grids) will update to show data for this item, if appropriate. 

To select multiple items, hold down the CTRL key. 

To select a rectangular selection of items, enter Select>Rectangular Selection mode and drag a rectangle on the 
diagram. 
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 Moving items 12.3.3

To move an item in the diagram, simply click on it and drag with the mouse.   

The circles at the ends on each arm are default control points, which serve as points which you can grab with the 
mouse to move either end, if required. To add extra control points to an arm, right-click on the entry or exit side of 
the arm and select Add new bend section.  There is no limit to the number of bend points you can add, so arms can 
be made to curve along as detailed a path as you required. Use the same right-click menu to remove arm sections 
or to straighten the arm. 

Many items can be positioned using the mouse but please note that this does not affect the model in any way.  
You must separately enter modelling data in the relevant data-entry screens. 

 Rotating items 12.3.4

Click on the Rotate icon, press the mouse button in the part of the diagram that you want to rotate around, and 
drag the mouse.  As you drag the mouse, the junction will rotate around the point where you first click. 

If the file contains several junctions then, in order to rotate just one junction, firstly select it using the Data 
Outline.  (Otherwise, the entire network will rotate.) 

 

 Changing spacing 12.3.5

You can explode or contract everything in the diagram by clicking on the Spacing button and then dragging the 
mouse.  This can be useful if needing to match the diagram to a background image. 

Alternatively, right-click in a blank area and select Tools>Adjust drawing spacing and then enter a percentage 
adjustment. 

 

 Aligning to a grid 12.3.6

Turn on Show>Grid to show a grid that items will snap to as you move them.  You can also align everything to the 
grid by right-clicking in an empty part of the diagram and selecting Tools>Align all items. 

 

 Adding labels 12.3.7

You can add textual annotations to the diagram via the Add Label mode.  In this mode, click anywhere on the 
diagram and type the annotation.  You can then move and resize the annotation by dragging it as with any other 
item.  To resize it, click on the label and then drag the red handles at either end. 
 

 Scale ruler 12.3.8

Show the scale ruler by clicking Show>Scale.  (If necessary, zoom out until the scale becomes visible.)  If you have a 
background image, suitably sized, or some other way of calibrating a scale, you can also use the scale as a ruler 
tool.  Move the ruler with the mouse and rotate/stretch it by dragging either end; the distance shown will 
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automatically update.  Although you can only measure straight lines, this can be a convenient way of confirming 
distances. 

 

To calibrate the ruler, stretch it so that it covers a known distance and then right-click on it and select Adjust Scale.  
Enter the known distance (in the current distance units).  The ruler will then show the entered distance and can 
subsequently used to measure other distances using the same scale. 

 

 Connecting junctions 12.3.9

You can link junctions as follows: 

1. Click the Connect button in the toolbar at the bottom of the diagram.     
2. Click in the first arm that you wish to connect (click in the grey ‘interiors’ of the arm) 
3. Click in the arm in the other junction that you wish to connect to.    

This will set up a link between the two junctions, shown with grey connection lines. This is exactly equivalent to 
going to the main Demand Screen and entering data manually on that screen’s Linked Arm tab.  The Feeding 
Junction and Feeding Arm shown there will be automatically filled in. 

To UNCONNECT two junctions, use the same process. 

Please see Linked junctions for more details. 

 

 Setting roundabout arm order 12.3.10

For roundabouts, the diagram implicitly shows the order of arms (i.e. which arm follows which around the 
roundabout) by the positions of the circulating flow links.  These reflect the value of the Data 
Outline>Junction>Arm Order data field.  Occasionally you may want to move the arms into a different order using 
the diagram and then assign this order to the data file.  To do this, click Set roundabout arm ordering from Junction 
Diagram from the main program Tools menu.  This will analyse the positions of the arms in the diagram and set 
the arm order from this. 

NOTE: Normally, you do not need to manually view or edit the Arm Order property.  Simply use the Tools>Set Arm 
Ordering option if the diagram looks wrong (e.g. if the circulating links cross over each other). 

NOTE:  The arm order of Priority Intersections is fixed, and cannot be altered. 
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The toolbar at the top of the Junction Diagram window provides access to a number of extra modes and menus 
where you can turn on various features and visualisations.  In general, the key at the bottom of the diagram 
indicates which options are switched on (if not visible, click Show>Key) 

 

 PICADY streams 12.4.1

PICADY junctions appear in the diagram as in the example shown below.  Each entry arm contains one or more 
streams, labelled to reflect the origin-destination of traffic on each stream.  Streams do NOT necessarily relate to 
lanes.    (See Priority Intersection streams for more information about streams.) 

 

Solid lines connecting entry streams to exit arms represent priority (unimpeded) streams; dotted lines represent 
non-priority streams.  E.g. C-A traffic travels unimpeded from Arm C to Arm A, and is shown with a solid 
connection.  C-B traffic turns right into Arm B and so has to give-way to priority traffic, so its connector is shown 
with a dotted line.  You cannot change these connections: they are automatically set by the program according to 
the junction type and other model features. 

Optionally, you can choose to hide the priority streams via Data Outline>Options>Sorting and Display>Hide Priority 
Streams. 

The initial shape of the junction depends on the junction type, but you can subsequently adjust the shape by 
dragging the control points on each arm. 

The major carriageway is represented by darker shading compared to the minor arms (if Options>Show junction 
background is turned on). 

For some types of staggered junction, as shown below, the diagram can appear quite complex as it includes 
representations of internal streams inside the junction (CD-A etc). 
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 OSCADY traffic streams and lanes 12.4.2

Please see OSCADY junctions. 

 

 Traffic flows – numerical overlays 12.4.3

A set of numbers is shown on the diagram next to each arm.   

By default, these numbers reflect the original origin-destination (O-D) data on each leg, i.e., the data entered in 
the O-D screen, representing the demand for each movement at the junction. 

You can optionally choose to instead show the actual calculated flows.  These numbers are outputs from the 
program and so will be zero until you run the file.  They depict the actual performance of the junction as opposed 
to the demand and so will always be smaller or equal to the demand.   

Each exit shows the exit flow leaving the junction at that arm; the same considerations apply as above. 

To show U-turners, turn on Options>Text overlays>Per movement>Show U-turners. 

You can select different modes by using the Flows dropdown, as follows: 
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Original O-D data, as entered:  in this mode, the ‘raw’, original movement demands are shown.  The numbers will 
be identical to the numbers entered in the O-D screen.  (NOTE: depending on options selected elsewhere, these 
may sometimes represent turning proportions.) 

Demand used as input to model:  this mode shows the demand after having been scaled according to the selected 
traffic profile type, flow scaling and any other effects.  It is the demand actually used by the model.  These figures 
can also be seen in the O-D screen in the Calculations>Model Demand tab and also as the demand shown in the 
main time segment results. 

Actual flows calculated by model:  this shows the final calculated entry and exit flows (throughput) which are 
results from the running the model.  These figures can also be seen in the O-D screen in the Calculations>Model 
Results tab, and also as the throughputs shown in the main time segment results.  In this mode, calculated 
circulating flows past each entry are also shown. 

Custom:  in this mode, the numbers shown reflect the options that you choose in the Text overlays tab of the 
Junction Diagram options screen.   

 
As with most other items in the program, you can change the units of these items (to e.g. PCU/hr) via the 
Data/Units screen. 

The various modes are illustrated in the following examples. 

 

 

The original turning counts in this example are 100 PCU/hr for 
each movement. 
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In this example, a ONE HOUR traffic profile is used.  This means 
that the demand used by the model in the central time segment 
is about 110% of the entered demand.  

  

 

 

The actual calculated throughput for each movement is only 93 
PCU/hr, which reflects the calculated capacity of each 
arm/stream. 

 Editing Traffic Flow  12.4.4

If the Flows dropdown is set to ‘original O-D data as entered’, you can edit the O-D data directly on the diagram. 

To do this, click the Edit Demand button, then double click on any of the green numerical O-D items in the diagram 
and enter a new value for the demand for that movement.   
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After entering a new value, the diagram will update and the new value will also appear in the O-D screen if 
displayed. 

Whilst still in Edit Demand mode, you can also use the following methods to select items: 

 Click on any O-D item to select it 

 To edit the item, double-click, or press ENTER 

 To move to the next/previous O-D item, use the arrow keys or press TAB or SHIFT+TAB. 

To exit Edit Demand mode, right-click in a blank area. 

 

 Traffic Flow – graphical overlays 12.4.5

These options provide a simple visualisation of flows through the junction.  The type of data shown depends on 
the setting of the Flows option, as described in the previous section.   

NOTE:  To adjust the overall width or opacity of the overlays, use Options>Graphic Overlays>Overlay 
width/opacity. 

The screenshot below shows the Overlays>Flows by Entry option.  The widths of the overlays are proportional to 
the flows and are colour-coded according to origin.  E.g. the red overlay represents vehicles entering on Arm 1.  
The diagram shows that the heaviest flow into the roundabout occurs on Arm 1, all of which turns right into Arm 3.   
On the other arms, there is a smaller flow, most of which turns left.  The diagram also shows that  the circulating 
flow past Arm 2 is composed mostly of the red traffic from Arm 1. 

           

 

In the example above, the Flow mode is set to ‘Original O-D data, as entered’.  After running the model and 
switching to ‘Actual flows calculated by model’, the flow overlay shows that the actual throughput on Arm 1 is less 
than the entered demand.  (You would therefore expect to see a large queue on this arm.).  This is also shown in 
the numerical data on the diagram. 
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These diagrams are all for the current time segment.  Choosing different time segments will give a simple 
animation of the traffic flows over time. 

Flow overlays can also be shown by exit, as shown below, which can sometimes be more useful.  In this case, the 
colour coding corresponds to destination.  In the example below, all traffic travelling to Arm 3 is shown in blue and 
this is the heaviest exit flow, with the largest contribution coming from Arm 1.   Again, the actual throughput 
calculated by the model is likely to be less than this. 
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The flow overlay tool can also be used at Priority Intersections, as in the T-junction example below, which clearly 
shows the heavy flows on the major roads. 

 

 

 Queue overlays 12.4.6

Please note that if you run a file in Lane Simulation Mode, a different set of visualisation options is available.  
The following section applies to files that have NOT been run in Lane Simulation mode. 

Provided the file has been run, for certain junction types you can use Overlays>Queues>End Queues option to 
show a red bar on each arm representing the length of the queue at the end of the time segment. 

Alternatively, use the Start and End Queues option to show the start and end queue (i.e. the queue at the start and 
the end of the time segment) on each arm for the current time segment.  The red section shows the start queue 
and the orange section the end queue. If a queue is decreasing, the start queue is shown in green and the end 
queue in red. Selecting different time segments will give a simple animation of queue build-up and decay over 
time. 

If the queue length is longer than the current length of the arm, then a thick black line is drawn at the end of the 
queue. 

If queue percentiles (see Queue Variations (percentiles) and Queue Markers) have been selected and the file run, 
 the various percentiles can be depicted on the diagram in different shades of red.  (The darkest red represents the 
95

th
 percentile queue).  Turn this mode on by selecting Overlays>Queues>Queue Percentiles. 

 

 Value and error overlays 12.4.7

Use Overlays>Value Comparison to show blue highlighting on each arm, where the depth of shading indicates the 
relative value of a chosen data field.  Set the data field simply by clicking on it in any Data Editor or Data Grid 
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screen. You can control the difference between the smallest and largest values via the Junction Diagram options 
screen. 

Use the Error Overlay Tool to highlight in red/amber/green/grey any warnings, errors or information tasks for each 
arm. These correspond to the messages shown in the Task List screen.   

 

 Whole Period Results overlay 12.4.8

For roundabouts, use Overlays>Whole Period Results to show items from the Summary Results Screen next to 
 each arm, for the current Analysis/Demand Set.   Red background shading indicates that results are not up to date 
and the file should be re-run.  The size and position can be adjusted using Options>Text overlays>Whole Period 
Results. 

 

 

 

Use the Style button to toggle in and out of stick diagram mode.  In this mode, all internal details of the junction(s) 
are hidden, leaving behind a simple diagram showing just the arms and any active overlays such as arm names and 
turning volumes.   

Adjust the size and spacing of the text items using the diagram Options screen. 

To show arm names instead of IDs, go to Data Outline>Options>Sorting and Display>Show arm and junction 
names. 
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This view can be particularly useful when working with multiple linked junctions as it provides a simple overview 
diagram showing the overall network without the details of each junction. 

 

Some overlays such as flow overlays are available in stick diagram mode. 

Clicking on a junction or an arm will take you to the properties for that item.  In general however there is limited 
interactivity in stick diagram mode and we recommend that you return to normal mode whenever you need to 
make changes to the diagram. 
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There are a large number of options controlling the appearance of the Junction Diagram, and you can access these 
via the Junction Diagram Options screen.  (Use the icon on the right-hand side of the main toolbar.) 

Most items are self-explanatory and are not listed here other than the ones of particular interest below.  Most tabs 
have a Defaults button, which will restore the options on that tab to their default values. 

Most Junction Diagram options are saved in the data file, so the same options will be used when you next load the 
file.  The options set here also affect the way the diagram is depicted in reports. 

Please note that some options only have an effect in certain modes, or for certain junction types. 

 

 Setting a background image 12.6.1

Add one or more background images via the Backgrounds tab, or from the diagram by going to 
Background>Manage backgrounds.  Press the Add button and then browse to an image file, which will then be 
placed in the middle of the Junction Diagram.  To adjust the opacity, position and size of the image, you must 
select it in the listbox.  The image will then be shown with a red outline and red handles in the Junction Diagram, 
which you can use to move and resize it.  Use the opacity slider to control how faint the image is relative to the 
rest of the diagram. 

The images are embedded in the main data file; there is no need to save the image files separately. 

 

Once you have added one or more images, you can quickly toggle them on/off by using the options in the 
Background button on the diagram toolbar. Especially when using a complex background image or diagram, this 
can help to quickly refer to items on the background drawing without having to always show these at the same 
time as the actual junction drawing. 
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Use the Show Background and Numbers option to show the background image, plus the calculated entry flows or 
turning movements, but without the usual lines and arrows.  An example of using this mode is shown below.  (The 
units can easily be turned off via the Junction Diagram Options screen, as can the size and offset of the other 
items.) 

 
 

The appearance also depends on the settings in the Options screen.  For instance, if in Lane Simulation mode, 
there is an option in the Options screen to switch off white lane interiors. 

 

 Showing other textual data 12.6.2

If the Flows of the Junction Diagram is set to ‘Custom’, then any data field can be shown on each arm by setting up 
options in the Text Overlays>Per Arm/Per Stream tabs of the Options screen. Select the data fields to use by 
clicking on them in the Data Editor (or a Data Grid) and then clicking the Select Field button.   
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If you have added a suitable background image, such as an aerial photograph or export from a CAD drawing, you 
can use diagram tools to estimate certain roundabout and mini-roundabout geometries. 

Please note that these tools are provided as a way to check existing measurements and to quickly obtain 
estimates for new measurements but are not a substitute for accurate measurements using a CAD package.   

You use the measurement tools by manipulating a series of control points and construction lines so that they lie 
along the entry kerb and so on for each arm, according to the descriptions in Appendix B - Measurement of 
 geometric parameters affecting capacity.  Assuming you have correctly set the scale, Junctions 9 can then use the 
control points to estimate the values of the roundabout entry width, flare length etc, and display them on screen.  
Optionally you can then save the values to the relevant data fields and run the ARCADY traffic model.   Whether or 
not you do this, the control points are always saved as part of the file. 

 

Start by adding a background image (see Setting a background image).  You may need to stretch the image to 
 make it big enough to easily work with and may also want to adjust the opacity. The background image should be 
in roughly the correct orientation and position relative to the rest of the diagram, although the exact positioning 
does not matter.  In the example below, an illustrative image of a typical roundabout has been used, and the main 
roundabout arms moved so that they roughly line up with the image.   Arm 1 is the eastern arm. 
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An important step is to set the scale.  The accuracy of all measurements will depend on this.   Make sure that the 
scale is visible (Show>Scale) and then position the scale over anything in the background image that is of a known 
distance.  In this example it is known that the upstream approach width on Arm 1 is 3.5m, but you could use any 
fixed distance such as a scale indicator on the background image.  Zoom in to obtain higher accuracy, although 
ultimately the accuracy will be limited by the quality of the background image. 

With the scale positioned over the known length, right-click on it and choose Adjust Scale and enter the distance in 
the current units.   (If you subsequently change the scale, all measurements will change accordingly.) 

 

 

Once the scale is set, you can enter Measurement Mode by using the Measure button. 

 

 

There are several options available: 

 Measure:  measures geometries but does not save them to file until you click Save in file. 
 

 Measure and save in file:  measures geometries and automatically saves them to file as you adjust them 
 

 View (read-only): shows existing measurements in read-only mode (i.e. they cannot be changed).  This is 
useful for checking existing measurements in a file without accidentally changing them. 
 

 Reset:  resets the currently active measurement, or all measurements, to their default positions. 
 

 Exit mode:  click here to exit Measurement Mode, hide all construction lines and return to the normal 
diagram view. 
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When you enter Measurement Mode, the background image remains visible, the main schematic diagram (arms, 
lanes, flows, IDs etc) is turned off and a set of construction lines and points shown instead.   These control points 
are shown for the currently active arm.  To measure a different arm, select it in the Data Outline or a data grid. 

When you first enter Measurement Mode, the current geometries for Arm 1 are automatically shown in the Data 
Editor (or a data grid) if they are not already shown. 

To show a different geometry – e.g. entry radius instead of entry width – click on it in the Data Editor or data grid.   
Some construction lines serve more than one geometry – for example, the approach width, entry width and flare 
length are all measured at the same time. 

 

In the diagram, note that: 

 Blue circles or arrows are control points that can be moved with the mouse.   You can control their size in 
Options>Measurements and can also choose whether they should stay the same size when zooming in 
(this makes them more visible when zoomed out, but reduces accuracy when zoomed in).  For maximum 
accuracy, zoom in as far as possible and reduce the control point size. 
 

 Black lines with arrows are the calculated ARCADY geometries – e.g. entry width (E), entry radius (R) etc. 
 

 Green, red and other coloured lines are construction lines generated automatically by Junctions 9. 
 

 The values as measured in the diagram according to the scale are shown in white text.  The current 
values actually saved in the file are shown in brackets.  (This can be turned off in Options>Measurements, 
as can the text size.) 
 

 If the measured value is outside the allowed range it is shown in red.  When you save to file, it will be 
capped at the minimum/maximum allowed value. 
 

 Each set of control points starts off in default positions roughly based on the position of the diagram arm 
(NOT the background image).  To return to these default positions, select Measure>Reset. 
 

 If you need more control points, in some cases you can right-click on an existing control point and select 
Add new control points 

As you move the blue control points with the mouse, the measurements will change.  When you are happy with 
each one, click Measure>Save in file and then choose whether to save just the current item, or all items.   (This 
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step is not needed if you are in Measure>Measure and save in file mode, because in this mode all measurements 
are saved as soon as you move the control points.) 

Usually you would save all measurements, so when you have finished, the two sets of numbers in the diagram will 
be the same.  Sometimes however if you are providing a second opinion for measurements, or re-assessing a file, 
you may want to re-measure all items without actually saving them.  In this case the two sets of numbers will differ 
until you click Measure>Save in file. 

Details of the ARCADY geometry definitions are given in Appendix B - Measurement of geometric parameters 
affecting capacity.  Assuming you are familiar with these definitions, the following sections show how to use the 
measurement tool for each geometry.  The control point size has been set to a fairly large value to aid visibility in 
the screenshots. 

 

 Standard roundabouts: Approach half-width, entry width and flare 12.7.1
length 

 Position E where the give-way line meets the median island or marking. 
 

 Position M1, M2 and M3 along the median line, following the curve of the road as best as possible.  M3 
should be upstream from any local flaring. 
 

 K6 should be roughly opposite M3, on the nearside kerb.  K5 to K1 should then follow the curve of the 
nearside kerb, towards the give-way line.  K1 and any of the other K points can be beyond the give-way 
line; you can position them anywhere along the kerb that gives the smoothest curve and/or the best 
match to the real kerb line.  

 

From these control points, Junctions 9 automatically measures the entry width (E), approach half-width (V) and 
effective flare length (L), according to the definitions in the appendix of this User Guide.  The yellow and orange 
lines are construction lines used in the measurement of the flare length. 

In the example, the scale was fixed to the known distance of 3.5m on this arm’s approach.  The approach half-
width (V) is measured at the same location and so has been measured as 3.5m.  (How precisely this happens 
depends on the resolution of the background image and the accuracy of positioning, which sometimes may be 
slightly subjective.) 
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NOTE:  by default, there are three “M” points and six “K” points.  If you need more control over the curve lines, 
you can add more control points by right-clicking on an existing control point and selecting Add new control point.    

 

 

 Standard roundabouts: Entry radius 12.7.2

 Use the two arrow control points to move the position and size of the circle.   
 

 The section marked ‘20m’ should be positioned along the nearside kerb in the vicinity of the roundabout 
entry for this arm. 
 

 The radius should be adjusted until the circle follows the kerbline as closely as possible within this 20m 
section.  It should represent the maximum curvature in this region – i.e. if there is a choice of positions 
and sizes for the circle, choose the one that gives the smallest circle (i.e. smallest radius and so largest 
curvature) 
 

 If necessary, you can drag the scale to measure out an approximate straight-line distance of 10m 
downstream from the entry and 25m upstream, as described in Entry radius (R), to help judge where to 
 position the 20m section. 
 

 In this example, the entry radius (R) has been measured as approximately 30m. 
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 Standard roundabouts: Inscribed circle diameter 12.7.3

 Use the two arrow control points to move the position and size of the circle.   
 

 The circle should touch the kerbline of both the entry and exit sides of the arm being measured (in this 
case, the eastern arm).  Some trial and error may be required. 
 

 The circle should roughly lie within the roundabout in the vicinity of the arm being measured but it does 
matter if the circle lies outside the roundabout elsewhere. 
 

 Often, a different diameter will be measured for each arm, although if the roundabout is symmetrical 
then they will be the same or similar. 
 

 For more advice, please see www.trlsoftware.co.uk/knowledgebase and search for “inscribed circle 
diameter”. 
 

 In this example, the inscribed circle diameter (D) has been measured as 49m. 
 

 

 

 

 

 

 

 

  

http://www.trlsoftware.co.uk/knowledgebase
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 Standard roundabouts: Conflict angle (entry angle) 12.7.4

Appendix B describes two methods of measuring the conflict angle, with advice on how to choose with method to 
use.  This is handled automatically by the measurement tool. 

 Position E in the centre of the approach of the arm being measured, and the arrow at the other end so 
that the line represents the typical direction across the give-way line of traffic entering the roundabout on 
this arm.   
 

 Position X somewhere in the circulating carriageway and position the arrow at the other end in the 
middle of the exit of the next arm from that being measured.  The line should point in the typical direction 
of traffic leaving the roundabout on the next arm from that being measured.  At small roundabouts - as in 
this example – this exit line will be close to the entry line set up in the previous step and will cross over it; 
at larger roundabouts it may be further away. 
 

 Position the unattached C at the centre of the roundabout and then position the other C so that the circle 
represents the middle of the circulating carriageway in the vicinity of the arm being measured. 

Depending on the size of the roundabout and the positioning of the items above, there are two ways in which the 
conflict angle (PHI) can be measured.  At small roundabouts the conflict angle is measured as half of the angle 
between the entry and exit lines and in this case is about 29 degrees. 

 

 

At larger roundabouts, the exit line for the next arm will not be in the vicinity of the entry of the arm being 
measured (and in fact does not need to be positioned at all).  In these cases, the conflict angle is measured as the 
angle between the entering traffic and the circulating traffic and in the example below is shown as about 26 
degrees.  The angle arc is drawn in a different colour to indicate that a different method is being used. 
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At some roundabouts, you will find that moving the control points slightly results in the measurement switching 
between the two methods (shown by the green or light blue colour for the angle arc), but in such cases you will 
usually find that both methods give approximately the same value. 
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 Mini-roundabouts: All measurements 12.7.5

For mini-roundabouts, all relevant geometric measurements are made using a single set of construction lines.   

 Position E where the give-way line meets the median island or marking. 
 

 Position X at the offside end of the give-way line on the next arm, on the side of the island closest to the 
exit of this arm. 
 

 Position M1, M2 and M3 along the median line, following the curve of the road as best as possible.  M3 
should be upstream from any local flaring. 
 

 K6 should be roughly opposite M3, on the nearside kerb.  K5 to K1 should then follow the curve of the 
nearside kerb, towards the give-way line.  K1 should be located within the exit of the next arm so that a 
line can be drawn between K1 and X.  The other K points can be positioned anywhere along the kerb that 
gives the smoothest curve and/or the best match to the real kerb line.  

 

 

The following items are then automatically measured according to the definitions in the appendix of this User 
Guide: 

 Entry width (E) 
 

 Approach road half-width (VF): this is measured upstream of any local effects and represents the ‘normal’ 
road width upstream of the junction 
 

 Minimum approach road half-width (VM):  this will either be the same as the approach road half-width 
(and located at the same point) or else will be located closer to the junction if there is any local narrowing 
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close to the junction.   
 
 

 Flare length (LM):  the orange and yellow lines are construction lines for the flare length, which is based 
on the location of VM. 
 

 Distance to next arm (An): the straight-line distance between the entry of the arm being measured and 
the exit of the next arm. 
 

 Entry corner kerb line distance (K): the curved distance along the kerb between the entry of the arm being 
measured and the exit of the next arm. 

 

NOTE:  If you need more control over the curve lines, you can add more control points by right-clicking on an 
existing control point and selecting Add new control point.    
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Pedestrians using pedestrian crossings installed close to a junction may reduce the vehicular capacity of the 
junction in two ways.  Firstly, for traffic approaching the junction, the combined capacity of the crossing and 
junction will be lower than either the vehicular capacity of the crossing or the junction capacity considered 
separately.  Secondly, the crossing may restrict traffic leaving the junction, causing blocking back, i.e. traffic 
queuing in such a way as to block the preceding entry.   

Junctions 9 can model Zebra (unsignalled), Pelican (signalled) and Puffin (adaptive signalled) pedestrian crossings 
at roundabouts and priority intersections. The models are different for each crossing type, but the same approach 
is used for all junction types.   

 

To set up a pedestrian crossing on an arm, use the Pedestrian Crossing section of the Data Outline for the 
arm, or press this button on the vertical toolbar. 

In the Crossing Type field, select the type of crossing.  You can then enter details of the crossing.  Please see 
Appendix F - Measurement of pedestrian crossing geometry for details of the parameters. 

 

For Zebra crossings, the crossing length may be described either as a length (Crossing Data Type=’Distance’) or as 
the time taken for a pedestrian to cross (Crossing Data Type=’Time’).  Depending on the options chosen, and 
whether the crossing has a central refuge, different parameters will be disabled in the lower part of the screen. 

Pedestrian Demand can be entered on the same screen (assuming a flat profile), or alternatively in the Demand 
 Screen (which can be useful if wanting to set up a more complicated profile). 

There are no special outputs from the pedestrian crossing models other than a reduction in capacity due to the 
effects described above.  Time segment results include a Pedestrian Demand output, which acts as a confirmation 
of the pedestrian demand on the crossing. 
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Pedestrian crossings are shown and can be positioned using the Junction Diagram Screen.  (Note that the position 
in the diagram has no effect on the model.) 

 

 Restrictions on pedestrian crossing modelling 13.1.1

Due to the complexities involved, pedestrian crossings cannot be modelled in all situations.  If you encounter one 
of these restrictions, consider using Lane Simulation Mode, which has fewer restrictions. The main differences are 
 summarised in the following table. 

 Normal model Lane Simulation 

Effect of crossing on entry side at roundabouts and T-
junctions 

  

Blocking back from zebra at roundabout   
Blocking back from pelican/puffin at roundabout   
Blocking back from any crossing at a T-junction    1  
Blocking back into arms other than the immediately preceding 
arm 

  

   
Crossing within flared section of T-junction minor arm   
Crossing on major road where right-turning traffic blocks 
straight-ahead traffic 

  

Crossing between linked junctions  2
  

   
“Crossing” with fixed capacity which can be used to model 
bottleneck restrictions etc 

 
3 

 
1  A warning may be shown if blocking is liable to occur. 
2  Can be modelled but it is recommended that Lane Simulation is used in preference. 
3  See Using a bottleneck restriction 

 

 
 

 

Mini-roundabouts are selected by setting the Junction Type to Mini-roundabout. 

The mini-roundabout model is based on research carried out in the late 1990s and first appeared in ARCADY 5.  
Some users noted a tendency for this model to underestimate capacity.  The reasons for this are unknown but 
during the development of Junctions 9 the original research datasets were re-analysed using the same 
assumptions as the original researchers but with improved analysis techniques including the exclusion of suspect 
data points. 

This led to a revised version of the mini-roundabout model which uses the same geometric parameters and inputs, 
and is of the same form, but which explains 68% of the variation in the entry flows of the raw data, compared to 
60% for the original model. 

The revised model tends to predict higher capacity for any given arm of a mini-roundabout.  The maximum queues 
on any given arm are, on average, around 40% smaller than with the previous model and tend to be more in line 
with user expectations.  Please note however that the actual difference that you see for any given file will depend 
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on the geometries and flows and in some cases you will see no difference compared to the original model.   As 
with any aspect of the ARCADY and PICADY models, if you have any feedback relating to the performance of this 
model, please contact TRL.  

Junctions 9 uses the revised mini-roundabout model by default but the original model is also available if required 
(for example if wishing to match results from previous versions of ARCADY).  The data input process is exactly the 
same for both models.   To select which model to use, go to Data Outline>Options>Analysis Options and change 
the Mini-roundabout model field.  The revised model, referred to as “JUNCTIONS 9” is the default choice, with the 
original model being referred to as “ARCADY 5”. 

 

 

 T-shaped mini-roundabouts 13.2.1

Some mini-roundabouts have a T-shape with unbalanced flows and may behave more like priority junctions than 
roundabouts, and as a result are difficult to evaluate accurately with any traffic model.   The results associated 
with such mini-roundabouts should be treated with caution. 

This also applies to any mini-roundabout that has a dominant ‘through’ movement.  The most common case is 
where the junction has a T-shape, particularly if a mini-roundabout replaces an older T-junction and has little or no 
deflection for the straight-ahead movement(s).  At such sites, some drivers may continue to treat the junction as if 
the original priority system is still partially in place.   If this is the case, consider adding a suitable intercept 
correction to the relevant arms.  Otherwise the capacity of these arms may be underestimated by the model. 

 

 

A roundabout is defined as “large” in ARCADY if it has an overall diameter in excess of 130 metres or if it connects 
with a dual carriageway or motorway passing under or over it (i.e. grade-separated), or if it connects directly with a 
motorway.   

The treatment of grade-separated roundabouts in ARCADY incorporates models derived from a number of 
research studies.  ALL arms of a grade-separated roundabout have a different capacity relationship from that 
applied to arms of a “normal” (non grade-separated) roundabout. 
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NOTE:  The ‘dumbbell’ case where a motorway exit slip-road connects with an all-purpose road at a small roundabout on a 
different level from, but not directly above or below, the motorway, should NOT be modelled as grade-separated. 

To set up a roundabout as grade-separated or as a large roundabout, go to Data Outline>Junction and set the 
Junction Type as “Large Roundabout”.  This will enable a Large Roundabout Data section for each arm where some 
additional data should be entered, as follows. 

Entry-to-exit separation:  this is the distance between the point where the arm enters the roundabout and the 
point at which the same arm leaves the roundabout. I.e., the distance between the centres of the entry and 
previous exit (on the same arm) measured around the roundabout perimeter. It is important to note that arms of 
this type should be treated as a single arm, not as separate entry-only and exit-only arms.  It is only applicable 
where the entry and exit for the particular arm are separated by a significant length of circulating carriageway.  For 
the other arms, a value of zero is entered.   

NOTE: When the entry (on-ramp) and exit (off-ramp) of a particular arm are not adjacent, i.e. ‘in effect’ it is an entry-only arm, 
the separation should be measured between the centres of the entry and the previous ENTRY (on the previous arm). If the 
separation is greater than 160 metres, 160 should be entered. 

 
 

 

 

Circulating flow:  This represents the mean circulating flow past each arm, in PCUs, for the central 30 minutes of 
the total modelled period.   This value represents a mean ‘historic’ value for the circulating flow, as opposed to any 
‘immediate’ value of the circulating flow at any time.  It represents an inherent ability of large roundabouts to 
cope with higher flows than ‘normal’ roundabouts.   

In general, the entry capacity in the absence of circulating traffic is larger, but the entry capacity decreases more 
rapidly as circulating traffic increases, compared with at-grade roundabouts.  In general, grade separated 
roundabouts have a larger intercept, but a steeper slope, in their capacity relationships. 

The observed value should be based on several days’ measurements. Naturally, the individual days on which flows 
are measured, for inclusion in the mean, should be representative of the situation being modelled, e.g. if 
modelling a weekday peak, the value entered would ideally be the mean taken from all five weekdays equally 
represented. 
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If circulating flows cannot be measured, it is also possible to ESTIMATE circulating flows automatically, given the 
current demand flows and turning proportions.  To do this, select Data>Estimate Circulating Flows from the main 
program menu.  The calculated circulating flows will be placed in the Circulating Flow field for each arm.  See also: 
Appendix H - Estimation of circulating flow for large roundabouts. 

Estimated circulating flows in this way should only be used when no other data is available, since it is a function of 
data that already exists rather than being supplied by the user as extra information. 

 

 

It is possible to model simple systems of linked junctions.  At its basic level, this involves the exit flow from an arm 
on one junction being fed into the entry on another junction. 

Each link is a ONE-WAY link as seen from the viewpoint of the downstream roundabout. (I.e. the link specifies 
‘where’ the traffic comes from, and refers to the upstream roundabout.)  Therefore if setting up a two-way link, 
you will need to set the properties for two links.   

In Junctions 9 there are two ways to model linked junctions: 

 The method for modelling linked roundabouts that was first introduced in ARCADY 7.   
 

 Lane Simulation Mode allows the simulation of all types of junction and is the recommended way of 
modelling linked junctions. Although simulation mode can be slower to run, it is more powerful because 
there is no limit to the number of storage space restrictions that you can set up. Please see Using 
 simulation with linked junctions. 
 

The table below summarises the main features that are available in the two modes. 

 ARCADY 7 model Lane Simulation 

Linked roundabouts   
Linked ARCADY roundabouts, PICADY T-junctions and OSCADY 
signalised junctions in any combination 

  

   
Linking mode: Simple vertical queueing     1

 

Linking mode: Queue limited      2 
Linking mode: Closely spaced     3 
 

1   Set lane storage to a very high value; this will be equivalent to vertical queueing. 
2   Simulation will not allow vehicles to enter downstream link if it is full of queueing vehicles 
3   Any lane storage down to 1 PCU can be used but the same model is used regardless of this value 
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 Setting up linked junctions 13.4.1

NOTE:  Roundabouts can be linked in any mode, but to link PICADY T-junctions or OSCADY junctions, you must use 
Lane Simulation Mode. 

To set up a link between two junctions, firstly add the junctions using the Data Outline and set up their geometries 
and other usual data.  In this example, Arm 1 of two roundabouts is to be linked. 

  
  

To link the junctions, click the Connect button in the Junction Diagram.  The mouse pointer will 
change to show that you are in Connect mode.  Click on one of the arms to connect (click on the grey 
interior of the arm) and then click on the other arm.   

Connecting lines will then be shown between the junctions.  The Arm ID is removed from the diagram if the 
junctions happen to be positioned close together. 

TIP:  To UN-connect two junctions, follow the same procedure as above; each time you use the Connect tool, the 
connection is toggled on and off. 

 

When you connect junctions, the program will automatically set up basic link data which can be seen (and edited 
manually) in the Demand Screen. 

On the General tab of the Demand screen, the Linked Arm option for the relevant arms will be ticked.   
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On the Linked Arm tab, a row will be enabled for the relevant arms.  The Feeding Junction and Feeding Arm ID are 
filled in automatically and refer to the ID of the junction and arm for the source of traffic.  Whether the other 
columns are shown depends on whether you are in Lane Simulation mode or not. 

 

 
Clicking in the Junction Diagram on each junction in turn will show the link data in the Demand screen for that 
junction.  Remember that each link is a one-way link and although the Connect Items tool will set up both sides of 
the link, you then need to manage each side separately. 

NOTE:  by manually entering the feeding junction/arm IDs you can set up more complex cases where, for example, an arm is 
connected to two different roundabouts. 

Traffic demand data for all arms that enter the system of linked junctions is entered as usual.  For the internal 
arms, any entered demand is irrelevant because it will be whatever traffic is able to flow from the upstream 
junction towards the downstream junction.  However, you still need to specify turning proportions at the 
downstream junction.  In the O-D screen, the internal arms are highlighted in yellow.  In the screenshot, the only 
value for Arm 1 is 1.0 for the Arm 1 – Arm 2 movement, and zero for the other cells.  This means that of the traffic 
that arrives at this arm from the upstream roundabout, all the traffic will turn left into Arm 2. 
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NOTE: If using the ARCADY 7 model, you may need to set the linking mode – see Linking modes (ARCADY 7 model). 

NOTE:  If using Lane Simulation, you may also need to set up lane storage values - see Using simulation with linked junctions for 
more details. 

 

When the file is run using either model, the exit flow from Roundabout 1 feeds into the entry on Roundabout 2, 
and vice versa.   

In the screenshot below, the turning counts have been kept very simple such that the only traffic entering the 
system is on the SE arm of Roundabout 2.  All this traffic turns left and heads towards the downstream roundabout 
and then turns left again and exits on the SW arm.   This is confirmed after running the file by turning on the 
Overlays>Flows by entry and Flows>Actual flows modes in the diagram.   The colouring of these overlays matches 
the arm ID colours and changes at the transition between the two roundabouts. 

 

 

 

Detailed results can of course be seen in the Summary Results screen and time segment results as usual. 
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 Linking modes (ARCADY 7 model) 13.4.2

This section describes the ARCADY 7 model that is available in Junctions 9 specifically for linked roundabouts, if not 
using Lane Simulation.  Please note that this model is an analytical one rather than being based on empirical 
studies.  As always, you should apply engineering judgement to the application of the model and to the 
interpretation of the results.  Particularly at very closely spaced junctions, there may be interactions between the 
two junctions that cannot be modelled.   

There are three main modes that can be used.  Select the mode and other options on the Linked Arm tab of the 
main Flows screen.  It is recommended that Simple (vertical queueing) mode is used in the first instance, and the 
other modes considered if you wish to investigate junction behaviour in more detail. 

Whichever mode you use, it is always a good idea to check that the model reproduces observed base conditions 
before modelling other scenarios 

NOTE:  Most linked roundabouts will be linked in both directions, so you need to set up these modes and other options from 

the perspective of EACH roundabout.  This is done automatically if you link roundabouts using the Connect tool of the Junction 
Diagram Screen. 

 

13.4.2.1 Simple (vertical queueing) 

 
In this mode, ARCADY will simply transfer the exit flow from the upstream roundabout to the entry of the 
downstream roundabout.  Any queue that forms between the roundabouts will be treated as a ‘vertical’ queue 
that may be longer than the space between the roundabouts.  This is the simplest and default mode and can be 
used to link any number of roundabouts.  However, it relies on the user checking whether the queues that form 
between roundabouts are longer than the available storage space.  If they are, then the simple conclusion is that 
the roundabout system does not cope with the volume of traffic. 

 

In the example system shown above, assuming that the SE arm has a high capacity but the internal link has a 
smaller capacity then in this example a large queue of 85 PCU forms on the internal link (Junction 1 Arm 1).   If this 
is greater than the storage space available then you must simply conclude that the junction will not operate 
satisfactorily. 
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13.4.2.2 Queue limited 

 
In this mode, the user specifies the available storage space between the roundabouts.   ARCADY will prevent the 
exit flow from the upstream roundabout rising above a level that would cause the queue between the 
roundabouts to be greater than this available space.  In other words, the queue on the ‘internal link’ is guaranteed 
not to exceed the storage space.  Instead, traffic leaving the upstream roundabout will be throttled, which will 
cause queueing on all relevant upstream arms.  This mode is suitable for all types of linked roundabouts other than 
closely spaced or double roundabouts, which are better modelled using the next option. 

NOTE:  due to model limitations, there is a limit of one restriction per roundabout.  Therefore if you need to use restrictions, they should be 
placed on only the critical arms.  The other arms should be modelled with simple linking. 

 
Continuing the same example from above, assume that the internal link is known to only have queuing space for 
25 PCU.  In simple linking mode, this would have no effect   To model the restricting effect of this queueing space, 
edit the Linked Arm properties in the Demand screen for Junction 1, select Queue limited as the Link Type and 
enter a value for the Internal storage space. 

Re-running the file now shows that the queue on the internal link has been limited to 25 PCU, causing a larger 
queue on the SE arm, and associated reduction in entry flow.  In a more complex file, this would affect all 
upstream arms, in accordance to turning proportions.  If there are two-way or multiple links, the effect will 
operate in all directions and so the results may not always been as immediately intuitive as in this simple example. 
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13.4.2.3 Closely spaced 

 
In this mode, the storage space is irrelevant and instead ARCADY prevents the exit flow from the upstream 
roundabout from exceeding the capacity of the downstream entry.  This should not be used at widely spaced 
roundabouts because it implies that drivers leaving the first roundabout can ‘see’ the capacity of the downstream 
roundabout.  However, at more closely spaced roundabouts, this may be a reasonable assumption if you feel that 
drivers tend to negotiate the entire junction in one manoeuvre.  If you don’t use this mode at such junctions, it 
implies that drivers enter the first roundabout and then separately stop at the internal give-way line for the second 
roundabout, in exactly the same way as they would do if the second roundabout were a great distance away.  
Whether or not this happens depends on the particular junction as well as local driver behaviour, so is a matter for 
individual judgement.   

This mode ensures that the RFC of the internal link does not exceed 1.0.  However, that in itself does not mean 
that there won’t be any queue on the internal link.  This is because, as the RFC approaches 1.0, a random queue 
can build up, which may be larger than the internal storage space.  (This random queue is due to the fact that 
traffic arrives at irregular intervals and is a fundamental aspect of queueing theory.)  If two roundabouts are 
closely spaced, the storage space between the roundabouts may only be a few PCU, which can easily be exceeded 
by the random queue.  To avoid this, Closely spaced mode ignores any random queue.   

Therefore in this mode, ARCADY will always show zero queue for the internal link, as it will prevent any uniform 
queue and will also ignore any random queue.   

NOTE:  due to model limitations, there is a limit of one restriction per roundabout.  Therefore if you need to use restrictions, they should be 
placed on only the critical arms.  The other arms should be modelled with simple linking. 

NOTE:  ‘Closely Spaced’ mode should only be used if you have good reason to believe that the description above of behaviour at the junction is 
accurate. 

 

 Setting the Internal Storage Space 13.4.3

The internal storage space represents the space available for queueing between the linked roundabouts, and is 
expressed in PCU.  As with all other options, this should be entered for EACH link.  Therefore if modelling a two-
way link (which most links will be), you will need to enter the storage space twice, for each link direction.  Usually 
this will be the same value. 

It should be remembered that the internal storage space represents the number of PCUs that can queue before 
the queue would interfere with other traffic.  At the double mini-roundabout in the diagram below, for example, 2 
PCU can queue whilst still allowing other traffic to pass.  Please note that if the storage space is small, as in this 
example, then there is more scope for more complex interactions which ARCADY may not be able to model, even if 
using the Closely Spaced option. 
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Diagram: Martin Llavallol, Peter Brett Associates. 

 

 

 Adjusting the flow between roundabouts (ARCADY 7 model) 13.4.4

It may be that some of the traffic leaving the first junction does not flow into the second junction but instead 
leaves the system.  Or, there may be a source of traffic inbetween the two junctions, which adds to the flow of 
traffic between the junctions.  Junctions 9 provides a simple way to adjust the traffic flowing between linked 
junctions.  In the Linked Arm tab of the Flows screen, each linked arm has the following additional properties that 
can be used in Simple (vertical queueing) mode: 

 
Uniform Flow:  this can be positive or negative and represents flow to be added to or subtracted from the internal 
link.  This represents a fixed source or sink of traffic that exists between the two junctions. 

Flow Multiplier:  enter a value above/below 100% to boost/shrink the flow between the junctions.  This can be 
used to represent a source or sink that scales in proportion to the overall flow.  You can also use this if you wish to 
connect more than one downstream junction to a single upstream junction.  For example, if an upstream exit arm 
feeds two downstream arms, set the Flow Multiplier of each downstream entry arm to 50%.   

To model more detailed scenarios, we recommend using TRANSYT. 
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 Linked roundabouts with bypass/filter lanes (ARCADY 7 model) 13.4.5

The example below shows a pair of linked roundabouts.  The NW arm has a left-turn bypass, or left-turn filter lane 
(see  

 

Bypass and filter lanes).  The total left-turn demand is 500.  Of this, a majority (400) uses the bypass, and the 
remaining 100 travels through Roundabout A. 

By default, ALL flows leaving Roundabout A are assumed to flow into Roundabout B.  I.e., the entry flow into B is 
500. 

 

Optionally, you can use the Flow Source property in the Linked Arm tab of the Flows screen for Roundabout B to 
control whether or not the bypass flows into Roundabout B.    

If the Flow Source is set to Exit Only, then traffic emerging from the bypass is discarded and the flow into B consists 
purely of the 100 PCU/hr that emerges from the exit arm of A.   This may be the case if, for example, the filter lane 
skips both junctions and carries traffic to the exit of the NE arm on Roundabout B.   Note that, in this case, the 
bypass traffic will NOT be reported in any arm’s exit flow and so will effectively ‘disappear’ from the model. 

Conversely, if set to Bypass only, then the flow into B consists purely of the 400 PCU/hr that emerges from the 
bypass, and the 100 PCU/hr from the exit arm of A is discarded. 

For more complex layouts, use of TRANSYT may be more appropriate. 

 

 

 
NOTE:  This feature applies to Roundabouts only, and the file must be in Advanced Mode. 
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Use of Lane Simulation Mode may be more appropriate in some cases, although that mode also carries its own set 
of assumptions.  
 

NOTE:  The descriptions below refer to drive-on-the-left junctions.  

At some junctions, a filter lane or bypass may be provided for traffic turning left.  Typically this lane will join the 
exit side of the next arm, and allows traffic to travel to this destination without having to give way to circulating 
traffic. 

There are many different configurations and layouts.  For example, left-turning traffic may merge or give-way to 
traffic leaving the roundabout on the next arm, and this point may be close or far from the roundabout.  The filter 
lane may simply be a exclusive lane on the main entry, or it may be separated from other lanes on the entry by 
some considerable distance. 

As such, no attempt is made to model these situations in detail, but instead Junctions 9 provides a generalised 
bypass facility.  This allows you to specify that a certain proportion of left-turning traffic bypasses the roundabout.  
The effect on the model is that the entry flow through the roundabout will be reduced, and thus the circulating 
flows and capacities of other arms will be changed. 

Important assumptions are that: 

 It is assumed that traffic using the bypass does not give way to circulating flow.  If the bypass is well separated from 
the roundabout, then this is a reasonable assumption.  However in other cases you should use engineering judgement 
to decide whether traffic using the filter lane comes sufficiently close to the main circulating carriageway that some 
or all drivers may in effect give-way to circulating traffic.  Using a bypass lane will generally give optimistic results, 
because the model will assume that all traffic using the bypass is effectively removed from the junction. 
 

 It is assumed that the bypass has an arbitrarily high downstream capacity.  Traffic using the bypass is assumed to 
merge with the exit side of the next arm in such a way that it never forms a queue. 
 

 The above assumption means that the bypass does not have a capacity or queue or any other results defined.  It also 
means that any blocking back of the bypass into the main approach is not modelled.   
 

 It is assumed that all traffic wishing to use the bypass can do so, and that this is not prevented by queued traffic in 
other lanes. 
 

 If you use a bypass, then all traffic demand entered in ARCADY on that arm must be measured upstream of the 
bypass.  

 
 

 Using bypasses 13.5.1

 
NOTE:  This feature applies to Roundabouts only, and the file must be in Advanced Mode. 

 
To add a bypass to an arm, use the Data Outline to edit Arm>Capacity>Bypass.   

Tick the Arm has Bypass option, and in the Bypass Utilisation, enter an estimate of the percentage of left-turning 
traffic that uses the bypass.   The remaining percentage of left-turning traffic is assumed to travel through the 
roundabout as usual, giving way to circulating traffic.  For some junction layouts, if all left-turning traffic 
unambiguously uses the filter-lane, then Bypass Utilisation can be set simply to 100%. 



 Additional Modelling Theory and Features    Page 172     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 

 

The bypass is represented in the Junction Diagram Screen by an extra indicator in the text overlays, which points 
from the arm with the bypass towards the destination arm for left-turning traffic. 

If the diagram is showing original turning counts (see Traffic flows – numerical overlays), then the bypass will show 
 the entered bypass utilisation (75%), and the original entered turning counts are ALSO shown, as below: 

 

 

If any arm has a bypass, the time segment results contain extra results.  These results distinguish between Total 
Demand, which includes the bypass demand, and Junction Demand, which excludes the bypass and can be 
thought of as demand at the give-way line. 

Bypass Demand shows the volume of traffic using the bypass.  (There is not a separate bypass ‘entry flow’, 
because the bypass is assumed to have infinite capacity.) 

Also shown on some arms is Bypass Exit Flow.  This shows the flow out of the bypass that leaves the system on 
Arm 2.  This will always be exactly equal to the bypass demand on the previous arm and is shown for confirmation. 
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 Bypasses at linked roundabouts 13.5.2

Please see Linked roundabouts with bypass/filter lanes. 

 

 Alternative treatment of filter lanes 13.5.3

The advice below is taken from older versions of the ARCADY User Guide, but is still relevant if you are modelling 
filter lanes and NOT using the bypass facility in Junctions 9. 

A filter lane, in this context, is a lane carrying left-turning traffic which does not have to give way to circulating 
traffic at the give-way line. Instead, the left-turners proceed virtually unhindered, and usually merge with other 
traffic some significant distance from the roundabout. The presence of a filter lane can be allowed for as follows.  
For each arm with a filter lane, measure the widths V and E from the centre of the road to the offside edge of the 
filter lane, i.e. the usual measurements but excluding the width of the filter lane.  Measure the entry radius, R, to 
the offside of the filter lane and conflict (entry) angle for the traffic not using the filter lane. The demand flow for 
the approach is specified excluding the filter lane flow. 

The roundabout is then modelled by ARCADY for all traffic not using the filter lane(s).  Any queuing for the filter 
lane would not then be included in the ARCADY output. 

Also not modelled, is the effect of entry starvation caused by a filter lane that is fed by a lane containing traffic not 
turning left.  (Starvation is the effect whereby traffic is unable to reach the give-way line due to being stuck in a 
queue of traffic wishing to make the other movement.)  There could be a significant number of left turners unable 
to make their exit if the queue (for the other movement(s)) extends past the point where the filter lane starts. 
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The basic calculations performed by Junctions 9 are of mean queues and delays expected at a particular time of 
day, averaged over many occasions.   

Although these calculations are generally relevant to an economic appraisal of a particular junction scheme, there 
are many situations when more information is desirable.  For example, the user might wish to know how often a 
queue will block back to another junction or fire station exit.  Mean daily queues will not provide this information - 
what is really required is the cumulative distribution of queue-lengths. Junctions 9 incorporates an optional facility 
for estimating the distribution of queue-lengths.  The calculations are based on knowledge of the development of 
mean queues through time, and also a derivation of time-dependent variance of queue-length.   

This optional facility is known as Queue Variations or Queue Percentiles, and must be turned on via Data 
Outline>Options>Analysis Options>Calculate Queue Percentiles.  This mode is automatically turned on if you show 
95

th
 percentile queues in the Summary Results Screen 

NOTE:  Queue Variations are only available for arms that have a synthesised demand profile (e.g. LEVELS, FOUR, ONE HOUR), 
and NOT when the profile type is set to DIRECT or FLAT. 

NOTE:   Queue Variations can be sensitive to extremes of flow and/or capacity, and in these cases will show N/A or similar. 

NOTE:   The use of Queue Markers is an associated option. You need to turn on Queue Variations before you can use Queue 
Markers. 

NOTE:   If using Lane Simulation Mode, the simulation automatically produces queue probability distributions, which are 
calculated in a different way and which are NOT subject to the restrictions mentioned above.   Using Entry Lane Simulation 
Mode therefore provides an alternative way to generate queue variation results.  It also provides ways to visualise queue 
distributions in a more detailed way.  For details, see  

 

Queue percentiles and Shaded percentile queues.   

 

 

 Using Queue Variations 13.6.1

Firstly, make sure that queue variations are turned on by ticking Data Outline>Options>Analysis Options>Calculate 
Queue Percentiles. 

Queue variations will then automatically be output when the file is run, for all arms that have a synthesised profile 
and where the magnitude of the queueing is appropriate for the queue variation model.  Outputs are available via 
the Data Outline in the Queue Variations subsection of the arm or stream time segment results. 

Outputs show firstly the Mean queue, which is identical to the End Queue shown in the main results.  Other 
outputs are Q05, Q50, Q90 and Q95, where Q95 for example represents the 95

th
 percentile value of the queue 

length.  Within a given time-segment, there is a 95% chance of the queue on any given day being equal to or less 
than the Q95 value, and similarly for the other outputs. 

Where ‘N/A’ is shown, this means either that queue variations have not been requested or else they cannot be 
calculated for mathematical reasons.  Usually this is because the mean queue is too small or too large but it can 
also occur in situations where the capacity is greatly exceeded.   



 Additional Modelling Theory and Features    Page 175     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

NOTE: Queue percentiles are capped at a maximum of 199 vehicles. 

 

 

The various queue outputs can be visualised over time easily using the Time Graph mode of the Analyser Screen, as 
in the example above.  Although the mean queue peaks roughly in the middle of the modelled period, the 95

th
 

percentile queue continues rising until some time later and it is not until 08:45 that it can be said for sure that the 
queue will be low. 

The 50
th

 percentile queue (Q50) will usually be close to, but not exactly equal to, the mean queue (shown in blue 
above).  There is a 50% chance that an observed queue on any given day will be higher than or lower than the 50

th
 

percentile queue.  But in some cases it may be that there is a small chance of there being an extremely low or high 
queue, and this will affect the mean queue such that it may differ from the 50

th
 percentile queue. 

 

 Using Queue Markers 13.6.2

Queue Markers are set up via Data Outline>Arm>Capacity>Queue Options.  The file must be in Advanced Mode.  
Queue Markers allow you to analyse the chance of the queue on an arm reaching a predetermined point, which 
may for example be a critical point such as another junction, or the exit from another road, and so on.  

Firstly, make sure that queue variations are turned on by ticking the Data Outline>Options>Analysis 
Options>Calculate Queue Percentiles. 

Turn on a queue marker on the arm by ticking the Queue Marker option, which will enable more options on the 
screen.   

For Priority Intersections, the queue marker distance is entered directly in metres, and is measured either from 
the give-way line (for minor arms) or, for major arms, from the centre line of the first minor arm entering the 
junction. On a flared minor road, the queue marker must be within the two-lane section.  Queue markers with 
Priority Intersections make a number of assumptions and simplifications, meaning that the queue variation results 
may not be as accurate as the usual mean queue calculations. 

For Roundabouts, there are two ways in which queue markers can be specified: 
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1. By entering a direct value that specifies the average number of PCU that will cause the queue to reach the 
critical point.  This value is measured from the give-way line and should take into account any flaring and 
any other effects such as lanes, parked cars, road markings, etc.  To use this mode, set the Queue Marker 
Type to ‘Direct’ and then enter a value in Queue Marker Position.  If you enter 15, then the queue marker 
is triggered simply when the queue reaches 15 PCU. 
 

2. By entering a distance from the start of any flaring and also specifying the flare storage.  To use this mode, 
which is most similar to the ARCADY 6 queue markers, set Queue Marker Type to ‘Distance + Flare’ and 
then enter a distance in Distance From Start of Flare.  This represents a distance back from the start of 
any flaring.  In addition, enter a value for the typical Flare Storage in PCU and also the number of Lanes on 
the Approach.  The latter is used by ARCADY to estimate how the total queue is distributed between lanes 
and thus whether the queue will reach the queue marker.  See Appendix E - Measurement of “Queue 
Marker” position for more details. 

 

Once the queue marker is set up, run the file and then check the Time Segment Results>Queue Variations outputs.  
For each time segment, there are two relevant outputs: 

Probability of Reaching or Exceeding Marker: this shows the chance that the queue will reach to the queue 
marker or beyond. 

Probability of Exactly Reaching Marker: this shows the chance that the queue will reach exactly as far as the 
queue marker.  

In the example below, a queue marker has been positioned at 20 PCU from the give-way line.  The Time Graph (see 
Time Graph Mode) shows that the queue reaches at least as far as the marker in several of the central time 
segments.  The 50

th
 percentile queue in this example is approximately 20 PCU in the time segment 0740-0745, and, 

accordingly, the graph shows that the probability of the queue marker being reached during this time segment is 
just under 0.6, or very close to 50%.  In time segment 0750-0755, the 5

th
 percentile queue is 17 PCU, so there is 

roughly a 95% chance of the queue being equal to or greater than 17 PCU, or in other words, reaching the queue 
marker.  Again this is shown in the graph as a 0.95 chance during this time-segment. 

 

Plotting the Probability of Exactly Reaching Marker as shown below does shows that there is a small chance in any 
given time-segment of the queue exactly reaching the marker, but that the queue is most likely to pass the marker 
point at 0740-0745.  After that, the queue is likely to exceed the marker point. 
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Alternatively, the X-Y Graph generator (see X-Y Graph Mode) can be used to examine the chance of the queue 
hitting different queue marker points.  The graph below on the left shows that there is a 100% chance of the 
queue being less than or equal to 10 PCU, but a 50% chance of it being less than approx 43.  The graph on the right 
shows the chance of the queue being exactly each point along the x-axis.  All probabilities are low but the highest 
is at about 40 PCU.  So the most ‘likely’ queue is somewhere between 40 and 45.  This is all confirmed by the Mean 
Queue output (or the End Queue in the usual time segment results) which gives a value of 43 PCU. 

 

Note that queue variations work on the assumption that the capacity of the entry is known.  In reality the capacity 
is also subject to some uncertainty and site-to-site variations.  If needed, the capacity scaling functions of Junctions 
9 can be used to explore this, along with the other modes of the Analyser Screen.   

 

 

 

Please see Entry and exit restrictions in Lane Simulation mode for additional methods of modelling restrictions in 
 Lane Simulation mode.   The following section refers to the methods which are available when NOT using Lane 
Simulation. 

Please note that the following sections apply only to roundabouts and you must be in Advanced Mode. 
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 Entry restrictions 13.7.1

To set up an entry restriction on any arm, enter a value in Data Outline>Arm>Capacity>Maximum Capacity.  The 
capacity on the entry will be capped at this value. 

 

 

 Exit restrictions 13.7.2

 
 
To set up an exit restriction on any arm (for example if there is road narrowing on the exit, or a bottleneck 
restriction, or any other effect that impedes traffic), enter values in Data Outline>Arm>Capacity>Exit Restriction.  
The Maximum Capacity entered here represents the capacity of the exit restriction.   

When the model runs, the exit flow on this arm will be capped (subject to some degree of approximation) to this 
value.  Depending on the roundabout configuration, this may cause blocking around the roundabout and the 
transfer of queues to upstream entries. 

NOTE:  In Lane Simulation Mode, there are various other ways to model exit restrictions. 

 NOTE:  Due to model limitations, there is a limit of one exit restriction per junction. 

NOTE:  An assumption is made that only vehicles trying to enter the arm with the exit restriction are affected, and that vehicles 
travelling to other destinations are unaffected.  This assumes that any vehicles queuing on the circulating carriageway leave 
gaps for other vehicles.  (In fact ARCADY assumes that the queues are pushed back entirely to the upstream arms and that 
vehicles do not queue on the circulating carriageway at all).  However, vehicles travelling to unrestricted destinations have to 
queue behind vehicles waiting to travel to a restricted exit, and this effect is modelled.  It is assumed that the entire entry width 
is available for all vehicles and individual lanes are not modelled.  Any tendency of small roundabouts to completely lock up in 
extreme conditions is NOT modelled.  NOTE:  In Lane Simulation Mode, different considerations apply. 



 Additional Modelling Theory and Features    Page 179     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

NOTE: If the roundabout is part of a linked system, and the link includes an automatic exit restriction, the read-only Linked Exit 
Restriction Present box will be ticked.  Trying to add another exit restriction on the same arm will result in an error. 

 

 

For all junctions in the file, Junctions 9 can assess the network’s Residual Capacity.  This is a measure of how much 
more traffic the system can cope with before a user-defined threshold is reached.  If the system is already 
overcapacity, then the residual capacity indicates by how much the traffic would need to be reduced to restore 
satisfactory operation. 

To turn on Residual Capacity, show the Summary Results Screen, click Columns>Network Residual Capacity and re-
-run the file. 

In the example below, the Residual Capacity is shown as “28.42% [Arm 3]”.  This means that overall flows at the 
junction could be increased by 28% before the user-defined threshold is reached, and that the first arm to be 
affected would be Arm 3.  This data is also shown in Data Outline>Junction Network. 

 

If the current Analysis Set’s Network Flow Scaling Factor is now set to 128% and the file re-run, the results now 
appear as below. 

 

As expected, Arm 3’s RFC has now reached 0.85, which in this example was the user-defined threshold.  The 
Residual Capacity now appears as almost zero, because this is the maximum volume of traffic that the junction can 
stand. 

If the flows are increased further, then the Residual Capacity will appear as a negative number.  In this example, it 
means that the flows must be decreased by 15% before all arms are within the user-defined threshold. 
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To set the user-defined threshold, browse to Data Outline>Options>Analysis Options. 

 

The Residual Capacity Criteria Type lets you choose which output (e.g. RFC, queue or delay) to use as the criteria, 
and the respective Thresholds determine the upper limits of what you consider to be acceptable junction 
performance. 

Values shown in the Data Editor, Data Grids and Reports are coloured in red if any of these thresholds is exceeded. 

 

 

 

 

 

NOTE:  Many of the items described in this section are only available if the file is in Advanced Mode. 
 

To check the operation of junctions at increased flows or decreased capacities, Junctions 9 provides a number of 
scaling factors.  To adjust the model to take into account variations between sites or localities, Junctions 9 allows 
the slope, intercept and capacity to be adjusted. 
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Some of these items can be edited as usual using the Data Outline and Data Editor; additionally, for roundabouts, 
most of these items are brought together into a single screen which can be launched from the main program 
menu:  Data>Roundabout Calibration (see Roundabout Calibration screen later in this section.) 

Some of these items have a Reason data field.  This is provided for the user to specify a reason why they are 
applying factors or corrections and will appear in reports. 

 

 Flow Scaling 13.9.1

Flows can be scaled both within each Analysis Set and within each Demand Set.  (See Working with Analysis Sets, 
Demand Sets and Time Segments).  Each Analysis Set definition includes a Network Flow Scaling Factor, which 
applies to all junctions and to all relevant Demand Sets.   

In addition, each Demand Set allows a Flow Scaling Factor to be entered individually. 

These two sets of factors combine together; the final scaled value of demand flow on each arm is always shown as 
the Demand output for each time segment.  The default value of each item is 100%.   

Flow scaling does NOT affect pedestrian flows or accident flows. 

There are several ways to study the effect of, for example, all flows on a junction increasing by 20%.  Firstly, a new 
Analysis Set could be created and its Network Flow Scaling Factor set to 120%.  Alternatively, a new Demand Set 
could be created and the Flow Scaling Factor for each arm set to 120%.  (The latter approach has advantages if a 
different factor is to be applied to each arm.)  A third way would be to add a new Demand Set and set its 
relationship (see Demand Set Relationships) to be 1.2 x another Demand Set. 

To answer the question ‘how much additional traffic can a junction cope with?’, one method is to generate an X-Y 
graph (see X-Y Graph Mode) of Max RFC against Network Flow Scaling Factor.  In the example below, the RFC on  
Arm B increases above 0.85 when the scaling factor is approximately 130%; the RFC on all arms increases above 
0.85 when the scaling factor is approximately 155%.  This means that the junction could cope with an increase of 
traffic of 30% before any of the arms approaches capacity.  For a Priority Intersection, a similar graph showing 
stream RFCs would be used. 

 

 

 Capacity Scaling (roundabouts) 13.9.2

Each Analysis Set definition includes a Network Capacity Scaling Factor, which applies to all roundabouts (NOT 
Priority Intersections) and to all relevant Demand Sets.    If a figure of 80% is entered, then all capacities calculated 
for all arms, for all relevant Demand Sets, will be reduced to 80% of their ‘normal’ values.  This provides a way to 
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check the performance of the roundabout(s) if it is suspected for whatever reason that capacities are being over-
estimated (or conversely, if capacities are thought to be pessimistic). 

Capacity scaling is applied after all other capacity effects are calculated, so automatically takes into account 
pedestrian crossings and all other model effects.  It acts as a ‘final’ scaling to capacity. 

In the example below, the highest RFC for any arm is 0.8 using current (100%) capacities, but this rises to 1.0 if the 
capacity on all arms were 80% of their current value. 

 

 

 Slope and Intercept (roundabouts) 13.9.3

As described in Capacity relationships, the maximum entry flow (Qe) at a roundabout entry is related to the 
 circulating flow (Qc): 

Qe = F – fcQc 

This is the equation of a straight line, where F is the intercept and fc the slope.  Both F and fc are determined by 
the geometry of the entry.  F has units of flow (the same as Qe and Qc), and fc is a ratio. 

For a particular circulating flow (Qc), the maximum entry flow (Qe) represents the capacity of the entry.  If the 
circulating flow is zero, then the capacity is equal to the intercept (F).   

The above describes only the most basic aspect of the ARCADY empirical roundabout model.  Depending on the 
nature of the roundabout, the relationship above is modified in various ways to take into account the roundabout 
type, other roundabout features and sub-models, and the final capacity shown in the outputs cannot necessarily 
be related to a ‘straight-line’ relationship.  However, the slope and intercept are important parts of ARCADY, as 
they describe the fundamental ability of an arm to feed traffic into the roundabout. 

The calculated slope and intercept are displayed in Data Outline>Arm>Capacity>Calibration. 

It is possible to enter the roundabout slope and intercept directly. To do so, tick the Enter Directly option and then 
type the values into the boxes.  The Final… boxes show either the calculated values or the directly entered values.  
These values are updated immediately whenever a relevant geometric parameter is changed, before the file is run. 
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 Slope and Intercept (Priority Intersections) 13.9.4

Initial slopes and intercepts for each stream at Priority Intersections are shown in reports.  These are indicative 
only, because they are liable to be modified for each time segment when the model runs. 

For simple T-junctions with no blocking or flares, the intercept of certain streams can be adjusted.  To make an 
adjustment, use the Data Outline to browse to Stream>Stream Advanced>Intercept Adjustment.  

Other stream types cannot be adjusted, because the interactions of the various streams when the model runs are 
too complex.   

 

 

 National and Custom Slope/Intercept Adjustments (roundabouts) 13.9.5

It may be that all roundabout slope and intercept calculations should be adjusted by a set amount to allow for the 
user’s location, and that these adjustments should be used for all modelled roundabouts.  If such adjustments are 
known, they can be entered in the Roundabout Calibration screen. These adjustments are direct adjustments, and 
so are added directly to the calculated values. 

National and Custom adjustments are applied before any other type of adjustment and represent an ‘underlying’ 
adjustment to be made to any roundabout.  Users are advised to check with any relevant national standards to 
determine if these adjustments are necessary.  You are likely to only occasionally set these values. 

If these adjustments are to be applied to all files, we recommend entering them into a new file, and then saving 
the file as a template file. 

 

 Site-Specific Adjustments (roundabouts) 13.9.6

The major source of error in queue-length and delay estimates comes from inaccuracies in the calculation of 
capacity.  Implicit in the capacity formulae is an error due to unexplained site-to-site variation, and this can be 
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removed for existing junctions by making on-site observations of the entry capacities.  The capacity formulae 
incorporating a correction calculated in a previous run will also be appropriate in cases when small modifications 
to the junction are being assessed.  The methods of collecting local data and the corrections to the capacity 
formulae are fully described in Appendix D - Site-specific measurements for capacity correction.   

A correction for a particular junction may still be appropriate in a new design, where minor changes are made at 
one or more junction entries, but only when these are made to the geometric parameters used in the capacity 
calculations (an example of a minor change is the movement of a kerb line to increase entry width). The use of 
previously calculated corrections is not appropriate if changes are made which are not related to parameters used 
in the capacity calculations.  Examples of such changes include:  altering the island size, changes in signing, re-
marking of the junction or complete resurfacing.  These features may result in a change of capacity, which would 
not be taken into account in the ARCADY model.  If such features are changed, and the user wishes to apply a 
capacity correction at the site, it would be necessary to take the traffic measurements after the changes have been 
carried out. 

There are two types of adjustment that can be made: 

1. Intercept Adjustments.  This is equivalent to the site-specific intercept correction facility in ARCADY 6.  
These adjustments are applied directly to the intercept (see Slope and Intercept), and represent changes 
to the maximum flow that would be possible across the give-way line in the absence of any circulating 
traffic.  Intercept adjustments can be calculated automatically from observations of entry flows and 
circulating flows at any arm, and apply to each arm individually. Intercept adjustments are applied at the 
start of the model, before any other model features such as pedestrian crossings are considered. 
 

2. Capacity Adjustments.  These represent a direct or percentage adjustment to make to the capacity on an 
arm AFTER all model features have been calculated.  In a way they are more straightforward than 
intercept adjustments, because they are corrections to the overall capacity on each arm without the user 
requiring any knowledge of slope or intercept data.  They can also be used whatever the roundabout type 
and regardless of how many modelling features are in use.  For the same reason, however, they should 
also be used carefully, as they can encapsulate (or disguise) any number of effects. 

The choice of which adjustment (if any) to make depends on the data available. 

Both types of adjustment can be viewed and manipulated via the Roundabout Calibration screen.  They can also be 
viewed as usual through the Data Outline, which may be convenient when using Data Grids to view all arms 
together. 

 

13.9.6.1 Site-specific Intercept Adjustments (roundabouts) 

 
This procedure produces a correction (of intercept) to the capacity relationship of the arm(s) in question, and the 
queue/delay calculations will consequently be affected. 

Site-specific corrections may be applied to any arm of a junction, and are in the form of a correction to the 
intercept of the entry capacity equation (see Appendix D - Site-specific measurements for capacity correction).  
Observations of circulating flows and entry capacities are made when there is continuous queuing at the junction 
entry.  The collected data is used within the program to calculate the correction to the intercept. 

Within the Roundabout Calibration screen, choose either Direct or Percentage as the adjustment Type within the 
Intercept Adjustments section.  Note that all data is for the current arm only (select a different arm by selecting 
any item within the arm in the Data Outline).  If known, the intercept adjustment can be entered directly.  
Otherwise, if you have observations of entry and circulating flows for the arm, press the Calculate button.  This will 
show a special screen: 
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In the upper grid, enter the observed entry and circulating flow for the arm, and then press the Calculate Intercept 
Adjustment for button. This will fill the lower grid.  In this example, the user has observed that the actual entry 
flow, for a circulating flow of 12 PCU/min, is 15 PCU/min.  The difference between the observed and the previously 
internally calculated entry flow is, in this case, 7.46 PCU/min and is displayed as the intercept adjustment.  I.e., the 
roundabout in reality operates better than predicted by ARCADY, and this difference is quantified as an intercept 
correction of 7.46 PCU/min, to be applied to all subsequent calculations.  This value is not stored in the file until 
you press the Store… button (otherwise, simply close the window).  Once stored, the adjustment is shown as in the 
example below, and will apply to any run of the model until turned off. 

 

The process above must be repeated for each relevant arm, if required. 

 

13.9.6.2 Site-specific Capacity Adjustments (roundabouts) 

 
This procedure produces a correction to the capacity relationship of the arm(s) in question, and the queue/delay 
calculations will consequently be affected. 

Within the Roundabout Calibration screen, choose either Direct or Percentage as the adjustment Type within the 
Capacity Adjustments section. Note that all data is for the current arm only (select a different arm by selecting any 
item within the arm in the Data Outline.  The capacity adjustment can be entered directly.   

These capacity adjustments should be treated as overall corrections to the junction performance and, as with 
intercept corrections, remain valid if minor changes to the junction are made.  They represent the difference 
between ARCADY’s view of the junction versus the actual observed behaviour, and this applies to the overall 
performance as opposed to simply the slope and intercept on each arm.  If the user wishes to consider using a set 
of corrections for more than one junction (if, for example, they believe the corrections to be necessary to 
compensate for local driver behaviour or other effects), they are advised to check carefully that the corrections are 
appropriate. 
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 Roundabout Calibration screen 13.9.7

This screen, accessible from the main Data menu, brings together several of the items discussed in this section.  
Most of the data items are also viewable through the Data Outline but the screen groups them together for 
convenience.   

NOTE: Where indicated by the yellow Analysis Set icon, some sets of data apply to the current Analysis Set only.  (See Analysis 
Sets) 

NOTE: Where indicated, some sets of data apply to the current arm only.  To switch arm, click on a different arm in the Data 
Outline.  The whole screen applies to the currently selected junction only. 

NOTE:  It is possible to obtain identical results by using the screen in various alternative ways.  The grouping of data simply 
reflects the intended purpose of each item. 

 

The screen roughly reflects in order from top to bottom the order of calculations when ARCADY runs a file.  
Usually, all adjustments and corrections are set to zero or 100%, and then the only meaningful data are the slope 
and intercept shown in the centre of the window.  Please see the other sections in this chapter for details of each 
item. 

ARCADY firstly calculates a slope and intercept for each arm from geometric parameters.  These are subject to 
National and Custom Slope and Intercept Adjustments.  

The intercept is then adjusted by the Intercept Adjustment. 

The adjusted slope and intercept are shown in the Final Slope and Final Intercept boxes.  These include any of the 
above adjustments.  If entering a slope and intercept directly, these are entered here and the Final… boxes then 
simply duplicate the entered values. 

The final values of the slope and intercept are used when the file runs to calculate the capacity of each arm. 
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Each capacity is subject to a Capacity Adjustment, which may be either a direct or a percentage adjustment. 

Finally, all capacities are subject to a Network Capacity Scaling Factor.  Also shown here, for convenience, is the 
Network Flow Scaling Factor. 

 

 

 

When modelling a standard roundabout, or a Priority Intersection, you can optionally specify conditions of daylight 
or darkness.  No distinction is made about the level of artificial lighting.  All of the junctions studied in the research 
that led to this part of the model had “adequate” road lighting; normally this will be the case for any junction 
modelled.   If the junction is totally without lighting (for example in a rural location), then its capacity will be lower 
than that shown by Junctions 9, even if the ‘darkness’ option is chosen. 

For mini-roundabouts, you can specify ‘normal’ conditions, daylight or darkness.  For mini-roundabouts, you can 
also specify the road surface conditions as normal, dry or wet.   

If you do not wish to model different lighting conditions, then the ‘Normal’ option should be chosen.  The program 
will then assume ‘average’ lighting conditions.  Similarly, if you do not want to model wet/dry conditions, the 
program will assume ‘average’ wet/dry conditions when the ‘Normal’ option is chosen. 

Mini-roundabout capacity and accident prediction are also affected by whether the junction is located in London.  
This was statistically significant in the research studies and thus is an option within the program, but it cannot be 
said for certain whether the London effect applies to any large city.  

All of these options are set in the Junction Network section of the Data Outline and thus apply to all junctions in 
the file.   

 

 

 Definition of Geometric Delay 13.11.1

Vehicles often have to slow down to negotiate a junction, even in the absence of other traffic.  The resulting delay, 
which is associated with the layout of the junction, is called geometric delay, and is the sum of three components: 

i) time lost decelerating and accelerating 
ii) time lost due to slower speeds through a junction 
iii) time lost due to longer distances through a junction 

The ARCADY and PICADY models can optionally calculate geometric delay, based on an extra set of geometric 
measurement inputs. Geometric delay depends on the size and layout of the junction and also the turning 
proportions, since some movements experience more delay than others.  

Delay is determined as an “extra” journey time over a “no-junction” alternative.   At Priority Intersections, 
geometric delay is assumed to be zero for major road straight-ahead traffic. 

Heavy vehicles suffer extra geometric delay due to the longer time, relative to cars, that they spend accelerating 
and decelerating.  The percentage of heavy vehicles is taken into account and influences the total geometric delay. 
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At roundabouts, the types of turn considered are left-turn, straight-ahead with a little deflection on the path 
through the junction, straight-ahead with a significant deflection, and right-turn.  To determine the type of turn, 
the angle between successive arms must be provided. 

 
NOTE:  ARCADY does not calculate any geometric delay values for mini-roundabouts. 

 

 

 Definition of point-to-point journey times 13.11.2

If geometric delay parameters are entered, Junctions 9 also outputs point-to-point journey times through the 
junction.  The estimated journey times reported by Junctions 9 are the sum of the total time that traffic takes to 
travel from a certain point upstream of the junction to a specified point downstream in the absence of any other 
traffic PLUS the additional travel time caused by the presence of the traffic (i.e. queueing delay).   

NOTE:  The point-to-point values calculated are not simply the geometric delay added to the queueing delays 
calculated by Junctions 9.  The reported geometric delay represents only the additional travel time due to the 
presence of the junction, and excludes the time to travel between the two points if the junction wasn’t there at all.   
Therefore the point-to-point journey time calculation takes into account the total time taken to physically traverse 
from one point to another as well as the delay due to queueing, deceleration/acceleration and junction 
negotiation. 

The journey time calculation begins at a user-specified distance (‘Distance included upstream’) upstream of the 
give-way line and ends at ‘Distance included downstream’ of the junction exit.  I.e., it includes the time taken to 
travel along the approach to the junction, through the junction to the exit arm, and then along the exit arm, 
together with any queuing delay at the junction entry.  See Appendix C - Measurement of geometric delay 
parameters for details of how to measure these distances. 

To be consistent with the calculation of geometric delay, it is assumed that a vehicle approaching the junction will 
decelerate from its cruise speed to a speed determined by the junction geometry and the turning movement being 
made. Similarly, a vehicle leaving the junction will accelerate from its exit speed until it reaches the desired cruise 
speed. 

The calculated journey time allows for these accelerations and decelerations. If for any arm the distance required 
for either acceleration or deceleration is greater than the fixed distance referred to above then a warning is shown 
in the Task List and you should enter a larger distance. 

NOTE: If modelling linked roundabouts, or a corridor of junctions, a point-to-point journey time matrix will be 
produced separately for each roundabout.  When considering the total journey time through several roundabouts, 
the user must add the appropriate components together.  In this case we also recommend setting the 
upstream/downstream distance to a low value to avoid double-counting time spent on internal links.) 

 

 Using Geometric Delay and Point-to-Point Journey Times 13.11.3

Some of the associated inputs and outputs are in matrix form and so are mostly handled by a special screen.  Other 
inputs and outputs are shown as usual in the Data Editor or Data Grids. 

Press this button on the vertical toolbar to show the Geometric Delay screen, which also handles 
point-to-point journey times.  For this button to be visible, the file must be in Advanced Mode. 
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Geometric Delay and point-to-point journey time calculations are turned OFF by default.  This is because the 
outputs produced are meaningless until the user has filled in all appropriate data.  To turn on the option, use the 
checkbox at the top of the Geometric Delay screen.  (Note that each junction has its geometric delay calculated 
separately.) 

The screen is split into Inputs and Results tabs. 

Within the Inputs tab, the Geometries tab provides data entry for all arm geometric parameters that affect 
geometric delay.  See Appendix C - Measurement of geometric delay parameters for full details of the geometric 
parameters.  See the previous section for a discussion of the Distance included up/down-stream parameters. 

The data requirements depend on the junction type.  The two screenshots below show the Geometric Delay 
screen for a Roundabout and a Priority Intersection respectively. 

 

 

For Priority Intersections, you should also specify whether or not all visibilities conform to UK Standard TD 42/95 
(‘Geometric Design of Major/Minor Priority Junctions’; UK DMRB Volume 6, Section 2, Part 6 TD 42/95).  If this 
option is not ticked, then the program will add 1.4 seconds of geometric delay to every vehicle, in accordance with 
the advice given in SR810. 

 

 

Distances through the junction for each origin/destination are entered on the next tab. 
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Assuming the file has been run, various results are shown within the Results tab. 

The Geometric Delay Total tab shows the geometric delay for each turning movement along with a total for each 
arm.  The units are those of total delay and, depending on the options selected in the Data>Units screen may be 
veh-min or PCU-hr. The results represent the total delay suffered by all vehicles passing through the junction in the 
time segment.  Results are available for each time segment, as confirmed by the clock icon.  Change time-segment 
by selecting from the time segment drop-down selector at the top of the main screen.  (To see a set of tables for 
each time segment, use the report generator.) 

 

Total geometric delay for the whole modelled period is shown in the Inclusive Geometric Delay tab.  This includes 
the geometric delay that would be experienced by any vehicles still queueing at the end of the last time segment.  
If the junction is within capacity then this value, for each arm, will simply be the sum of the time segment values.  
If the junction is oversaturated then the inclusive geometric delay will be higher than the sum of the time segment 
values. 

 

The geometric delays calculated are the totals for all vehicles making a particular turning movement during the 
period being modelled. Since vehicle flows during the modelled period are unlikely to be representative of the 
whole day (the modelled period is usually a peak) it follows that it is not possible to obtain accurate total daily 
geometric delays by simply factoring up the values output by the program - total geometric delays per unit time 
will vary throughout the day. 



 Additional Modelling Theory and Features    Page 191     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

Geometric delays calculated for asymmetric roundabouts are subject to some error due to the fact that, for some 
movements, the “no-junction” journey time will not be accurately defined by specifying a single point as the centre 
of the junction. 

 

For the whole modelled period, the Geometric Delay per light vehicle shows the average delay (in minutes or 
seconds) for a light vehicle.  This represents the average time that a vehicle is slowed down by having to negotiate 
the junction, for a particular turning movement, relative to the case where the junction does not exist.  These 
figures are independent of the traffic demand, and so values are always shown for u-turners. 

 

The Point-to-point journey time tab shows the average journey time for each origin-destination pair. These are 
influenced by geometric delay, queueing delay and the entered upstream/downstream distance.  Results are 
available for each time segment, as confirmed by the clock icon.  Change time-segment by selecting from the time 
segment drop-down selector at the top of the main screen.  (To see a set of tables for each time segment, use the 
report generator.) 

 

Finally the Point-to-point summary journey time tab shows the average journey time for each route for the whole 
modelled period.  These values can be thought of as averages of the time-segment values. 
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In addition to the results shown in the Geometric Delay screen, some additional values are shown in the Data 
Outline/Editor in the usual way in the Geometric Delay sub-section of the arm or stream time segment results.  
Geometric Total Delay is identical to the totals as shown in the Geometric Delay tab and represents the total 
geometric delay suffered by traffic entering on the arm/stream, for the current time segment.  Geometric Rate Of 
Delay shows the rate of delay per minute (or second or hour, depending on selected units). 
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Junctions 9 includes a number of accident prediction models for various junction types. 

Depending on the junction type and options selected, the rates may be shown as either frequencies or indices.  
Frequencies give an absolute accident rate, while indices express the predicted accident rate in relative terms only.  
Frequencies are those expected for a junction of a particular design in the UK, and are not necessarily appropriate 
for other countries.  Therefore if used outside the UK, frequencies should be interpreted as indices. 

The program derives an index by relating the accident frequency that would have been calculated by the model to 
the mean accident frequency of all the junctions studied - this mean is arbitrarily assigned an index of 1.0.  It is 
important to note that the accident index does not give any indication of the absolute accident frequency of a 
particular junction because, as already mentioned, the model formulae implicit in the derivation of the index may 
not be fully representative of these junctions.  It is, however, reasonable to suppose that the index will provide an 
indication of the relative safety of one layout versus another at a particular junction - this is the only purpose of 
the index. 

 

 

 Standard roundabouts 13.12.1

The number of personal injury accidents per year at four-arm at-grade roundabouts can be estimated by the 
program by using models derived by TRL research. 

The accident frequencies are calculated and displayed separately for various accident categories. The total is 
deduced by the summation of the individual categories. ARCADY displays the total accident frequencies for 
vehicles and pedestrians, entering/circulating traffic, approaching traffic, single-vehicle and other vehicle.   

Accident ‘frequencies’ are not calculated for standard roundabouts that are not four-arm at-grade types, because 
these were not represented in the original study and may behave differently.  However, providing they have a 
central island diameter greater than or equal to 4 metres (i.e. they are not mini-roundabouts) accident ‘indices’ are 
estimated.   

Accident frequencies or indices are calculated for each arm as a function of traffic flows, percentages of 
motorcycles, geometric characteristics of the junction and geometric characteristics of the arm under 
consideration on the approach to the junction. 

 

 

 Mini-roundabouts 13.12.2

The number of personal injury accidents per year can also be calculated for mini-roundabouts using models 
derived from TRL research.  The models are different depending on whether the mini-roundabout has 3 or 4 arms, 
and each one is split into a ‘Simple’ and ‘Detailed’ version.  The Simple models require mainly flow data alone, 
whereas the Detailed models require more geometric parameters in addition to more detailed flow data.  
Naturally, this second model will give a more accurate prediction, but at the expense of having to provide more 
information. 
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 Priority Intersections 13.12.3

PICADY makes use of separate accident models for rural and urban 3 and 4 arm priority junctions. Each model is 
split into a ‘Simple’ and ‘Detailed’ version.  The Simple models require mainly flow data alone, whereas the 
Detailed models require more geometric parameters in addition to more detailed flow data.  Naturally, this second 
model will give a more accurate prediction, but at the expense of having to provide more information. 

The accident model, parameters and outputs are different for rural and urban junctions.  The rural/urban choice is 
set via the Junction Environment field in the Accident Prediction data section.  (If the Urban environment is not 
selected, then the junction is assumed to be rural.) 

The table below summarises the models available and any restrictions.  Each model includes a Simple and Detailed 
version. 

  T-junction Crossroads Stagger 

URBAN frequencies frequencies 

 
frequencies 

 

Dedicated model if stagger length<=20m. 

If stagger length>40m, user can model as 2 T-junctions. 

If stagger length between 20m and 40m, see below ** 

RURAL* frequencies 
cannot be 
modelled 

indices  
 

modelled internally as two T-junctions,  
but stagger length must be >40m 

 

* If the junction is rural, there must NOT be a kerbed central reserve on the main road. 

** For urban crossroads with stagger lengths greater than 20m, but less than 40m, you should use engineering judgement to 
decide how to model the junction.  It is suggested that if the stagger length is up to 30m, then the usual model can be used; if 
the stagger length if over 30m, then model as 2 T-junctions. 

 

 

 Traffic data requirements for accident prediction 13.12.4

All accident flows in Junctions 9 are entered as AADT (Annual Average Daily Totals), with all pedestrian flows 
entered as 12-hour counts. 

Older versions of the product also used 12-hr and 16-hr counts.   The conversion factors used to convert 12 or 16-
hour counts to AADTs are not used in ARCADY 7/8.  However, if an ARCADY 6 or PICADY 5 file is imported, the 
relevant conversion factors will be used to convert the flows to AADTs. 

For standard roundabouts, the model requires entry, exit and circulating flows for various vehicle types.  It is 
possible to estimate the exit and circulating flows if only the entry flows are known, although this involves some 
assumptions and so is only recommended if detailed data is not available. If entry and exit flows are known, then 
the circulating flows can be estimated; this is a more accurate method.  Click Data>Complete Safety Flows… and 
then select the most appropriate option. 
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If you wish to estimate AADTs based on peak-hour flows, conversion factors based on peak hour flow groups and 
Seasonality Index are suggested in Part 4 of the COBA manual, which is available online from 
https://trlsoftware.co.uk/support/downloads. 

For mini-roundabouts and Priority Intersections, origin-destination flows are required.  Depending on the accident 
model type, you may also need to enter this data for each vehicle type and for pedestrian flows. 

 

 

 Using Accident Prediction  13.12.5

Accident Prediction is configurable separately for each junction via Data Outline>Junction>Accident 
Prediction.   Press this button on the main vertical toolbar to skip to this section.  Note that the file 
must be in Advanced Mode. 

Select either Simple or Detailed accident prediction via the Accident Prediction Type option. 

The Accident Prediction section contains some other parameters which depend on the junction type and which 
apply to the entire junction.  In particular the Junction Environment is used in the conversion of accident 
frequencies to indices and to determine whether the rural or urban model should be used for Priority Intersection 
accidents. 

All other data is entered for each arm individually, as follows. 

Accident Prediction is affected by various geometric parameters, which can be edited via Data 
Outline>Junction>Arm>Accident Prediction>Accident Parameters.  The screen shown will depend on the type of 
junction and the number of arms; the example below is for a standard roundabout.  As usual, Data Grids are a 
convenient way of viewing data for all arms together.  Some parameters are the same as those entered elsewhere 
in the normal Capacity section of the Data Outline – for example, entry width and approach width.  These items 
can be entered directly if required (for example if wishing to run accident prediction without running the capacity 
model) but, by default, they are taken automatically from the relevant data section of the Data Outline.  This is 
confirmed by the tick in the Use geometries from capacity option.  The three disabled items are filled automatically 
from Capacity>Standard Geometry data.   

See Appendix G - Measurement of accident prediction parameters for details of how to measure the parameters. 

 

https://trlsoftware.co.uk/support/downloads
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The Accident Prediction models use different flow definitions compared to those used elsewhere in ARCADY.  All 
flows are in AADTs and usually expressed in 1000s.  Unlike the rest of ARCADY, flows for specific vehicle classes 
may need to be entered, depending on the roundabout type and the accident model chosen.   

Viewing and editing of accident prediction flows depends on the roundabout type. For standard roundabouts, 
browse to Data Outline>Junction>Arm>Accident Prediction>Accident Flows and use the Data Editor or Data Grids 
as usual.  For all other junction types, browse to Data Outline>Junction>Accident Prediction (or press the main 
Safety button) and then in the Data Editor click the Flow Matrices... link.  This will show a special screen for 
accident flows, with the various tabs enabled/disabled according to the junction and accident model type. 

 

 

Results are shown when the file is run.  For roundabouts, the results are shown for each arm and can be found in  
Data Outline>Junction>Arm>Accident Prediction>Accident Arm Results.  For Priority Intersections, the results apply 
to the whole junction and can be found in Data Outline>Junction>Accident Prediction>Junction Accident Results.   
For Detailed accident models, this section will also contain a Details subsection listing the predicted accident rates 
for approximately 15 different accident categories. 

The type of results shown will depend on the junction type, the number of arms and the type of accident model.  
Results are shown in terms of predicted accidents per year.  Totals are also shown, which are simply the sum of the 
various accident types.  Indices are shown when frequencies cannot be calculated, and should be taken to 
represent the relative safety of the roundabout.  

   

 Interpreting accident prediction results 13.12.6

Caution needs to be taken when trying to understand the effects of individual junction features and geometric 
values on the accident frequencies calculated.  For example, the models may predict on average more accidents at 
priority junctions with a crossing than those without, for given vehicle and pedestrian flow.  However, in the 
samples used to develop the models in Layfield et al (1996) and Summersgill et al (1996), those junctions without 
crossings had significantly lower flows than those with crossings, and the error structure of the models must 
reflect that.   Similarly, the predicted accident rate may decrease as the mean vehicle speed increases.  This is likely 
to be because the high speed sample sites in the study were also associated with, for example, well designed 
layouts.   

As you select different features, you are effectively selecting the set of junctions within the sample data set with 
those same features, and the results then indicate the typical accident rate of those junctions.  This is not the same 
as simply saying, for example, ‘if feature X is changed then the accident rate will change by Y%’.  
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The accuracy of the results from the program will reflect the accuracy of the input.  For example, if data is input at 
the coarsest level, using all the default options available, it is unlikely that the results will accurately reflect 
operation at a particular site. 

At a typical site, the standard error of the capacity prediction for a standard roundabout, at the mean point, is 15 
percent. This standard error takes account of both the random variability between supposedly identical sites, and 
the random variability that may occur at a single site at different times of day.  The equivalent value for a Priority 
Intersection is 13%.  At mini-roundabout sites the unexplained variance in capacity (outside the model) is less than 
40%, a value 38% smaller than if the standard roundabout model was used to model a mini-roundabout. 

For a given capacity, the queue-length and delay predictions are the average values of broad distributions, and 
there will be considerable fluctuations in the values observed at the same time on different days. Small numbers of 
individual observations of these quantities are unlikely to be sufficient to provide reasonable approximations to 
the average values predicted by the program.   

Predicted queues and delays are average values derived by the model from traffic counts taken (ideally) over a 
number of days.  Obviously traffic flows can vary from day-to-day and this will, in turn, lead to variation in queue 
length from day-to-day.  As a result, individual observations of queue lengths on site on any one occasion may 
differ considerably from those predicted.  Indeed, assuming that the average flow used to model the junction was 
unbiased, predicted queues will be exceeded by observed queues half the time. Therefore, if proper validation of 
an ARCADY/PICADY/OSCADY model is required, the junction operation will need to be observed on many 
occasions and the measured queue lengths averaged.  Only then can the queue lengths predicted by the model be 
compared with those found on-site. 

As mentioned above, individual capacity predictions are subject to statistical error.  If the capacity is accurately 
predicted, then the queue-length and delay predictions will correspond to the average values of correct 
distributions.  However, in a minority of cases the capacity characteristics of individual sites may differ appreciably 
from the average, and queue-length and delay estimates will consequently be affected.  Thus, if the capacity is less 
than average the queues and delays will be underestimated and if it is greater than average they will be 
overestimated. 

Where possible and where relevant, the accuracy of the capacity and delay calculations for an existing junction 
may be improved by use of local traffic observations to modify the entry capacity equations of one or more 
streams (see Site-Specific Adjustments).  

Use of the program should in general be limited to situations in which the values of the parameters involved lie 
within the range of values over which the relationships used have been calibrated.   

In general, for any use of the program, you should check wherever possible that the results approximately match 
observed behaviour at the junction before modelling other scenarios. 

 

 Collection of flow (demand) data 13.13.1

It is recognised that the collection of flow data is always costly, but the accuracy with which it is obtained is 
reflected in the accuracy of the results.  The absolute minimum required is origin-destination flows averaged over 
a one hour period. For existing sites, origin-destination flow data does have the disadvantage that is not a measure 
of demand (which is what ARCADY/PICADY/OSCADY need) but a measure of throughput. 

If traffic counts are being taken on-site it is important to remember that it is demand information that is required, 
not vehicle counts across the stopline / give-way line. Therefore, traffic counts would be required sufficiently far 
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upstream of the junction not to be significantly affected by queueing.  Additionally, turning proportions need to be 
taken at the junction.  

Avoid counting traffic on days when it may be atypical such as: public holidays, school holidays and days on which 
local events (e.g. road works) disturb flow patterns.  Also, in general, avoid taking flows on a Friday.  Keep abreast 
of happenings in the locality: for example an accident nearby may disrupt local flows. It is important to know if 
counts are reliable.  The results from Junctions or any such program cannot be reliable unless the demand data is 
reliable. 

 

 

This section describes some special situations and how to deal with them.   

Many more situations are discussed on the product Knowledge Base at 
https://www.trlsoftware.co.uk/support/knowledgebase. 

 

 Entry-only and exit-only arms (roundabouts) 13.14.1

There may be some entry-only or exit-only arms at the roundabout, for example in a one-way system.  An entry-
only arm should be treated as an ordinary arm.  It is worth noting that since there will be no traffic leaving the 
roundabout at this arm, the specification of turning proportions will reflect this fact.  Also, in this case the entry 
width E is the entire width of the road.  Similarly V is the total approach road width.  

Any exit-only arm should be included in the total number of arms at the roundabout, and identified using the Exit 
Only data field within the Geometry data section. Exit-only arms cannot be specified for mini-roundabouts (they 
could affect the model in a way which has not been studied). 

 

 One-way major roads (Priority Intersections) 13.14.2

If the major road is one-way, you can set this as the Major Road Direction property of the junction.  The effect of 
this is to automatically alter some of the internal geometries used in the model. 
 

https://www.trlsoftware.co.uk/support/knowledgebase
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 Staggered junctions (Priority Intersections) 13.14.3

Rural Staggers 

In certain circumstances, and for queue and delay predictions only, a rural staggered junction may be modelled as 
two separate T-junctions.  Modelling this way is inappropriate if there is likely to be any interaction between the 
two component T-junctions.  

For the purposes of accident prediction, splitting up a staggered junction into two T-junctions will give misleading 
or inaccurate results, because there may be some double counting.  When accident predictions are performed 
with a junction modelled as a rural staggered junction, the model splits it up into two T-junctions, but only models 
accidents up to 20 metres from each of them - there is no over-counting because accident analysis is disallowed if 
the stagger distance is less than 40 metres.   
 

Urban Staggers 

For the purposes of queue and delay predictions only, urban staggered junctions may be modelled as two separate 
T-junctions.  As with rural junctions, this approach is inappropriate if there is likely to be any  
interaction between the two component T-junctions.  

For the purposes of accident prediction, PICADY does not model urban staggered junctions as two separate T-
junctions, as is the case with rural junctions, but uses a model developed specifically for crossroads and staggered 
junctions with stagger lengths up to 20 metres.   Because for urban ‘T’-junctions accidents are included up to 20 
metres from the junction, staggered junctions greater than 40 metres can be modelled as two separate T-
junctions.   
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For accident prediction for urban crossroads with stagger lengths greater than 20 metres, but less than 40 metres 
you may use engineering judgement to decide how to model the junction, but you are advised to model them as 
follows:  

 Stagger lengths between 20 and 30 metres - model as staggered crossroads.  
 

 Stagger lengths between 30 and 40 metres - model as two separate ‘T’-junctions.  
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NOTE:  The file must be in Advanced Mode. 

NOTE:  You can adjust the time taken by simulation runs by adjusting the Stop Criteria.  Generally you do not need to wait 
for a run to finish and can press the Stop Simulation button as soon as results become apparent. 

NOTE: If running several Analysis or Demand Sets, any sets that use Lane Simulation mode will be included but will slow down 
the overall run time.    

NOTE:  You can generate x-y graphs whilst in Lane Simulation mode.  If you do so, we recommend increasing the convergence 
criteria (see Stop Criteria) to a high value (e.g. 10%) and using a relatively small number of points to reduce the overall run time. 

 

 

Lane simulation was first introduced in Junctions 8 to provide a way to compare different entry lane configurations 
at roundabouts.  In Junctions 9 it was extended to also cover T-junctions, pedestrian crossings and exit lanes, and 
for Junctions 9.5 it has been extended to also model signalised lanes, and circulating lanes at roundabouts. 

Running a file in lane simulation is generally slower than running a file in normal mode.  However it has the 
following advantages which represent the main reasons for considering lane simulation for any given file: 

 Models different entry lane configurations at roundabouts 

 Models uneven lane usage 

 Models blocking back from pedestrian crossings and downstream junctions 

 Models linked junctions (roundabouts, T-junctions and signalised junctions) without the restrictions of the ARCADY 7 
linked roundabout model  

 Models situations which may not be allowed normally (e.g. PICADY junctions with certain combinations of crossings, 
flares and blocking) 

 Models signalised situations which may not be allowed in OSCADY, or combination junctions such as partially 
signalised roundabouts 

 Models circulating lanes at roundabouts 

 Confirms which lanes physically exist (in contrast to the slightly more abstract use of streams in PICADY) 

 Intuitive visualisations of model results 

 Automatic collection of queue percentile data 

 

Although Lane Simulation makes use of the core ARCADY/PICADY models, it is not in itself derived from empirical 
studies.  Therefore you should (as always) apply engineering judgement to both the application of the model and 
the interpretation of the results.   

 

 Unequal lane usage at roundabouts 14.1.1

At its core, ARCADY uses empirical models that relate the entry flow on a roundabout arm to the circulating flow 
past the arm.  For a given circulating flow, the entry flow depends on various geometric aspects of the entry arm.  
One of the most important is the entry width.  It was found that capacity increases continuously with entry width, 
and this was found to be a better indicator of capacity than the discrete number of lanes at the entry.   
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ARCADY, however, does assume that the entire width of the entry is available to all vehicles for most of the time.  
In many cases, this assumption is valid, because a well-designed roundabout will encourage the use of the entry 
width to all vehicles.  It is also perfectly valid if, for instance, there are lanes marked on the road but vehicles can 
use any lane and do so frequently.  

The assumption becomes less valid if there is significant unequal lane usage, or if there is regular and significant 
entry starvation.  This can happen if traffic predominantly uses only part of the road.  For example, if 90% of traffic 
turns left, then a lane marked as being for left-turners would clearly be used far more than a lane for right-turners.  
Entry starvation can occur if, for example, there is a short lane for left-turners that is regularly blocked by queueing 
vehicles in an adjacent lane.  In both cases, ARCADY continues to assume that the entire entry width is available, 
which may lead to an over-estimate of capacity.   

An associated issue is that the queues predicted by ARCADY occupy the entire road width in an arbitrary way.  For 
example, if the model predicts a queue of 10 vehicles, the real-life situation could be 10 vehicles in one lane, or 5 
vehicles in each of two lanes, and so on; ARCADY does not provide this information. 

Lane Simulation mode addresses these points.  This allows you to: 

 Set up different numbers of lanes on each arm 

 Define the allowed movements from each lane 

 Run a special version of the model which uses the core ARCADY empirical model whilst allowing for 
individual lane movements 

 See the estimated queues and other results for each lane 

Using Lane Simulation Mode, you can compare the relative performance of different lane configurations.  

It is important to note that the ARCADY empirical model was developed from a dataset that would have included a 
variety of lane configurations.  In other words, the ARCADY model inherently includes some allowance for lane 
usage.  However, if there is significant unequal lane usage, then the Lane Simulation Mode may prove useful. 

 

 Applicability of lane simulation to roundabouts 14.1.2

Lane Simulation Mode in Junctions 9 is provided as a tool to investigate alternative lane configurations at 
roundabouts.  It should not be taken as forecasting junction performance to the same level of accuracy as the main 
ARCADY model. 

It is based on the assumption that the overall capacity of each arm is the same as that predicted by the core 
ARCADY model.  It does NOT attempt to derive the detailed capacity of individual lanes from first principles. It does 
not, for example, consider visibility or behavioural effects due to the presence of neighbouring lanes.  Also, it is 
assumed that all lanes on a given arm are subject to the same circulating flow.   

These assumptions mean that, if you use Lane Simulation to model a single lane on each arm, then you will see 
approximately the same results as a normal ARCADY run.  In other words, in simple cases, the results from Lane 
Simulation and from a normal run will converge.  In more complex cases, the results will differ, but the core 
empirical ARCADY model is always used to provide ‘baseline’ data for the run.  Lane Simulation can therefore be 
thought of as an extension of the original ARCADY model, rather than a completely new model. 

The movements that you set up on each lane may be based on lane markings, or directional signs, or simply based 
on the expected behaviour of traffic at the junction.   In fact the expected behaviour takes precedence over any 
physical markings/signs; i.e. you should set up lanes in the way you think they will actually be used by traffic. 

There are some restrictions on the use of this mode – for example it cannot be used if there are bypass lanes.  Any 
such restrictions will be shown in the Task List if necessary. 
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Circulating lanes are NOT modelled.  It is assumed that the circulating and exit road widths are sufficient for the 
amount of traffic being modelled.   

Because the Lane Simulation model is an analytical one rather than being based on empirical studies, you should 
(as always) apply engineering judgement to both the application of the model and the interpretation of the results.   

 

 Applicability of lane simulation to other situations 14.1.3

Lane Simulation can also be used to model: 

 Pedestrian crossings on both entry and exit arms 
 

 PICADY T-junctions 
 

 Linked roundabouts and T-junctions 
 

 Signalised lanes 
 

 Circulating lanes at roundabouts 

Where relevant, the simulation is based on the core ARCADY/PICADY models but the simulation aspect allows for 
more reliable and/or flexible modelling of certain situations.  

It is important to remember that the original ARCADY/PICADY research was only concerned with isolated junctions 
that fell into reasonably well defined categories.  The use of simulation for situations which would not normally be 
possible in the core models can provide useful insights into the likely traffic behaviour but should not be taken as 
providing the same level of accuracy as the main models.  Whether using Lane Simulation or not, it is always a 
good idea to check that the model reproduces observed base conditions before modelling other scenarios. 

 

 

 

Except for the simplest cases, modelling the queueing behaviour of traffic in multi-lane configurations quickly 
becomes very complex, especially at give-way situations where both arrivals and departures are random.  Unlike 
the rest of ARCADY/PICADY/OSCADY, Lane Simulation uses a simulation technique, which is based on the simple 
modelling of individual vehicles.  (This does NOT allow for effects such as individual vehicle speed and so on; 
rather, it is mainly concerned with queueing behaviour.) 

Each vehicle is assigned a lane according to the vehicle’s desired movement (based on the entered turning 
proportions) and the allowed movements on each lane.  If there is a choice of more than one lane, then the lane 
with the shortest queue at that moment is selected.  

Optionally, the length of each lane can be defined, in terms of the number of PCU that can be stored in the lane.  If 
such a lane is filled with queueing vehicles, then new vehicles cannot enter the lane and instead will queue in 
upstream lanes.   

At any point on an approach where the number of lanes changes (i.e. where each new Lane Level begins), each 
vehicle again chooses a suitable lane, using the same rules.  Vehicles do not change lane at any other time. 
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The simulation runs for the entire modelled period - for example 60 minutes – with results being collected and 
reported for the usual time segment periods (e.g. each 15 minutes).  A single simulation run would be unlikely to 
give useful results, because it could be unduly influenced by the random nature of the simulation.  Instead, many 
runs (trials) are performed in succession, with the results from the runs being averaged to give an overall result.  

When in Lane Simulation mode, ALL arms are modelled using the simulation.  It is not possible to selectively turn 
the model on or off for individual arms. 

 

 

 Lanes and Lane Levels 14.2.1

For T-junctions, lanes are assigned automatically based on the main PICADY geometry options and cannot be 
changed.  See Using simulation with PICADY T-junctions. 

For roundabouts, lanes and lane levels are set up directly by the user (in addition to entering ARCADY geometries). 
The example below shows a roundabout where each arm consists of a single lane (blue) that widens into two lanes 
(red/green) at the give-way line.   

 

 

Traditionally, you would measure the approach width (V) as 
the width of the blue section, and then measure the entry 
width and flare length (E, L) and other geometries based on 
the total size of the red+green sections.  In other words, 
you wouldn’t distinguish between the blue/red/green 
sections; they would all effectively be the same colour. 

 

 

 

 

When using Lane Simulation, however, you must 
consider the individual lanes and, if necessary, make a 
judgement about where they begin.  The diagram 
shows the eastern arm when modelled in Lane 
Simulation mode.  It consists of three lane or lane 
segments, organised into two lane levels. 

 

 

Lane Level 1 contains the give-way line, and Lane Level 2 is the upstream section.  There is no limit to the number 
of lane levels that you can add, although two or three will be sufficient for most cases.  Within each lane level, the 
nearside lane is generally labelled as ‘lane 1’. In general, referring to lane numbers in this way is not necessary 
because you can simply click on the required item in the Junction Diagram. 



 Lane Simulation Mode    Page 205     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

The lane numbers can optionally be shown on the diagram via settings in the Junction Diagram Options screen. 

In this example, it’s assumed that there are two discrete lanes at the give-way line of the eastern arm.  Both of 
these lanes have limited storage of, say, 2 PCU. So in total, there is storage for 4 PCU in Lane Level 1.  Note that 
these don’t necessarily have to be real lanes:  the lanes in ARCADY simply represent discrete columns of vehicles, 
whether or not there are actual lane markings on the road. 

If the total road width is too narrow for two lanes at the give-way, then you should either model the arm as 
containing a single lane only, or else use the normal ARCADY model instead of Lane Simulation. 

In marginal cases you may need to apply engineering judgement.  For example, if the ‘flare’ can only fit a single 
vehicle, then it could be modelled as a separate lane with storage of 1, or, alternatively, you could enter a non-zero 
value as the flare length on the adjacent lane. Both methods would be valid. 

When the simulation runs, vehicles are firstly assigned to Lane Level 2, which is the most upstream (outer) level.  
When they reach Lane Level 1, they are assigned a lane according to their destination and the allowed movements 
on each lane.  If there is a choice of lanes, the one with the instantaneous shortest queue is used.  This is 
equivalent to saying that, in the upper diagram above, vehicles choose to enter either the red or green lane, at the 
point where the blue section ends.  Of course, this may be an automatic choice, as in many cases there will only be 
one allowed lane for the vehicle’s desired movement. 

In reality there is not a discrete point where vehicles ‘make a choice’, and the transition on the road from one 
number of lanes to another is gradual.  Therefore the point where the Lane Levels begin is somewhat arbitrary, 
and should be based on your best judgement of where you consider the road to have widened from, say, one to 
two lanes.   

Within the Junction Diagram, you can ‘slide’ each Lane Level relative to the other lanes, to give the alternative 
arrangement shown below.  This may feel more natural if there is a pronounced left-turn flare or bay at the give-
way, but note that the positioning within the diagram does NOT affect the model. 

 

However, if the lane movements are now changed to the ones shown below, then this is a change to the model, 
and different results will be obtained.  In other words, the lane movements affect the model, but the visual layout 
within the diagram does not. 
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 Turning on Lane Simulation Mode 14.3.1

NOTE:  The file must firstly be set to be in Advanced Mode. 

Lane Simulation mode can be turned on for individual Analysis Sets.  This can be done either for a new file, or for 
 an existing file, and can be changed at any time. 

Use the Data Outline and Data Editor to tick the Use Lane Simulation property for the current Analysis Set:  Some 
of the items available in the Data Outline and main vertical toolbar will change to reflect the different options 
available in this mode. 
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Alternatively, simply press this button on the main vertical toolbar.  This will automatically switch the 
current Analysis Set into Lane Simulation mode and will also launch the main Lane Simulation Screen, 
from where you can control the simulation. 

 

 Setting up lanes 14.3.2

For T-junctions, lanes are set up automatically based on the main PICADY geometry options and cannot be 
changed.  See Using simulation with PICADY T-junctions. 

For signalised junctions, lanes may be initially set up automatically depending on the initial type of junction 
selected, but otherwise can be changed at any time by the user. 

For roundabouts, lanes can be set up by the user.  By default, each roundabout arm contains a single lane.  (If you 
run the simulation at this point, the results will be equivalent to the traditional ARCADY results.) 

The arrows inside each lane show the allowed turning movements.  By default at a roundabout, all movements are 
allowed in each lane.  Each lane is assumed to be infinitely long, although the actual length shown in the Junction 
Diagram depends on how the arms and lanes have been positioned.  You can make the lanes ‘longer’ by using the 
control points to stretch the arm.  As with most control points in the Junction Diagram, this does NOT affect the 
model; the diagram is schematic only. 

 

There are several ways to set up the number of lanes on each arm: 

1. In the Junction Diagram, right-click on a lane and use the menu options to add or delete lanes and lane 
levels.  This is usually the easiest method. 
 

2. In the Lane Simulation screen, use the Quick Setup tab and enter the number of lanes for each of up to 
three lane levels. 
 

3. Use the Data Outline, as with any other item in Junctions 9.  This is recommended for advanced users 
only. 
 

In this example, each arm widens from a single lane upstream to two lanes at the give-way line.   After using any of 
the methods above, Arm 1 looks like this (all movements are still allowed on each lane segment): 
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Note that if you add lanes, you are NOT necessarily adding capacity to the junction.  Depending on which 
capacity mode you are using, you may need to re-enter arm geometries.  Please see Setting up lane geometries 
 for details. 

 

 Moving and selecting lanes 14.3.3

You can ‘slide’ downstream lane levels relative to upstream lane levels.  To do this, move the mouse over a lane 
until the cursor changes to a 2-way directional pointer.  Dragging the mouse will then slide that lane level. 

To move the entire arm, use the control points at either end of the arm, or move the grey ‘interior’ of the arm or 
the arm ID.  The same system is used to select lanes (to access their properties etc) and arms. 

If you need to make lanes curve, e.g. to follow a background image, you can right-click on any of the lanes and use 
Add new bend section as usual.   

Each lane level is automatically assigned an ID, where Lane Level 1 is always the closest one to the junction.   
Within each lane level, each lane is also assigned an ID, where Lane 1 is always the nearside lane.  Lane IDs can 
optionally be displayed by turning on Junction Diagram>Options>Other>Show Lane IDs.  For example, lane “[1,2]” 
refers to the second lane in the first lane level. 

 

 Setting lane movements 14.3.4

For T-junctions, lanes are set up automatically based on the main PICADY geometry options and cannot be 
changed.  See Using simulation with PICADY T-junctions. 

For roundabouts and other junction types, there are several ways to set up the allowed movements on each lane: 
 

1. In the Junction Diagram, click on the Assign Lanes button. 
 

 
 
Next, click on the lane that you want to alter.    
Then click on a destination arm.  (The destination arm can be the same as the arm containing the lane, 
which will affect U-turners.) 
 
The corresponding movement for the lane will be toggled on or off. 
You can repeat the process for other lanes until you cancel Assign Lanes mode. 
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2. Alternatively, in the Lane Simulation screen, you can use the Lane Movements>Normal Movements tab.  
Select the lane of interest by selecting it either in the Junction Diagram, or in the Data Outline, or by 
clicking a row header in the grid.  The grid shows the allowed movements for each destination, which can 
be toggled on and off by clicking in the grid. 
 

Additionally, you can quickly turn on or remove all movements for an entire arm by using the Quick Setup tab in 
the Lane Simulation screen. 

In this example, the nearside lane at the give-way line on each arm is used for left-turners only, with other traffic 
using the offside lane.  (Note that the upstream lanes are assigned as catering for all movements, including U-
turns, since the turning proportions in this example include a few U-turners on each arm.) 

 

 

In general, you will get ‘best’ performance if you simply allow all movements on all lanes – and that will give results 
most similar to those from a normal ARCADY run – but such a configuration will not necessarily satisfy safety and 
other design constraints. 

 

 Setting up lane lengths 14.3.5

If any arm has more than one Lane Level, then you must enter the ‘length’, or ‘storage’ of all lanes other than 
those in the upstream Lane Level (which is assumed to have infinite length).  Double click on any lane to show its 
properties, check that its Has limited storage field is ticked, and then enter the length of the lane in terms of the 
maximum number of PCU that can queue in the lane as the Storage value.   

Usually, all lanes in a given Lane Level will have the same storage.  

If the storage is disabled this is because either it is irrelevant, or is has been set automatically for you – for 
example, it may be based on pedestrian crossing data (see Using simulation with pedestrian crossings). 
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 Setting up demand flows 14.3.6

Demand is entered in exactly the same way as for a normal ARCADY/PICADY/OSCADY run.  You do NOT need to 
specify how much traffic uses each lane; this is estimated automatically when the simulation runs. (But see 
Secondary lane movements ) 

 

 Setting up lane geometries 14.3.7

By default, lane geometries are not entered individually.  Instead, you must enter geometries for each ARM in 
exactly the same way as for a normal ARCADY or PICADY run. 

T-junctions 
 
The capacity of each lane is either considered to be infinite (for priority lanes) or else obtained directly from the 
core PICADY model based on the major arm geometries. 
 

Signalised lanes 

The saturation flow for signalised lanes can be specified directly or calculated automatically.  See Using simulation 
with traffic signals. 
 

Roundabouts 

 
Unfortunately there is not a researched method of predicting the capacity of individual roundabout lanes based on 
their individual geometries which would also be compatible with the core ARCADY model.  There are however 
three methods that you can choose from as the Arm>Capacity>Lane Simulation>Lane Capacity Source for each 
roundabout arm: 

1. Evenly split [default mode]:  in this mode, you measure and enter the geometry of the full arm in exactly 
the same way as usual, ignoring any lanes.  This is used to calculate the overall capacity of the 
roundabout arm, using the core ARCADY empirical model.  This capacity is then evenly distributed across 
the lanes.  This is the simplest mode and simply assumes that, for instance, if there are two lanes at the 
give-way, then each lane will receive half of the overall arm capacity. 
 

2. Apportion from lane geometry:  This mode can be useful if it is obvious that one lane is much wider, for 
instance, than another lane.  In this mode, you enter a full set of geometry for each individual lane in 
Lane>Lane Geometry, bearing in mind the typical destination of traffic from each lane.  (You must ALSO 
enter the geometry of the overall arm, as usual).  The arm geometry is used to calculate the overall 
capacity of the arm, using the core ARCADY empirical model.  Then, the lane geometries are used to 
calculate a nominal capacity for each lane, as if each lane were a separate arm.  Finally, the overall arm 
capacity is apportioned to each lane, according to the relative nominal capacities of each lane.  At the 
same time, this method ensures that the overall capacity of the whole arm is the same as that calculated 
by the core ARCADY model.  If you enter a set of identical geometries for each lane, then this method will 
reduce to the Evenly split method described above. 
 

3. Directly entered:  in this advanced mode, you can enter a slope and intercept for each lane. 
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Please note that capacities apply only to lanes at the give-way line.  Upstream lanes are assumed to have infinite 
capacity, which means that vehicles will only ever queue in upstream lanes as a result of lanes at the give-way line 
being full. 

 

 Running the simulation 14.3.8

Once the steps in the previous sections have been set up, and if there are no errors in the file, you can run the 
simulation.  (In fact you can open an existing ARCADY/PICADY file, change to Lane Simulation mode and run the 
simulation immediately; this will use the default configuration and will often give similar results to the original 
ARCADY/PICADY run.  Note however that this does not apply to OSCADY files, as the data required for simulation 
of signalised lanes differs from that used in OSCADY.) 

 
Firstly make sure that the Lane Simulation screen is visible.  If not, press the Lanes button on the 
main vertical toolbar.   Alternatively, this will be shown automatically if you press the normal Run 
button on the main toolbar. 

When you press the Start simulation button (or start the process by clicking the normal Run button), Junctions 9 
will begin to model vehicles at the junction.  This involves running a large number of trials of the simulation (each 
of which models the entire modelled period, e.g. 90 minutes), with vehicles being randomly generated in 
accordance with the entered demand flows.  The results from each trial are averaged, and as the number of trials 
increases, the accuracy of the results gradually improves. 

 

Depending on a) your PC performance, b) the complexity of the junction and c) the modelled time period (e.g. 90 
minutes), please note that it may take some time to run the simulation.   

Whilst the simulation is running, the main Junctions 9 UI will regularly update any open screens, so that you can 
see the results and any selected visualisation immediately and throughout the simulation. If you find that the UI 
appears to freeze, try changing the Results Refresh Speed. 

As the simulation runs, some important numbers are shown at the top-right of the screen: 

 Number of trials:  this is the total number of trials run so far.   
 

 Duration: the time spent running the simulation, shown for reference (this is a function of your PC speed 
and is NOT related to the modelled time period) 
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 Convergence:  this is an indication of how much the results from each trial vary from the overall average.  
As the simulation runs, this number will gradually decrease.  By default, the simulation will continue to 
run until the convergence reaches 1%.   

As mentioned above, the simulation will stop automatically when the convergence indicator reaches a suitably 
small number, which by default is 1%.  However, you do not need to wait for this.  In most cases, the performance 
of the junction will be obvious almost immediately, and you can press the Stop Simulation button as soon as the 
results become apparent.  For example, the Summary Results screen may show almost straight away that the 
queue on Arm A is 10 PCU.  If you leave the simulation running then it may eventually show a more accurate value 
of, say, 8 PCU, but you may well not need this level of accuracy.  For comparing alternative lane configurations, for 
example, the overall conclusion of whether the junction performs well or not is usually obvious very quickly. 

However, if you wish to obtain repeatable results, then you may wish to leave the simulation running until it stops 
automatically.  In this case, you may also want to set the Random Seed to a fixed number, and the Stop Criteria to 
your own preference. 

Note that if the demand is low, then the simulation can take a long time to stop.  This is because the random 
variation between trials will be large compared to the flows and queues.  Again, however, this only applies to the 
case where you leave the simulation running until it stops automatically. 

 

 

As soon as the simulation starts, the Summary Results screen is shown.  (Unless your user preferences have turned 
this off.) In this screen and in any other screen that shows results, the values will change as the simulation runs.  

In this example, the flows and configuration on all four arms is identical, so in theory the results on each arm 
should be identical.  If you stop the simulation immediately after starting, then you may see results similar to the 
below.  You can see that the delay on each arm is somewhere around 100s, but that there is consideration 
variation between arms.  If you re-started the simulation and again stopped it straight away, you may well see 
different numbers – although the overall conclusion of whether the queue and delay is low/medium/high will be 
the same. 

If at this point, after only a few trials, you plot a Time Graph (see Time Graph Mode) – in this case using 5-minute 
time segments – you can see the shape due to the ONE HOUR profile type, and the rough position of queues, but 
it’s also clear that the results are only approximate. 

 

 

If you leave the simulation to run for longer, however, then the results become more accurate and the variation 
between arms reduces – although note that there will always be a certain amount of variation.  Note that the 
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overall conclusion about the junction performance – e.g. that the queue is approximately 10 on each arm - is the 
same whether or not you leave the simulation running for a long time. 

 

 

 Simulation numerical results 14.4.1

As the simulation runs, results are collected for each time segment, and these can be seen in the usual areas of the 
Data Outline.  The Summary Results screen shows the maximum values over the modelled period, as for any 
Junctions 9 run. 

Detailed results are available both for each arm, and for each lane, via the Data Outline or the main Results toolbar 
button.  In general, results for an arm are the sum of the lane results on that arm. 

The key difference between simulation results compared to a normal ARCADY/PICADY/OSCADY run is that results 
from the simulation are ‘measured’ from the individual vehicle simulation, rather than being predicted analytically.  
For example, the Demand is measured as the number of generated vehicles, and although this generation rate is 
based on the junction traffic demand, it will not be exactly the same.   If there are multiple Lane Levels, then the 
demand on downstream lanes corresponds to the amount of traffic assigned to each lane.  For example, if a 
downstream lane does not allow a particular movement, then the demand for that movement on the lane will be 
zero. 

Throughput is measured as the flow of vehicles across the give-way line / stopline (i.e. vehicles emerging from the 
downstream end of the lane). 

Queues are simply the number of waiting vehicles, measured at the start and end of each time segment. 

For lanes, Delay represents the total time spent queueing in the lane. If there are multiple Lane Levels, then the 
total delay on the arm will be roughly the sum of the lane level delays. 

For roundabouts, the Capacity for each lane is shown using the calculated slope and intercept for that lane, which 
in turn depend on the capacity mode selected; see Setting up lane geometries for details.  Capacities for upstream 
lanes are not shown, because such lanes are assumed to have infinite capacity.   

Each roundabout lane that enters the junction (i.e. any lane with a give-way capacity) has an RFC calculated, which 
is simply the ratio of flow (demand) to capacity on that lane.  You should interpret these carefully, because a very 
low RFC may simply mean that the demand on the lane is very small due to entry starvation, or a lack of allowed 
movements on the lane.  For this reason, it is usually better to look at the overall queue and delay situation on the 
whole arm and junction.  

For PICADY junctions, capacities and RFCs are not shown because although base capacities are taken from the core 
PICADY model, they are combined and adjusted in various ways which mean that the throughput and queue and 
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delay are the most useful measure of performance.  Similar considerations apply to signalised lanes and circulating 
lanes. 

An RFC for each arm is NOT calculated.  This is because it is difficult to define what is meant by the capacity of the 
whole arm when in Lane Simulation mode.  The maximum entry flow on the arm (i.e. the capacity) depends not 
only on geometries, but also on the lane configuration and turning movements.  A low RFC could mean that the 
flow is low compared to the capacity (i.e. the usual interpretation), but it could also mean that the flow is low 
because it is restricted due to the lane configuration/movements.  For this reason, arm RFCs are not shown.   

For any junction type, if you wish to calculate the maximum possible entry flow for a given lane configuration and 
set of turning proportions, then you can set the current Analysis Set’s Flow Scaling Factor to a high value, which 
will have the effect of flooding the junction with extra demand.  The calculated Throughput on each lane and arm 
will then represent the most that the junction can cope with.  However it is important to note that if the turning 
proportions change, then the overall capacity may change.   

 

 Arm/lane/movement results 14.4.2

Numerical results for arms and lanes, for time segments and for the whole period, are available via the Data 
Outline or the Results button on the main toolbar.  Results can be viewed in the Data Editor or Data Grid as for any 
other type of result. 

 

It is also possible to view certain results for individual movements on lanes.  To do this go to the Options tab on the 
Lane Simulation screen and click the Movement time segment results link. 

In the example below, the throughput on the arm is 617, the queue is 5.8 and the average delay per vehicle is 36s: 

 

The per-lane results show how this is split between the two lanes on the arm.  The arm delay is a direct 
measurement of the delay of all vehicles on the arm, but in most cases will be equivalent to the average of the 
lane delays weighted by the demand on each lane. 

 

 
The per-movement results show the “demand” for each movement (the count of vehicles wanting to make each 
movement which appear at the upstream end of the lane), along with the queue and delay for the movement.  In 
this example, on Lane 1, the turning proportions are such that most traffic is heading to Arm 2 (i.e. turning left), 
and it is this traffic that makes up most of the queue and delay on this arm.   
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This is confirmed in the Average queues for each destination visualisation, which shows that the queue on the 
nearside lane is composed mostly of left-turners. 

 

 

 Queue percentiles 14.4.3

(See Queue Variations (percentiles) and Queue Markers for a description of queue percentiles.) 

Queue percentiles are produced automatically from the queue probability distributions that are built up as the 
simulation runs.  This means that they are always available regardless of whatever traffic profile mode is selected.  
(This is in contrast to queue percentiles from normal ARCADY/PICADY runs, which are sometimes unavailable 
depending on the other modelling options used.)  Therefore Lane Simulation can be used to produce detailed 
queue percentile results, even if there is only a single lane on each arm. 

Queue percentiles can be shown in visualisations on the diagram.  They are also reported for each lane and arm in 
the usual place in the Data Outline provided that Options>Analysis Options>Calculate Queue Percentiles is turned 
on. 
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 Diagram visualisations 14.4.4

From the Lane Simulation screen, you can choose from several visualisations to display queues on each lane in the 
Junction Diagram.  This can be extremely useful when looking at the overall performance of the junction, or when 
comparing alternative lane configurations.   

Visualisations can be shown and animated as the simulation is running, or after the simulation has finished.  Note, 
however, that visualisation data is NOT saved in the data file.  That is, you must re-run the simulation if you load 
a file and wish to display visualisations. 

 

The visualisations show data that is collected from the simulation for each second of the modelled period.  
(Additionally, data for each time segment is collected and stored in the usual Data Outline locations.)  As you drag 
the Time slider in the Lane Simulation screen, queues in the Junction Diagram are shown for the indicated time.  
Alternatively, you can use the main Time Segment drop-down menu to skip to a certain time in the modelled 
period. 

Note that the queues are scaled in the diagram according to the current scale of the drawing; see Scale ruler for 
more details.  To display the full extent of the queues, you may need to stretch the position of the arm control 
points, or else ‘zoom out’ by altering the scale. 

The visualisation types are described in the following sections. 

NOTE:   Visualisations are available almost immediately after starting the simulation.  Leaving the simulation to run for longer 
will not model a longer time period but will simply refine the accuracy of the results. 
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14.4.4.1 Individual vehicles 

 
In this mode, individual QUEUEING vehicles are shown, colour-coded according to their destination.  The names of 
each arm are also colour-coded accordingly.  So, for example, all red vehicles are travelling to Arm 1. 

Vehicles of the same colour have subtle random shading applied (e.g. light red or dark red); this is simply to make 
it easier to tell whether a queue of vehicles for the same destination is moving or static. 

 

As you drag the Time slider, or use the animation controls, you can see the progress of individual vehicles.  Note 
that the graphics represent a single trial of the simulation, rather than averages.  Unlike the other modes, the 
accuracy of this visualisation does NOT improve as the simulation runs for longer.  The purpose of this mode is 
simply to display roughly which lanes are used by which vehicles.  If you start the simulation again, the individual 
vehicle animation is unlikely to be the exactly same as the last run unless you use a fixed Random Seed. 

In the example shown above, each coloured block represents a single vehicle.  (Technically, each block represents 
1 PCU, so a heavy vehicle will appear in the animation as two consecutive blocks.)   

The coloured blocks represent QUEUEING TRAFFIC.  If an arm is well within capacity, then there will be minimal 
queueing and you will not see any coloured blocks. 

You can control the size of the blocks by adjusting the junction diagram scale. 
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14.4.4.2 Average queues for each destination 

 
This uses colour coding to show the average amount of traffic queueing on each lane, for each movement.  

 

In the snapshot above, there are large queues for traffic on Arm 4 and traffic on Arm 2 that is turning left into Arm 
3.   

Note that average queues may be shown in upstream lane levels even though there appears to be space in the 
downstream lane levels – e.g. as shown on Arm 1 and Arm 3 in the screenshot.  This can have two causes:  firstly, 
the lane may be partially starved of traffic due to blocking from an upstream queue.  Secondly, because the values 
are averages, there will be some times when the overall queue is short, and this will reduce the average below the 
value of the storage of the lane.  This is illustrated in the example below: the storage of the downstream lane is 5, 
and the average queue is less than 5, even though the average queue in the upstream lane is greater than zero. 

 

Downstream 
(storage=5) 

Upstream Total 

 
3 0 3 

 
1 0 1 

 
5 1 6 

 
5 0 5 

 
4 0 4 

 
5 4 9 

 
5 2 7 

 
2 0 2 

AVERAGE 3.75 0.875 4.625 
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14.4.4.3 Shaded percentile queues 

 
This mode uses a single colour (blue), with the intensity of the shading representing the probability of queues.  
The darker the colour, the more likely it is that the queue will reach that point.   

 

Generally, the shading will be darker towards each give-way line.  I.e., it is highly likely that the queue will be at 
least 1 PCU, but unlikely that it will be, say, 100 PCU.  As you drag the Time slider, the diagram will show how these 
probabilities evolve over time.  

In the snapshot above, the offside lane on Arm 2 is paler than the nearside lane.  This shows that there is less 
likelihood of the offside lane being full, whereas the nearside lane is almost certain to be full. 

 

14.4.4.4 Single percentile queues at X% 

 
This mode is similar to Shaded percentile queues, except that only queues above a certain threshold are shown.  By 
default, X is 50%, but can changed using the slider control.   

In the first snapshot below, there is a 50% chance that the queue on each lane will be longer than the blue bars.  In 
the second snapshot, the slider was changed to 90%, and so the blue bars represent the 90

th
 percentile queue 

lengths – i.e., there is only a 10% chance that the queues will be longer than the bars.  (The queue bars are capped 
to the position of the arms, so may be longer than those shown below.) 
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Circulating lanes at roundabouts can optionally be modelled in Lane Simulation mode.  This can be useful if 
modelling partially signalised roundabouts where there are signals on one or more sections of circulating 
carriageway.  It can also be used if you wish to examine blocking back along the circulating carriageway, or if the 
lane choice on the circulating sections is important.   

NOTE:  It is not possible to specify that traffic entering the roundabout gives way to only certain circulating lanes.  
It is assumed that traffic gives way to ALL circulating traffic. 

To turn on circulating lanes, turn on Data Outline>Junction>Use Circulating Lanes.  The Junction Diagram will then 
show the circulating lanes between the roundabout arms.   

TIP:  You can use the Spacing tool in the diagram, or the Auto-arrange button to increase the spacing so that the 
circulating lanes can be seen more easily. 

 

Circulating lanes can also be viewed in the Data Outline as with any other lane type.   They are divided into two 
types: 

 Circulating Link:  these sections link the entry of one arm with the exit of the next arm.  In the example 
above, the orange lane is the circulating link between Arm 3 and Arm 1.  It is associated with Arm 1 in the 
Data Outline.   
 

 Circulating Base:   these sections go between the exit and entry sides of an arm.  In the example above, 
the green lane is the circulating base for Arm 1.   Traffic entering the roundabout on Arm 1 gives way to 
the traffic flowing out of this section. 

The arrows in the circulating sections point to the destination arms that can be ultimately reached from the lane.  
(As opposed to the immediate next movement.)   By default, all movements are allowed, as with any other lane 
type.  For example, arrows that resemble u-turns indicate that vehicles on the lane can reach the previous arm 
eventually, by progressing through the roundabout. You can change which arms can be reached from each lane by 
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using the Assign Lanes tool as usual.  In this mode, firstly click on the circulating lane that you are setting up, and 
then click on the destination arm.    

Additional circulating lanes (and lane levels if required) can be added as usual by right-clicking on an existing lane 
and clicking Add another lane. 

By default, each circulating lane has storage for 3 PCU, meaning that, on average, around 3 PCU can queue in the 
lane.   You can change this, again as for any lane, by double clicking on the lane to access its properties and 
changing the Storage value.  The length of the lane as shown in the Junction Diagram will reflect the storage. 

The example below shows a roundabout that has been set up with circulating lanes: 

 

 
When the simulation runs, vehicles entering the junction will pass through the relevant circulating lane sections for 
their desired destination until they exit the roundabout.  If there is a choice of lanes in a given lane level, they will 
use the one with the shortest queue (if any) at that moment.   

Circulating lanes by themselves do not, by default, have any sort of capacity restriction.  Instead, vehicles are 
assumed to pass straight through without any delay.  Therefore you will not see any queues on circulating lanes 
unless there are signals or a restriction somewhere that leads to blocking back into the circulating lanes.  In the 
example below, there is a restriction on the southeast exit (this could be due to a signal, a bottleneck restriction, 
or a downstream junction, for example), which has caused blocking back on the affected circulating lanes, as 
shown by the individual vehicle animation in the diagram. 

NOTE:  Whether blocking on circulating lanes actually occurs in reality, and whether it prevents access to other 
lanes, depends on the size of the roundabout, lane geometry, driver behaviour and so on. 
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 Positioning modes 14.5.1

By default, circulating lanes are automatically positioned between the relevant arm entries/exits.  If you move an 
arm, the circulating lanes will also move.  Optionally you can position the circulating lanes manually, which can be 
useful if aligning the diagram with a background image.  To do this, right click on a lane and choose 
Positioning>Manual.  In this mode, you can drag the lane level to any position, and it will remain in that position 
even if you move the arms or junction.   To restore the automatic positioning, choose Positioning>Automatic. 

Circulating lanes can have ‘bend sections’ added as with other lane types by right-clicking and choosing Add new 
bend section.  (You must be in manual positioning mode to do this.) 

The example below shows a partially signalised roundabout where the circulating lanes have been positioned 
manually. 
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 Signals at roundabouts 14.5.2

Signals can be applied to circulating lanes, as with any other type of lane.  (See Using simulation with traffic 
signals.) In this way it is possible to model partially signalised roundabouts, as in the example below where the 
northeast section of the roundabout is signalised and the other arms are normal give-way roundabout arms. 

NOTE:  To use traffic signals you must register the OSCADY 9 - Signalised Intersection Module. 

NOTE:  It is possible to signalise all lanes, to model a fully signalised roundabout, but in such cases it may be easier 
to use TRANSYT, to avoid restrictions in Junctions such as only having a single signal controller for the entire 
junction.  A file started in Junctions can be exported to TRANSYT so that you do not have to start again from 
scratch. 

In the individual vehicle animation, the state of each signal phase in shown in red/green, and queueing vehicles are 
coloured according to their desired destination.  The animation can be stepped through to see how the queues 
build up and decay over the signal cycle. 

 

 

 Results for circulating lanes 14.5.3

Numerical results for circulating lanes are shown in the Data Outline, Data Grids and reports as with other lane 
types.  The reported demand on circulating lanes reflects the volume of traffic entering the upstream end of the 
circulating lane. 

Any queues on circulating lanes are NOT included in overall arm results, other than indirectly if circulating lanes 
cause blocking back onto the entry arms. 
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If the file contains a T-junction and Lane Simulation is being used, PICADY streams are hidden and replaced with 
lanes.   The lanes and the movements allowed from each lane are set automatically according to the values 
entered in the main PICADY geometry screens, and cannot be manually altered. 

 

 Major arm properties 14.6.1

A default PICADY T-junction in Lane Simulation mode looks like this: 

 

By default C-B traffic blocks C-A traffic is turned on.  This corresponds to a single lane on Arm C that carries both 
straight-ahead and right-turning traffic.  By default, there is a single lane on Arm B that carries both left-turning 
and right-turning traffic. 

Running the simulation and using the Individual vehicles visualisation shows queued vehicles colour-coded by 
 destination and shows a combination of traffic on Arm B and Arm C, as expected.  Note that the coloured blocks 
only show QUEUEING traffic.  Arm A traffic is unimpeded (i.e. never queues) and so no coloured blocks are shown 
on Arm A.  Straight-ahead traffic on Arm C is unimpeded, but will queue when waiting behind a right-turning 
vehicle, as shown in the screenshot. 
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Running the file shows results for each ARM in the Summary Results screen.  For this file, the results match the 
stream results from the equivalent PICADY file (note that they are very unlikely to match precisely and you may see 
slightly different results if the file is re-run.)   Note that RFCs are not shown; see Simulation numerical results for 
 the reasons why. 

     

 

If C-B traffic blocks C-A traffic is turned off, this implies that right-turning traffic has its own lane, or a right-turn 
bay.  You must then tick the Has right-turn lane/bay option in the PICADY geometry screen.  This will automatically 
create a lane for right-turners.  After running the file, straight-ahead vehicles on Arm C never queue as they have 
their own unimpeded lane. 

     

NOTE: exit-lanes have been turned off for clarity. 
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For this file, the queue on Arm C is about the same as the C-B stream queue from a normal PICADY run.  The delay 
is only about half the PICADY delay though, because the Arm C delay in Lane Simulation mode takes into account 
the undelayed straight-ahead vehicles in the other lane.   The detailed results for each lane confirm that the delay 
for the right-turning lane is 62s, about the same as the stream C-B delay. 

   

 

 

If there is a right-turning BAY on Arm C, this is set up as usual by entering a non-zero value for the Blocking queue 
option.  (If this is very large then the situation will be as in the previous example.)  In Lane Simulation, a short lane 
is automatically set up, with its Storage set to the Blocking queue.  In this example, the storage is 2 PCU, so the 
third right-turning vehicle will queue in the nearside lane and block other traffic.    

     

NOTE: exit-lanes have been turned off for clarity. 
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 Minor arm properties 14.6.2

The Minor Arm Type for Arm B can be set to One lane,  Two lanes  or  One Lane Plus Flare.   The lanes on Arm B are 
automatically set up according to this option, as shown below.   When using a flare, the Flare Length property is 
used to set the storage for each of the short lane sections.   

 

                                        

NOTE: exit-lanes have been turned off for clarity. 

 

When looking at lane results, the Destination Arms field confirms the movements allowed from each lane. 
Movement shown in brackets – e.g. “(A,C)” – indicate that there are intermediate downstream lanes on the same 
arm.   
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NOTE:  To use traffic signals you must register the OSCADY 9 - Signalised Intersection Module. 

Each Lane Simulation has a Signalised property.  If ticked, the lane will be simulated as a signalised lane, using the 
signal properties set up in the main signals screens (see Working with Traffic Signals). 

You can apply signals to one or more lanes at any junction type.  For example, if the underlying junction is an 
ARCADY roundabout, then the result will be a partially signalised roundabout.   (Also see Signals at roundabouts.) 

NOTE:  Lane Simulation allows you to model signalised situations which may not be possible with the normal 
OSCADY model, or where signals are present at other junction types.  However, you can only evaluate existing 
signal timings in Lane Simulation; you cannot generate optimised timings.  To generate new timings, you must use 
the OSCADY model (see OSCADY junctions), or, if that is not possible, consider using TRANSYT.    

To simulate a fully signalised junction, you can either start off by switching on the Signalised property for each lane 
in an existing file, or, more conveniently, you can use the New File screen and select, for example, T-junction + 
Signals + Lane Simulation mode.  This will create a T-junction in Lane Simulation mode with signals on each 
approach. 

Signalised lanes are indicated in the Junction Diagram by a circle showing the signal phase controlling the lane. 

To change whether a lane is signalised, and to select which phase it runs on, right-click on the lane and use the 
Signal Phase menu. 

 

In this example it is assumed that a simple staging arrangement is used where each of the three approach lanes 
runs on a separate phase, in a separate stage.  Information relating to the stage properties, stage sequence etc, is 
set up in the main signals screens (see Working with Traffic Signals), independently of Lane Simulation. 

When the simulation runs, the Individual Vehicle animation in the Junction Diagram can be used to show the signal 
state on each lane.  This is shown as a red/green colour for the phase ID and should not be confused with the 
colour coding of the vehicle queues, which refer to the vehicles’ destination arms. 
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 Lane-specific signals data 14.7.1

This section describes data that should be entered for each signalised lane.   This is independent of the junction-
wide data controlling the Stage Library, Stage Sequence, cycle time, and so on.   

To access signals data for a lane, right-click on it in the Junction Diagram and select Signals Phase>Signals 
Properties (or browse to it in the Data Outline). 

 

Phase:  enter the ID of the signal phase that controls the lane.  (The phase must have already been created in the 
main Signals part of the file.)  This can also be set via the lane’s right-click menu. 

Relative start/end displacement:  any values entered here will combine with the global start/end displacement 
(see Start/end displacements).  This allows individual lanes to have shorter or longer effective greens than others. 

Use RR67:  this controls how saturation flows are calculated from geometries; please see the next section. 

 

14.7.1.1 Saturation flows 

In Lane Simulation mode, a separate saturation flow is calculated or entered for each movement allowed on each 
lane.  Each simulated vehicle will ‘use’ the saturation flow appropriate to its desired movement.  (For instance, a 
vehicle making a turning movement will cross the stopline at a slightly slower rate compared to a vehicle going 
straight ahead.) 



 Lane Simulation Mode    Page 230     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

Properties for each movement are available inside each lane in the Data Outline, or, more conveniently, by right-
clicking on a lane and selecting Movements; this will launch a Data Grid with its filter set to show only information 
for that lane.  (If you reset the filter you will see data for all movements for all lanes.) 

 

In the example above, Arm A contains a left turn and a straight-ahead move (movements A-B and A-C 
respectively).   In the Signals properties for the lane, the user has specified: 

 Gradient = 0 

 Width = 3m 

 Nearside lane = true (this should be ticked if the lane is the only lane on the arm) 

For more details about these geometric measurements, see OSCADY Geometric data. 

The Movements grid confirms which movements are allowed from each lane.   (You can set movements here, or, 
use the Assign Lanes tool in the diagram.)  For each allowed movement, you should enter a turning radius for the 
average path of vehicles making that movement.  In this example: 

 Turning radius for the A-C movement = 9999m (use this if the movement is straight-ahead) 

 Turning radius for the A-B movement = 6m 

From this data, the saturation flows are calculated as 1915 PCU/hr and 1532 PCU/hr for the A-C and A-B 
movement respectively. 

You may wish to directly enter your own saturation flow for each movement.  To do this, turn off Use RR67 on the 
lane’s signal properties. (RR67 refers to a research report that specifies how saturation flows can be estimated 
from geometric properties.)  The Saturation Flow field for each movement will then be directly editable. 
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 Opposed movements 14.7.2

Opposed movements (e.g. opposed right turns in the UK) are set up individually via the Movements grid for the 
relevant lane (see previous section for how to easily access this). 

 

In the example above, the Movements grid for the lane on Arm C is displayed.  This lane allows movements to Arm 
A and to Arm B, and the movement to Arm B is opposed by all traffic from Arm A.  I.e., any vehicles on Arm C 
wishing to turn right into Arm B must give way to straight-ahead and left-turning traffic from Arm A.    

This is set up by ticking the Opposed option for the C-B movement, and then entering “A-C” as Opposing 
movement 1 and “A-B” as Opposing movement 2.   Up to three opposing movements can be entered; all are 
treated in the same way. 

The Junction Diagram indicates that the C-B movement is opposed by drawing the connector curve with a dotted 
line. 

The Max opposed flow represents the saturation flow for the C-B movement if the opposing traffic flow is zero.  
This is calculated automatically from the geometries unless you turn off Lane>Signals>Use RR67, in which case you 
can enter your own value.  Generally this value is slightly less than the usual saturation flow because opposed 
vehicles always need to check for the presence of opposing traffic. 

Each opposing movement has a Slope coefficient which reflects how the opposed flow decreases as the opposing 
flow increases.  A suitable default is provided, based on typical lane geometries.   

NOTE:  the ability to model opposed situations in Lane Simulation is flexible and can be applied to various 
situations, but also contains various simplifications and assumptions.  For more comprehensive modelling of 
opposed turners, consider use of TRANSYT. 
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 Intermittent stages 14.7.3

In Lane Simulation mode, Library Stages can be set up to only run on an intermittent basis.  Two options are 
available, in the Library Stage’s properties: 

 Run every N cycles: by default this is set to 1, meaning that the stage will run every cycle.  If you set it 
instead to 2, then it will only be used every 2

nd
 cycle, and so on.   For instance if the Stage Sequence is 

1,2,3,4, and Library Stage 4 is set up only run every two cycles, then the resulting sequence in Lane 
Simulation would be 1,2,3,1,2,3,4,1,2,3,1,2,3,4…. 
 

 Probability of running:  by default this is 100%, meaning that the stage has a 100% chance of appearing in 
each cycle (assuming it is contained in the Stage Sequence of course).  If set to, say, 50%, then there will 
be a 50% chance of any given cycle containing the stage.  (The overall rate will be apparent over a large 
number of cycles.)  This can be used to simulate an event that occurs randomly, such as a pedestrian 
stage. 

To confirm the behaviour of such stages, it is useful to use the Signals log. 

 

 Signals log 14.7.4

Following or during a Lane Simulation run, pressing the Signals Log link at the top-right of the main Lane 
Simulation screen will show a “recording” of the signal state of each phase, covering a length of time similar to one 
time segment (e.g. 15 minutes).  This can be useful to confirm that the pattern of signals is as expected. 

 

Use the Spacing slider to control the appearance. 

The numbers at the bottom show the time in seconds, and the ID of each Library Stage when it begins.  

In the example above, the Signals Log confirms that the stage sequence shown in the Timings Diagram simply 
repeats every cycle, as expected.  If however, Stage 3 is set to only run every 2 cycles (see Intermittent stages), the 
Signals Log confirms this behaviour: 
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Firstly, enter all pedestrian crossing data in the usual data entry screens (see Pedestrian crossings for details). 

For T-junctions, the lanes on the relevant arm are automatically split in two, with the crossing being inserted 
between the two lane levels, on both the entry and exit side of the arm.  The length of the lane sections closest to 
the junction can be seen as the Storage property of the lanes, and is set automatically from the relevant crossing 
properties (Space between crossing and junction entry etc). 

If the crossing is on an arm with a flare, or a short right-turn bay, Junctions 9 may create three lane levels, with the 
crossing positioned before or after the flare/bay, depending on the relative lengths of the items. 

 

 

For roundabouts and other junction types, the process requires some additional manual steps.   

 Firstly, add the crossing and set its properties as usual.    

 Then right-click on the entry lane of the relevant arm and click Add another lane level.   

 Right-click on the newly created upstream lane and select Has crossing.  The crossing will then appear.    

 Double click on the downstream lane section and set the Storage property to be distance between the 
crossing and the roundabout.  This will usually be the same as the crossing’s Space between crossing and 
junction entry property and a warning will be shown if it is significantly different. 

This process is only needed on the entry side of the arm and is needed because Junctions 9 will not otherwise 
know at which lane level to place the crossing (given that the lane structure on the entry side of a roundabout arm 
is more user-configurable than on the exit side or at T-junctions). 
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After running the file, the Individual vehicles animation will show whether the crossing is ‘red’ or ‘green’, as seen 
 by traffic, for each simulated second.  The simulation models the random arrival of pedestrians, based on the 
pedestrian demand, and the time they spend on the crossing.  For pelican crossings, the various timing properties 
are taken into account.  In the example below, the crossing is red to traffic (i.e. is being used by pedestrians) and a 
queue of vehicles has formed behind it, as well as the separate queue of vehicles at the give-way line.     

 

Vehicles may also queue behind the crossing on the exit side of the arm.  See the next section for details. 

 

 

Each junction arm is usually automatically set up with a single exit lane.   

In general, exit lanes will only show a queue if there is a pedestrian crossing on the exit, or a downstream linked 
junction which blocks back, or you have added some sort of exit restriction manually.  Blocking back from both 
zebra and pelican crossings is modelled, for both roundabouts and T-junctions, for any number of arms. 

In the example below, there is a pedestrian crossing on Arm 1.  When the crossing is red to traffic, it causes a 
queue behind it on both the entry and exit sides.  On the exit side, this queue prevents traffic on Arm 3 from 
entering the roundabout – i.e. there is blocking back into the previous arm.   This may also affect traffic on other 
arms. 

 

NOTE:  the coloured blocks show queueing traffic, colour coded with their destinations.  Do not confuse their colours with the 
red/green signal state of the crossing. 
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NOTE:  the individual vehicles animation is a snapshot from a single run of the simulation.  The other visualisations and overall 
results will give a better indication of whether queueing on the exit side and any associated blocking back is actually a problem 
when averaged over many runs. 

 

View lane time segment results to see results for exit lanes.  The demand for an exit lane is the traffic measured as 
appearing at the upstream end of the exit lane (i.e. at the junction exit).  The throughput is the traffic measured 
leaving the downstream end of the exit lane (i.e. away from the junction) and will be the same as the demand 
unless there is a crossing or blocking from another junction.  If there is blocking, then the exit lane will record its 
own queue, which will be limited in size to the Storage of the exit lane. 

In the screenshot below, 300 PCU/hr enters the junction on each of Arms A, B and C and all traffic exits on Arm B.  
The ‘demand’ and ‘throughput’ for the Arm B Exit Lane is therefore shown as about 900 PCU/hr. 

 

Often, exit lanes have no queues and are not needed in the results.  If this is the case, you can hide them from 
results to simplify data grids and reports by clicking Data Outline>Options>Sorting and Display>Hide exit lanes.  
They will still be modelled, but the rows in grids etc for exit lanes will be hidden. 

 

 

 

In Lane Simulation mode there are several ways to apply capacity restrictions on entries and exits. 

 

 Setting an entry lane’s minimum/maximum capacity 14.10.1

Each entry lane has a Minimum Capacity and Maximum Capacity property.   These can be used to ensure that the 
capacity of the lane does not fall below, or rise above, a fixed value.  If you set the same value for the minimum 
and maximum capacity then in effect you will be fixing the capacity of the lane to that value.   Please note however 
that the capacity may be adjusted when the simulation runs, and so, particularly for PICADY junctions, these data 
fields should be treated as ways of nudging the capacity up or down rather than as absolute values. 
 

 Using a bottleneck restriction 14.10.2

In Lane Simulation mode you can add a “bottleneck” restriction to any lane.   This applies to any junction type and 
overrules any automatic lane creation (used particularly for PICADY) and so to use bottleneck restrictions you must 
firstly turn on Data Outline>Options>Lane Simulation Options>Suppress automatic lane creation. 
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After turning on the option mentioned above, double click on the lane to access its properties and tick the Has 
Bottleneck option.  You can then enter the Bottleneck capacity, which should reflect the maximum flow of traffic 
through the restriction.   

The Bottleneck type sets whether vehicles will progress through the bottleneck using uniform or random 
“departures”.  Generally, uniform departures are applicable for signalised situations, and random departures 
applicable for other situations. 

After adding the bottleneck restriction, then running the file may show queueing at the restriction which may 
block back to upstream lanes. 

TIP:  If you need the restriction to be placed at a particular location on the lane, you can split lane into two Lane 
Levels and set the storage of the upstream section to represent the position of the restriction. 

 

 

Please see Linked junctions for general considerations regarding linked junctions. 

In Lane Simulation mode, any number of junctions of any type can be linked together.    

To link junctions, use the diagram Connect tool as described in Setting up linked junctions.  The screenshot below 
 shows the junction diagram immediately after connecting a basic roundabout and T-junction. 

 

If you look in the Demand screen you will see that the Linked Arm property has been set for the relevant arms but 
that there are no properties in the Linked Arm tab other than the IDs of the feeding junction and arm. 

In Lane Simulation mode, the only properties required are the lengths, expressed in PCU, of the lane sections 
inbetween the junctions.  (All other lane sections are assumed to be infinitely long.)   To edit these, double click on 
any lane section to show the Data Editor or a Data Grid of lane properties and edit the Storage property. 

NOTE: Make sure that Options>Sorting and Display>Hide exit lanes is turned OFF.  Otherwise, you will not be able to see or edit 
all necessary items. 
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By default all internal lane sections have a storage of 3 PCU.   In either direction there are two internal lane 
sections: firstly the exit lane (see Exit lanes and blocking back) from the first junction and secondly the entry lane 
 at the second roundabout.  In total therefore the storage between the two junctions will be 6 PCU until you 
change the storage values.    

For instance if the space between the junctions is actually 10 PCU, then you could enter a storage of 5 PCU for 
both the exit lane and the entry lane.  Alternatively you could set the exit storage as 1 PCU and the entry lane’s 
storage as 9 PCU, or any other combination that adds to 10 PCU.  

NOTE:  If there are crossings or flares or multiple lane sections at either junction, then there may be more lane sections 
between the junctions.   The total space between the junctions is represented by the sum of the Storage of each lane section. 

NOTE:  The minimum storage for any lane section is 1 PCU.   When the simulation runs, any vehicle that has a PCU value large 
than the storage for a lane will not be able to access that lane.  Therefore if there are heavy vehicles at the junction, it is 
recommended that you enter a storage of at least 2 PCU for each lane section. 

 

In the junction diagram the lane lengths are automatically scaled according to their Storage.  If you cannot see the 
end of a lane, extend or reposition the arm until the entire lane can be seen.   The actual positions and orientations 
etc in the diagram do not in any way affect the model, but to aid visibility the arm IDs are automatically hidden if 
you move the junctions close together. 
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Assuming that demand, turning proportions and other basic data has been set up, running the simulation will 
model vehicles passing between the junctions.   Any blocking back between the junctions is modelled and will be 
reflected in the results. 

Immediately after running the simulation it can be useful to turn on Overlays>Flows by entry  and Flows>Actual 
flows calculated by model and confirm that the relative volumes of flows are roughly where you would expect. 

 

 
The usual simulation visualisations will show an animation of QUEUED vehicles for each simulated second.  In the 
snapshot shown below, traffic is able to progress from west to east from the roundabout and past the T-junction 
without any issues.  However in the other direction, there is queueing at the eastern roundabout arm (perhaps it 
has a more restrictive geometry) which causes blocking back past Arm B of the T-junction. 

 

NOTE:  Any priority reversal or tendency of Arm B traffic to force its way out is NOT modelled.  The snapshot above shows that 
there is a POTENTIAL problem at this site. 

 

More complicated systems of junctions can be set up in the same way.   
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 Advice about simulating linked junctions 14.11.1

As ever, you should always check that the model replicates base conditions before attempting to model new 
scenarios. 

Please also note the following: 

 If the number of lanes widens between junctions – e.g. a single-file exit lane widens to two entry lanes at the next 
junction – you should add a dummy extra lane level at the upstream end of the second junction.  This lane level 
should contain a single lane.  This will act as a temporary location for vehicles to be placed before they make a 
decision about which entry lane to move into (this cannot be done before they leave the previous junction). 
 

 
 
 
 

 The core PICADY model assumes that the capacity of the minor arm streams depends on the demand on the 
controlling streams.   If traffic in the controlling stream is stuck in a queue that blocks back to a previous junction, 
then the simulated minor arm traffic may not be ‘aware’ of the full extent of the demand that they are (according to 
the core PICADY model) giving way to.  This situation is detected and a Task List warning shown. Congested situations 
such as these present various modelling difficulties.  Therefore if the simulation shows any sign of congestion for any 
junction type then you should treat the results as simply indicating that a problem exists.  The actual real-life 
behaviour is likely to be very site-specific. 
 
 

 At closely spaced junctions such as double mini-roundabouts or any site where there is room for only a few vehicles 
between junctions, there may be detailed traffic interactions that the simulation is unable to model. 
 
 

 Any queueing or interaction WITHIN junctions is not modelled.  In effect, the interior of each junction is assumed to 
always be clear of vehicles.   In the example below, the green right-turning vehicle at the front of the queue on Arm 3 
will be able to leave, even though in reality the blocking back queue (red) from the downstream junction may block 
part of the circulating carriageway.  Similarly, the orange right-turning vehicles on Arm B will be able to depart 
because it is assumed that the vehicles queueing back from the roundabout (green/brown) will leave a gap at the Arm 
B give-way line.  As mentioned above, the results from a congested situation like this are indicative only and the 
actual detailed behaviour is likely to vary from site to site. 
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 The Connect tool in the junction diagram will connect two arms and fill in for you the Feeding junction and Feeding 
arm IDs in the Demand screen.  It assumes that the entry on the first junction should be connected to the exit of the 
second junction and vice versa.  However if you manually enter IDs on the Demand screen you can set up more varied 
cases where the entry and exit sides of an arm are connected to different junctions, as in the example below: 
 

 
 

 
 
 

 

Bypasses or filter lanes are not modelled explicitly but advanced users can represent them using one of the 
following methods (other than simply removing the bypass traffic altogether): 

 Roundabouts only:  Set up two (or more) lanes at the entry, with the nearside lane allowing only left-
turners.  Set Arm>Capacity>Lane Simulation>Lane capacity source to ‘Directly entered’.  Enter 9999 for 
the intercept for the nearside lane.  For the other lanes, enter the slopes and intercepts that were 
originally shown for those lanes.   Any traffic in the nearside lane will then, in effect, not give way to the 
circulating traffic and so will act as if there is a filter lane on the arm.   
 

 More generally:  connect the junction to an upstream dummy T-junction (possibly one-way) which can 
filter off left-turning traffic.   If the bypass traffic re-joins traffic exiting from the main junction at a point 
further downstream, you can use another T-junction to connect the streams, with suitable geometric 
parameters.   
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 Secondary lane movements  14.13.1

NOTE: Secondary lane movements only apply to certain junction types. 

The allowed movements that you set up on each lane may be based on lane markings, or directional signs, or 
simply based on the expected behaviour of traffic at the junction.   In fact the expected behaviour takes 
precedence over any physical markings/signs; i.e. you should set up lanes in the way you think they are actually 
used by traffic. 

It may be some traffic making a particular movement has a preferred choice of lane but also considers alternative 
lanes.  If this is true of all traffic, then simply mark all relevant lanes as allowing the movement.  However, if only a 
certain proportion of traffic considers these alternative lanes, then you can set up secondary movements. 

To set up secondary movements, use the Lane Movements>Secondary Movements tab in the Lane Simulation 
screen.  Any secondary movements are shown in the diagram in a different colour to the normal movements.  In 
the example below, the normal lane for straight-ahead traffic is the offside lane, but the nearside lane can also be 
used, as shown by the pink arrow. 

 

In the Secondary Movements grid, you should also enter an estimate of the percentage of traffic that considers 
using these secondary lanes.  In the example, if this value is set to 10%, then 10% of traffic wanting to go straight 
ahead will consider using the nearside lane.  (Vehicles will only actually use that lane if its queue is shorter than 
other relevant lanes.)   This percentage applies to the entire arm.   

If you know that all traffic obeys lane markings without exception, then you would be unlikely to set up secondary 
movements.  At some junctions, on the other hand, driver familiarity and/or congestion may mean that some 
proportion of traffic tends to use these ‘alternative’ lane choices.  In this case, you should consider setting up 
secondary movements and making an estimate of their usage. 

 

 Simulation options 14.13.2

Options controlling Lane Simulation can be found in Data Outline>Options> Lane Simulation Options.   
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14.13.2.1 Stop Criteria 

 
The simulation will stop automatically when the Convergence shown in the simulation screen reaches this value.   
You can, of course, stop it manually at any point.   

You can also set a Stop Criteria Time and a Stop Criteria Number of Trials; the simulation will stop when any of the 
criteria is met.  For example you can limit the duration of all runs to 5 seconds by entering the Stop Criteria Time as 
5s.  

 

14.13.2.2 Random Seed 

 
This is used to seed the random number generator used in the simulation.  By default, a new random seed is used 
for each simulation, which means that repeatedly running the same model will give slightly different results.  If you 
want to be able to exactly replicate a set of results on repeated runs, you should set the seed to a fixed number 
before running the simulation. 

 

14.13.2.3 Results Refresh Speed 

 
When the simulation is running, the main GUI windows will be refreshed at regular intervals according to this 
value.  By default this is set to a few seconds.  If you find that the simulation runs very slowly or that the GUI seems 
to lock up, try setting this to a higher value. 

 

14.13.2.4 Individual Vehicle Animation number of trials 

 
When animating Individual vehicles and the animation reaches the end of the modelled period, it will loop round 
 to the start and continue animating.  Usually, the animation only uses a single ‘recording’ of the modelled period 
(e.g. 60 minutes).  Therefore the second play of the animation will be identical to the first.  However, if you enter a 
value for this option which is greater than 1, the animation will consist of that many modelled period trials.  E.g. if 
you enter a value of 5 and run the simulation, then the animation will loop 5 times before repeating itself.  Doing 
so will use increasing amounts of memory, but will effectively add more ‘randomness’ to the animation. 

 

14.13.2.5 Average animation capture interval 

 
When animating average queues, these are ‘stored’ by the simulation by default every 60 seconds.   (The 
animation interpolates between sets of queues to give the impression of a smooth animation.)  Optionally you can 
configure the simulation to store queue more frequently by entering a smaller number.   This can be useful if 
animating signalised lanes where the queues need to be stored multiple times per signal cycle.  However, reducing 
the interval will use more memory and it may be easier to instead simply rely on the Individual vehicles animation, 
 which is always available for each simulated second. 

 

14.13.2.6 Use quick response 

The core ARCADY/PICADY models assume that the capacity of a give-way entry is based on the circulating flow 
(ARCADY) or demand (PICADY) of the controlling/opposing stream(s), which is fixed for each 15-minute time 
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segment.  This also applies to opposed right-turners in signalised cases.  When using Lane Simulation, the 
controlling flows are re-assessed continuously and so can vary within a time segment.  However, there is a limit to 
how often this re-assessment can be reliably performed. 

If the controlling/opposed traffic is stopped by a pedestrian crossing or a red signal, then traffic on the controlled 
stream(s) may see a corresponding period when it is easier to enter the junction.  (E.g. at a T-junction, traffic 
entering on Arm B may benefit if Arm A or Arm C traffic is held up at a crossing.  At a partially signalised 
roundabout, if traffic on another arm is stopped at a signal, then the circulating flow from that arm will quickly 
drop to zero.)   Because this period, and also the time taken for vehicles to “notice” the change, may be shorter 
than the minimum re-assessment period described above, there is special provision to ensure that any controlled 
streams act as if the relevant controlling flow has immediately dropped to zero while the controlling stream is 
stopped. This makes various assumptions and ignores any queues that may be discharging from the controlling 
stream when the crossing/red light first activates.  If you wish to NOT use this provision, turn this option off. 

The individual vehicle animation can be useful for checking whether traffic responds to crossings in the way you 
would expect, although note that the random nature of arrivals and departures can often be a more important 
factor.   

NOTE:  There is a limit to how far “back” the effects of such changes can be traced and the validity of the 
associated assumptions.  If in doubt, it may be worth considering use of TRANSYT. 

 

14.13.2.7 Suppress automatic lane creation 

Depending on the junction type, lanes and lane levels may be created automatically, and some of the manual 
options configuring lanes may be disabled.   This is often so that the automatically created lanes are correctly 
based on the underlying ARCADY or PICADY geometries, and to prevent accidental misuse or inappropriate 
combinations of options. 

If you wish to model a situation which cannot be set up, ticking this option removes some restrictions and you are 
then free to adjust the lanes and their properties in a more freeform way.  If using Lane Simulation in this way you 
should be particularly careful to ensure that the results appear to be sensible and match known site observations 
where appropriate before extending to other situations.  

 

14.13.2.8 Last Run Random Seed / Last Run Number of Trials 

The values of these items used in the most recently run simulation are shown here for reference.   
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NOTE:  To use traffic signals of any type you must register the OSCADY 9 - Signalised Intersection Module. 

There are two ways of using traffic signals: 

1. Set the junction type as “Signalised” (or select appropriate options in the ‘new file’ screen).  The junction 
will then use the OSCADY model (as opposed to the ARCADY or PICADY models) for isolated signalised 
junctions, which can both evaluate and optimise the signal timings. The OSCADY model is described in 
more detail in OSCADY junctions. 
 

2. For any junction type in Lane Simulation mode, individual lanes can be signalised and evaluated (but not 
optimised).  For more details of this mode, see Using simulation with traffic signals.    

The rest of this section describes the general set up of signals data, as required in any file with signals. 

For more information about junction types in Junctions 9, please see Junction types in Junctions 9. 

 

 

 

This button will show the Signals screen for the currently selected junction.  Use the padlock to lock it to 
that junction.  This screen shows the most important traffic signals data.  Much of the data is also 
available via the Data Outline. 

The format of signals data in OSCADY 9 is very similar to that used in TRANSYT 15.   Signals data is defined for each 
junction separately.  The main steps involved (in no particular order) are: 

 Define the number of phases and set which phases control which traffic streams / lanes.   Every 
stream/lane running on a particular phase will see identical traffic signals.  Phases are usually identified by 
letters A, B, C, etc. 
 

 Enter an Intergreen Matrix.  This defines the minimum time between the end of one phase and the start 
of the next phase, and is entered for each pair of conflicting phases (phases which cannot run together).  
These minimum times are usually defined mainly for safety reasons. 
 

 Define a set of Library Stages.  A stage is a group of one or more phases that run together.  Optionally, 
Library Stages can be generated automatically, based on the Intergreen Matrix.   Library Stages serve as a 
‘palette’ that can then be chosen from.  
 

 Define one or more Stage Sequences.  These determine which Library Stages to use, and in what order.  
Optionally, all possible sequences can be automatically generated. 
 

 Check the Resultant Stages which are automatically produced by the program.  These represent the 
‘actual’ stages that will be used by the traffic model, with various properties derived from the Library 
Stages and Intergreen Matrix etc. 
 

 Optionally, enter any required Phase Delays.  These let phases start or end early or late relative to when 
they would normally run.  
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 Enter any required other data, such as Start and End Displacements, and select a Cycle Time. 
 

 If evaluating a set of existing signal timings, adjust the signal timings.  Then run the file in evaluation 
mode, which will calculate traffic model results for those timings. 
 

 If optimising the timings and/or cycle time, choose the relevant optimisation options and then run the file 
in optimisation mode.  This will calculate the best timings and then calculate traffic model results for 
those timings.  (Optimisation is only available if using the OSCADY model and is not available in Lane 
Simulation mode.) 

Most data can be entered using the Data Outline and Data Editor / Data Grids, as with any other data in Junctions 
9.  Additionally there are some specialised screens which make it easier to view and edit signals data. 

The next section is a walkthrough for setting up a simple signalised junction, which will illustrate the steps 
involved.   The details vary depending on whether you are using the OSCADY model or Lane Simulation mode, but, 
the steps involved in setting up phases, stages and sequences are the same. 

 

 

NOTE:  The steps do not necessarily have to be followed in the order given. 

 Creating the file 15.2.1

15.2.1.1 Using the OSCADY model 

To use the OSCADY model, start a new file and choose Junction Type = T-junction;   Control Type = Signals. For 
more details about the OSCADY model, please see OSCADY junctions. 

Alternatively, the OSCADY model will be used if you change the junction type at any time to “Signalised”, assuming 
the file is not in Lane Simulation mode.  (For more information about junction types in Junctions 9, please see 
Junction types in Junctions 9.) 

Showing the Junction Diagram will show three arms, each containing a single Traffic Stream, each containing a 
single lane, each of which allows movements to all other arms.  To begin with, every Traffic Stream is controlled by 
the same phase (Phase A).  The black bars at the ends of the lanes represent Traffic Streams, which are only used 
for the OSCADY model and hence distinguish the OSCADY model from a signalised junction in Lane Simulation 
mode. 
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15.2.1.2 Using Lane Simulation Mode 

To create a signalised junction in Lane Simulation mode, start a new file and choose Junction Type = T-junction;   
Control Type = Signals and also tick Use Lane Simulation mode.   

Alternatively, if in Lane Simulation mode, you can signalise individual lanes at any time. For more details, please 
see Using simulation with traffic signals. 

Showing the Junction Diagram will show three arms, each containing a single signalised lane, each of which allows 
movements to all other arms.  To begin with, every lane is controlled by the same phase (Phase A). 

 

 

 Setting the phases 15.2.2

If using the OSCADY model:  clicking on the black bar at the end of each Traffic Stream, or the red phase letter, will 
take you to the properties for the Traffic Stream.  One of the properties is Phase, which can be set directly using 
the Data Editor.  It is often easier to set the phase by right-clicking on the Traffic Stream or Lane in the diagram and 
using the Signal Phase menu.  This menu includes the option to add a new phase, and then use it. 

If using Lane Simulation mode:  as above, with the Phase property found in the Signals section of each Lane. 

The phases themselves are shown in the Data Outline in Junction>Signals>Phases and in the Phases tab of the 
Signals screen. Phases can be added, deleted and renamed here.  If necessary you can enter a Minimum Green for 
each phase. 

In this example, the right-click menu in the diagram is used to set each Traffic Stream to run on a different phase:  
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 Setting the Intergreen Matrix 15.2.3

Click this button on the main vertical toolbar to show the Intergreen Matrix screen for the junction. 

 

The Intergreen Matrix screen shows the matrix for the current junction.  Use the padlock to lock it to a particular 
junction. 

The matrix defines which phases are compatible with each other - i.e. which phase pairs can run together in the 
same stage.  If two or more phases are compatible with each other, then there is no conflict between the phases 
and it is possible for those phases to run together in the same stage.  The matrix is symmetrical, so that if Phase B 
is compatible with Phase C, then Phase C must also be compatible with Phase B.  Hence, when one phase conflict is 
defined, its ‘opposite’ is automatically added with a zero intergreen. 

The values entered in the matrix for conflicting phase pairs should represent the minimum length of time, in 
seconds, between the first phase (the row) ending and the second phase (the column) starting.  These are usually 
based on safety considerations. 

Junctions 9 uses the intergreen matrix to calculate constraints for stages and phases that are used by the signal 
optimisers. It is optional whether to specify a full set of intergreens or only those related to the phase-to-phase 
transitions that are actually in use.  It is however, often useful to define a full matrix as it will mean that 
subsequent changes to stage orders can be handled easily. 

Edit the matrix by double clicking in a cell to toggle a conflict on or off, by typing a number in each cell, or by 
pressing the Delete key to remove a conflict. 

Conflicts between phases are shown with a red background.  The remaining cells of the intergreen matrix will be 
either white or pale yellow.  Pale yellow is used to suggest where conflicts ‘might’ be required, i.e. where conflict 
pairs are currently not running together. 

In this example we will assume that all phases conflict, so each cell in the matrix will be coloured red, and all 
conflicts are entered as 5 seconds: 

 

 

For reference, the resulting interstages (the minimum gap between stages) that result from the intergreens are 
shown in the Interstage Matrix tab. 

It is also possible to specify that certain stage changes should never occur, in the Banned Stage Changes grid.   This 
is useful when auto-generating Stage Sequences, as the generated sequences will only include permitted stage 
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changes.  If a banned stage transition should appear in an active Stage Sequence this will lead to an error in the 
Task List.  

 

 Defining Library Stages 15.2.4

There are several ways to define Library Stages, including: 

 Directly, by browsing to Data Outline>Junction>Signals>Stage Library.   

 By using the Stage Library tab of the Signals screen 

 Using the Stage Sequence Screen, right-clicking and choosing Add New Library Stage 

 Using the Timings Diagram, right-clicking and choosing Add New Stage>New Library Stage 

 Auto-generating stages. 

The most direct way is to click the Signals button on the main vertical toolbar and go to the Stage Library tab.  This 
will show a data grid where you can add more Library Stages by right-clicking on the row header or by pressing the 
Create New Stages button. 

For this example we will define a separate Library Stage for each phase, by typing directly in the Phases In Stage 
field.   E.g. only Phase A runs in Library Stage 1, and so on.  (If more than one phase runs in a stage, enter them as a 
comma-separated list – e.g. “A, B”.) 

 

Usually the minimum duration of each stage is calculated automatically based on the minimum lengths of the 
relevant phases.  You can if you wish override these and enter your own minimum time for each Library Stage in 
the User stage minimum field. 
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 Defining Stage Sequences 15.2.5

There are several ways to define Stage Sequences, including: 

 Directly, by browsing to Data Outline>Junction>Signals>Stage Sequences.   

 By using the Stage Sequences tab of the Signals screen 

 Using the Stage Sequence screen 

 Using the Phase Timings screen and its right-click menus 

 Auto-generating sequences 

A Stage Sequence is simply the list of Library Stage IDs, in the order that they should run.   In this example we will 
simply type 1, 2, 3 as the order in the Stage IDs field of the one and only Stage Sequence in the file. 

Optionally, you can create more than one sequence, so that you can compare the performance of each sequence. 

NOTE:  when directly editing a sequence in this way the Task List may show errors.  These will be dealt with later. 

 

 

 Checking the sequence and initial timings 15.2.6

 
Click this button on the main vertical toolbar to show the Stage Sequence screen for the junction. 

 
This button will show the Phase Timings screen for the junction. 

These screens can be used to edit sequences and timings and are also useful for confirming that the signal data is 
correct. 

In this example, the Stage Sequence screen confirms that the Stage Sequence is 1,2,3, and shows graphically which 
phases, and which Traffic Streams / Lanes are red or green in each stage. 
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The Phase Timings screen shows more detail about the timing of the stages and phases (using the current cycle 
time, which will be default of 60s).   Because the timings of the newly added Library Stage 3 have not yet been set, 
this stage has arbitrary timings which lead to the errors in the Task List. 

 

To resolve these errors, press the Repair Timings button.   This will spread the stages out, subject to certain 
constraints such as their minimum greens, intergreens, etc, to give a sensible starting point for the stage timings: 
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 Checking the Resultant Stages 15.2.7

Junctions 9 automatically creates Resultant Stages, based on the Library Stages, the Stage Sequence, and the 
properties of the stages and phase.   These are used by the traffic model and optimiser and contain properties 
such as the actual start and end time of each stage.  They can be seen in the Phase Timings screen, can be 
browsed to (Data Outline>Junction>Signals>Resultant Stages) and also in the Resultant tab of the Signals screen. 

Each Resultant Stage is numbered, with Resultant Stage 1 always being the first stage in the Stage Sequence.  In 
this example, this happens to be Library Stage 1, but it could be any Library Stage.  For instance if the Stage 
Sequence was 2,3,1, then the IDs would be: 

Resultant Stage ID Library Stage ID 

1 2 

2 3 

3 1 

 

Each Resultant Stage has several properties as follows.  Most are auto-calculated and cannot be edited. 

 Call to stage:  the time when the stage starts, before any preceding interstage.  This is the same as the 
end of the previous stage. 

 Stage start:  the time when the stage starts, after any preceding interstage.   

 Stage end:  the time when the stage ends. 

 User stage minimum:  this is a repeat of the User stage minimum entered for the corresponding Library 
Stage, shown here for reference. 

 Stage minimum:  this is usually auto-calculated from the relevant phase minima but will be replaced by 
the User Stage minimum is that is bigger. 

 

 Setting the cycle time 15.2.8

The cycle time can be set directly by browsing to Data Outline>Junction>Signals>Cycle Time or on the first tab of 
the Signals screen. 

When changing the cycle time you may see a warning and the signal timings may automatically be adjusted.  You 
may also need to press the Repair Timings button in the Phase Timings screen. 

 

 Running the file in evaluation mode 15.2.9

By default, OSCADY will run in evaluation mode, meaning that it will calculate the capacity of each Traffic Stream 
using the current timings. 

Assuming that there is a demand of 100 PCU/hr for each movement (using a ONE HOUR profile), then running the 
file will show Summary Results similar to the following:  
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The results for Arm B are slightly different because this arm does not have a straight-ahead movement. 

If the signal timings are adjusted manually, by dragging a stage start/end in the Phase Timings screen, or by 
directly typing in new timings, then the change to the performance of the junction will be reflected when the file 
next runs:  

 

 

 Optimising the signal timings (OSCADY model) 15.2.10

This applies only if using the OSCADY model.  (Timings cannot be optimised in Lane Simulation mode.) 

To turn on signal optimisation, browse to Data Outline>Junction>Signals>Optimisation, or use the first tab of the 
Signals screen. 

If only Optimise Stage Lengths is ticked, then the existing cycle time is used, and the model, when run, will 
calculate the best signal timings (those that maximise capacity and/or minimise delay) for that cycle time.   The 
new timings will be placed in the Resultant Stages, replacing the previous timings. 

If Optimise Cycle Time is also ticked, then the optimal cycle time will be found and then then stage lengths will be 
optimised for that cycle time. 

In this example, optimising the timings will be similar to simply pressing the Repair Timings button, because the 
stages and streams all have similar properties and so there will not be any advantage to any one stage being longer 
than the others. 
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Assuming you have entered an Intergreen Matrix, you can automatically generate all possible Library Stages: 

 In the Signals screen, go to the Stage Library tab and press Auto Generate Stages 

 Or, in the Phase Timings screen, click Tools>Auto Generate Library Stages 

The generated Library Stages will appear in the Data Outline and will replace any existing stages. 

The Library Stages that are actually used when the traffic model runs will depend on the Stage Sequence in use.   
The Resultant Stages section of the Data Outline always shows the final stages used in the traffic model. 

 

 

Each junction has a current Stage Sequence and may also have a set of alternative sequences.  The currently used 
sequence is indicated in the Data Outline, Timings Diagram and the Stage Sequence Diagram with an asterisk.   

To set which sequence should be used when the file runs (i.e. set the currently used sequence), you can do one of 
the following: 

 Browse to Data Outline>Junction>Signals and set the Sequence to use data field to the ID of the Stage 
Sequence you wish to use.  (E.g. enter “1” to use Stage Sequence 1.) 

 In the Signals screen, go to the Stage Sequences tab and set the Sequence to use field 

 In the Stage Sequence screen, when viewing the sequence of interest (by clicking on it in the Data 
Outline), click Tools>Set as active sequence. 

The contents of a Stages Sequence can be defined manually, by browsing to the Stage Sequence in the Data 
Outline and then editing the Stage IDs field.  This is a comma-separated list of the Library Stage IDs that should run 
in the Stage Sequence. 

You can also use the Stage Sequence Screen to define or alter Stage Sequences. 

You can also automatically generate Stage Sequences: 

 In the Signals screen, go to the Stage Sequences tab and press Auto Generate Sequences 

 Or, in the Phase Timings screen, click Tools>Auto Generate Sequences 

This will generate a set of the top ten shortest sequences.  The generated sequences will appear in the Data 
Outline and will replace any existing sequences. 

 

NOTE:  Only the currently active sequence is used when the file in run.  If you wish to compare the performance of 
several sequences, you can set Sequence to use as the x-axis variable for an X-Y graph in the Analyser Screen, with 
stream queue or delays as the y-axis variable.  You can also use the Analysis Set system to use a different sequence 
in each Analysis Set.  (Note however that the sequence itself will also be per-Analysis Set, so it may be just as easy 
to simply have different stages in Sequence 1 for each Analysis Set.) 
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This button will show the Phase Timings screen for the currently selected junction.  Use the padlock to 
lock it to that junction. 

The Timings Diagram shows the timings for each phase and the stages that each phase runs in.   

By default the diagram shows the currently active Stage Sequence (i.e. the one that will be used when the file 
runs), and in this mode the stage blocks are shown in light blue.    

If you click on a different Stage Sequence in the Data Outline, the stage blocks are shown in yellow, to indicate that 
the sequence shown will NOT be used by the traffic model. 

The example below shows some of the main features of this screen: 

  

 Periods when a phase is green to traffic are shown as green blocks for each phase.   
 

 Stages are shown as blue (or yellow, as described above) blocks.   A stage starts when the last phase in the 
stage starts.  E.g. in the example above, Stage 3 starts when Phase B begins.  Similarly, a stage ends when 
the first phase in the stage ends. 
 

 The IDs shown at the top of each stage refer to the Library Stage IDs.  Double clicking on a stage block will 
take you to the relevant Library Stage in the Data Outline.  Shown in a smaller font in brackets are the 
Resultant Stage IDs.  In the example above the Stage Sequence is “1, 3, 2”.   The Library Stage defines 
which phases run in the stage, and various other properties such as the stage minimum; the Resultant 
Stage contains actual timings such as the start and end times. 
 

 The green diagonal lines show intergreens from the Intergreen Matrix.  The Appearance menu contains 
some options to control which intergreens to show. 
 

 The numbers along the top show the start time, duration, and end time for each stage. 
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 Use the slider at the bottom-right to rotate the whole diagram.  (This is for display purposes only and does 
not affect the timings.) 
 

 If the signal timings appear to be “broken” for any reason, press the Repair Timings button. This will re-
distribute timings evenly between the stages in order to try to satisfy any phase delays, intergreens and 
stage and phase minimums.   

 

 Using the Timings Diagram to edit stages 15.5.1

In general, if you manipulate the signal timings by dragging items, other items will be pushed out of the way so 
that constraints such as intergreens are not broken.  If this is not possible, or if the timings are for whatever reason 
invalid or confusing, you can often recover from this by pressing the Repair Timings button. 

You can use the following methods to alter the timings and sequence: 

 Drag the start or end of a stage to shorten/lengthen the stage.  This affects the current Stage Sequence 
only.  The new timings will be placed in the Stage Start/End fields of the relevant Resultant Stage. 
 

 Drag in an interstage area to rotate all stages (in general this will have no effect on the traffic model) 

 Drag the start/end of a phase’s green period to extend or shorten it.  This will create and delete Phase 
Delays, as appropriate.  Phase delays affect ALL Stage Sequences.  NOTE: to remove a phase gaining delay 
you will need to right-click and select the option “Remove Delay”. 

 Right-click on a stage to show a context menu to add a new stage, remove the stage, change the phases 
running during the stage, or to ‘trim interstage’.  (Trimming an interstage removes any phase delays so 
that all phases run as determined solely by the stage timings and intergreens).   If you add or remove a 
stage, this affects the current Stage Sequence only.   If you change which phases run in a stage, then you 
are changing the definition of the Library Stage, and so this will affect ALL Stage Sequences. 

 Right-click on a stage while horizontally level with another phase to quickly select Enable Phase X in 
Library Stage Y. 

 Use the options in the Tools menu to auto generate Library Stages and Stage Sequences; reset 
stages/green periods, or create a specific number of stages.   

When you make changes to timings using the Timings Diagram, these changes will automatically be reflected in the 
following fields, which can be viewed in the Data Editor / Data Grid.  Likewise, if you manually type new values in 
these fields, the changes will be reflected in the Timings Diagram. 

 The Stage Start etc fields of each Resultant Stage 

 The Stage Ends field of the current Stage Sequence 
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Phase delays are shown in Data Outline>Junction>Signals>Delays, in the Delays tab of the Signals screen and are 
also displayed graphically in the Timings Diagram.  They can be added manually via the Data Outline or the Signals 
screen, or by dragging a phase’s green period in the Timings Diagram. 

The diagram below illustrates losing and gaining delays.   

 

Phase Delays are depicted as in the following example: 

   

Phase B has a phase-losing delay which applies when Stage 3 ends and Stage 2 is the next stage.  (These are Library 
Stage IDs, so the delay will apply to any Stage Sequence where Library Stage 2 follows Library Stage 3.)  The delay 
is a relative delay of 5 seconds.  This is shown in the Timings Diagram as a dark green section at the end of Stage 3.  
If the delay is removed, then Phase B will end at 33s instead of 38s. 

Relative phase gaining delay 
= 2 s  

Where Phase B would normally start 

Absolute phase gaining 
delay = 8 s 

2 seconds 

Intergreen A to B = 6 seconds 

Phase B 

End of Stage 1 Start of Stage 2 

Phase A 

Stage 1 to 2 = 10 seconds 

Phase losing 
delay = 3 s 
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Phase C has a phase-gaining delay which applies when Stage 1 ends and Stage 3 is the next stage.  This is an 
absolute delay of 10s, meaning that there is a gap of 10s between Stage 1 ending and Phase C starting.  This is 
shown as a dotted line before the start of Phase C’s green period. 

 

 Relation between phase delays and start/end lags 15.6.1

When looking at the data fields for individual Green Periods, you will see a Start Lag and End Lag.  These are 
automatically calculated from other data such as Phase Delays. 

The Start Lag is the gap between the end of the previous stage and the start of the phase green period.  This will 
generally be non-zero unless there happens to be a zero-length Intergreen. 

The End Lag is the gap between the end of the stage and the end of the phase green period.  This will generally be 
zero unless there is a relevant phase-losing delay. 

 

 

 

This button will show the Stage Sequence screen for the currently selected junction.  Use the padlock to 
lock it to that junction. 

This screen shows which Traffic Streams / Lanes are green in which stage.   The positioning of the items is based on 
their position in the main Junction Diagram. 

 

If viewing the active Stage Sequence (the one that will be used when the traffic model runs; denoted by an asterisk 
[*] after the sequence, and set in the Sequence to Use field in the Signals screen), then the stage IDs are shown 
with a light blue background. 

If viewing a different Stage Sequence, the stage IDs are shown in yellow, to indicate that the sequence shown will 
NOT be used by the traffic model. 

If viewing the Stage Library, the stage IDs are shown in brown. 

The type of item shown is changed either by clicking on a Stage Sequence or a Library Stage in the Data Outline, or, 
by selecting from the Show menu, and can be locked by clicking on the padlock. 
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You can interact with the screen as follows.  Any changes that you make will apply to the currently selected Stage 
Sequence and the Library Stages in the sequence, and will be reflected in other screens such as the Timings 
Diagram. 

 Zoom in by using the mouse-wheel or the Zoom slider.  Pan by moving the mouse with the middle mouse 
button held down. 
 

 Double click on a Traffic Stream / Lane arrow or a phase letter to toggle whether the relevant phase is red 
or green during the stage 
 

 To change which phase a Traffic Stream / Lane runs on, right-click on the arrow and select from the Signal 
Phase drop-down menu. 
 

 Double click in a blank part of a stage to take you to the corresponding stage in the Data Outline, where 
you can edit its properties such as its minimum green etc. 
 

 To change the stages in the sequence, right-click in a stage and use the drop-down menu to remove the 
stage, add an existing Library Stage at that point in the sequence, or create a new Library Stage. 
 

 To change the order of stages, drag and drop any stage in the sequence to a new location.  An orange box 
will indicate the location where the stage will be inserted. 
 

 To set the sequence being viewed as the active sequence for the junction (i.e. the one that will be used 
when the traffic model runs), click Tools>Set as active sequence. 
 

 The Options menu contains various options to control the appearance of the diagram. 
 

TIP:  Using a second Stage Sequence diagram, which has been locked to the Stage Library, you can drag stages 
from the library and drop them into the Stage Sequence shown in your other diagram.  

NOTE:  If you know the IDs of the stages that you wish to use, you can simply enter them directly in the Stage IDs 
field of the current Stage Sequence.  The Stage Sequence diagram serves as a visual reminder of which traffic 
movements will run in each stage. 
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The amount of traffic that can pass through a signal controlled junction depends on the effective green time 
available to traffic and on the maximum flow of vehicles past the stop line during the green period (saturation 
flow). 

The terms 'saturation flow' and 'effective green' should be familiar to most traffic engineers.  In reality, for any 
stop line, the saturation flow will vary over the green time as well as from cycle to cycle.  For modelling purposes it 
is necessary to simplify this.  As with most signalised junction models, the saturation flow averaged over many 
cycles is used in OSCADY.  A further simplification is that the saturation flow is modelled as a constant value which 
applies over the entire effective green.  In reality the saturation flow will grow from zero to a maximum value over 
a finite time (due to the acceleration of vehicles from standstill) and decay over the amber period (because the 
point in the amber at which drivers stop varies from cycle to cycle).  The diagram below shows the relationship 
between a typical real case and the simplified values used in OSCADY and also shows the relationship between the 
actual green and effective green. 

From this 'real' curve three values required by OSCADY are derived: the modelled saturation flow; the start-
displacement; and the end-displacement. The displacements give the start and end of the effective green in 
relation to the actual green.  Start and end displacements, which are assumed to apply to all Traffic Streams, are 
entered in Data Outline>Junction>Signals or on the first tab of the Signals screen.  

 

 

Pedestrian phases and stages are not represented explicitly.  You can however represent portions of the cycle that 
are for pedestrians (i.e. not available to traffic) by adding phases and stages that do not control any traffic (or, by 
setting up dummy streams/lanes with zero flow.)  Assuming that the Minimum Green property is set, the 
appropriate stage will then appear in the Stage Sequence and can, optionally, be labelled as being for pedestrians 
only by setting its ID or Name property. 
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It is possible to copy all signals data from one junction to another, and between Junctions 9 and TRANSYT 15*.  To 
do this, select anything within the junction of interest (or controller stream in TRANSYT) and then on the main 
program toolbar in either product click Edit>Copy Signals or Paste Signals.   This covers most items in the Signals 
section of the Data Outline.  If pasting signals, any existing phases, stages etc will be overwritten with the new 
data.  

If transferring signals data between Junctions 9 and TRANSYT 15, some data may not be relevant to the destination 
product and will be ignored, or, replaced with defaults. 

Also see Exporting to TRANSYT 15. 

* TRANSYT 15.5.2 or above. 

 

 

Signals data can be transferred between Junctions 9 and TRANSYT 15 as described in Transferring signals data. 

It is also possible to export an entire Junctions 9 file to a TRANSYT 15 (.t15) file.   In this way you can start a file in 
Junctions 9 and then transfer it to TRANSYT 15 if you need to use the more advanced facilities available in 
TRANSYT 15.  (Please see http://www.trlsoftware.co.uk/TRANSYT for more information about TRANSYT 15.) 

To export a file, click File>Export>to TRANSYT 15. 

The resulting TRANSYT 15 file will not necessarily contain everything in the Junctions 9 file (and some items cannot 
be exported in any case), but is designed to give you a good starting point which you can then build on in TRANSYT 
15.   Exported items include: 

 Arms, Traffic Streams and lanes from OSCADY junctions are converted to equivalent TRANSYT items.  The 
main properties of these items are filled in, but you should check them carefully in TRANSYT and fill in any 
blanks or incorrect values. 
 

 Lane simulation lanes are each converted to a TRANSYT traffic stream containing a single lane. 
 

 Signals data is exported in its entirety.   
 

 Traffic demand is exported by converting each junction’s OD matrix to an equivalent OD matrix in 
TRANSYT, with locations corresponding to the junction arms. 

For simple signalised files you should find that running the file in TRANSYT gives approximately the same results as 
the Junctions 9 file.  If however the file contains items such as opposed right turns, or give-way arms in partially 
signalised roundabouts, these items may need to be checked and re-entered using the TRANSYT system.  If in 
doubt please contact software@trl.co.uk for advice.  

 

http://www.trlsoftware.co.uk/TRANSYT
mailto:software@trl.co.uk
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NOTE:  To use traffic signals of any type you must register the OSCADY 9 - Signalised Intersection Module. 

Please see Working with Traffic Signals for a general description of traffic signals in OSCADY 9, plus a walkthrough 
of setting up an OSCADY junction.   The following sections describe the OSCADY model in more detail. 

The OSCADY model is used to evaluate and obtain optimised signal timings for simple, signalised junctions.  It is 
specifically designed to model isolated (uncoordinated) signalised junctions.  To assess and optimise networks of 
signal controlled junctions, including signalised roundabouts, we recommend use of TRANSYT. 

Signalised junctions can also be evaluated (but not optimised) in Lane Simulation mode (see Using simulation with 
traffic signals).  This includes the ability to include signalised lanes in other junction types, for example signalised 
lanes in an ARCADY roundabout.  For more complicated cases, TRANSYT may be more appropriate, which can 
evaluate and optimise signals in all cases. 

For more information about junction types in Junctions 9, please see Junction types in Junctions 9. 

 

The amount of traffic that can pass through a signal controlled junction depends on the effective green time 
available to traffic and on the maximum flow of vehicles past the stopline during the green period (the saturation 
flow). 

Whilst the cycle time and the green time for each traffic stream can be varied, the interstage (or phase-to-phase 
intergreen) periods are fixed.  Much of the time a junction spends in interstages is lost to traffic.  As the cycle time 
increases, the proportion of the cycle lost to traffic reduces, implying that junction capacity increases with cycle 
time.  This is true in many situations and it can sometimes be necessary to run long cycle times for a junction to 
operate within capacity.  However, for junctions operating within capacity, queueing and delay will usually 
increase with increasing cycle time.  Hence the two objectives of minimising queueing (hence delay) and 
maximising capacity may conflict.  In some situations, an appropriate compromise must be reached which would 
be difficult to achieve manually.  This is, of course, one of the main reasons why OSCADY exists. 

 

 

In OSCADY, each junction approach (arm) is divided into one or more Traffic Streams, each of which contains one 
or more Lanes. 

Each lane has a set of allowed movements defined (e.g. straight-ahead, left-turn etc) and geometric properties 
such as lane width. 

All lanes in a Traffic Stream are controlled by the same signal indications, and it is assumed that the traffic 
behaviour and resulting queues and delays will be roughly equal in all lanes within a Traffic Stream.  Within a 
traffic stream, there must be at least one common movement between lanes.  Reasons to split an arm into more 
than one Traffic Stream therefore include: 

 When different lanes are shown different signal indications 

 When the traffic behaviour and/or demand is significantly different between lanes 

 When the lanes do not share a common movement 
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Traffic Streams and Lanes are shown inside Arms in the Data Outline and are shown graphically in the Junction 
Diagram.   

An example of an OSCADY junction is shown below.  Traffic Streams are represented by the solid black lines which 
span across the ends of the lanes in the Traffic Stream.  Controlling signal phases are shown in the red circles.  Lane 
movements can be set using the Assign Lanes mode in the diagram.  Access the properties of a lane by double 
clicking in the lane section; for a Traffic Stream, double click on the black bar or on the phase circle.  Right-click on 
a lane or Traffic Stream to access menus for setting signal phases and for adding/deleting items. 

 

When the traffic model is run, some checks are performed to make sure that the grouping of lanes into Traffic 
Streams is appropriate.  The example junction below will show two errors when the model is run: 

 

 

 The two lanes in the Traffic Stream on Arm A do not share any common movements.   You should split the 
Traffic Stream into two, each containing a single lane, even though both lanes are controlled by the same 
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phase.  (You can do this by right-clicking on the stream, choosing Add another Traffic Stream, then 
deleting one lane from each of the two streams.)  
 

 The same applies to Arm B. 

 
The example below will also show an error, because the lanes allow the same movement and are therefore 
expected to be grouped together into a single Traffic Stream.  (You can do this by right-clicking on one of the lanes, 
choosing Add another lane, and then deleting the other Traffic Stream.) 

 

A further type of warning may be shown in the Task List after running the file if the traffic model finds that the 
turning proportions mean that lane usage within a Traffic Stream is likely to be biased towards one movement.  In 
this case, it may be advisable to use a different arrangement of streams. 

TIP:  to rearrange the order of lanes or Traffic Streams, edit their properties and change their ID.   The diagram 
sorts the IDs alphabetically and then places the items from nearside to offside.   The position in the diagram does 
not affect the traffic model. 

 

 

 

The geometric data for each lane is used by the model to automatically calculate saturation flows (the flow across 
a stopline while there is still a queue remaining).  These are combined across lanes depending on the allowed 
movements from each lane to produce saturation flows for the movements in the relevant traffic stream.  These 
are modified further if there are opposed right turners.   (The final calculated saturation flow is shown in the time 
segment results for each stream.) 

The geometric data items are properties of each lane which you can access by double clicking on the lane or 
browsing the Data Outline. 

Gradients should be an average measurement taken from 60 metres upstream of the stopline and expressed as a 
percentage.  Looking towards the junction, uphill gradients are positive and downhill gradients are negative.   

Lane widths should be measured at 5 metre intervals over a distance of 20 metres upstream from the stopline and 
the average value calculated.  For flared approaches the lane width is the width of the lane excluding the width of 
any modelled bay. 

The Turning Radius for a lane is measured as the minimum radius of curvature of the path of a typical vehicle 
making a turning movement from the lane.  If more than one movement is allowed, use the one with the tightest 
curve (i.e. the lowest turning radius). 

Tick Nearside Lane if the lane is the nearside lane on an approach, or is the only lane on an approach. 
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 Movements 16.3.1

The allowed movements from each lane are set up by using the Assign Lanes tool in the Junction Diagram, in the 
same way as that described in Setting lane movements.  They can also be entered directly into the Destination 
 arms field of each lane.  (Each Traffic Stream also has a Destination arms field, which is read-only and shows the 
destinations from all lanes in the stream.) 

Each Traffic Stream also has a Straight Move property, which defines the straight-ahead movement.  This is 
needed for saturation flow calculations.  Usually this will refer to the ‘opposite’ arm, but because the number and 
position of arms in an OSCADY junction is unconstrained, it is necessary to enter the ID for this arm rather than 
OSCADY automatically determining it.   If, however, the file was started from the new file setup screen, then the 
arms will be automatically positioned and the Straight Move property filled in for you.   For a standard T-junction, 
the Straight Move values will be as in the example below.    

         

Notes: 

 Straight Move is blank for Arm B.   
 

 If the only movement on a lane is that defined by Straight Move, then the Turning Radius on the lane is 
irrelevant and will not be shown. 
 

 The arrows in the Junction Diagram always point towards the destination arms but do not themselves 
imply what counts as a ‘straight-ahead’ move.   For example, if traffic flowing from A to C actually has to 
follow a path involving an initial turn (for instance if Arms A and C are noticeably staggered) then the 
arrow will still point straight ahead, but the move would not actually be a straight-ahead move.  In this 
case you would not enter a value for Straight Move and you would instead enter a value for the lane’s 
Turning Radius, representing the initial path of vehicles.  (If the stagger is only slight, the distinction is not 
important.) 
 
 
 
 



 OSCADY junctions    Page 265     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 

All traffic demand is entered via the usual Traffic screens (see Working with Traffic Flows).   For confirmation 
purposes, each lane and Traffic Stream includes a Demand section in the Data Outline, which shows the calculated 
demand.  It is not possible to overwrite these.   

Because demand is entered per-arm, it is not possible to manually enter demand for individual Traffic Streams.  If 
you wish to override the automatically calculated demand for an individual Traffic Stream, you can add a new arm 
to the junction and move the stream into that arm, and then enter the demand for that arm.  (This is possible 
because the number and position of arms for OSCADY junctions does not in itself affect the traffic model.) 

 

 

Most signals data is set up via the main signals screens, which are described in Working with Traffic Signals.  The 
only data specific to OSCADY junctions is as follows: 

 For each Traffic Stream, specify the signal phase that controls the phase.  This can be done most easily by 
right-clicking on the stream or phase circle (or any lane in the stream) in the Junction Diagram and using 
the Signal Phase menu.  Alternatively, edit the Traffic Stream’s properties and set the Phase field. 
 

 If the signals sequence involves phase delays, these will be converted automatically to a type of extra 
effective green for the relevant streams.  These are shown in the Signals EEG property of each Traffic 
Stream. 
 

 Notional Extra Effective Green Time (NEEG) 16.5.1

Each Traffic Stream has a Notional EEG (or NEEG) field.  This can be a positive or negative value, and is used to 
adjust the effective green time of the Traffic Stream to account for differences in traffic behaviour or layout, or any 
other effect, without changing the actual signal timings.  A positive NEEG will lead to a higher capacity for the 
Traffic Stream. 

The entered NEEG is combined with any automatically calculated NEEG (due to, for example, flared approaches) 
and the total is shown in the Traffic Stream results. 
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By default, when you run the traffic model for an OSCADY junction, the existing signal timings are used to evaluate 
the performance of the junction (i.e. produce queue and delay results etc). 

If you wish to optimise the timings, based on the current Stage Sequence, turn on the options in the Optimisation 
section of the Signals screen before running the file: 

 

There are two options: 

 Optimise stage lengths:  the existing Cycle Time will be used, but the stage lengths will be optimised. 
 

 Optimise cycle time:  the cycle time will be optimised as well as the stage lengths.  The new cycle time 
will be placed in the Cycle Time field once the file has run.   Use the Maximum cycle time field to set the 
upper limit on the optimised cycle time.   

The optimisation of signal timings (cycle time and stage lengths) in OSCADY involves two steps.  Firstly, a set of 
timings is found which maximises capacity.  If, with these timings, the junction is within capacity, then the timings 
are replaced by a new set which minimise delay at the junction.  If the junction involves opposed right turns, the 
capacity of such streams depends on the degree of saturation of the opposing stream(s), which depends on the 
signal timings.   Hence an iterative approach is used. 

The type of optimisation (capacity-maximising or delay-minimising) used in the last run is shown in Data 
Outline>Junction>Signals>Optimisation>Optimiser message.   

The optimised signal timings are then used to determine the queue, delay and capacity results. 

NOTE:  The OSCADY signal optimiser has various constraints, such as the requirement that if a stream is green in 
more than one stage, those stages must be consecutive.  If these constraints are too restrictive, consider use of 
TRANSYT. 

NOTE:  If there are several Stage Sequences, only the currently active one (Data 
Outline>Junction>Signals>Sequence to use) is optimised.   See Using multiple Stage Sequences. 
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It is also possible to use the Analyser Screen to manually examine the junction performance for different cycle 
times.  The example below, where the stage lengths are optimised for each cycle time, is fairly typical.  At short 
cycle times, much of the cycle is wasted in Intergreen periods and there may not be enough green time for the 
queue on each stream to clear.  At high cycle times, traffic will be needlessly delayed waiting for other streams.  
There is an optimum value for the cycle time shown by the lowest part of the curve; this is found automatically by 
the OSCADY optimiser when using the Optimise Cycle Time option. 

 

 Optimiser demand source 16.6.1

The signal optimiser works with a single set of traffic demand.  The resulting optimised timings are then applied to 
ALL time segments.   There are several options for how this traffic demand should be derived, set in 
Signals>Junctions>Optimisation>Optimiser demand source: 

 Average:  this is the default value.  In this mode, the demand for each stream is averaged over the time 
segments in the modelled period.  The signal timings are therefore optimised for the average demand.  
This usually provides a good compromise between timings that might individually be more suited for low-
demand time segments at the start of the modelled period or high-demand time segments in the middle 
of the peak period. 
 

 Specific time segment:  in this mode, select which time segment to use by typing in the Time segment 
providing demand field.  (E.g. enter “3” to use demand from the 3

rd
 time segment, which, if using an ONE 

HOUR profile, will be one of the high-demand time segments.)  The signal timings will be optimised for 
the demand for this time segment only.  Although this should give the best junction performance for this 
time segment, it may not work so well for the other time segments.   
 
To individually optimise each time segment one at a time, you can select Specific time segment mode and 
then set Time segment providing demand as the x-axis in an X-Y graph in the Analyser Screen or set it to 
different values in different Analysis Sets.   
 

 All time segments: in this mode, all the time segments in the file are represented in the optimiser as if 
they are separate streams with different flows, and the optimiser will attempt to find the best timings for 
the entire set of ‘virtual’ streams. In some cases this can give better results than the default Average 
mode, but, it can also be unduly influenced by individual time segments with high demand.   
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When the OSCADY model runs, a set of results is produced for each time segment for each Traffic Stream.  (To go 
straight to these results, use the drop-down menu on the main toolbar Results button and choose Time Segment 
Results (OSCADY streams). 

Most of these results have the same meaning as for ARCADY and PICADY junctions, as described in Time Segment 
 Results.  Additional outputs are described below. 

 

Calculated saturation flow:  this is the saturation flow for the stream as calculated by the model, taking into 
account the lane geometries, allowed movements, and other effects such as opposed right turners.   

Effective green time:  the effective green time for the stream is based on the lengths of the stage(s) that the 
stream runs in, adjusted by the appropriate start and end displacement. 

NEEG: this is the sum of any manually entered NEEG (Notional Extra Effective Green) plus that calculated 
automatically due to flared approaches. 

DOS:  Degree of Saturation is equivalent to RFC (Ratio of Flow to Capacity) shown for ARCADY/PICADY junctions. 

Queues:   The End Queue is the queue at the end of the time segment and is the number of vehicles queueing at 
the last end-of-red in the time segment (i.e. the start of the last effective green in the time segment).    Note that 
the maximum back-of-queue position (i.e. distance back from the stopline) will be larger than the queue shown, 
because the back of the queue will continue to extend during green, until the entire queue clears.  The Start Queue 
is the End Queue from the previous time segment and shows whether the queue increased or decreased during 
the time segment. 
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If a lane is associated with a short flare or bay, edit the lane’s properties and tick Has bay.  You can then enter the 
following details: 

 Bay position (left/right):  this is used only for display purposes. 

 Bay storage:  enter the approximate number of PCU that can gain access to the bay and queue when the 
signal is red. 

 Bay saturation flow ratio:  enter the ratio of the saturation flow of the bay relative to the lane that it is 
associated with.  By default this is 1.0. 

The bay is fed traffic by the main lane (the one where you tick Has Bay). 

From this data, OSCADY calculates a ‘notional extra effective green time’ (NEEG) that represents the extra capacity 
associated with the bay, and this extra capacity is added to the relevant Traffic Stream.   The calculated NEEG, 
which combines with any other sources of NEEG, is shown in the Traffic Stream time segment results. 

NOTE:  If using Lane Simulation Mode, the behaviour of vehicles at short lanes for a given set of signal timings can 
be investigated in more detail. 

 

 

If right-turning traffic on a Traffic Stream is opposed by traffic from an opposite arm, tick the Right turners 
opposed option on the Traffic Stream’s properties.   The Traffic Stream will then have an Opposition section in the 
Data Outline (also via the shortcut in the Data Editor). 

In the example below, right-turners on Arm C are opposed by Arm A, so the Right turners opposed option is ticked 
for the Traffic Stream on Arm C. 
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The opposition data for this Traffic Stream is filled in as follows: 

 Opposed destination:  enter the ID of the arm that opposed traffic is travelling to (Arm B in this case) 
 

 Opposing arm ID:  enter the ID of the opposing arm (Arm A in this case) 
 

 Opposing movements:  this defines the individual opposing movements from the opposing arm.  In this 
example, right-turners on Arm C are opposed by all traffic from Arm A, so the opposing movements are A-
B and A-C.  Enter the destination part of these movements – i.e. “B, C”.  If the right-turners on Arm C gave 
way to only the straight-ahead traffic from Arm A, and not the left-turners, then the only opposing 
movement would be A-C, in which case you would enter “C” as the opposing movement. 
 

If this data is set up correctly, the Junction Diagram will show the opposed movement with a dotted line, and the 
opposing movement(s) with a thick line. 

Additionally, each lane has a Storage for right-turners property.  Enter here the average number of right turning 
vehicles, if any, that can be stored in advance of the stopline without interfering with any other traffic movements 
from the same lane.  Vehicles waiting here are able to clear at the end of the green and so the Traffic Stream will 
benefit from a slight capacity increase. 

 

The table below describes some further considerations for opposed right-turners: 

 Right-turners have exclusive lanes Right-turners share lanes with unopposed traffic 

Early cut-off/late 
release provided  

See Early cut-off / late release  
See Early cut-off / late release.  Additionally, it may 
sometimes be best to model all shared traffic as 
running only during the unopposed stage. 

Early cut-off/late 
release NOT 
provided 

If traffic flows are relatively light, then right-
turners will be able to turn through gaps.  This is 
fully modelled and no user intervention is needed. 
 
However if traffic flows are relatively high, then 
right-turners may only be able to turn during the 
interstage at the end of the opposed stage.  To 
ensure that this period is long enough, consider 
modelling it as a separate stage, using the same 
methods as described in Early cut-off / late release.    

This is fully modelled and no user intervention is 
needed. 
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 Early cut-off / late release 16.9.1

It is recommended that early cut-off / late release sequences are set up as separate stages.  On-street, in one stage 
the opposed and opposing streams will run together, and in a consecutive stage the opposed stream will run alone 
(so will be unopposed). 

The method of modelling in OSCADY 9 depends on whether you are evaluating a set of fixed timings, or optimising 
the timings. 

 

16.9.1.1 Evaluating fixed timings 

In evaluation mode, the streams and stages should be set up as they are on-street.  In the example below, the 
right-turners on Arm C are opposed by Arm A (running on Phase A) in Stage 1, and then run exclusively in Stage 2.  
(Note that Arm C also carries straight-ahead traffic, which in this example runs on a separate Phase C which 
happens to have the same timings as Phase D.) 

   

The OSCADY model has a limitation that each stream can only have a single saturation flow, which in this case will 
be a time-weighted average saturation flow for the two stages.   To avoid this limitation, consider using TRANSYT, 
which explicitly calculates a saturation flow for each timestep. 

 

16.9.1.2 Optimising timings 

Due to the restriction described above where each stream has a single saturation flow, the unopposed stage will 
appear to the optimiser to be less efficient than the opposed stage (because only one stream runs in the 
unopposed stream, compared to two streams in the opposed stage).  This means that the optimiser will tend to 
favour the opposed stage, and will reduce the length of the unopposed stage down to its minimum. 

The signal optimiser timings are likely to be such that opposed turners have little opportunity to turn through gaps 
in opposing traffic, and so can be neglected in the traffic model.  If any turning does occur on-street, that can be 
considered to be a bonus.  The right-turners should therefore be modelled as running ONLY in the unopposed 
stage.  The saturation flow used by the optimiser will then be for the unopposed period, and so an optimised 
length for the unopposed stage will be produced. 

Using the same example as above, the file is modified so that the right-turning traffic stream on Arm C is set to be 
unopposed, and running only in Stage 2: 
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When the optimiser runs, it will generate a duration for Stage 2 based on the assumption that the right-turning 
demand will be met entirely by Stage 2. 

In reality of course some right-turners will be able to turn during the opposed stage, and so the timings will tend to 
be pessimistic.  Some allowance can be made for this by entering a non-zero Notional Extra Effective Green Time 
(NEEG) for the right-turning stream. 

Once the optimised timings have been generated, you can restore the file to the version that more closely 
represents the on-street situation, and then re-run the file in evaluation mode (see previous section).  Note that 
this may give slightly different results due to the way the saturation flows are calculated. 

TIP:  As an alternative technique, you can use the Analyser screen with the x-axis set to the Stage Start for the 
relevant Resultant Stage to optimise the length of the unopposed stage in evaluation mode without using the 
signal optimiser.   

NOTE:  To avoid the limitations described in this section, consider using TRANSYT, which explicitly calculates a 
saturation flow for each timestep. 
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Junctions 9 includes models for roundabouts, TWSC and AWSC intersections as defined in the TRB Highway 
Capacity Manual (HCM).  The models are based on those in HCM 2010, with roundabout coefficients based on 
those in HCM 2016. 

These are provided as independent models and are entirely separate from the main empirical ARCADY/PICADY 
models. They are provided for users in North America and other regions who wish to run intersection analyses 
using the HCM methods. 

To use HCM models, set the intersection type to be one of the available HCM intersection types: 

 

 
HCM mode will work regardless of driving side, but the rest of this section assumes that drive-on-the-right is used. 
 
TIP:  Users in North America may wish to turn on File>Preferences>US Terminology. 

Also please note that: 
 

 ‘ARCADY’ / ‘PICADY’ = the ARCADY/PICADY empirical (Kimber, geometry-dependent) models 

 ‘HCM’ = the HCM 2010 model, with roundabout coefficients from HCM 2016 (by default) 

 ARCADY intersection / HCM intersection = the currently active type of model  
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There are some important differences between the HCM model and the ARCADY model for roundabouts, 
including, but not limited to, the following: 

ARCADY model HCM model 

Capacity depends on arm and roundabout geometry No dependence on geometry 

Iterative method used to allow for interdependence of 
circulating and entry flows 

No iterative method; flows are trivial sums only 

Entry flow cannot be higher than capacity No allowance for over-capacity entries 

Queues and delays are accurately calculated for both small 
and large RFC (V/C ratio) 

Queues and delays are only defined for small RFC (V/C ratio) 

Queues are mean queues, with percentile queues optionally 
calculated 

Only the 95
th

 percentile queue is defined 

Lanes are either dealt with intrinsically, or else explicitly 
using Junctions 9’s Lane Simulation mode.   

Single or two-lane entries are defined 

Time profiles with any number of time segments Single 15-minute time segment only 

 

 
If you compare results from an ARCADY roundabout and a HCM roundabout, you should not expect to see the 
same results.  We recommend that you familiarise yourself with the relative merits of the various models. 
 
In particular, if an entry is over-saturated, the HCM model does not cap the entry flow.  Therefore the circulating 
flow past other arms may be inaccurate, which will affect the capacity of those arms, their estimates queues, and 
so on.  To remind the user of this limitation, a warning is shown if the RFC (V/C ratio) is 0.85 or above.   
 
If the currently active junction is a HCM Roundabout, then the buttons on the main vertical toolbar will change.  
Some options that are inapplicable to HCM will disappear, and instead a HCM button will appear.  Pressing this will 
show a special HCM screen where data specific to HCM roundabouts can be entered. 
 
Other data, such as turning counts, can be entered using the usual ARCADY screens. 
 
The rest of this section is a step-by-step guide to setting up a HCM roundabout, using data from the ‘Example 
Problem 1: Single-lane roundabout with bypass’ on pages 21-28 to 21-32 of HCM 2010 Chapter 21. 

 

 Setting up the file 17.1.1

Start a new file.  In the Data Outline, browse to the intersection of interest and set its Intersection Type to ‘HCM 
Roundabout’. 

 As soon as you do this, a new HCM button will be shown in the main vertical toolbar.  This will give you access to a 
special screen where you can access most of the items relevant to HCM.  Alternatively, you can use the Data 
Outline, Data Editor and Data Grids as usual, since all HCM data is available in the Data Outline. 

 

 Setting up legs 17.1.2

The roundabout has four legs, so use the Data Outline or the Junction Diagram to add the necessary number of 
legs.   
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The legs do not have names but in this example have been entered as ‘Eastbound’, etc, with the short ID of each 
leg set to EB, NB, WB, SB.  You can choose to show either the short IDs or the full names in the Data Outline and 
diagram by setting Data Outline>Options>Sorting and Display>Show names. 

If you show the Junction Diagram at this point, it will look similar to the below. 

 

 

 Setting up lanes and movements 17.1.3

Press the HCM button.   This will show the HCM 2010 screen.  Click on any leg in the list on this screen to show the 
lanes for that leg. 

 

The grid for each lane shows the lane type, the number of conflicting lanes, and the destination legs that vehicles 
can travel to from that lane.  In many cases, the destination lanes are set automatically.  For example, if the lane 
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type is ‘Single lane’, then Junctions 9 assumes that all movements are allowed.  However if you set the lane type as 
‘Nearside’ or ‘Offside’, then the Destination Legs field becomes editable and you can set the allowed movements.  
These are reflected in the lane arrows shown in the diagram. 
 
The destination legs are used to calculate the demand to each leg and the circulating flow.  (NOTE:  in HCM mode, 
the circulating flow is effectively circulating ‘demand’ rather than actual flow.) 
 
To add or delete lanes for each arm, you can either right-click in the header of a row (as with other data grids in 
Junctions 9), or you can press Create Lanes, which will offer to delete existing lanes first. 
 
To quickly see ALL lanes at the roundabout in a single data grid, press Show lanes for all legs. 
 
In the example, all legs are single-lane only, but there are right-turn bypass lanes on two of the legs.  Setting up a 
bypass requires two steps, as follows. 
 
 

 Setting up bypass lanes 17.1.4

The Westbound arm has a right-turn bypass that yields to exiting vehicles. 
The Southbound arm has a right-turn bypass that forms its own lane (i.e. does not yield). 
 
To set these up, go the HCM screen and select the Westbound arm.  Add another lane, as described above.  The 
grid will then show two lanes.  The lanes do not have separate IDs or names, and are not shown in any particular 
order.  The order only really matters if you are using the diagram to depict the layout, in which case you can click 
on each lane in the diagram to confirm which row in the grid it corresponds to.  In general, the first lane in the grid 
represents the nearside lane. 
 
Note that the remaining, non-bypass lane, should be left as ‘Single Lane’ type. 
 
For the newly added lane, change the Lane Type to ‘Yielding Bypass’.  The Destination Legs will automatically 
change to show that the only destination for traffic using the bypass is the next leg. 
 
Repeat the above for the Southbound arm, this time using the ‘Non-yielding bypass’ lane type. 
 
If you look at the main program Task List at this point, you will notice some errors.  These are because, as well as 
setting up the bypass lanes, you must also tell ARCADY that a bypass exists on the leg as a whole, and specify how 
much traffic uses the bypass. 
 
To do this, use the Data Outline to browse to the Bypass data section of the Westbound leg. 
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Tick the Leg Has Bypass option.  The Bypass Utilisation field determines how much traffic actually uses the bypass. 
If set to 100%, as in this example, then ALL right-turning traffic use the bypass and skip the roundabout.  If set to 
50%, then half the right-turning traffic will use the bypass but the other 50% will turn right by going through the 
roundabout as usual. 
 
The Yields To field allows you to tell the model that traffic emerging from the bypass lane yields either to traffic 
exiting the roundabout (the default), or, alternatively, to both traffic exiting AND to circulating traffic.  Which 
option to choose here is a matter for individual judgement, but in general, the closer the bypass exit is to the 
roundabout, the more likely that bypass traffic will act as if yielding to both exiting and circulating traffic.  You may 
want to try both options to see how much of a difference this makes, and then take the pessimistic result. 
 
For consistency with the example in HCM 2010 Chapter 21, set the utilisation set to 100% and leave Yields To as 
Exiting Traffic Only. 
 
Repeat the above for the Southbound leg, and the errors in the Task List will disappear. 
 
Bypass lanes are not shown explicitly in the diagram, but instead are indicated by extra arrows showing the 
direction of bypass flow.  Note that the non-bypass lanes still show right-turners as an allowed movement – this is 
required in case the bypass utilisation is less than 100%. 
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 Setting up traffic demand volumes 17.1.5

From the main vertical toolbar, launch the O-D screen, which operates as usual. It may be easier to set the ‘Data 
Matrix Style’ on the Turning Counts screen options to ‘By Exit’ rather than ‘By Destination’.   
 
The demand volume, entered as vehicles per hour, is as follows: 
 

 
 
If the Intersection Diagram is displayed and set to show original turning counts, it can be used to check that the 
correct turning counts have been entered.  Note, however, that the diagram may always show these numbers as 
PCE/hr rather than Vehicles/hr, so be sure to pay attention to the units shown at the bottom of the diagram. 
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 Setting up truck (heavy vehicle) percentages 17.1.6

From the Demand Screen, click the Truck % link, which operates as usual.  The default truck % recommended in 
HCM is 3%.   
 
In the example, the truck percentage for all movements is 2%.   
 
 

 Setting up other demand options 17.1.7

Browse to the current Demand Set definition and tick Single time segment only.  The entire modelled period will 
then be a single time segment of 15 minutes length. 
 
The traffic profile type should be set to PHF (Peak Hour Factor).  The default PHF is 0.92.  In the example, the PHF is 
stated as 0.94, and this can be entered in the PHF tab of the Demand screen or at the bottom of the O-D screen. 
 
The total demand for the Westbound leg is then calculated by Junctions 9 as follows: 
 

 Total demand in veh/hr = 1135  

 Total demand in veh/hr in the modelled peak 15 minute segment = 1135 / PHF = 1135 / 0.94 = 1207 

 As above in PCE/hr = 1207* (1 + HV%) = 1207 * 1.02 = 1231 

 
 

 Setting up pedestrian volume 17.1.8

Pedestrian crossings are not added explicitly, but pedestrian flow can be entered on the Pedestrian Flows tab of 
the Demand screen.   In the example, a pedestrian flow of 50 ped/hr is stated for the southern (Northbound) arm.  
Note that it is possible to set up a PHF for pedestrian flows, but, since this would be unusual, the PHF for 
pedestrians is set to 1.0 by default.  Pedestrians are assumed to affect ALL lanes on the leg. 
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 Setting HCM version 17.1.9

By default, HCM roundabouts in Junctions 9.0.2 onwards use roundabout coefficients from HCM 2016 (HCM 6
th

 
edition).  If you need to use coefficients from HCM 2010, or use your own coefficients, please see HCM 
 Roundabout Calibration. 

 

 Running the model and viewing results 17.1.10

To run the HCM model, press the main Run button in the usual way. 
 
Assuming there are no errors, results can be viewed as follows: 
 

 From the HCM screen, press Show lanes for all legs to show results for all lanes 

 From the HCM screen, press Leg results to show results for all legs  

 All results can be found in the Data Outline 

 The Summary Results screen will show overall summary leg and intersection results, as usual.  Use the 
Columns menu to control which results are shown. 

 Generating a report in the usual way will list all input and results. 
 
Results for legs and intersections are derived from the component lane or leg results by using sums and demand-
weighted averages, as defined in HCM 2010. 
 
The screenshot below shows the results for all lanes, with results shown in PCE/hr. 
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The Demand and Pedestrian Flow are derived directly from the user-entered demands and, if necessary, bypass 
utilisation. 
 
The Conflicting Flow is calculated from these demands and using the movements implied by the Destination Legs. 
 
Capacity is calculated using the appropriate HCM 2010 capacity category for the lane, and the other results (95

th
 

percentile queue, delay, V/C ratio and LOS) are calculated as defined in HCM 2010. 
 
Certain results are highlighted in red: these are items that exceed the thresholds set in Data 
Outline>Options>Analysis Options>  V/C Ratio/Delay/Queue Threshold. 
 
 
 
 
 
The full set of results is shown below, firstly as the quoted figures in HCM 2010 Chapter 21, and secondly as the 
results from Junctions 9.  The minor differences are due to rounding of intermediate results in HCM 2010 Chapter 
21.  In particular, the overall intersection delay is just over 35s in the Junctions 9 results, which gives a LOS of E 
rather than the quoted value of D in Chapter 21.   Please note that you will obtain different results if using HCM 
2016 roundabout coefficients. 
 
 HCM 2010 Chapter 21 Junctions 9 

 Control Delay LOS Control Delay LOS 

LANES     

Northbound entry 39.6 E 40.07 E 

Southbound entry 19.9 C 20.07 C 

Southbound bypass lane 0 (*) A * 0.07 (*) A * 

Eastbound entry 46.7 E 47.02 E 

Westbound entry 56.5 F 57.55 F 

Westbound bypass lane 41.5 E 41.87 E 

     

LEGS     

Northbound 39.6 E 40.07 E 

Southbound 6.6 A 6.74 A 

Eastbound 46.7 E 47.02 E 

Westbound 48.4 E 49.12 E 

     

INTERSECTION 34.8 D 35.24 E 

 
 
* The capacity for a non-yielding bypass is assumed to be arbitrarily high, giving an arbitrarily low delay. 
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The Summary Results screen also shows the Network Residual Capacity.  (If you can’t see this, go to the Summary 
Results screen and check the Columns menu.)  This shows that the demand on the Westbound leg would have to 
be reduced by 4.79% in order to satisfy the currently active threshold option (see Options>Analysis 
Options>Residual Capacity Criteria. 
 

 
 
 
Because the V/C ratio for at least one leg is greater than 0.85, the HCM screen shows a warning, which is also 
repeated in the Task List and in reports.  This is a reminder that the HCM model may not be reliable in these cases. 
 
As an illustration of the reason for this warning, consider how the circulating flow increases as the overall demand 
increases.  The graph on the left shows that the ARCADY model will cap the entry and thus circulating flows, 
whereas the graph on the right shows that, with the HCM model, the circulating flow would eventually become 
infinite.  These effects can also be important if the V/C ratio is close to 1.0 for short periods, and are fully 
accounted for in the ARCADY model by its time-dependent queueing model. 
 
 

          
   
 
 

 Multi-lane roundabouts  17.1.11

 
The ‘Example Problem 2: Multilane roundabout’ on pages 21-33 to 21-38 of HCM 2010 Chapter 21 describes a 
more complex roundabout. 

This can be set up in the same way as described in the previous sections, but with the following extra steps. 

Firstly, ensure that the Number of Conflicting Lanes is correctly entered for each entry lane.  For the Southbound 
entry, for example, both entry lanes conflict with two circulating lanes. 
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Secondly, on the two-lane entries (Southbound, Eastbound and Westbound legs), the two lanes should be set as 
Nearside or Offside types, so that the correct capacity model is used.   For these lane types, the Destination Legs 
field must be entered manually.  For example, traffic using the nearside (right) lane on the Southbound entry can 
travel only to the Eastbound arm, so that arm’s ID (‘EB’) is entered.  On the offside (left) lane, vehicles can travel to 
the southern (NB) and eastern (WB) arms, so ‘NB, WB’ is entered.  The circulating flows will then be calculated 
correctly. 

 

 

Thirdly, the split of traffic that has a choice of lanes must be considered.  This is modelled in detail by Junctions 9’s 
Entry Lane Simulation mode, but, assuming you are using HCM mode, there are two methods: 

 
1. Set up the movements that you believe are used on-street (regardless of lane markings etc).  If there is a 

choice of lane, Junctions 9 will assume that such traffic is evenly distributed across those lanes.  Junctions 
9 will calculate flows using this assumption in conjunction with the input turning counts.  
 

2. Use the methods described in HCM 2010 Chapter 21, pages 21-15 and 21-21.  Junctions 9 will not perform 
these calculations, but does allow you to enter the traffic split that you arrive at. 

 
The multilane roundabout example uses the second method.  This involves two modifications to the data: 
 
Westbound entry:  the offside (left) lane is quoted as operating as a ‘de facto left-turn lane’, and so its Destination 
Legs should be set to ‘NB’ only. 
 
Eastbound entry:  the lane movements are unmodified, which means that both lanes carry straight-ahead traffic.  
HCM 2010 suggests a default split for such cases – regardless of turning proportions - which you can apply if you 
wish.  In the example, the quoted figure is that 0.53 of ALL demand on the entry uses the nearside (right) lane, and 
0.47 of ALL traffic uses the offside (left) lane.  In order to set this up, enter these ratios in the Destination Legs 
fields, in the format ‘=XX’, as shown in the screenshot below.   Lane arrows in the diagram are NOT shown in this 
case. 
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When these modifications are made, the results from Junctions 9 will match those quoted in HCM 2010 Chapter 
21, as shown below.  Please note that you will obtain different results if using HCM 2016 roundabout coefficients. 
 
 HCM 2010 Chapter 21 Junctions 9 

 Control Delay LOS Control Delay LOS 

LANES     

Northbound entry 13.4 B 13.42 B 

Southbound left lane 14.2 B 14.19 B 

Southbound right lane 18.7 C 18.7 C 

Eastbound left lane 27.2 D 27.18 D 

Eastbound right lane 35.4 E 35.45 E 

Westbound left lane 13.9 B 13.87 B 

Westbound right lane 11.7 B 11.71 B 

     

LEGS     

Northbound 13.4 B 13.42 B 

Southbound 16.8 C 16.76 C 

Eastbound 31.5 D 31.56 D 

Westbound 12.9 B 12.88 B 

     

INTERSECTION 19.7 C 19.79 C 
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 HCM Roundabout Calibration 17.1.12

HCM calibration is available from the Calibration link on the HCM screen.   This will show a datagrid of the A and B 
coefficients for each lane type (see HCM 2010 Chapter 21 page 21-23).  These are related to the critical and follow-
up headway of each lane type, as described in HCM. 
 
To set all coefficients to default values from either HCM 2010 or HCM 2016, use the links at the bottom of the 
screen.  The screenshot below shows HCM 2016 defaults. 
 

 
 
The calibration values apply to the entire file. 
 
If you want to investigate the sensitivity of a roundabout, you can use the x-y graph generator, and other 
functions, of the Analyser Screen as usual.  (As well as the A and B parameters, you can alter the overall 
roundabout capacity scaling factor as with any ARCADY run.)  However if you want to change several calibration 
parameters then it is probably easiest to do this by copying the data file into a new file and then making the 
changes.   
 
 

 

Some of the same considerations and data entry methods described in HCM Roundabouts apply. 
 
 
The rest of this section is a step-by-step guide to setting up a TWSC intersection, using data from the ‘Example 
Problem 1: TWSC T-Intersection’ on pages 19-43 to 19-52 of HCM 2010 Chapter 19. 

Begin by browsing to the intersection of interest and set its Intersection Type to ‘HCM TWSC’.   Some TWSC 
properties apply to the whole intersection and will appear as properties of the intersection when the type is set to 
TWSC. 

Showing the Junction Diagram is useful as it will confirm how many lanes are present on each leg.  By default, 
there is a single lane on each leg which allows all movements.   Dotted lined represent non-yielding movements 
from the minor streets, as with PICADY diagrams. 
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To add more lanes, right-click in a lane and use the Add/Delete options.   

If you add lanes, movements are assigned automatically using the most common defaults, but you can change 
them if necessary by double clicking on the lane to show its properties and changing the Destination legs property, 
or as follows:  

In the Junction Diagram, click on the Assign Lanes button. 
 

 
 
Next, click on the lane that you want to alter.    
Then click on a destination arm.  (Click on the grey central part of the arm.  The destination arm can be the same as 
the arm containing the lane, which will affect U-turners.) 
 
The corresponding movement for the lane will be toggled on or off. 
You can repeat the process for other lanes until you cancel Assign Lanes mode. 

Leg IDs are assigned automatically but if you wish you can enter a name for each leg and then display this name in 
the diagram etc; see Sorting and Display Options. 

In this example there is one lane on the eastbound and northbound approaches, and two lanes on the westbound 
approach.   The intersection is a T-intersection, so the southbound approach does not exist at all.  Rather than 
delete Leg B, delete the default lane on Leg B leaving behind a dummy leg with no lanes.  Then use the Assign Lanes 

tool to remove the movements from the other legs that are showing as entering this dummy leg. 
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Enter the HV% of 10% on all approaches using the Vehicle Mix screen as usual. 
There are a number of properties that can be specified for the intersection, each leg and each lane, but in this 
example all are left as their default values. 

In the properties for the current Demand Set, set the profile type to FLAT, use a 15-minute time segment length 
and tick Single time segment only. 

The traffic demand (turning volumes) can be entered using the Origin-Destination (O-D) screen as usual, or directly 
 in the Junction Diagram (see Editing Traffic Flow).   (Check that the units for data entry are set to vehicles/hour.)  
The completed values are as shown in the screenshot above. 

Click the main toolbar Run Model button to run the HCM TWSC model and generate results.  These will be shown 
in the Summary Results screen as usual for legs and the whole intersection, and you can see individual lane results 
by browsing the Data Outline.  
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The results shown in Junctions 9 match those shown in HCM 2010 Chapter 19 other than minor rounding 
differences: 

 HCM 2010 Chapter 19 Junctions 9 

Westbound left delay (s) 8.3  Arm A, Lane 2 = 8.34 

Westbound left Q95 0.4 Arm A, Lane 2 = 0.44 

Northbound approach delay (s) 14.9  Arm D = 14.96 

Northbound approach Q95 1.3 Arm D = 1.4 

Intersection delay (s) 4.1  4.14 

 

A more complex example is given in ‘TWSC Example Problem 3’ in HCM 2010 Chapter 32.  Setting this up in 
Junctions 9 requires the following additional steps: 

 Use a PHF traffic profile type, with PHF factor set to 0.92 

 Intersection>Median Type = ‘Raised Curb’ 

 Intersection>Median Storage = 2 vehicles 

 For the minor legs, browse to HCM Leg Properties and tick Has Flare and set Flare Storage = 1. 

 Set up three lanes on each of the major legs.  

When complete, the intersection will look like this in the diagram (note that not all geometric properties are 
shown): 
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Some of the same considerations and data entry methods described in HCM Roundabouts apply 
 
 
The rest of this section is a step-by-step guide to setting up a AWSC intersection, using data from the ‘Example 
Problem 1: Single-lane,T-Intersection’ on pages 20-22 of HCM Chapter 20. 

Begin by browsing to the intersection of interest and set its Intersection Type to ‘HCM AWSC’.    

Showing the Junction Diagram is useful as it will confirm how many lanes are present on each leg.  By default, 
there is a single lane on each leg which allows all movements.   Dotted lined represent non-yielding movements 
from the minor streets, as with PICADY diagrams. 

 

To add more lanes, right-click in a lane and use the Add/Delete options.   

If you add lanes, movements are assigned automatically using the most common defaults, but you can change 
them if necessary by double clicking on the lane to show its properties and changing the Destination legs property, 
or as follows:  

In the Junction Diagram, click on the Assign Lanes button. 
 

 
 
Next, click on the lane that you want to alter.    
Then click on a destination arm.  (Click on the grey central part of the arm.  The destination arm can be the same as 
the arm containing the lane, which will affect U-turners.) 
 
The corresponding movement for the lane will be toggled on or off. 
You can repeat the process for other lanes until you cancel Assign Lanes mode. 
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Leg IDs are assigned automatically but if you wish you can enter a name for each leg and then display this name in 
the diagram etc; see Sorting and Display Options. 

 

In this example there is one lane on the eastbound, westbound and southbound approaches.  The intersection is a 
T-intersection and the northbound approach does not exist at all.  Rather than delete Leg D, delete the default 
lane on Leg D leaving behind a dummy leg with no lanes.  Then use the Assign Lanes tool to remove the movements 
from the other legs that are showing as entering this dummy leg. 

 

 

Enter the HV% of 2% on all approaches using the Vehicle Mix screen as usual. 
In the properties for the current Demand Set, set the profile type to PHF, use a 15-minute time segment length 
and tick Single time segment only.  In the Demand screen, enter 0.95 as the PHF. 

The traffic demand (turning volumes) can be entered using the Origin-Destination (O-D) screen as usual, or directly 
 in the Junction Diagram (see Editing Traffic Flow).   (Check that the units for data entry are set to vehicles/hour.)  
The completed values are as shown in the screenshot above. 

Click the main toolbar Run Model button to run the HCM AWSC model and generate results.  These will be shown 
in the Summary Results screen as usual for legs and the whole intersection, and you can also see individual lane 
results by browsing the Data Outline.  
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The results shown in Junctions 9 match those shown in HCM 2010 Chapter 20 other than minor rounding 
differences: 

 HCM 2010 Chapter 20 Junctions 9 

Eastbound approach headway 4.97 s (end of Step 11) Arm C = 4.98 

Eastbound approach capacity “approximately 720” veh/hr Arm C = 710 

Eastbound service time 2.97 s Arm C = 2.98 

Eastbound approach delay 13.0 s Arm C = 13.03 

Eastbound Q95 2.9 veh Arm C = 2.92 

Westbound approach delay 13.5 s Arm A = 13.54 

Southbound approach delay 10.6 s Arm B = 10.65 

Intersection delay 12.8 12.86 

 

 

A more complex example is given in ‘AWSC Example 2’ in HCM 2010 Chapter 32, p32-53.  Setting this up in 
Junctions 9 requires the following additional steps: 

 Use a FLAT traffic profile type 

 Set up two lanes on Arms A+C and three lanes on Arms B+D 

 Assign lane movements as shown in the diagram below (should just need to remove the default straight-
ahead movements from Lane 1 of Arms B+D) 

When complete, the intersection will look like this in the diagram (note that not all geometric properties are 
shown): 
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Click this button on the vertical toolbar to show the Analyser Screen.  You must be in Advanced Mode. 

 
The Analyser Screen includes a number of powerful tools for 
producing graphs and charts and for studying the effects of small 
changes in input parameters.  It also includes an optimising tool that 
attempts to maximise or minimise the value of any output 
parameter by varying a selection of data parameters. 

The various modes of the Analyser Screen are selected via the large 
buttons at the top of the window, with sub-modes appearing as 
appropriate.  The lists of input and output variables are used for all 
modes, although certain items and columns will become disabled or 
may disappear depending on the mode selected. 

Before using any Analyser mode, we recommend performing a 
normal run first to make sure there are no errors in the file. 

TIP:  to use the graphs within your own reports: simply right-click on 
a graph and select one of the Copy options, then paste it into your 
application. 

 

 

The Analyser Screen is split between ‘inputs’ in the upper half of the screen and ‘outputs’ in the lower half.   

Inputs cover any data field item that can be entered in the Data Editor.  To add an input to the list of input variables, 
click on it in the Data Editor (or a Data Grid) and then click on the Add:… option in the Input Variables panel.   

Outputs cover any data field that is shown in the Data Editor as a result type, i.e., any item with a light green 
background.  (Advanced users can also add other data items as outputs.)  To add an output to the list of output 
variables, click on it in the Data Editor (or a Data Grid) and then click on the Add:… option in the Output Variables 
panel. 

You can quickly select certain pre-defined common graphs by using the Common Graphs links. 

For both inputs and output, turn on Auto-add in order to automatically add each field clicked on in the Data Editor.  
This is useful when adding a large number of data fields. 

Only numerical items can be added.  Items may refer to a particular arm and/or time-segment, or may be more 
general items such as overall flow scaling factor. 

Use the Remove options to clear the lists and Reset Ranges to reset all ranges to default values. 

Once you have added items, you can quickly go back to the corresponding item in the Data Editor by double-clicking 
any row in either list. 

Outputs may have a colour assigned for each item, to distinguish the various outputs on graphs. Set a colour by 
double clicking in the colour column.  Use the Auto-colour to quickly assign colours. 
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For both inputs and outputs, use the Add All Arms/Streams buttons to quickly add a copy of all current inputs or 
outputs for all arm/streams/lanes in the file.  (If the file contains a mixture of different junction types, this may result 
in a graph that shows outputs for both Roundabout arms and Priority Intersection streams.) 

For outputs, there is also an Add all Time Segments button to add the same output for each time segment. 

The lists can be sorted by any column by clicking the column header. 

 

 Saving graphs; using graphs in reports 18.1.1

You can save the definition of X-Y graphs and Time graphs by clicking Save Graph at the bottom of the screen.   To 
retrieve a saved graph definition, select it from the dropdown list. 

These definitions are saved with the file.  Note that only the definition is saved (i.e. the input/output variables and 
ranges), not the actual graph itself. 

You can also embed graphs in reports.  To do this, firstly save the graph definition.  Then go to the Report Viewer, 
 click the Graphs option and click the browse button to select one or more of the saved graphs.  Refreshing the 
report will then include the graph(s) at the end of the report.  If necessary, a separate set of graphs will be 
generated for each Analysis/Demand Set. 
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This mode produces graphs showing how one or more outputs from Junctions 9 vary as an input variable is altered 
over a defined range. 

If there is only one input and output variable, then the input variable is used as the graph’s x-axis, and the output 
variable as the y-axis.  If there are more items, then you must select the items to use by clicking in the Input/Output 
Variable lists and, if necessary, holding down CTRL to select multiple rows. 

As an example, consider a graph of showing how the RFC on Arm 1 varies as the flow scaling factor on Arm 1 is 
varied.  To set this up, follow these steps: 

 Show the Analyser Screen and select X-Y Graph mode. 
 

 Show the main Demand screen, make sure that Arm 1 is displayed, and click on the Flow Scaling Factor for 
Arm 1.  Click on the Add option in the Input Variables section of the Analyser screen to add this variable.  
 

 Show the Data Editor and browse to time segment results for Arm 1 (for a particular time segment, or for 
the whole period).  In the Data Editor, click on the RFC data field and then click Add in the Output Variables 
section of the Analyser screen to add this variable. 
 

 The range of the input variable is set by default to the built-in range of the variable, which in this case is 1-
999.  A step-size is also set automatically, but you may wish to change this depending on the accuracy and 
speed required.  The Analyser screen should now look like the below: 
 

 
 

 Press either the Line or Bar button under the X-Y Graph mode button to generate the graph.  This will 
perform a set of model runs and plot the results.  As might be expected, the RFC increases steadily as the 
flow scaling is increased. 
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NOTE: the order of graph points is assigned randomly; this is so that the shape of the graph becomes apparent 
quickly and you do not have to wait for each point to be plotted one by one. 

Right-click on the graph to access a menu for copying the graph to the clipboard. 

 

Almost any set of parameters can be investigated in this way by using the x-y graph generator.  The example below 
shows how accident index increases as the proportion of motorcycles entering the roundabout increases. 

 

 

To plot more than one item, simply add the items required to the Output Variables list and then select all those to be 
plotted by holding down CTRL whilst clicking on the rows. 
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The example below shows the end queue on all arms as the network flow scaling factor is increased beyond 100%.  It 
shows that, as overall traffic flows are increased, the queue on Arm D (the purple line) becomes a problem before 
queues on the other arms become significant. 

 

 

If the items plotted are different items but of the same type, then the scale and gridlines are shown as usual.  For 
example, the graph below shows demand, capacity and entry flow for a particular arm varying as the flow scaling 
factor is increased, all shown in units of veh/min.  (To use different units, use the Units screen.) The graph clearly 
shows demand increasing linearly (the blue line), and capacity (green) decreasing as the roundabout becomes busier.  
The actual entry flow (red) initially increases in line with demand but is then limited by the decreasing capacity. 
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If the items plotted are of different types then the scale is removed and the graph becomes schematic only.  In these 
cases, such as the below, the lines should only be used to study trends and not to read absolute values.  The units of 
each item are shown in the key as usual and, by choosing different units, the relative ‘sizes’ of each type of item can 
be controlled.  

 

 

 About X-Y Graphs 18.2.1

When running x-y graphs, one variable is altered while everything else in the file remains constant.  Often this will 
be unrealistic, since there are so many interactions between variables, especially geometric ones.  For this reason 
the Scatter Mode may often be a better choice, even though it only gives results in terms of a maximum and 
minimum value.   

In particular, if plotting a geometric item such as entry width as the x-axis, remember that all other geometries will 
be held constant.  If reality, if there is a flare, then the effective flare length would also alter as the enter width 
changes.  However, the x-y graphs are still extremely useful in terms of showing trends and the overall effects on 
results. 
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When using approach width, entry width or flare length as input variables, you may find that nothing is generated.  
This is usually because, for example, you have specified a zero flare length and then try to vary the entry width.  Zero 
flare length implies that the entry width equals the approach width, and ARCADY checks for this and prevents any run 
if this rule is broken.  Similarly, you cannot alter the flare length if the approach and entry widths are equal.  We 
recommend setting all three parameters to different values BEFORE using them in the Analyser screen 

 

 

This mode provides a way to see how any output variable varies over time (if at all).  Note that, unlike the other 
modes, you must have previously run the file. 

The Input Variables panel is not active in this mode.  In the Outputs Variables panel, set up the output(s) that you 
want to study.  If any of the variables do not vary over time (i.e. they are not part of a time-segment input or output), 
then they will be ignored. 

Press the Line or Bar buttons to plot the data graphically, or use Table to show the data numerically, as shown in the 
examples below which show how RFC varies over time.  The data in the Table screen can be selected and copied into 
a spreadsheet or similar. 

 

 

After using the Add All Arms options and assigning colours, the graph now shows the RFC for all arms on the same 
graph: 
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It is also possible to plot charts where different types of item are shown, as in the example below where a variety of 
outputs for Arm A are shown.  In this case, the label and scale on the y-axis is removed as there is no scale that can 
be used for all of the items; the graph is schematic only. 

 

For more advanced analysis, we suggest using the Table mode and then selecting the entire table and pasting into a 
spreadsheet. 

 

Advanced users may wish to make use of a further mode: if the Line or Bar button is pressed using the right-mouse 
button, the graph window will appear outside the main program window and will be semi-transparent, allowing 
several graphs to be overlaid as in the screenshot below.  This can be useful if overlaying graphs that use different 
units and scales, where, for example, one set of points would be much smaller than another and so would not show 
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up. Instead, plot the graphs separately and then overlay them using this right-click mode.  Remember that the graphs 
will become ‘detached’ from the main Junctions 9 window. 

 

 

 

 

 

The Optimiser Mode attempts to find values of all selected input variables that cause the values of all selected 
output variables to meet user-defined targets.  Obviously this is not always possible, but by setting the target to a 
very low or high value, you can easily see the minimum/maximum achievable values.  The optimiser works by using 
an algorithm that varies the input variables in such a way that it quickly finds a solution, although, leaving the process 
to run for longer can lead to improved accuracy.   

As an example, consider varying both the entry width and flare length on each arm in order to minimise RFC on all 
arms.  To do so, set the screen up as shown below.  The Max value of the flare length is set to 999 by default, but 
usually you will want to choose more realistic ranges.  The column titled Optimised Value starts off by showing the 
current value of the variable to be optimised and will change during the optimisation process.  The Current value of 
each output variable shows the value of each output from the last run of the program, and is shown for comparison 
purposes.  In the Target column, enter the desired value for each item.  In this case, we want the RFC to reduce as far 
as possible, so zero has been entered. 
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To begin the optimisation process, click the Go button.  This may take some time but can be cancelled at any point 
and the best values found so far will be used.  During optimisation, the screen will update periodically to show the 
optimised values and achieved value of each output.  (Note that these do not necessarily show the best values so far, 
but, the best value so far will be used if the optimisation is cancelled.) 

NOTE: In some cases, the optimiser may appear to do nothing.  This is often because the ranges of the input 
variables are such that the file will not run when the optimisation process begins.  This may be due to the effect of 
other variables which are not necessarily in the list.  In this example, the entry width is set to vary between 3 and 
16m.  If however the approach road width was 10m, then it would be best to set the entry width to vary between 10 
and 16m, so that all values of entry width are valid given approach road width.  

NOTE: We recommend that you set the min and max ranges in the optimiser to values that are valid and consistent 
with the roundabout geometries.  For example if the approach width on an arm is 7m, the minimum possible entry 
width is 7m (otherwise an error will occur).  In this case, the entry width range should be set to 7-16m and the 
optimiser will optimise within this region.   

When the run is complete, the achieved values and final optimised are shown, as below: 
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In this case the results are unremarkable and the optimiser has simply set both the entry width and the flare length 
on each arm to its highest allowed value, as this has reduced the RFCs.  To transfer the optimised values into the 
actual data file, press the Use Optimised Values button. 

If the vehicle accident index on each arm is added as an output variable and the optimisation repeated, the effects 
would now compete, as increasing entry width improves capacity but worsens safety.  In this case, the optimiser (if 
otherwise unconstrained) would leave entry width set to a minimum but would increase flare length to its maximum, 
because flare length (in isolation, as used for capacity) has no effect on accidents.   Accidents are however affected 
by approach width, so are indirectly affected by flare length.  An improved run, therefore, would make use of 
approach width as well as entry width and flare length.  In general, the more parameters that are varied, the more 
‘realistic’ the optimisation, although obviously in reality most parameters will actually be constrained in some way. 

 

Another use of the Optimiser is not to set the targets very low or high, but to set them to the same values are their 
current values.  By varying small numbers of input variables, you may then be able to find alternative geometries 
(say) that give the SAME results. 

For example, say the entry width and flare length on an arm are 6m and 12m respectively, and this gives an RFC on 
the arm of 0.536.  If the entry width is reduced to 5m, what flare length would give the same RFC?  To answer this, 
change the entry width, then add the flare length as the only input variable in the Optimiser.  Add the RFC as the only 
output variable, and set its target to 0.536 – i.e., the same as the current value.  Start the optimiser: this time the 
answer should appear very quickly and in this case is approx 32m.  If you use 32m as the new flare length, then run 
the file, you should get exactly the same results as before.  

(If you set the target RFC to zero, the optimiser will simply set the flare length as high as possible.) 

 

NOTE:  Working with flare lengths as described above requires a certain amount of interpretation.  It is not 
necessarily easy to translate a set of entry widths and flare lengths into an actual design, but, the example above 
illustrates how the optimiser can be used to get approximate figures that may then feed into a more detailed design 
process. 
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Scatter Mode chooses a large number of random values for all input variables, between user-defined ranges, and 
assesses their effect on all output variables. 

In the simple example below, the user has investigated the effect of changes in the entry width of Arm A.  The 
original value for the entry width was 4m, which gave an end queue on the arm (in a particular time segment) of 13.6 
vehs (as shown in the Current column of the output variables).  If the entry width measurement was inaccurate by 
0.2m, what would the effect be on the end queue?  To answer this, the Min and Max values have been set to 3.8m 
and 4.2m and the Go button clicked to run the analysis.  The Low and High values of the end queue appear as 
approximately 11 and 17 vehicles.  That is, an uncertainty of 0.2m in the entry width measurement leads to a 
possible variation in queue of 6 vehicles.  The answer is arrived at by choosing many random values of entry width 
within the range and performing a run of the analysis model, and recording how the chosen result varies. 

NOTE:  Any effects shown here are independent of the uncertainty in capacity estimates and the underlying random 
nature of queues.  The range of queue shown in this example is a range of mean queues. 

 

Rather than manually entering the Min and Max values, a more convenient method is to turn on Auto-set ranges and 
then choose a range, such as 10%, in the drop-down box.  The Min and Max will then automatically be set to 10% 
below and above the current value of the parameter, and will be updated whenever the current value changes.   
(The above example could be set up by setting the auto-range to 5%.) 

The above example is a simple one and could just have easily been obtained by plotting an x-y graph of end queue 
against entry width.  The Scatter Mode is much more useful when varying more than one input parameter.  For 
example, what if ALL geometric measurements are considered to be uncertain by, say, 5%?  The Scatter Mode can be 
used to investigate this question because it automatically takes into account interactions between different input 
variables – unlike an x-y graph, which can only consider one varying parameter at a time. 

The screenshot below shows an example where all of the main geometric parameters for a mini-roundabout for Arm 
A have been added as input variables.  The Min and Max have been automatically set to 5% below and above the 
current value of each variable.  The Low and High results now reach from approximately 9 to 24 vehicles, 
representing a significant variation in queue length and demonstrating why it is important to make accurate 
measurements.  The example could be continued by using the Add All Arms options for both input and output 
variables to study the effect on all arms of variations on all arms. 
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 Scatter Mode: advanced features 18.5.1

If the Speed-Accuracy slider is set to the most accurate setting then the Scatter Mode will take longer to run but 
may give more accurate results.  (Usually, this will not be necessary unless varying a large number of parameters.) 

The Bias Ends option is turned on by default and is used to ensure that the minimum and maximum values of each 
input variable are considered more often than would otherwise be the case.  Scatter Mode works by choosing 
random values of each variable and carrying out runs. Generally, the extremes of output variable (i.e. the Low and 
High results), correspond to extremes of input variable (although it is unpredictable which input variable will have 
the most effect).  Some input variables have greatest effect when they are set to their minimum, and others when 
set to their maximum.  The Bias Ends option means that the Low and High results are usually arrived at quickly. 

Advanced users may use the Capture results spread option to study results in more detail.  When this is turned on, 
each output variable shows a Capture Min and Capture Max parameter.  These are initially set to the min and max 
allowed value for each variable.  Whenever the Scatter Mode process chooses a set of random input variables that 
cause the results to lie between the Capture range, the input variables used are captured and made available to 
the user. 

(In this mode, the Bias Ends option is NOT recommended.  You will usually also want to move the Speed-Accuracy 
slider to the accurate end.) 

The data appears as a temporary text file in your default text editor, which will automatically appear when the 
Scatter run is complete. 
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This is not much use on its own but is intended to be copied and pasted into a spreadsheet such as Excel.  The data 
is arranged with all input variables as columns, followed by all output variables as further columns.  Each row 
represents one run of ARCADY.  By sorting the results in the spreadsheet, the individual input variables which gave 
that result can easily be identified and studied or plotted, and so on. 

 

The Capture Results mode can also be used to find alternative sets of input variables that give the same, or very 
similar, results.  For example: for a given approach width, there are many pairs of entry width and flare length that 
give the same capacity (and hence RFC, delay, queue etc).  If the entry width is fixed, then the optimum flare 
length can be found by using the x-y graph or the Optimiser mode.  If however neither value is fixed, then a set of 
potential values can be found by using the Scatter mode.   Set the entry width and flare length as input variables 
with suitable ranges, and capacity (or queue or some other suitable result) as the only output variable.  Set both 
the Capture Min and Capture Max of the capacity to be within a few percent of the desired capacity.  (Note: you 
cannot set the Capture Min and Capture Max to the same number.)   

The process may take some time to complete but it can be interrupted at any time.  The example extract below 
shows some results from the above example.  A selection of entry width and flare length pairs are listed, each of 
which gives a RFC of approximately 0.8.   The larger entry widths are associated with smaller flare lengths, and vice 
versa. 
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Junctions 9 includes a facility to store within a file a log that lists all changes made to the file.  This can include two 
types of information: 

 Manually entered status changes such as “Ready for approval” 

 Automatic log of every change made to the file  

Both types of information are saved with the file and include the date, time and username, so providing an audit 
trail which is especially useful if a file passes between several people and/or undergoes several revisions. 

To access the Audit Trail, use the button in the main toolbar or go to File>Audit Trail. 

To begin with, this will show a blank screen.  Click Add status/comment to show a screen where you can pick a 
status from a built-in list, or enter your own, along with any comments or description. 

 

After clicking Save, a row will be added to the Audit Trail showing the new entry. 

Tick Prompt on each save to force this screen to be shown every time you save the file. 

 

TIP: right-click anywhere in the grid and turn off Keep inside main application window to let the audit trail window float outside 
the main Junctions 9 window.  

Manually adding a status in this way obviously requires you to enter something meaningful each time.  An 
alternative method is to turn on Log everything, which will then provide an automatic log of everything that 
happens to the file. 
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The screenshot below shows an example of the Audit Trail in Log everything mode. 

 

Note that: 

 Manually entered status updates are shown in blue.  You can filter to only show these rows by clicking 
Show only status changes. 
 

 Running the file and saving the file are special events which are shown in grey. 
 

 All other rows describe what was changed in the file. 
 

 The Active Set shows the Analysis Set and Demand Set that were active when the change was made. 
 

 If you undo or redo changes, rows will be removed/restored in the Audit Trail.  (I.e. the Audit Trail does 
not log explicitly that an undo/redo occurred.) 

 
You can clear either the entire log, or all entries up to a certain time, by using the Clear menu.    

You may wish to produce a version of the file with all audit trail information removed.  You could do this by simply 
clicking Clear and then saving the file, but an alternative method is to click File>Create Client Copy.  This will export 
a version of the file with a new name and with the audit trail removed, but with the original file unchanged. 

 

 

 

For users who are familiar with the card type format of ARCADY 6 or PICADY 5, this screen (Tools>ARCADY 
6/PICADY 5 Card Viewer) shows a representation of the current data file in this format.  The screen will 
continuously update as you change input data.   
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Please note that this is a viewer screen and as such is read-only; you can’t edit the file using this screen.  If you 
wish to do so, we suggest copying the data from this screen into a text editor (or just use the File>Export>To 
ARCADY 6… main menu option), making changes, saving the text file as a .vai or .vpi file and then importing it into 
Junctions 9. 

The bottom of the screen shows any warnings associated with the conversion process.  Some data cannot be 
converted into ARCADY 6/PICADY 5 and may be lost.  Please note that the warnings are not exhaustive and so to 
check if a file will run in ARCADY 6/PICADY 5 you should always do a full export and try loading and running the file 
in the old program. 

 

 

This tool (Tools>Measurement Converter) is useful for converting distances from one unit to another, and also 
when converting measurements from a scale drawing. 

 

Enter the measurement of interest and the units of the measurement.  Next enter the scale of the measurement 
or set to 1 if this is not applicable.  The measurement in the current ARCADY units is then shown at the bottom of 
the screen.   (Set the current ARCADY units via the Data>Units screen.) 

 

If you wish to use the converted measurement as data within ARCADY, click in the result box and drag the value 
into any numeric data field in the Data Editor. 
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Autodesk® Vehicle Tracking includes a roundabout design tool that can communicate with the ARCADY module in 
Junctions 9. This link makes it possible to design a roundabout in a CAD package and obtain instant feedback about 
the roundabout’s capacity performance. The communication happens in real time and so there is no need to 
prepare multiple versions of ARCADY files to try out different geometry options: instead, simply make changes to 
the roundabout geometry directly in Autodesk® Vehicle Tracking and see immediate capacity results displayed on 
the drawing.  

For full details of Autodesk® Vehicle Tracking and related products, please contact Autodesk® or see 
http://www.autodesk.com/products/vehicle-tracking/overview 

The link also supports AutoTrack Junctions v9.01 or above, which was available from Savoy Computing prior to 
being superseded by Autodesk® Vehicle Tracking. 

 

 

Every time you make a change to a roundabout in Autodesk
®
 Vehicle Tracking, the main roundabout geometries 

(entry width, flare length, etc) are calculated and passed to ARCADY.  You can see the geometries in the usual 
ARCADY screens but will notice that they are read-only.  Every time the geometries change, ARCADY performs a 
full model run and passes the main results (max queue, max delay RFC, LOS) to Autodesk

®
 Vehicle Tracking, which 

displays the results on the drawing. 

Traffic flows, and all other options, are entered in ARCADY in the usual way. 

If you save the Autodesk
®
 Vehicle Tracking file, this will also automatically save the ARCADY file.  By default, the 

two files will be saved to the same location.  When you subsequently load the Autodesk
®
 Vehicle Tracking file, the 

associated ARCADY file (containing traffic flows and other options) will automatically be launched. 

There is no need to have ARCADY running before using the link.  Instead, Autodesk
®
 Vehicle Tracking automatically 

launches ARCADY whenever it is required.   

ARCADY will update any screens that you currently have displayed whenever any data changes.  For maximum 
speed, we recommend closing any screens that you do not need. 

 

Most of the options and processes that control the link are controlled by Autodesk
®
 Vehicle Tracking rather than 

ARCADY.   

Full details of how to use the link are included in the Autodesk
®
 Vehicle Tracking User Guide, but a brief overview is 

given below.   

 

http://www.autodesk.com/products/vehicle-tracking/overview
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 Configuring ARCADY 20.3.1

ARCADY is launched automatically by Autodesk
®
 Vehicle Tracking, so there is no need to configure anything 

beforehand. 

Whether you allow ARCADY to be launched from Autodesk
®
 Vehicle Tracking or you already have it running, the 

menu at the top-right of the Junctions 9 main screen will show a coloured background as follows: 

 

NO COLOUR:  The link is turned off.  You can turn the link on and off by using the dropdown menu and clicking 
Listen for Autodesk

®
 Vehicle Tracking. 

RED:  The link is enabled, but there is no current connection.   

AMBER:  A connection was attempted but failed.  If this happens, try closing both programs and start again. 

GREEN:  There is an active connection between ARCADY and Autodesk
®
 Vehicle Tracking.  This means that at least 

one file in ARCADY is controlled by Autodesk
®
 Vehicle Tracking.   

 

If necessary, you can alter the port that ARCADY listens on via File>Preferences>Program Links.  If you change this, 
you must also change the equivalent option in the other program. 

 

 

 Configuring Autodesk® Vehicle Tracking 20.3.2

Autodesk
®
 Vehicle Tracking will attempt to automatically find the path where you have installed Junctions 9 so that 

it can launch Junctions 9 whenever a link is required.  If this appears not to work, or if you have more than one 
version of Junctions 9 installed, the path can be set manually in the program settings. 

Please see your Autodesk
®
 Vehicle Tracking User Guide for other configuration options. 
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The following is a step-by-step guide which demonstrates all important aspects of using the link. 
 

1. Close all programs. 
 

2. Launch Autodesk
®
 Vehicle Tracking (via your preferred AutoCAD® host application) 

 
3. In Autodesk

®
 Vehicle Tracking, add a new roundabout and add at least two arms.  (NOTE:  The link may 

not work if there are fewer arms.)  Using the roundabout properties editor, enable the ARCADY link.   
Alternatively, click the ‘Resync’ button, which will enable the link. 
 

4. You should find that ARCADY is automatically launched, either when you first opened Autodesk
®
 Vehicle 

Tracking or when you enabled the link for the roundabout.  Note that ARCADY may be minimised by 
default, but you should be able to see it by clicking on the Windows task bar.  The connection status in 
ARCADY should show as green, and a new file will be present.  If the connection status icon is grey, click 
the arrow and turn on ‘Listen for Autodesk

®
 Vehicle Tracking.  If the connection status is red or amber, 

check the configuration options in both programs. 
 
It can take a few moments to launch ARCADY and for the link to be established. 
 

5. Switch to ARCADY.  In ARCADY, the main geometric parameters are shown with a light green background 
to indicate that you cannot edit them as they have been provided by Autodesk

®
 Vehicle Tracking.  The 

same applies to certain other options, such as roundabout and arm names, driving side and so on.  
 

 
 

6. If you make any relevant change in Autodesk
®
 Vehicle Tracking, the change will immediately be reflected 

in ARCADY. This includes adding/deleting/renaming roundabouts and arms as well as any change that 
affects geometry of the roundabout. 
 

7. Enter traffic flows, turning proportions, vehicle mix and any other required options in ARCADY exactly as 
normal.  If you omit this step, then all flows will be nominal default flows and so all results will show 
very small queues and delays.   
 

8. To force a re-synchronisation of data at any time, use the Resync button in Autodesk
®
 Vehicle Tracking.  
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9. As you drag control points in Autodesk
®
 Vehicle Tracking that affect the roundabout geometry, the new 

geometric measurements are constantly sent to ARCADY, the model run, and the results updated.  If you 
show the Summary Results screen in ARCADY, or any other results screen, you can see the effects of the 
new geometry.   
 
More immediately, you can also see the results directly on the drawing in Autodesk

®
 Vehicle Tracking via a 

set of information boxes next to each arm.  These show the maximum queue, delay, RFC and LOS over the 
modelled period and are shown in the same units as your current preference in ARCADY. 
 

 
 
 

10. If you make a change in ARCADY (for example, to traffic flows), you can re-run the model in ARCADY at 
any time.  For the changes to reflect in Autodesk

®
 Vehicle Tracking, you must use the Resync button in 

Autodesk
®
 Vehicle Tracking. 

 
11. You can use the Undo/Redo buttons in both ARCADY and Autodesk

®
 Vehicle Tracking independently.   

 
12. If there is a program error in ARCADY, all results in Autodesk

®
 Vehicle Tracking will appear as ‘ERROR!’.  In 

this case, look at the Task List in ARCADY to see where the error is. 
 

13. If the geometric parameters are outside the ARCADY allowed ranges, ARCADY will cap them before 
running the model. The results may then not be appropriate for the roundabout drawing.  Autodesk

®
 

Vehicle Tracking will usually show warnings about capped geometries by showing symbols near to the 
affected arm(s). 
 

 
 
 

14. In Autodesk
®
 Vehicle Tracking, save the file.  This will prompt ARCADY to also save the file, using the same 

name but the .ARC8 extension.  Subsequent saves from Autodesk
®
 Vehicle Tracking will re-save both files. 

 
15. In ARCADY, note that you cannot close the file.  This is because file options such as saving and closing the 

file are controlled by Autodesk
®
 Vehicle Tracking for any file that was originally opened by Autodesk

®
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Vehicle Tracking.  You can, however, load other ARCADY files at the same time and switch between them. 
 

16. Close Autodesk
®
 Vehicle Tracking.  ARCADY will also close, unless you have loaded any other files. 

 
17. Re-start Autodesk

®
 Vehicle Tracking and open the saved file.  ARCADY will automatically launch and load 

in the associated ARCADY file with traffic flows and other options. 
 

18. When loading a saved file, it is a good idea to use the ReSync button in Autodesk
®
 Vehicle Tracking to 

force a full re-calculation of geometries and re-run of the model. 
 

19. If you save the ARCADY file using a different name, or to a different location, it will no longer be 
associated with the Autodesk

®
 Vehicle Tracking file. 

 

 

Please be aware that there are certain items that may appear to be present in the Autodesk
®
 Vehicle Tracking 

drawing but which are not modelled in ARCADY.  For example, you can add pedestrian crossings in Autodesk
®
 

Vehicle Tracking but currently these are not passed to ARCADY and so you would need to separately add the 
crossings into the ARCADY file. 

Any item that is controlled by Autodesk
®
 Vehicle Tracking is shown in ARCADY with a light green background and 

cannot be altered.  If in doubt, see if you can edit the item as you normally would in ARCADY; if you can, then that 
item is NOT being supplied by Autodesk

®
 Vehicle Tracking. 

Currently Autodesk
®
 Vehicle Tracking calculates geometric parameters for standard roundabouts – i.e., V, E, L’, R, D 

and PHI. 

You may be able to use options in Autodesk
®
 Vehicle Tracking to reveal the construction lines that are used to 

calculate the ARCADY parameters.  Essentially, they are the same as those described in the Appendix of this User 
Guide or in DMRB TD 16/07.   

As with the rest of ARCADY, the link is provided as a tool and the user is reminded to check the appropriateness of 
the solution.  Therefore we recommend that, particularly for final designs, you check the parameters calculated by 
Autodesk

®
 Vehicle Tracking (or any other program) against those derived by your usual methods. 
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The references below cover a representative sample of the research used in ARCADY and PICADY.  The programs 
also make use of unpublished research and computational algorithms. 

 
1. BINNING JC (2004). ARCADY 6 USER GUIDE, TRL Limited, TRL Application Guide AG49.  Crowthorne: TRL Limited.  
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7. BURTENSHAW G (2012). JUNCTIONS 8 USER GUIDE, TRL Limited, TRL Application Guide AG67.  Crowthorne: TRL 

Limited.  
 

8. TRANSPORTATION RESEARCH BOARD (TRB) (2010).  Highway Capacity Manual 2010.  Washington D.C. 
 

9. GRIFFITHS J D (1979). Mathematical Models for Delays at Pedestrian Crossings. Bulletin of  IMA No.11/12 
 

10. KENNEDY, J V, R D Hall, S R Barnard (1998). Accidents at Urban mini-roundabouts, Transport Research Laboratory, 
TRL Report 281. Crowthorne: Transport Research Laboratory. 
 

11. KIMBER, R M (1980).  The traffic capacity of roundabouts.  Department of Environment Department of Transport, 
TRRL Report LR 942: Crowthorne: Transport and Road Research Laboratory. 
 

12. KIMBER, R M and R D COOMBE (1980).  The traffic capacity of major/minor priority junctions.  Department of the 
Environment Department of Transport, TRRL Report SR 582.  Crowthorne: Transport and Road Research Laboratory.  
 

13. KIMBER, R M and ERICA M HOLLIS (1979).  Traffic queues and delays at road junctions.  Department of the 
Environment Department of Transport, TRRL Report LR 909.  Crowthorne: Transport and Road Research Laboratory. 
 

14. KIMBER R M, DALY P, BARTON J, and GIOKAS C (1986). Predicting time-dependent distributions of queues and delays 
for road traffic at roundabouts and priority junctions.  Journal of the Operational Research Society, 37 (1), pp 87-97 
1986 
 

15. KIMBER, R M and HOLLIS, Erica M (1979). Traffic queues and delays at road junctions. Department of the 
Environment Department of Transport, TRRL Report LR 909: Crowthorne: Transport and Road Research Laboratory. 
 

16. LAYFIELD R E, I SUMMERSGILL, R D HALL and K CHATTERGEE (1996).  Accidents at urban priority crossroads and 
staggered junctions, TRL Research Report TRL 185.  Crowthorne: Transport Research Laboratory 
 

17. McDONALD M, N B HOUNSELL and R M KIMBER (1984).  Geometric delay at non-signalised intersections.  
Department of the Environment Department of Transport, TRRL Report SR 810. Crowthorne: Transport and Road 
Research Laboratory. 
 

18. MARLOW, M and G MAYCOCK (1982).  The effect of Zebra crossings on junction entry capacities.  Department of the 
Environment Department of Transport, TRRL Report SR 724.  Crowthorne: Transport and Road Research Laboratory. 



 References    Page 316     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

19. MAYCOCK, G and HALL, R D (1984) Accidents at 4-arm roundabouts. Department of the Environment Department of 
Transport, TRRL Report LR 1120: Crowthorne: Transport and Road Research Laboratory. 

 
20. PICKERING D, R D HALL and M GRIMMER (1986).  Accidents at rural T-junctions.  Department of Transport, TRRL 

Report RR 65.  Crowthorne: Transport and Road Research Laboratory. 
 

21. SEMMENS, Marie C (1982).  The capacity of some grade-separated roundabout entries. Department of the 
Environment Department of Transport, TRRL Report SR 721: Crowthorne: Transport and Road Research Laboratory. 

 
22. SEMMENS, Marie C (1988) The capacity of entries to very large roundabouts. Department of Transport, TRRL Report 

RR 142.  Crowthorne: Transport and Road Research Laboratory 
 

23. SUMMERSGILL I, J V KENNEDY and D BAYNES (1996).  Accidents at three-arm priority junctions on urban single 
carriageway roads, TRL Research Report TRL 184.  Crowthorne: Transport Research Laboratory.  
 

24. WEBB, PJ and J R PEIRCE (1990). ARCADY/3 USER GUIDE, Department of Transport, TRL Application Guide AG17.  
Crowthorne: Transport Research Laboratory. 
 

25. WEBB, PJ and J R PEIRCE (1990). PICADY/3 USER GUIDE, Department of Transport, TRL Application Guide 
AG18.  Crowthorne: Transport Research Laboratory. 
 

26. KIMBER R M, M McDONALD and N B HOUNSELL (1986). The prediction of saturation flows for road junctions 
controlled by traffic signals. Department of Transport, TRRL Report RR67, Crowthorne: Transport and Road Research 
Laboratory. 
 
 
 
 
 



 Appendix A – Importing from and exporting to from ARCADY 5/6    Page 317     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 

Files created using ARCADY 6 (or ARCADY 5) or PICADY 5 can be imported into Junctions 9 by dragging them into 
Junctions 9 or by using the File>Open menu. During the import process, warnings or other information may be 
shown.   

Immediately following an import from ARCADY 6 / PICADY 5, the units in Junctions 9 are set so that they are 
equivalent to the units used in ARCADY 6 / PICADY 5 such as vehicles/min and so on. You can of course 
immediately set these to your own preferences. 

There are some subtle differences between ARCADY 6 / PICADY 5 and Junctions 9 in the units used for certain 
items, such as flare storage space and pedestrian crossing blocking space.  Generally, in Junctions 9, these are 
always expressed in PCU since they represent a space or area.  In ARCADY 6 / PICADY 5, however, some items are 
instead represented as a number of vehicles, the assumption being that the entered values use ‘average’ vehicles.  
These values should be checked carefully following an import.  These differences can lead to differences in the 
results compared to ARCADY 6 / PICADY 5, although these will generally only be noticeable when there are a high 
percentage of heavy vehicles.    

The use of Analysis and Demand Sets differs between ARCADY 6 / PICADY 5  and Junctions 9 and although 
Junctions 9 will read in ARCADY 6 / PICADY 5 style Demand Sets, the user will usually have to do some manual 
adjustment after the import in order to make the most of the Junctions 9 implementation. 

Exporting Junctions 9 files to ARCADY 6 / PICADY 5 format is possible by selecting File>Export>To ARCADY 
6/PICADY 5….  You can see a preview of the data that will be exported at any time by using Tools>ARCADY 
6/PICADY 5 Card Viewer.  After generating the export file you may be shown warning and/or information to be 
aware of.  The issues discussed above apply in reverse; in addition, any use of features found in Junctions 9 but not 
the older programs are clearly not capable of being exported.   

 

 

Users of previous versions of ARCADY or PICADY may be used to the Progress 
Checklist system and the layout of screens in previous versions.  This section gives a 
brief overview of the equivalent locations in Junctions 9.  
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ARCADY 6 / PICADY 5 Progress 
Checklist 

Junctions 9 equivalent 

Run Information Data Outline>File Description 

Modelling Parameters 

 

 

 

These are part of the properties of each Demand Set.  Access these via Data 
Outline>Demand Set Definitions>Demand Set. 

 

Junction Type 

 

 

Set the junction type in the Junction section of the Data Outline.  
Pressing this button on the vertical toolbar will jump to this location. 

For roundabouts, set the number of arms by adding or deleting arms in the Data 
Outline. 

Set arm names via the Arm section of the Data Outline, for each arm. 

Flow scaling factors can be set in the Demand Screen (see Demand Screen) 

To add an image of the junction, set a background image in the Junction Diagram. 

Principal Options 

 

 

Traffic Demand Data Type:  Set in each Demand Set’s properties.  Can also be set for 
individual arms in the Demand Screen.  (See Demand Screen) Note that to use the 
ARCADY 6 ODTAB mode, select the ONE HOUR profile and tick the Use Turning Counts 
option. 

Heavy Vehicles:  Use the  

Vehicle Mix screen. 

Turning Proportions: Use the Origin-Destination (O-D)  screen. 

Capacity Relationships:  See Data Outline>Junction. 

Lighting/Road Surface:  See Data Outline> Junction Network. 

Site-specific data:  See Slope/Intercept, Flow and Capacity Adjustments.  

Accident Analysis:  Set via Data Outline> Junction >Safety Options 

Queue Length Variations:  Set via Data Outline>Options>Analysis Options 
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Geometries, Queues and Capacities 

 

 

Most geometric data is set in the Junction > Capacity>Geometry section of the 
Data Outline.  Pressing this button on the vertical toolbar will jump to this 

location. 

You can edit geometric data for any junction type by using the Data Editor or Data 
Grids.  For Priority Intersections (PICADY junctions) there is also a special screen 
which is shown automatically if appropriate. 

There are no yellow line drawings in Junctions 9 but the Glossary Screen (see Getting 
help) shows detailed diagrams for many parameters. 

The various tabs in the ARCADY 5/6 screen have equivalents in the Data Outline, 
inside the Arm>Capacity section. 

To edit distances through the junction (for geometric delay), use the Geometric Delay 
screen (see Geometric Delay and Journey Times). 

To edit site-specific or intercept corrections, see Slope/Intercept, Flow and Capacity 
Adjustments. 

Demand Data 

 

To set up Analysis and Demand sets, see Working with Analysis Sets, Demand Sets and 
Time Segments. 

Use the Flows Screen to enter demand flows and use the Vehicle Mix and Turning 
Proportions screen to set up other data.  See Working with Traffic Flows. 

Crossing Data 

 

Most pedestrian crossing data is set in the Junction > Capacity>Crossings 
section of the Data Outline.  Pressing this button on the vertical toolbar will 

jump to this location. 

Pedestrian Flows are entered in the Flows Screen along with all vehicular demand. 

Accident Prediction Set up accident prediction options in Data Outline>Junction>Safety Options.  
Pressing this button on the vertical toolbar will jump to this section.  You 

may need to be in Advanced Mode to access this data. 

The actual data is then entered by browsing to the appropriate section(s) of the Data 
Outline, which depend on the junction type and accident prediction level. 
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Viewer 

 

 

There is no need to use a separate viewer program in Junctions 9; all results exist in 

the data file and can be explored using the Data Outline.  The Summary Results 
 Screen is a convenient way of viewing main results. 

You can, however, generate reports in a similar way to ARCADY 6/PICADY 5 when 
required: see Generating Reports. 

If you want to see outputs in a similar order to the tables in the ARCADY 6/PICADY 5 
Viewer,  you can use the built-in custom grids that are available via the drop-down 
menu on the main DataGrids button. 

PICADY 5 ‘Quick Report’ 

 

 

This is similar to the Summary Results Screen, which appears automatically 

 whenever you run a file. 
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The geometric parameters used in the calculation of capacity are split between those which apply to ALL 
roundabouts, standard roundabouts and mini-roundabouts.  

NOTE: where distances are quoted in metres, the corresponding distances in your local units should be used.  
Junctions 9 includes a unit conversion screen for conveniently converting measurements. 

NOTE:  the diagrams and measurements shown here are for drive-on-the-left situations.  Equivalent diagrams 
that show drive-on-the-right modelling are available within Junctions 9 via the Glossary screen for any 
roundabout that has its driving side set to ‘right’. 

 

 Approach road half-width (V) 23.1.1

The approach road half-width, v, is measured at a point in the approach upstream from any entry flare, from the 
median line to the nearside kerb, along a normal (see Figure 23-1 ).   It should be measured upstream of any local 
effects of the design of the entry, i.e. prior to any flaring and prior to any narrowing that may exist.   

 

Point A is the point of maximum entry deflection at the offside end of the give-way line where it meets the median 
island (or marking) 

Figure 23-1 
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 Entry width (E) 23.1.2

The entry width is measured from the point A along a normal to the nearside kerb (see Figure 23-1).   

 

 

 Effective flare length (l’) 23.1.3

 
The effective flare length is recorded as zero if there is no flare.  Note that if a zero flare length is entered then 
ARCADY will check that E=V and show an error otherwise.  Conversely, if E<>V then a non-zero flare length must be 
entered. 

The construction to be used to obtain the average effective length over which the flare is developed, l´, is 
illustrated in Figure 23-2. 

 

Note:  the shape of the line CF mirrors that of the nearside kerbline.  Similarly, the shape of line DG mirrors that of 
the centre line or kerb of the central island if one exists. 

Figure 23-2 

 

AB = E (the point A is as in Figure 23-1). 

 GH = V (the point G is the best estimate of the start of the flare). 

 GD is parallel to AH and distance v from it. 

 CF´ is parallel to BG and distance ½ BD from it. 
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 The simplest way to obtain the measurements is as follows: 

1. If not already done so, draw the projection line AB as used to measure the entry width (see 
above).  
 

2. Draw ‘tram lines’ parallel to the centre of the road, towards the give-way line, from the point G 
at the start of the flare. 
 

3. This line (GD) intersects the line AB, which is the line along which the entry width (e) is 
measured, at point D. The flare length (l’) is measured from the point C, which bisects BD along a 
line parallel to the kerb and distance ½ BD from it, to a point F´ where it intersects line GD. 

The effective flare length is then defined as l´ = CF´.  (The line over which l´ is measured is often curved as it 
matches the curve of the nearside kerb.)   

 

NOTE: The point G can often be chosen by identifying the first point upstream of the giveway line where the 
nearside kerb and centre line of the road are parallel to each other. 
 
Also note that on occasions when the line A-B is NOT perpendicular to the island kerb (or centre line) the line D-A is 
not always (v) wide. 

 

TIP: measurement of median line  

In order to measure some parameters, it is first necessary to define a line “midway” between the kerbline and 
centre line (or centre island) on the entry to the roundabout. It is sometimes also necessary to define a midway 
line on the roundabout exits. 
 
Naturally, the midway line (or centre line, or median line) passes through all the centre points. Each centre point is 
defined as the centre of a line drawn from kerb to centre line (or island) at right angles to the kerbline. 
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 Conflict angle (entry angle) (PHI, ) 23.2.1

The conflict angle, or entry angle, serves as a geometric proxy for the conflict angle between entering and 
circulating streams.  Two constructions are used for the conflict angle:  the first applies to well-defined 
conventional roundabouts, and the second to all other types. 

For conventional roundabouts (i.e. those with identifiably parallel-sided weaving sections, where the arms are 
well separated), the angle measured is in effect that between the projected path of an entering vehicle and the 
path of a circulating vehicle. The construction is illustrated in Figure 23-3. 

 

Figure 23-3 

 

A´D´ is a line parallel to the path taken by the circulating flow, along the centre of the circulating carriageway.  (A 
proxy for the average direction of travel for traffic circulating past the arm.) 

EF is a line midway (along its entire length) between the nearside kerbline and the median line or nearside edge of 
any median island. 

BC is a tangent to EF at the point where EF intersects the give-way line. 

PHI is then measured as the angle between BC and the tangent to A´D´ at the point of intersection of the two lines. 

 

For other cases the construction is as in Figure 23-4.  This construction is used when there is insufficient 
separation between entry and adjacent exit to be able to define the path of the circulating vehicle clearly.  In this 
case, circulating traffic which leaves at the following exit will be influenced by the angle at which that arm joins the 
roundabout.  The angle between the projected entry and exit paths is measured and then halved to fine PHI, as 
follows: 
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Figure 23-4 

 

EF is a line midway (along its entire length) between the nearside kerbline and the median line or nearside edge of 
any median island. 

BC is a tangent to EF at the point where EF intersects the give-way line. 

JK is as EF but for the following exit. 

GH is a tangent to JK at the point where JK intersects the boundary of the roundabout circulation. 

L is the point of intersection between BC and GH. 

PHI is then defined as [angle HLB] / 2.  

 
Note that if angle GLB exceeds 180 degrees, then PHI is defined as zero. 

 

If it is not clear which of the two methods should be used, the following should clarify the situation. All three 
vehicle paths (entry, exit and circulatory carriageway medians) should be constructed, and the entry and exit paths 
projected towards the roundabout centre. The choice of construction for PHI depends on where these projections 
meet: if the meeting point is closer to the centre of the roundabout than the arc of the circulatory carriageway 
median, then the construction for conventional roundabouts as shown in Figure 23-3 should be used; if they meet 
outside that area, then the construction for small roundabouts as illustrated in Figure 23-4 should be used. In the 
limiting case where all three medians intersect at a point, it is common for the circulatory carriageway median 
approximately to bisect the angle between the other two medians, so that the two methods become equivalent 
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 Entry radius (R) 23.2.2

The entry radius is measured as the minimum radius of curvature of the nearside kerbline at entry – see  Figure 
23-1.  For some designs the arc of minimum radius may extend into the following exit, but this is not important 
provided that a half or more of the arc length is within the entry region. 

 

When the radius of the kerbline is continuously changing (i.e. it is a transitional curve) TRL recommend measuring 
the entry radius as follows: 

1. De-lineate a length of kerbline which extends from a point 25 metres upstream of the give-way 
line to 10 metres downstream of the give-way line (measured along the curved path of the 
nearside kerbline). 

2. Within the length of kerbline defined above, choose a 20 metre length with the maximum 
average curvature (i.e. this 20 metre length has a greater average curvature than any other 20 
metre length you could have chosen). This process will have to be done by eye and is therefore 
somewhat subjective. (If the length of kerbline in (1.) is less than 20 metres long, then use 
whatever length is available for defining (2.)). 

3. Measure the average radius of the 20-metre length defined in (2.). This measurement becomes 
“r”. 

 

 Inscribed circle diameter (D) 23.2.3

The inscribed circle diameter, D, is the diameter of the largest circle that can be inscribed within the junction 
outline (see Figure 23-1) 

In cases where the outline is asymmetric, the local value in the region of the entry being considered is taken. 
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 Minimum approach road half-width (Vm) 23.3.1

The minimum approach road half-width, or Vm, is the minimum approach half-width, measured anywhere within 
the final 100 metres of the approach. 
 
Mini-roundabouts require the entry of both Vm and the usual approach half-width (V).   V represents the half-
width upstream of any local effects such as widening or narrowing.   Vm can never be greater than V, and Vm 
should not be positioned upstream of V. 
 
In most designs, where the road is straight or widens towards the mini-roundabout, then both V and Vm will be 
measured at the same point and will take the same value. 
 
However if the road narrows towards the mini-roundabout, as it does with some designs, then Vm should be 
measured at the narrowest point and will be measured at a point closer to the roundabout than V. 
 

 Effective flare length (mini-roundabout capacity) 23.3.2

The effective flare length  for mini-roundabouts is the average effective flare length, constructed in the same way 
as for standard roundabouts but using the MINIMUM approach road half-width instead of the approach road 
half-width.  
 

 Distance to next arm (An) 23.3.3

The distance to next arm, An,  is the straight line distance from the offside end of the give-way line on the current 
arm to the nearest point of the median marker or island (whichever is nearest) on the next arm after that (see 
Figure 23-5).  

The diagram shows the the measurement of K for Arm X and of A for Arm n.   

 

Figure 23-5 
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 Entry corner kerb line distance (K) 23.3.4

The entry corner kerb line distance, K, is the length of the entry corner kerb line, measured from a point on the 
entry kerb from which a perpendicular would be raised to the offside end of the give-way line, to a point further 
along the kerb from which a perpendicular would be raised to the offside end of the exit width measurement on 
the next arm clockwise (see Figure 23-5) 

 

 Gradient over 50m 23.3.5

The gradient over 50m, G50, is the gradient measured on the approach over the last 50 metres prior to the entry.  
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NOTE:  These parameters are measured opposite the minor arm that major arm traffic makes an offside turn into.   

 

 Width of carriageway [W]  23.4.1

This parameter represents the total width of the major carriageway.  You should make several measurements as 
shown below which are then combined to give: 
  
Total carriageway width W = (W1 + W2 + W3 + W4) / 2 
 
The diagram shows how to measure W at a T-junction.  At a staggered junction, two values are required: one in the 
vicinity of Arm B and one in the vicinity of Arm D. 
 
Note that the width of any central reserve or turning bay is NOT included.   
 
Where a layout has metre strips (or any hatching) alongside the kerbs, the carriageway width should exclude the 
metre strips or hatching width. 
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Figure 23-6 Components of major widths 

 

 

 Width of kerbed central reserve [WCR] 23.4.2

If there is a kerbed central reserve at dual-carriageway sites, its width should be measured as shown in Figure 
 23-6 d).  The central reserve width affects the capacity of traffic making an offside movement out of the minor 
road into the major road. 
 
 WCR = (W5 + W6) / 2 

Where a layout has metre strips (or any hatching) alongside the kerbs, the central reserve width should include any 
metre strips or hatching width around the kerbed central island.  

The diagram shows how to measure this value at a T-junction.  At a staggered junction, two values are required: 
one in the vicinity of Arm B and one in the vicinity of Arm D. 
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 Width for traffic making offside turn into minor arm [Wr] 23.4.3

This measurement is required if there is explicit provision for traffic turning right from the major road into the 
minor arm, such as a right-turn lane or bay.  In this case, tick the Has right-turn lane/bay option. If there is no such 
provision, and right-turning traffic uses the main carriageway, then this measurement is not needed and 
automatically takes a nominal value of 2.2m. 
 
The diagram shows how to measure this value at a T-junction.  At a staggered junction, two values are required: 
one in the vicinity of Arm B and one in the vicinity of Arm 
 
As shown in Figure 23-7 , the average of measurements taken at 5m intervals over a distance of 20m should be 
used. The 20m is from the extended centre line of the appropriate minor arm.  Any measurement greater than 5m 
is reduced to 5m before the average is taken. 
 
The diagram is appropriate for any situation, whether the right-turn bay is kerbed or not.  Note however that if 
there is a kerbed central reserve, its width is entered separately - although in many cases it will take the same or 
similar value as Wr.  The central reserve width affects the capacity of traffic turning right out of the minor road into 
the major road (e.g. B-A), whilst Wr affects the capacity of traffic turning right from the major road into the minor 
road (e.g. C-B). 
 

 
Figure 23-7 Measurement of major road offside-turn lane width 

 
 
 

 Visibility for traffic making offside turn into minor arm 23.4.4

This is the distance that can be seen along the major road by drivers waiting to turn right into the minor arm.  One 
visibility measurement is made, from the mid-point of the right-turning lane, or the position assumed by vehicles 
waiting to turn right, towards the centre line of oncoming major road traffic at a height of 1.05m. 
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 Blocking due to traffic making offside turn into minor arm 23.4.5

This determines whether traffic turning right from the major road into the minor road blocks straight-ahead traffic.  
As far as the program is concerned, the answer to this question is unrelated to the geometry of the junction 
entered elsewhere (i.e. it cannot be derived internally by the program). 
 
There are three possible answers: 
 

- No blocking:  the road is sufficiently wide, or has sufficient lanes, that right-turning traffic never 
blocks straight-ahead traffic.  I.e., traffic travelling straight ahead on the major road is completely 
unimpeded by any vehicles waiting to turn right into the minor road.  In this case, the Blocking 
Queue parameter is not applicable. 
 

- Full blocking:  right-turners block straight-ahead traffic, and there is no right-turn bay.  Thus even 
a single vehicle waiting to turn right will hold up straight-ahead traffic.  In this case, the Blocking 
Queue parameter should be set to zero. 
 

- Partial blocking:  there is a right-turn bay (or other provision) that can hold a certain number of 
vehicles waiting to turn right.  Any extra vehicles will spill into the main carriageway and cause 
blocking.   The Blocking Queue parameter should be set to the maximum number of right-turning 
vehicles that can queue, positioned ready to turn right, without blocking the progress of vehicles 
travelling straight ahead. 

 
 
 

 

 Minor arm types and lane widths 23.5.1

The text below refers to the measurements required for Arm B at a T-junction.  At a 4-arm junction, there are also 
equivalent measurements for Arm D. 
 
On the minor road there may be one lane, two lanes, or one lane that widens into two lanes (“one lane plus 
flare”).  If there are two full lanes extending back from the give-way line to beyond the normal maximum queue 
length, the arm should be modelled as having two lanes.   At flared junctions, it is recommended for simplicity to 
firstly model the arm with two lanes in order to establish whether the normal maximum queue length extends 
back beyond the end of the flare. 
 
 
Minor arm lane width for one lane or two lanes   
 

Where there are clear lane markings the width is measured directly. The average of measurements taken 
at 5m intervals over a distance of 20m is used (a,b,c,d,e).  I.e., the relevant lane width is calculated as: 
 
  W = (a + b + c + d + e)/5 metres 
 
Any measurement > 5m is reduced to 5m before the average is taken. Where the lane markings are 
unclear or absent, the diagrams in Figure Figure 23-9 and Figure 23-10 are used. 

 
 
Minor arm road width for ‘one lane plus flare’ 
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The minor road half-widths are measured at the give-way line and at 5 metre intervals from the give-way 
line (i.e. at 5m, 10m, 15, and 20m) perpendicular to the carriageway-dividing line. The width of the give-
way line is measured directly. The widths at 5, 10, 15 and 20 metres are measured along a line at right 
angles to the carriageway-dividing line, across to the kerb (these lines will generally be parallel to the 
give-way line). The measurements (unlike one/two lanes measurements) are not limited to a maximum of 
5 metres, nor averaged – all five widths are entered directly into PICADY (see Figure Figure 23-8). 
 
 

Flare length 
 

If ‘one lane plus flare’ is selected, then the flare length should be entered as the maximum number of PCU 
lengths back from the give-way line for which vehicles can queue two abreast.   
 
Optionally, this value can be estimated automatically from the lane widths.  Only use this option is the 
flare is less than 20m long.  If the flare is longer than this, you must explicitly enter the flare length. 
 
 
 
 

 
Figure 23-8 Measurement of minor road lane widths (one lane, or flare) 
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Figure 23-9 Measurement of minor road lane widths (two lanes; left lane - no lane markings) 

 

23-10 Measurement of minor road lane widths (two lanes; right lane - no lane markings) 

 
 

 Visibility for minor road streams 23.5.2

The visibility distances for these streams are measured from points 10m back from the give-way line on lines 
bisecting each lane. Visibility to the left is measured from the offside lane to a line bisecting the far major road 
carriageway. Visibility to the right is an average of the measurements made from each lane to the line bisecting 
the near major road carriageway. All measurements are made at a height of 1.05m above the carriageway surface. 
(Note that the distances for accident prediction are measured differently but will generally give very similar 
values.) 
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The user should note that the UK Departmental Standard for the geometric design of major/minor priority 
junctions (TD 42/95) measures visibility from a point 9m back from the give-way line. If this information is available 
for a junction it may be used instead of the value measured at 10m distance. 
 
For a new junction which is to be constructed to the UK Department’s standard the user may choose to take as 
input to PICADY, the visibility requirement specified in the standard. In such cases it should be appreciated that the 
value input will be the minimum visibility at the junction (as specified by the standard), the actual value (of the 
built junction) possibly being greater. Hence the resulting capacity will possibly be a slight under-estimate. 

 
23-11 Measurement of minor arm visibility 
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 Entry and exit speed 24.1.1

The speed of traffic approaching or departing from the junction is measured at a point on the arm far enough away 
from the junction for it not to affect the traffic speed.  Where new roads and junctions are being assessed, the 
appropriate speed may be estimated by use of speed/flow curves. 

 

 

 Entry angle 24.1.2

The construction required in the measurement of the entry angle, ENA, is shown in Figure 24-1. 

The line EF is a straight line along the centre of the arm from a point upstream of any local flaring or curvature 
which may be present to deflect entry traffic. 

GH is parallel to the nearside kerbline at the approach to the junction and at a distance of 2 metres from it. 

JK is a curve drawn at a distance of 2 metres from the central island in the area of the junction entry. 

When possible, PQ is drawn as a common tangent to the curves GH and JK. 
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The entry angle, ENA, is measured as that between the lines EF and PQ.  When no common tangent can be drawn 
to the two curves the entry angle takes the value 0. 

 

Figure 24-1 

 

 

 

 Exit angle 24.1.3

The exit angle, EXA, is measured in a similar manner to the entry angle (see Figure 24-1) but using curves VW and 
KL in the junction exit area. A common tangent is drawn (whenever possible) and the exit angle, EXA, is the angle 
between this tangent and the line EF. 

 

 

 Exit radius 24.1.4

The exit radius  is the minimum radius of the nearside kerbline at the exit from the roundabout to the arm in 
question. (This is similar to the entry radius used in standard capacity geometries.) 
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 Sight distance 24.1.5

The sight distance is the visibility to the offside direction (i.e., to the right in the UK) to the most distant circulating 
vehicle that an approaching driver can see, measured from a point 15 metres upstream of the entry and at a 
height of 1.05 metres.  The measurement is along a curve following the outer kerbline of the circulating area. The 
line ST on Figure 24-2 gives an example of the measurement in a particular example, for the eastern arm.   
 

 

Figure 24-2 

 

 
 

 Entry-to-centre distance 24.1.6

The measurement of the distance from junction entry to the centre of the junction is shown as D1 in  Figure 24-2.  
The point X is the midpoint of the central island, whether or not the island is circular.  The distance D1 is measured 
from the point X to the junction entry at a point midway between the nearside kerbline and the median line of the 
arm. 

 

 Centre-to-exit distance 24.1.7

The distance D2 is measured from the centre of the junction (point X in Figure 24-2) to the junction exit. 
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 Angle to next arm 24.1.8

To measure the angles between arms the required construction is illustrated in Figure 24-1. The angle to be 
measured, ANGL, is that between the line EF for the arm in question and that associated with the following arm – 
i.e., the line XY.  If the alignment of two adjacent arms is such that they are parallel or even diverge as they 
approach the junction, then the measured angles should be treated as 0 and negative respectively.  The sum of the 
angles measured between each pair of arms must be 360 degrees. 

 

 Distances through junction 24.1.9

The distances through the junction from one arm to another, are measured along a typical path taken by a vehicle 
making the turning movement from the junction entry to the junction exit. 

 

 

 

 Entry and exit speed 24.2.1

The speed of traffic approaching or departing from the junction is measured at a point on the arm far enough away 
from the junction for it not to affect the traffic speed.  Where new roads and junctions are being assessed, the 
appropriate speed may be estimated by use of speed/flow curves. 

 

 Entry Radius 24.2.2

The entry radius is measured as the minimum radius of curvature of the nearside kerbline in the area of the left-
turn from the arm under consideration. Figure 24-3 illustrates the location of the measurements in the cases of 
arms A and B.  



 Appendix C - Measurement of geometric delay parameters    Page 340     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 
Figure 24-3 Measurement of entry radius (ER) for arm A and B 

 
 
 

 Exit Radius 24.2.3
The exit radius is measured as the minimum radius of curvature of a typical vehicle path making the right-turning 
movement into the minor arm under consideration (see Figure 24-4). 

 
Figure 24-4 Measurement of exit radius (EXR) for arm C 
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 Stagger Length 24.2.4
The distance travelled along the major road in a staggered junction by traffic from one minor arm to the other (B-D 
or D-B) is measured as the distance along the major road from a position opposite the mid-point of the minor arm 
entry to a position opposite the mid-point of the exit into the other minor arm (see Figure 24-5). (Different from 
accident data, which uses absolute stagger distance.) 
 

 
Figure 24-5 Measurement of stagger distances (geometric delay) 

 
 
 

 

 
Point-to-point journey time calculations begin at user-specified distances (Distance included up/down-stream) 
upstream of the give-way line and downstream of the junction exit.  That is, the journey time includes the time 
taken to travel along the approach to the junction, through the junction, and then along the exit arm, together 
with any queuing delay.  

For roundabouts, the upstream/downstream distance is measured simply from the arm entry and exit respectively. 
 

For Priority Intersections, the distances are measured as follows. 

Priority Intersection Minor arms:  The distance included up/down stream is measured from the give-way line back 
to the point at which the journey starts for traffic arriving on that particular minor arm. This same distance also 
defines the distance which traffic travels along the exit to the journey end point.  
 
Priority Intersection Major arms:  The distances are measured from the centre of the junction.  For a four-arm 
junction the centre of the junction is a point equidistant from the extended kerblines of the nearest minor arms, 
while for a three-arm junction it is the point opposite the extended centre line of the minor arm. 
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Figure 24-6 Measurement of point-to-point journey-time distances (geometric delay) 
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To correct the capacity formula for local conditions the following procedure should be adopted.  The relevant entry 
must be substantially overloaded during peak periods before these measurements can be made. 

On-site counts are made of the total inflow (light and heavy vehicles) from the entry and the corresponding 
circulating flow across the entry (light and heavy vehicles) for successive minutes during which there is continuous 
queuing in all available lanes in the approach to the entry.  (There need not necessarily be queues in all lanes at 
the give-way line).  Queuing on the approach should occur continuously for periods of twenty minutes or more 
during peak periods.  The approach queues should be stable for at least five vehicle lengths upstream of any entry 
widening.  At minimum, a total of sixty minutes of saturation should be obtained.  (Note that, when counting 
circulating flow for any arm, traffic exiting by that arm should not be included, but traffic exiting by the next or 
successive arms should be. 

The mean entry flow and mean circulating flow are calculated for all of the saturated minutes together, both in 
PCU/min (or hour), assuming 2 PCUs for each heavy vehicle. 

When site-specific data is being collected for arms with pedestrian crossings care should be taken in making 
observations.  It is essential that the junction entry is operating under saturated conditions, and is not affected by 
the crossing.  This requires traffic queuing at the junction entry at all times, downstream of the crossing.  
Observations should not be made when there is any blocking back into the junction, whether it is due to a 
pedestrian crossing on the next arm, or for any other reason. 
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The below applies only when the Queue Marker Type is set to ‘Distance’.   Otherwise, the size of the queue can be 
entered directly. 

In ‘Distance’ mode, the distance from the critical queue marker point to the give way line must be expressed as 
two values, QMARK and QFLARE, as shown below. 

(i) QMARK (Distance from Start of Flare) is the distance from the queue marker to the start of the flare (from 
which point the number of vehicles queuing side-by-side will become indeterminate).  NOTE:. The queue marker 
must be upstream of the flared section. If there is no flare, QMARK is simply the distance from the queue marker 
to the give-way line. 

(ii) QFLARE (Flare Storage) is the average number of PCUs able to queue in the flared area up to the give-way 
line. If there is no flared area, then QFLARE is set to zero.  
 

 
 

 

Figure 26-1 
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 Space between crossing and junction entry (VGAP) 27.1.1

This is the average number of PCUs which can be held in the reservoir space (in all lanes) between the pedestrian 
crossing and the junction entry, the shaded area X in Figure 27-1.   

 Vehicles queueing on exit (VBLOCK) 27.1.2

For roundabouts, this is the average number of PCUs in a queue at the pedestrian crossing on an exit from the 
junction which would reach back into the junction and block half of the previous junction entry.  This is the number 
of PCUs which would fill the shaded area Y in Figure 27-1.  

 Crossing length 27.1.3

If there is no central refuge then the length of the pedestrian crossing is measured from kerb to kerb. 

If there is a central refuge then two distances are measured, corresponding to the portion of the crossing that 
covers the entry and exit side of the arm. 

 

 



 Appendix F - Measurement of pedestrian crossing geometry    Page 346     

 
 

 

 

 

Junctions 9 User Guide (Issue D) 

 

Figure 27-1 

 

 
 

 

 Space between crossing and junction entry (left/right) 27.2.1

Space between crossing and junction entry [left] and [right] are the numbers of PCU which can be held in the space 
between the crossing and the junction. For two-lane minor roads, the [left] value is the number in the left-hand 
lane and [right] the number in the right-hand lane (see Figure 27-2 (a)). For a single lane minor road, the whole 
area is measured as [left] and no value is input for [right]. 
 
For a flared minor road, the [left] value is equal to the number of vehicles in the left-hand lane of the flare plus half 
those which can fit in the single lane section, and the [right] value equals the number of vehicles in the right-hand 
lane of the flare plus half those in the single lane section.  
 
For major road crossings, the [left] value is not required and the [right] value is the number of vehicles in the right-
turning lane between the crossing and the point where the right-turn is made (see Figure 27-2 (b)).  
 
At arm A of a T-junction, neither the [left] nor the [right] value is required. 
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Figure 27-2 Measurement of space between crossing and junction [left] and [right] of unsigned ‘zebra’ crossings 

 
 
 

 Space between crossing and junction exit  27.2.2

 
For Priority Intersections, Space between crossing and junction exit [blocking] is the number of vehicles in a queue 
at the pedestrian crossing on an exit from the junction which would reach back into the junction as far as the 
major carriageway (for crossings on minor arms), or as far as the nearest point where a minor arm enters or leaves 
the main carriageway (for crossings on the major road).  
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The methods of measurement shown in this appendix represent those employed by the original studies that were 
used to formulate the accident models. 

 

 

 Circulating flows 28.1.1

The traffic flow circulating past an arm consists of traffic making several turning movements but does not include 
any traffic to or from the arm under consideration.   
 

 Pedestrian flows 28.1.2

Pedestrian flows: (Two-way flows measured in 1000’s).  All pedestrians crossing the road within 20 metres of the 
give-way line are included.  Flows on a pedestrian crossing should be included if the edge of the crossing nearest 
the give-way line is within 20 metres.  Any pedestrians crossing the centre of the roundabout should be included in 
the corresponding movement(s) across the nearest arm(s). 
 

 Effective flare length 28.1.3

The effective flare length for accident prediction is measured in the same way as for standard roundabout capacity 
measurements. 

 

 

 Central island diameter 28.2.1

The central island diameter (CID) is in cases of non-circular islands the maximum value. 
 

 

 Entry path radius 28.2.2

 
NOTE:  ARCADY 7/8 uses radii instead of curvatures as used in previous versions.  Radius = 1/curvature.   
 
The entry path radius is defined in terms of the shortest path for a vehicle taking the second exit* from the 
roundabout.  Consider a vehicle making a through movement to the second exit at the roundabout in the absence 
of other traffic.  Starting approximately 50m back from the give-way line, construct a path 2m wide with flowing 
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curves representing the shortest path the vehicle could take through the roundabout keeping on its own side of 
the road but otherwise ignoring lane markings.  The heavy line in Figure 28-1 represents the locus of one such 
path.   

* The only exception is at a roundabout which has been installed at a T-junction, where a vehicular path entering 
the roundabout on the head of the “T” should also leave on the head of the “T”.  

 
 
Normally the path is assumed to start 1 metre from the nearside kerbline (as in Figure 28-1), but it may also start 1 
metre from the carriageway dividing line or kerbline of a central reserve, or anywhere between these two points.  

The entry path radius for a particular path is a measurement of the maximum curvature in the region of the entry 
and hence is the smallest radius. The final resultant entry path radius for the entry (i.e. the value entered into 
ARCADY) is the minimum entry path curvature obtainable from all possible paths and hence the largest radius 
from all possible paths.  
 
The sign convention is that the curvature is positive if deflection is to the nearside (left in the UK) and negative if it 
is to the offside (right in the UK).  If the path is straight, enter zero.  

 

Figure 28-1 
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 Approach radius 28.2.3

 
NOTE:  ARCADY 7/8 uses radii instead of curvatures as used in previous versions.  Radius = 1/curvature.   
 
The approach radius is defined in terms of that section of the junction approach road within the range from about 
50m (to be clear of the immediate entry geometry) to 500m from the roundabout give-way line. The approach 
radius is the minimum radius (maximum curvature) of the bend nearest to the junction within this section of the 
approach.  Figure 28-2 illustrates this parameter in two cases.  The sign convention is that bends to the offside 
when approaching the roundabout are positive and bends to the nearside are negative.   
 
If an approach is straight, enter zero. 

 

Figure 28-2 

 

 
 

 Angle to next arm 28.2.4

Angle between arms: The angle between the approach arm and the next arm  is the angle subtended by 
projections of the relevant approach centre lines as shown in Figure 28-1.  If the approaches are curved then the 
tangents to the centre line at the entry points (P) are used for this construction. 
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 Minimum exit width 28.3.1

The minimum exit width is the minimum exit width (e.g. opposite a refuge) within 50 metres, or clear of the 
preceding junction (whichever is the closest). 
 

 Entry width 28.3.2

The entry width along give-way:  if there is a splitter island, the complete length along both parts of the give-way 
line and across the front of that island should be recorded. 
 

 Distance: Junction centre to projected arm centre line 28.3.3

The minimum distance from junction centre to projected arm centre line: For arm n, this is the length of a normal 
from the projected centre line tangent at An to the centre of the central island C, i.e. from Cn to C (see Figure 28-3, 
which shows the measurement of this parameter for Arm 3).  
 
Drive-on-the-left: The value is negative if the projected centre line is to the right of C, otherwise it is positive. 
 
Drive-on-the-right: The value is negative if the projected centre line is to the left of C, otherwise it is positive. 

 

Figure 28-3 
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 Distance: Junction centre to entry corner kerb line 28.3.4

The minimum distance from junction centre to entry corner kerb line is the distance from the centre C of the 
central island to the point Kn on the entry kerb of arm n which is nearest to the central island. (See Figure 28-3, 
which shows the measurement of this parameter for Arm 2).  
 

 Distance: Junction centre to give-way line 28.3.5

The distance from junction centre to offside end of give-way line is the distance from the centre of the central 
island C to the to the point An. (See Figure 28-3, which shows the measurement of this parameter for Arm 2). 
 

 Length of island 28.3.6

The length of island is the overall length (including hatching) of any island, any part of which is within 20 metres of 
the give-way line.  The island may be kerbed only, hatched only, or both, and may or may not continue beyond 20 
metres.  Islands at pedestrian crossings are included.  Where pedestrian gaps exist the island should be treated as 
continuous.  
 

 

 

 Angle to next arm  28.3.7

The angle between arms [n] and [n+1]  should be measured between the tangents to the centre lines or entry side 
of an island at the specified distance from both the entry and exit. (See Figure 28-4) 
 

 

Figure 28-4 
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 Gradient on approach 28.3.8

The gradient from 50-100m on approach (measured as a percentage) should be the average gradient of the 
approach measured between 50-100 metres from the junction. 
 

 Sight distances 28.3.9

Sight distances should be measured, ideally, using an observer height of 1.05 metres and a target height of 0.26 
metres (car tail lights). The observer should view from the indicated distances back from An along the middle of 
arm n.  The target should be on the nearside.   

For sight distance to offside (i.e. to the right for drive-on-the-left), the position of the target should be recorded 
relative to the ‘datum’ point D(n-1).  The result should be recorded as negative if the target is forward of the 
datum point.   

For sight distance ahead at 4-arm mini roundabouts the position of the target should be recorded relative to the 
‘datum’ point D(n-2).  The result should be recorded as negative if the target is forward of the datum point.   

 

Figure 28-5 

 Number of entry / exit lanes 28.3.10

The number of entry lanes on the approach should be recorded upstream of any flaring, or at 100 metres, or clear 
of the preceding junction (whichever is closest), but not nearer than 20 metres.   
 
The number of exit lanes should be recorded at the same point. 
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 Presence of entry path curvature 28.3.11

The presence of entry path curvature indicates the presence of entry deflection on the "practical path" for any 
turning movement, taking account of lane markings.  

In order to measure entry path curvature, it is necessary to construct the centre line of the smoothest possible 
path through the junction.  The vehicle should be assumed to be 2 metres wide so that the centre line of its path is 
at least 1 metre from the nearside kerb, any kerbed island, or any lane used for travel in the opposite direction. 
The radius of curvature should be measured in the vicinity of the entry.  The vehicle path curvature is the inverse 
of the radius.  Straight paths have a curvature of zero. 

A ‘practical’ vehicle path is used to determine the presence of any entry path curvature.  Unlike the ‘classic’ vehicle 
path that keeps to the correct side of the island and is no closer than 1 metre to it, the ‘realistic’ path allows the 
vehicle to pass over, or around the wrong side of the central island if it is a shorter path. For the ‘practical’ path the 
‘realistic’ path should be assumed if the central island is flat and the ‘classic’ path otherwise. 

Lane lines should be taken into account. Assume that the vehicle will use the left lane for a left turn, the right most 
lane for a right turn and whichever gives the shortest smooth path for a straight ahead movement. The path 
should keep at least 1 metre away from any hatched area or from the edges of whichever lane it uses at any 
particular time, unless the lane is less than 2 metres wide, in which case the path should follow the centre of the 
lane.   

In any cases where the resulting curvature of the ‘practical’ path is tighter than 5 metres (the minimum turning 
circle of a typical car) the realistic path should be used. 

The presence of entry path curvature (taking account of lane markings) can usually be assessed without making 
the measurements. 

 

 Approach curvature 28.3.12

The approach curvature within 100 metres is the curvature of the arm on the approach to the junction upstream of 
any local flaring.  It assessed on a 7-point scale from “sharp” to “moderate” to “slight” in either direction, plus 
“straight”.    
 
 

 

Where measurements refer to within the junction, this means that, in general, a feature on a major arm is within 
approximately 20 metres of the extended kerbline of the nearest minor arm.  A junction feature on the minor arm 
is ‘within the juncion’ if it is within 20m of the give-way line. 

The parameters required depend on the junction type and other options.  Most of the items described below are 
for detailed urban accident prediction.   

 

 Angle to next arm 28.4.1

Angle between arm n and arm n+1 are the angles on the approach between each arm and the next arm clockwise, 
that is, between arms A and B, arms B and C, arms C and D, and arms D and A respectively. They are measured 
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from 1:500 plans between the projected tangent to the centre lines at 20 metres from the junction on the former 
arm and the projected tangent to the centre line at 0 m from the junction on the latter arm. For example, the 
angle between arm B and arm C was measured between the projected tangent to the centre line at 20m from the 
give-way line on arm B and the projected tangent to the centre line at OC on arm C. 

 
     Figure 28-6 

 
 

 Number of entry lanes 28.4.2
 
Number of entry lanes or number of ahead lanes by arm are as indicated by the lane markings. For entry on the 
major left (drive-on-the-left) (arm C) at a T-junction, this includes any separate right turn lane at least 1.5 metres 
wide at the centre of the junction. 
 

 Stopping sight distance 28.4.3
 
Stopping sight distance for arm n, is the distance away from the junction that an approaching driver can see a car 
at the junction (measured up to a maximum distance of 250 metres). The view is measured from a driver's eye 
height of 1.05m to an object of height 0.26m (car tail-lights). If the distance to the next major junction is less than 
the stopping distance, this value should be used. 
 

 Pedestrian flows 28.4.4
 
Pedestrian flows are measured as 12-hour flows crossing the centre of the junction and ‘within the junction’ on 
each arm. Pedestrians using a pelican or zebra crossing are included provided that the crossing is also within the 
junction. The flows should be measured on a weekday avoiding school holidays. 
 

 Gradient 28.4.5
 
Gradient on major arm is measured differently for ‘T’-junctions and crossroads/staggers. For ‘T’-junctions only an 
estimate is required as to whether the gradient over 50 metres approach to the junction is steep uphill, level or 
slight slope, steep downhill. The gradient is defined as positive if the road is uphill, negative if downhill and zero if 
level (any gradient smaller than 3.5% (positive or negative) is treated as level). For crossroads and staggered 
junctions the gradient is measured as the average percentage gradient over 0-50m of the approach, from the 
reference lines OA and OC (see Figure 28-7 to Figure 28-9). 
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Figure 28-7 

 

 
Figure 28-8 
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Figure 28-9 

 
 
 
 
 

 Absolute stagger length 28.4.6
 
Absolute stagger length is the absolute displacement between the perpendiculars from the centre lines of the 
opposite minor arms. A junction is defined as staggered if the absolute stagger length is greater than 5 metres. 
(This is different from geometric delay parameters, which use distance travelled along the major road in a 
staggered junction by traffic from one minor arm to the other.) 

 
 
Figure 28-10 

 
 
 

 Visibility to Nearside and offside from minor arm 28.4.7
 
Visibility to left/right from minor arm is the visibility to the left/right viewed from the centre line of the minor arm 
at 9 metres back from the give-way line on arms B and D. The visibility is the furthest distance for which an 
approaching two wheeled vehicle could be seen. Object and eye heights are 1.05m above the road surface and the 
object is on the opposite side of the carriageway to the minor road for the visibility to the left, but the same side 
for the visibility to the right. The visibilities are measured when not obstructed by parked or stationary vehicles. 
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The distance recorded is along the major road from opposite the centre line of the minor arm to the object (up to 
a maximum of 250m). If the distance to the next major junction is less than the visibility, this value is used. 

 
Figure 28-11 

 
 
 

 Radius of entry corner 28.4.8
 
Radius of entry corner on major arm is the radius of curvature (in metres) of the entry corners of each major arm 
as measured from 1:500 plans. 

 
 
 
 

 Approach width (rural accident prediction) 28.4.9
 
The approach width refers to the part of the road available to vehicles approaching the junction.  It is measured at 
30 metres from the centre of the junction where there is no ghost island, or at 30 metres from the pointed end of 
the taper where there is a ghost island.  
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One of the variables used in modelling large and/or grade-separated roundabouts is the circulating flow past the 
arm in question, during the central 30 minutes of the modelled period. When modelling new junctions it is, of 
course, not possible to measure any flows directly, and various methods of estimating them are used. Given that 
demand flows have been estimated rather than measured, the following describes a satisfactory method of 
estimating circulating flows (CIRFLO) - its accuracy will be in keeping with the accuracy of the demand flows. The 
method should be used only when circulating flows cannot be measured directly. 

The automatic initial estimation of CIRFLO can be run by clicking Data>Estimate Circulating Flows for Large 
Roundabouts.  The method, as described below, is used to calculate the circulating flows.  The values are 
automatically placed in the relevant part of the Data Outline and can then be viewed as usual using the Data 
Editor.  

For a four-arm roundabout, the maximum circulating flow past each arm, assuming there are no U-turners, is as 
follows: 

CircA = Flow (D  B) + Flow(D  C) + Flow(C  B)  .............….……….… (1) 

CircB =  Flow (D  C) + Flow(A  C) + Flow(A  D)  ........…………...…… (2) 

CircC =  Flow (A  D) + Flow(B  D) + Flow(B  A)  …….............….……  (3) 

CircD = Flow (B  A) + Flow(C  A) + Flow(C  B)  ..................…………. (4) 

The flows for the O/D movements given above should be known for the central hour of the modelled period, since 
these will have been used to specify the demand flows on each arm. According to the ARCADY method for 
synthesising the shape of the peak profile, the demand flows for the peak half hour will be 55 percent of the peak 
hour flows.  

So the maximum circulating flow past Arm A (for example) during the central  

30 minutes of the peak hour flow will be: 

0.55 (Flow (DB) + Flow (DC) + Flow (CB)) veh (or pcu) .....…....……….. (5) 

i.e.  

1.10 (Flow (DB) + Flow (DC) + Flow (CB)) veh (or pcu) per hour ………. (6) 

The maximum circulating flow takes no account of suppressed demand - it assumes that no arms are overloaded. 
In practice, it is likely that the junction will be overloaded during the central 30 minutes of the modelled period, 
and this will reduce all circulating flows. If, for example, all circulating flows were reduced by 10 percent (a typical 
figure) then the best initial estimate of CIRFLO (again using Arm A as an example) would be: 

0.90 x 1.10 (Flow (DB) + Flow (DC) + Flow (CB)) veh (or pcu) per hour …(7) 
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Equation (7) is approximately equal to equation (1) so it is sufficiently accurate to use equations 1 to 4 as initial 
estimates of CIRFLO for each arm.  

 

i.e.  CIRFLO past Arm A =  Flow (D  B)   +  Flow(D  C)   +  Flow(C  B) 

where all the units are in vehicles (or pcu) per hour. 

 

The initial estimates of circulating flows (CIRFLO) past each arm can be used during a first pass of the program. This 
first pass will enable a better estimate of circulating flows to be made, based on the amount of traffic emerging 
from each arm, and the turning proportions, during the central 30 minutes of the modelled period. The amount of 
traffic emerging from each arm is equal to the demand flow or capacity of the arm, whichever is the lesser. Both 
demand flow and capacity can be read from the program output, for each time segment throughout the modelled 
period. The turning proportions can be assumed to be the same as those entered in the Origin-Destination table in 
the program input. 

Better estimates of the circulating flows can then be made, using equations (1) to (4) but with the flows on the 
right-hand side of the equations now based on traffic emerging from each arm, rather than the demand flow on 
each arm. 

These better estimates of CIRFLO can then be used in a second pass of the program. In principle, it would be 
necessary to repeat this process for a series of iterations, to gradually home-in on the most appropriate correct 
circulating flows. In practice, it has been found that the circulating flows used in this second pass are sufficiently 
close to the true values, particularly given the accuracy of the original demand flows from which they are derived. 

It should be borne in mind that the iterative process referred to above is necessary only when arms are overloaded 
- in this case the entry flows affect, and are affected by, the circulating flows. If no arms are overloaded during the 
central 30 minutes of the modelled period, the circulating flows can be obtained directly from the demand flows, 
with no iterative process being necessary. 

NOTE:  ARCADY only provides the initial estimates of CIRFLO.  It takes no account of the potential differences 
between the demand data and the amount of traffic emerging from each arm. 
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AADT  

Average Annual Daily Total (flow) 

Approach half-width 

The same as “approach width” – it is the width of the side of the carriageway which is approaching the junction, 
measured at a point upstream from any entry flare, from the median line to the nearside kerb, along a normal.  

At-grade roundabout 

Opposite of grade-separated  

Capacity (of an arm) 

The maximum amount of traffic that an arm can cope with.  If an arm is over-capacity, queues will build up 
uniformly over time.  Queues may be a problem even when the stream is not over capacity, due to the random 
nature of traffic arrivals.  

Demand  

The number of vehicles per unit time wishing to use a traffic stream or junction.  If this exceeds the capacity, then 
a queue will build up. 

DOS 

Degree of Saturation. See RFC. 

Drive-on-the-left / Drive-on-the-right 

‘Drive-on-the-left’ indicates that vehicles travel along the left-hand-side of the road, as in the UK and Japan. ‘Drive-
on-the-right’ indicates that the vehicles travel along the right-hand-side of the road, as in mainland Europe and the 
USA. 

Early Cut-Off 

An arrangement of stages whereby the phase for opposing traffic terminates before that for the opposed traffic. In 
other words, opposed traffic initially has to give way to oncoming traffic, but later on they may be given a clear 
run. 

Effective Green 

The effective green is the time used for modelling purposes to compensate for the time taken to reach saturation 
flow at the start of green, and the time into amber treated as green by drivers. The relationship between the 
actual green time for a stage (or phase) and effective green is defined by the start and end displacements. 

Entry capacity 
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The maximum inflow at an entry. It is observable only when the demand flow at that entry is sufficient to cause 
continuous queuing on the approach. 

Entry flow 

The number of vehicles per unit time entering a junction from a particular arm. 

Extra Effective Green (EEG) 

The equivalent additional green time available to a particular stream of traffic (due perhaps to reduced lost time). 

Geometric delay 

Delay suffered by vehicles due to the presence of the junction even in the absence of other traffic – i.e., the 
physical presence and shape of the junction. 

Grade-separated roundabout 

a roundabout with: 

 i) a road (typically trunk, motorway or interstate) passing above or below it. 

OR 

 ii) a motorway (interstate) linking directly with it. 

Headway 

The time between the fronts of two successive vehicles or pedestrians. 

Heavy vehicle 

A vehicle with more than 4 tyres in contact with the road (includes buses, cars pulling trailers and caravans, etc). 

Intercept 

Maximum entry flow of an entry when there is zero circulating traffic. 

Interstage 

Period between the end of green on one stage and the start of green on the next. Where there are multiple phases 
starting and ending at different times, this is the maximum time between the first one ending and the last one 
starting. 

Late Release 

An arrangement of stages whereby the phase for opposing traffic starts after that for the opposed traffic.  In other 
words, opposed traffic initially gets a clear run, but later on has to give way to oncoming traffic. 
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Light vehicle 

A vehicle with 3 or 4 tyres in contact with the ground. 

Passenger Car Unit (PCU) / Passenger Car Equivalent (PCE) 

A unit of measurement of traffic flow or capacity - equivalent to that of a single car.  Individual vehicle classes are 
given different PCU values (for the purpose of traffic capacity calculations). 

PCU values vary from country to country and also depend upon the number of vehicle categories used. E.g. when 
using just two categories light vehicles and heavy vehicles (i.e. ‘lights and heavies’) PCU values used are typically 1 
and 2 respectively.  In the UK typical values for six categories are as follows: 

Vehicle type description PCU factor 

Bicycles 0.2 

Motorcycles 0.4 

Cars/light goods (3/4 wheels) 1.0 

Medium goods (two axles but > 4 tyres) 1.5 

Buses, coaches 2.0 

Heavy goods (more than two axles) 2.3 

    

When differentiating between just two classes of vehicles (lights and heavies) the following values are used:  

Vehicle type description PCU factor 

Light vehicle 1.0 

Heavy vehicle (>4 tyres) 2.0 

 

For the purposes of modelling pedestrians they too can be given a PCU value. (Pedestrians never mix with any other 
type of traffic so there is no need to assign a value relative to vehicle types etc.) 

Pelican Crossing 

Signalled pedestrian crossing.   (Mid-block crossing) 

Priority Intersection 

An unsignalised intersection where a minor road meets a major road and where traffic on the minor road must 
give way (yield) to traffic on the major road.  Examples include T-junctions, crossroads and staggered junctions.  
For the purposes of Junctions 9, the term ‘priority intersection’ refers to the junction types that can be modelled in 
PICADY, and does NOT include roundabouts. 

Puffin Crossing 

Signalled pedestrian crossing with pedestrian detection.  (Adaptive pedestrian crossing.) 

Queueing delay 

Extra time take by vehicles to negotiate the junction due to the presence of other traffic. 
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RFC 

Ratio of demand flow to capacity (see also Traffic Intensity).  Also known as volume-to-capacity (VC) ratio or DOS 
(Degree of Saturation) 

Roundabouts 

standard roundabout - A roundabout having a one-way circulatory carriageway around a kerbed central island 4m 
or more in diameter and usually with flared approaches to allow multiple vehicle entry.  

mini-roundabout – A roundabout having a one-way circulatory carriageway around a flush or slightly raised 
circular marking less than 4m in diameter and with or without flared approaches. (A few roundabouts that have a 
central island diameter greater than 4m are designed to allow vehicles to run over them and therefore operate in 
the same way.) 

Saturation Flow 

The maximum inflow per unit time of vehicles from a particular stream when the traffic signal is green for that 
stream. 

Slope 

Rate of change of the entry capacity with the circulating flow.   

Stage 

Period of time during the signal cycle which is green for one or more streams and during which all signal aspects 
remain unchanged. 

Stream 

See Traffic Stream. 

Time-Dependent Queueing Theory 

Theory for predicting average queue lengths (averaged over many occasions) taking account both of the 
systematic variation of 'average' demand flow and capacity in time and of random fluctuations in these quantities 
due to individual vehicles. 

Time Segment 

When analysing a network over a extended time period, the time period can optionally be split into several time 
segments of shorter length.  This allows varying traffic conditions to be modelled.  Traffic flows are assumed to be 
constant within each time segment, but may vary from one time segment to the next.  Signal timings are assumed 
to be constant over the entire time period.  Output results are reported for both averages over all time segments 
and for each segment giving a detailed breakdown of the network performance over the modelled time period.  
Typically 10 or 15 minutes. 

Traffic intensity 

The ratio of demand flow to capacity (RFC). 
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Traffic stream 

Vehicles within or approaching a junction which are considered together for the purpose of determining 
capacities, queues and delays.  At roundabouts the traffic on each approach shares a common entry capacity and 
in this sense is treated as a single stream. 

For OSCADY junctions, all lanes in a traffic stream must be controlled by the same signal indications. 

Truck 

See ‘Heavy Vehicle’ 

Within the junction 

As a general rule, a particular feature on a major arm should be regarded as being ‘within the junction’ if it is 
within approximately 20m of the extended kerbline of the nearest arm.  A junction feature on the minor arm is 
‘within the junction’ if it is within 20m of the give-way line. 

Zebra Crossing 

Unsignalled pedestrian crossing.   
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